This software includes the Python Release 2.3.2 software. The Python software is:
Copyright © 2001, 2002, 2003 Python Software Foundation. All rights reserved.
Copyright © 2000 BeOpen.com. All rights reserved.
Copyright © 1995-2000 Corporation for National Research Initiatives.
All rights reserved.
Copyright © 1991-1995 Stichting Mathematisch Centrum. All rights reserved.

The SOFTIMAGE|XSI application uses JScript and Visual Basic Scripting Edition from Microsoft Corporation.

This document is protected under copyright law. The contents of this document may not be copied or duplicated in any form, in whole or in part, without the express written permission of Avid Technology, Inc. This document is supplied as a guide for the Softimage product. Reasonable care has been taken in preparing the information it contains. However, this document may contain omissions, technical inaccuracies, or typographical errors. Avid Technology, Inc. does not accept responsibility of any kind for customers’ losses due to the use of this document. Product specifications are subject to change without notice.

Documentation Team
Judy Bayne, Grahame Fuller, Amy Louise Green, Edna Kruger, Luc Langevin, and Jamal Rahal. Special thanks to Rejean Gagne.

Printed in Canada.

Part No. 0130-05536-02

05 2004
Contents

Fundamentals

Roadmap ........................................... 19
Where to Find Information ..................... 20
Document Conventions ........................... 22
Softimage Customer Service .................... 24

Section I • In The Beginning

Chapter 1  

XSI Fundamentals .................................. 29
The Foundations of XSI ............................ 30
SOFTIMAGE|3D Legacy and Compatibility ..... 31
Compatibility in Workflow ....................... 31
Importing from SOFTIMAGE|3D ................. 32
Functionality, Productivity and Workflow ..... 33
Architecture ......................................... 33
Projects and Databases ......................... 33
XSI Scenes .......................................... 34
XSI Models ........................................... 34
XSI Interaction Model .............................. 35
The XSI Selection Model .......................... 35
Keyboard Shortcuts ............................... 36
Drag and Drop ...................................... 36
XSI is Non-modal .................................... 37
Properties and Property Editors ................. 37
Global and Local Coordinate Systems ......... 38
Transformations ..................................... 38
XSI is Object-Oriented ............................. 39
Visual Feedback in 3D Views ................... 41
Modeling ............................................. 42
Animation ............................................ 43
Low-Level Animation .............................. 43
Character Setup .................................... 44
Non-linear Animation ............................. 45
Shaders—Materials, Textures, and More ..... 47
Rendering .......................................... 49
XSI is Customizable ............................... 51

Chapter 2  

Starting SOFTIMAGE|XSI ......................... 53
Starting SOFTIMAGE|XSI ........................ 54
Starting XSI on Windows ....................... 54
Starting XSI on Linux ............................ 56
# Chapter 4

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Views</td>
<td>103</td>
</tr>
<tr>
<td>Working with Views</td>
<td>104</td>
</tr>
<tr>
<td>Working with Views Docked in the Viewports</td>
<td>105</td>
</tr>
<tr>
<td>Working with Floating Views</td>
<td>107</td>
</tr>
<tr>
<td>The Explorer</td>
<td>110</td>
</tr>
<tr>
<td>Viewing the Element Tree</td>
<td>111</td>
</tr>
<tr>
<td>Selecting Scene Elements in the Explorer</td>
<td>112</td>
</tr>
<tr>
<td>Setting the Scope of the Explorer</td>
<td>113</td>
</tr>
<tr>
<td>Filtering the Display</td>
<td>114</td>
</tr>
<tr>
<td>Finding Elements in the Explorer</td>
<td>114</td>
</tr>
<tr>
<td>Sorting and Reordering Objects in the Explorer</td>
<td>116</td>
</tr>
<tr>
<td>Using Context Menus in the Explorer</td>
<td>118</td>
</tr>
<tr>
<td>Renaming Scene Elements</td>
<td>119</td>
</tr>
<tr>
<td>Other Explorer Views</td>
<td>119</td>
</tr>
<tr>
<td>The Schematic View</td>
<td>121</td>
</tr>
<tr>
<td>Selecting Elements in the Schematic View</td>
<td>122</td>
</tr>
<tr>
<td>Displaying Scene-Element Information</td>
<td>122</td>
</tr>
<tr>
<td>Defining the View</td>
<td>124</td>
</tr>
<tr>
<td>Navigating in the Schematic View</td>
<td>126</td>
</tr>
<tr>
<td>Arranging the Schematic View</td>
<td>127</td>
</tr>
<tr>
<td>Building Hierarchies in the Schematic View</td>
<td>130</td>
</tr>
<tr>
<td>The Spreadsheet</td>
<td>132</td>
</tr>
<tr>
<td>Displaying a Spreadsheet View</td>
<td>133</td>
</tr>
<tr>
<td>Using Queries</td>
<td>133</td>
</tr>
<tr>
<td>Navigating within the Spreadsheet</td>
<td>134</td>
</tr>
<tr>
<td>Editing Cell Contents</td>
<td>134</td>
</tr>
<tr>
<td>Selecting Scene Elements from the Spreadsheet</td>
<td>134</td>
</tr>
<tr>
<td>The XSI Explorer</td>
<td>135</td>
</tr>
<tr>
<td>Opening an XSI Explorer View</td>
<td>136</td>
</tr>
<tr>
<td>Choosing a Viewer</td>
<td>136</td>
</tr>
<tr>
<td>Choosing an Element to View</td>
<td>136</td>
</tr>
<tr>
<td>The Browser</td>
<td>137</td>
</tr>
<tr>
<td>The Tree View</td>
<td>138</td>
</tr>
<tr>
<td>Viewing Folder Contents</td>
<td>139</td>
</tr>
<tr>
<td>Setting Favorites</td>
<td>141</td>
</tr>
<tr>
<td>Accessing Files from the Browser Path Controls</td>
<td>141</td>
</tr>
<tr>
<td>Accessing Computers on a Network</td>
<td>142</td>
</tr>
<tr>
<td>Net View</td>
<td>143</td>
</tr>
<tr>
<td>Displaying Net View</td>
<td>144</td>
</tr>
<tr>
<td>Configuring Net View</td>
<td>144</td>
</tr>
<tr>
<td>Working with Net View</td>
<td>145</td>
</tr>
<tr>
<td>XSI Web</td>
<td>146</td>
</tr>
</tbody>
</table>
Contents

Chapter 5  Viewing 3D Objects  ................................................. 147
Viewing in SOFTIMAGE|XSI .............................................. 148
3D Views .............................................................. 149
Viewports ............................................................. 149
The Object View ....................................................... 151
Customizing the Display in 3D Views ............................ 154
Changing 3D View Colors ............................................ 154
Customizing the Grid ................................................. 155
Types of 3D Views ..................................................... 156
Camera Views .......................................................... 156
Spotlight Views ......................................................... 156
Viewpoints ............................................................ 157
Other Views (Viewports Only) ....................................... 159
Navigating in 3D Views .............................................. 160
Framing Objects in 3D Views ....................................... 160
Zooming ................................................................. 161
Tracking ................................................................. 162
Orbiting and Pivoting .................................................. 162
Dollying and Rolling .................................................. 162
Walking and Flying .................................................... 163
Driving ................................................................. 164
Combination Mode ..................................................... 166
Resetting Coordinates ............................................... 167
Setting Object Visibility ............................................... 168
Setting Visibility for All Objects in All 3D Views .............. 168
Setting Visibility for All Objects per Viewport ................ 168
Setting Visibility per Object ......................................... 169
Hiding and Unhiding Objects ........................................ 171
Setting Visibility for Selected Polygons ......................... 172
Setting Object Display ............................................... 175
Display Types .......................................................... 175
Setting Display Options per 3D View ............................ 178
Setting Display Options for All Cameras ....................... 179
Setting Scene Colors .................................................. 186
Setting Display Options per Object .............................. 187
Improving Scene Display Performance ......................... 189
Outputting XSI Views to an Avid Mojo ......................... 192
Troubleshooting ......................................................... 193

Chapter 6  Rotoscopy ......................................................... 195
Rotoscoping ............................................................. 196
Tips for Rotoscoping .................................................. 196
Displaying Rotoscoped Images .................................... 197
Navigating in a Rotoscoped View ................................ 199
Rotoscoping in the Render Region ............................... 200
Compositing the Alpha Channel .................................. 200
## Section II • Working with Scene Elements

### Chapter 7

**Basic Scene Elements** ............................................................. 203
- What Are the Elements in XSI? ............................................. 204
- Objects .................................................................................. 204
- Components of Objects ......................................................... 204
- Selecting Elements ............................................................... 204
- Organizing Objects into Structures ....................................... 204
- Properties for Anything ......................................................... 205
- Weight Maps for Modulating Parameter Values .................. 205
- Element Names .................................................................. 206
- Valid Names ....................................................................... 206
- Namespaces and Unique Names .......................................... 206
- Renaming Elements ............................................................. 207
- Viewing Object Names in 3D Views .................................... 208

### Chapter 8

**Selecting** ........................................................................... 209
- Selecting ............................................................................. 210
- About Selection .................................................................. 211
- What You Can Select .......................................................... 211
- Feedback on What’s Selected .............................................. 212
- Selection Filters, Tools, Modes, and Interaction Models ...... 212
- Selection and Hierarchies ..................................................... 214
- Other Useful Tools for Selection ......................................... 215
- Overview of Selection ......................................................... 216
- Overview of Selecting Objects ............................................ 216
- Overview of Selecting Components .................................... 217
- Selection Keyboard Shortcuts ............................................. 217
- Extending the Selection ....................................................... 218
- Deselecting ......................................................................... 218
- Activating the Last-used Selection Tool and Filter .......... 218
- Using Selection Tools .......................................................... 219
- Rectangle Selection Tool .................................................... 220
- Lasso Selection Tool ............................................................ 221
- Freeform Selection Tool ..................................................... 222
- Raycast Selection Tool ........................................................ 222
- Rectangle-Raycast Tool ...................................................... 223
- Paint Selection Tool ............................................................. 223
- Selecting Objects ................................................................ 225
- Object Selection Modes ....................................................... 225
- Object Selection Filters ....................................................... 226
- Selecting Objects Using the Different Interaction Models .... 227
- Single versus Multiple Selection ....................................... 228
- Selecting Groups of Objects ............................................... 228
Contents

Selecting Components .................................................. 230
Overview of Selecting Components ............................. 230
Component Selection Modes ............................................. 231
Component Selection Filters ............................................. 232
Selecting Components Using the Different Interaction Models . 233
Selecting Ranges and Loops of Components ....................... 234
Selecting Clusters ......................................................... 238
Viewing Selected Components and Clusters ......................... 239
Selecting Properties in the 3D and Schematic Views ............... 240
Displaying Properties ..................................................... 240
Property Selection Filters ................................................. 241
Selecting Properties ....................................................... 242
Selecting in the Explorer ................................................ 243
Different Types of Explorers .......................................... 243
What You Can Select in the Explorer .............................. 243
Selecting Nodes in the Explorer ..................................... 244
Modifying the Selection .................................................. 246
Refining the Selection with the Selection Explorer ............... 246
Modifying the Selection with Filters ............................... 246
Converting Hierarchy Selection ...................................... 247
Navigating Hierarchies .................................................. 248
Navigating Component Selection ................................... 250
Navigating Constraint Relationships ............................... 251
Selecting by Name ........................................................ 252
Typing in the Selection Name Boxes ............................... 252
Using Wildcards and Regular Expressions in Names ............. 254
Defining Selectability .................................................... 255
About Selectability ........................................................ 255
Setting Object Selectability .......................................... 256
Selection Tips .............................................................. 257
Combining Selection Techniques .................................... 257
Running Commands Automatically When the Selection Changes 257
Selecting Points That Overlap Others ................................ 257

Chapter 9

3D Objects ................................................................. 259
What's an Object in XSI? ............................................... 260
Geometric Objects ......................................................... 260
Nulls ................................................................. 260
Implicit Objects .......................................................... 260
Control Objects .......................................................... 260
Cameras ................................................................. 262
Lights ................................................................. 262
Geometric Objects ......................................................... 263
## Contents

**Chapter 12**  
**Components and Clusters**  
Components and Clusters ........................................ 310  
Components .................................................. 311  
Displaying Components ....................................... 311  
Selecting Components ......................................... 311  
Types of Components .......................................... 312  
Clusters ....................................................... 316  
Viewing Clusters .............................................. 317  
Selecting Clusters ............................................. 317  
Creating Clusters ............................................. 318  
Adding and Removing Components from Clusters ............ 319  
Changing Cluster Display Colors .............................. 319  
Cluster Reference Frames .................................... 320  
Local Materials and Polygon Clusters ......................... 320  
Removing Clusters ............................................ 321  
Manipulating Components and Clusters ....................... 322

**Chapter 13**  
**Hierarchies** .................................................. 323  
What Are Hierarchies? .......................................... 324  
Creating Hierarchies .......................................... 325  
Selecting Objects in a Hierarchy .............................. 326  
Navigating in Hierarchies ..................................... 328  
Cutting Links in a Hierarchy ................................ 329

**Chapter 14**  
**Layers** ........................................................ 331  
Layers .......................................................... 332  
Layer Attributes ................................................ 332  
The Default Layer .............................................. 333  
Accessing Layers .............................................. 334  
Accessing Layers from the Explorer ........................... 334  
Accessing Layers from the Layers Panel ....................... 334  
Accessing Layers from the Layer Control ..................... 335  
Working with Layers ........................................... 336  
Creating a Scene Layer ........................................ 336  
Setting the Current Layer ..................................... 336  
Moving Objects to a Layer ..................................... 337  
Setting Layer Attributes ..................................... 337  
Selecting Layers ................................................ 340  
Selecting the Objects in a Layer .............................. 340  
Deleting a Layer ................................................ 341
Section III • Working in 3D Space

Chapter 15  Coordinate Systems  ........................................ 345
  Coordinate Systems ........................................ 346
  Cartesian Coordinates ...................................... 346
  XYZ Axes .................................................. 346
  XYZ Coordinates ........................................... 346
  XZ, XY, YZ Planes ......................................... 347
  Global and Local Coordinate Systems ...................... 348
  Softimage Units ........................................... 349

Chapter 16  Transformations ............................................. 351
  Transformations ............................................ 352
  About Transforming Objects ................................ 353
    Local versus Global Transformations .................... 353
    Manipulation Modes ..................................... 353
    Manipulation Methods ................................... 354
    Hierarchies .............................................. 354
    Centers ................................................... 354
    Useful Tools for Transformation .......................... 355
    Transformation Preferences ............................... 357
    Transformation Basics ................................... 358
    Transforming Interactively ................................ 358
    Setting Values Numerically ............................... 365
    Transforming Hidden Objects .............................. 366
    Translating Objects ...................................... 367
      Translation Modes ..................................... 368
      Using the Translate Manipulator ....................... 370
      Imposing Limits to Translations ....................... 371
      Snapping Multiple Objects ............................. 371
    Rotating Objects ........................................ 372
      Rotation Modes ........................................ 373
      Using the Rotate Manipulator ........................... 374
      Setting the Center of Rotation ......................... 375
      Imposing Limits to Rotations ........................... 376
      Setting the Rotation Order ............................. 376
      Animation and Rotation ................................ 377
    Scaling Objects ........................................... 378
      Scaling Modes ......................................... 379
      Using the Scale Manipulator ............................ 380
      Setting the Center of Scaling ........................... 380
      Shearing (Scaling Orientation) ......................... 382
      Hierarchical (Softimage) Scaling versus Classic Scaling 383
      Transforming with the Bounding-Box Manipulator .... 385
<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
</table>

Center Manipulation ................................. 387
Setting the Center Pivot ............................. 388
    Modifying the Pivot's Pose ....................... 388
    Displaying Pivots ................................. 390
Freezing Transformations .............................. 392
Resetting Transformations .............................. 393
Set Neutral Poses ...................................... 394
    Setting Neutral Poses ......................... 394
    Removing Neutral Poses ......................... 395
Match & Align Transformations ........................ 396
    Matching Transformations ....................... 396
    Aligning Objects ................................. 396
Transform Setup ....................................... 399
Transformations Hierarchies ......................... 401
    Basics Transforming Hierarchies ............... 401
    Child Transform Compensation .................. 401
    Parent Constraint .............................. 402
Velocity Acceleration ................................ 403
    Understanding Motion Components .............. 403
    Calculating Velocity Acceleration ............. 403
    Removing Velocity Acceleration ................ 403

<table>
<thead>
<tr>
<th>Chapter 17</th>
</tr>
</thead>
</table>

**Reference Planes** ................................ 405

**Reference Planes** ................................ 406
**About Reference Planes** ............................. 407
    Types of Reference Planes ....................... 408
    Reference Planes Explorer ....................... 408
    Reference Planes and Symmetry .................. 408
**Using Reference Planes** ............................ 409
**Creating Reference Planes** ......................... 410
**Deleting Permanent Reference Planes** ............... 411
**Activating Reference Planes** ....................... 412
**Transforming Elements with Reference Planes** .... 413
    Transforming Elements Ref Mode ................ 413
    Transforming Elements Plane Mode .............. 414
**Reference Plane Options** ........................... 416

<table>
<thead>
<tr>
<th>Chapter 18</th>
</tr>
</thead>
</table>

**Snapping** ......................................... 417

**Snapping** ......................................... 418
**Snapping to Targets** ............................... 419
    Overview Target Snapping ........................ 419
    Snapping Manipulation Modes ..................... 420
    Tools Target Snapping ............................ 420
**Defining Targets** .................................. 421
**Setting Options for Snapping to Targets** ......... 424
## Contents

- Controlling Grid Size for Snapping ........................................... 427
- Setting the Grid Snapping Increments for XYZ Modes ............ 427
- Setting the Grid Snapping Increments for View Mode .......... 428
- Setting the Grid Snapping Increments for Plane Mode ......... 429
- Incremental Snapping ................................................................. 429

### Section IV • Data Management

#### Chapter 19

- Data Management in XSI .......................................................... 433
- Data Management in XSI .......................................................... 434
- Where Files Get Stored ............................................................ 435
- Setting a Workgroup ................................................................. 436
- Setting Thumbnails ................................................................. 438
  - Assigning Thumbnails to Scene Elements ...................... 439
  - Viewing Thumbnails in the Thumbnail Viewer ............... 440

#### Chapter 20

- Scenes .................................................................................... 441
  - About Scenes ................................................................. 442
  - Creating Scenes ............................................................... 443
  - Deleting Scenes ............................................................... 443
  - Opening Scenes ............................................................... 444
    - Opening Scenes with Auxiliary Data ....................... 446
  - Merging Scenes ............................................................... 448
  - Image Clips and Merged Scenes ..................................... 449
  - Saving Scenes ................................................................. 450
    - Saving Scenes with a Different Name ....................... 450
    - Saving Scenes to a Different Project ...................... 450
    - Copying Referenced Files Under Project ............... 451
    - Correcting External File Paths for Scenes ........... 451
  - Displaying Scene Information ......................................... 453
    - Displaying Information for Selected Scene Elements 453
  - Getting the Scene Version ............................................... 454
  - Modifying Scene Data with the Scene TOC ..................... 455
    - Enabling Scene TOC Files ........................................ 455
    - Disabling Scene TOC Files ..................................... 455
    - Modifying the Scene TOC ......................................... 456
  - Backing Up and Recovering Your Work ......................... 459
    - Autosaving Scene Files ............................................ 459
    - Backing Up Saved Scenes ........................................ 459
    - Recovering Scene Files ............................................ 460
## Chapter 21: Projects

- What's a Project? ................................................. 464
- The Project Manager .................................... 464
- The Project Structure ........................................ 465
- Creating a New Project .................................. 467
- Opening an Existing Project ........................... 468
- Setting a Default Project ................................. 469
- Deleting Projects .............................................. 469
- Maintaining Project Lists ................................. 470
- Automating Project Lists ................................ 471
- Managing Invalid Projects .............................. 472

## Chapter 22: Models

- What Are Models? ............................................. 474
- Types of Models .............................................. 475
- Models and Namespaces ................................... 476
- Integrating 3D Models with Property Overrides .... 476
- Overview of Models ......................................... 477
- Creating Local Models ...................................... 478
- Selecting and Editing Models .......................... 478
- Merging Scenes as Models ............................... 478
- Exporting Models ............................................. 479
- Importing Local Models .................................... 481
- Image Clips and Imported Models ..................... 482
- Using Referenced Models ................................ 483
- Exploring Referenced Models ......................... 483
- Importing Referenced Models .......................... 484
- Changing the Resolution of Referenced Models ... 486
- Offloading Referenced Models .......................... 487
- Modifying and Animating Referenced Models .... 488
- Updating Referenced Models ............................ 490
- Using External Envelope Deformers ................. 494
- Referenced Models in Groups, Layers, and Partitions ... 495
- Referenced Models and Materials .................... 495
- Referenced Models and Actions ....................... 496
- Deleting Referenced Models ............................ 496
- Converting Referenced Models to Local ............ 496
- Instantiating Models ......................................... 497
- Displaying Instances ....................................... 498
- Viewing Instance Relationships ....................... 499
- Notes on Working with Instances .................... 499
Roadmap
Where to Find Information

The SOFTIMAGE®|XSI® package includes a comprehensive set of learning and reference materials. Use this Roadmap to find the information you need to get up and running quickly and effectively.

Start with the Setup & Licensing guide to install, configure and license all components.

Familiarize yourself with the Limitations & Workarounds for this version, at www.softimage.com/support.

Explore The Principles of XSI—a collection of video clips on DVD-ROM providing overviews of the core features, tools and workflows in XSI. New features for this release are also showcased here.

If you are new to SOFTIMAGE|XSI, work through the Tutorials to learn XSI in the context of basic productions. The tutorials provide a full-color set of lessons showing you how to perform typical tasks step-by-step. You can install the scenes from the Media CD.
Where to Find Information

XSI Online Guides
A complete online library of HTML-based procedural guides on how to use the XSI toolsets (you can install these guides from the Documentation CD):

- Fundamentals
- Animation
- Character Animation
- Nonlinear Animation
- Modeling & Deformations
- Shaders, Lights & Cameras
- Rendering & Compositing
- Simulation
- Customization

Online Help
On-screen reference information on interface elements, commands, and parameters.
To access:
- Click the ? button in any property editor or data view that displays this symbol.
- Choose the Help > Contents and Index menu.

Documentation CD contains:
- Fully updated digital versions of XSI, XSI SDK, BatchServe, and mental ray® documentation.
- Browse documentation on CD, print from PDF, or install XSI user guides on your system and access them in XSI from the Help > Online Guides menu.

XSI SDK Online Guides
A complete online library of HTML-based Developer and Reference guides on how to use the SOFTIMAGE|XSI SDK toolset. To access: open the script editor and click ?.
Context-sensitive help on all scripting commands, objects, methods and properties is available through the online Scripting Reference. To access: open the script editor and choose Help > Scripting Reference or click F1 while you are working in the editing pane.

www.softimage.com
Visit our web site for tutorials and more. Use the embedded Net View to surf XSI Local for samples and tools, or surf XSI Net for scripts, add-ons, and other resources.
Document Conventions

The following are ways that information is displayed in the SOFTIMAGE|XSI documentation.

**Typography Conventions**

<table>
<thead>
<tr>
<th>Type style</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Menu commands, dialog-box and property-editor options, and file and directory names.</td>
</tr>
<tr>
<td><em>Italics</em></td>
<td>Definitions and emphasis.</td>
</tr>
<tr>
<td><strong>Courier</strong></td>
<td>Text that you must type exactly as it appears. For example, if you are asked to type <code>mkdir style</code>, you would type these characters and the spacing between words exactly as they appear in this book.</td>
</tr>
<tr>
<td>&gt;</td>
<td>The arrow (&gt;) indicates menu commands (and subcommands) in the order that you choose them: <code>Menu name &gt; Command name</code>. For example, when you see <code>File &gt; Open</code>, it means to open the <code>File</code> menu and then choose the <code>Open</code> command.</td>
</tr>
</tbody>
</table>

**Visual Identifiers**

These icons help identify certain types of information:

- **Notes** are used for information that is an aside to the text. Notes are reminders or important information.

- **Tips** are useful tidbits of information, workarounds, and shortcuts that you might find helpful in a particular situation.

- The **3D icon** indicates information about differences in workflow or concepts between SOFTIMAGE|3D and SOFTIMAGE|XSI.

- **Warnings** are used when you can lose or damage information, such as deleting data or not being able to easily undo an action. Warnings always appear before you are about to do such an action!
Keyboard and Mouse Conventions

SOFTIMAGE|XSI uses a three-button mouse for most operations. These are referred to as the left, middle, and right mouse buttons. In many cases, you will use the different buttons to perform different operations; always use the left mouse button unless otherwise stated.

- The two-button mouse is not supported in SOFTIMAGE|XSI.
- If you are using a left-handed mouse or other pointing device, substitute primary button for left button, and so on.

This table shows the terms relating to the mouse and keyboard.

<table>
<thead>
<tr>
<th>When this term is used...</th>
<th>...it means this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Click</td>
<td>Quickly press and release the left mouse button. Always use the left mouse button unless otherwise stated.</td>
</tr>
<tr>
<td>Middle-click</td>
<td>Quickly press and release the middle mouse button of a three-button mouse.</td>
</tr>
<tr>
<td>Right-click</td>
<td>Quickly press and release the right mouse button.</td>
</tr>
<tr>
<td>Double-click</td>
<td>Quickly click the left mouse button twice.</td>
</tr>
<tr>
<td>Shift-click, Ctrl–click, Alt+click</td>
<td>Hold down the Shift, Ctrl, or Alt key as you click a mouse button.</td>
</tr>
<tr>
<td>Drag</td>
<td>Hold down the left mouse button as you move the mouse.</td>
</tr>
<tr>
<td>Alt+key, Ctrl+key, Shift+key</td>
<td>Hold down the first key as you press the second key. For example, “Press Alt+Enter” means to hold down the Alt key as you press the Enter key.</td>
</tr>
</tbody>
</table>

Comments?

If you have anything you’d like to say or ask about the SOFTIMAGE|XSI documentation, please do not hesitate to e-mail us at education@softimage.com.
Softimage Customer Service

Technical support in North America for SOFTIMAGE|XSI is provided directly from Softimage Customer Service. Immediate assistance for any technical issue is available through hotline, and through electronic and web support services.

Softimage resellers working together with Softimage Customer Service provide support worldwide.

Licensing Support

You can request your new license file through the license request form provided at softimage.com/licensing or by contacting your reseller directly.

SDK Support

Support for the SOFTIMAGE|XSI SDK is separate from product support for SOFTIMAGE|XSI. The SDK support program provides a private web-based discussion forum where you can talk to fellow developers and submit support questions through our web-based technical support form. The web also provides answers to frequently asked questions, source code examples and case studies. Late-breaking SDK information, workarounds, tips and techniques can also be found in the knowledge base.

Training Support

If you’re interested in SOFTIMAGE|XSI training, you’ll find a complete overview of courses, education centers, and training programs at softimage.com/education.

Hotline Support

If you’ve purchased a maintenance contract to receive support directly from your Softimage reseller, you’ll find assistance for contacting your reseller at softimage.com/Corporate/Sales/Buy/ In all other cases, contact Softimage Customer Service at the following numbers and during these hours:

**World Wide**
Tel:  1 (514) 845-2199  
Fax:  1 (514) 845-8252

**Hours**
9 AM to 7 PM (EST)
2 PM to 12 AM (GMT)
1400 to 2400 (UTC)

**North America**
Tel:  1 800 387 2559  
Fax:  1 (514) 845-8252

**Hours**
9 AM to 7 PM (EST)
2 PM to 12 AM (GMT)
1400 to 2400 (UTC)

**UK and International**
Tel:  + 44 1 753 650 670

**Hours**
9 AM to 6 PM (GMT)
0900 to 1800 (UTC)
4 AM to 1 PM (EST)
Electronic Support

If you have an active maintenance contract and would like to reach us electronically, you will find a Support Request form at http://www.softimage.com/Support/XSI/TechnicalSupport/supportrequestform.asp.

For general inquiries about Softimage support services, send an email to support@softimage.com.

Web Support

The Support and Download sections of softimage.com provide quick access to a wide range of resources from the SOFTIMAGE|XSI teams and user community. Downloads—including Presets, Scripts, and Quick Fix Engineering (QFEs)—provide the latest solutions for XSI. Online user guides, tutorials, and knowledge-base articles ensure you get the most out of working with XSI. It’s like having a dedicated Softimage Customer Service engineer sitting at your desk!

Mailing Lists

If you have an e-mail account, you can join the worldwide network of SOFTIMAGE|XSI users exchanging ideas. To subscribe to the XSI discussion group, send an e-mail to majordomo@softimage.com with subscribe XSI as the body of your message. Use the message lists for information on related groups. Visit softimage.com/Archives/Help.htm for more information about our discussion groups and mail server.

The discussion groups are provided for technical exchanges between customers. Although customer service is not provided through these discussions, we do contribute.

Student/Teacher Program Support

If you’ve purchased SOFTIMAGE|XSI through the Student/Teacher program, installation support is offered by Softimage (see the support contact information above). For usage support, you are welcome to join the XSI mailing lists.
Softimage Customer Service Addresses

North America
Softimage Customer Service
3510 Saint-Laurent Boulevard
Montreal, Quebec
H2X 2V2 Canada

UK and International
Softimage Customer Service Europe
Pinewood Studios
Pinewood Road
Iver Heath, Buckinghamshire
SL0 0NH United Kingdom
Section I • In The Beginning
Chapter 1  XSI® Fundamentals
The Foundations of XSI

SOFTIMAGE® |XSI® is the next-generation, non-linear 3D animation system that integrates modeling, animation, texturing, rendering, compositing, simulating, and scripting into a single, seamless environment.

No matter how you choose to get started with XSI, jump right in and learn as you go or diligently read through the XSI user guides, your understanding of the guiding principles in the design of XSI and of a few core concepts and features are key to successfully using XSI.

In particular, if you are familiar with SOFTIMAGE|3D, knowing what makes XSI different from it will significantly reduce your learning curve.

Read through the topics summarized in this chapter—these are the philosophies, features, techniques, and workflows that are fundamental to working with XSI.
SOFTIMAGE|3D Legacy and Compatibility

SOFTIMAGE|3D Legacy and Compatibility

Given the success of SOFTIMAGE|3D and the fact that there is a large user base that needs to be preserved and supported, it was critical to keep all of the strong concepts of SOFTIMAGE|3D and improve on any weaknesses during the design of XSI.

Compatibility in Workflow

Migrating from SOFTIMAGE|3D to XSI may not seem easy at first, due to ingrained habits. However, the learning period can be significantly reduced when you know that SOFTIMAGE|XSI has maintained compatibility with a lot of the strong SOFTIMAGE|3D workflows.

On the user interface front, the overall look and feel and workflow of SOFTIMAGE|3D was preserved. For example:

- We reused 95% of the base SOFTIMAGE|3D key mappings, especially in regards to navigation, selection, and basic modeling. In addition, we adopted standard key mappings like Ctrl+X (cut), Ctrl+C (copy), and Ctrl+V (paste). (These were not part of SOFTIMAGE|3D as it was not originally designed for Windows operating systems).

- You can immediately recognize the unique left and right panels of SOFTIMAGE|3D also in XSI. However, the layout of commands has been cleaned up so that common functions appear on the right, and the toolbars on the left are designed more logically in a way that will sustain the long-term addition of new tools.

- The typical SOFTIMAGE|3D workflow is that you select objects, apply a command, then pick additional inputs. This is preserved in XSI.

- In XSI, you can still middle-click to repeat the last command used in a menu.
Importing from SOFTIMAGE|3D

An absolute requirement was to be able to take the scene data created in SOFTIMAGE|3D and import it directly into XSI, with proper conversions automatically applied.

SOFTIMAGE|XSI provides full import capability of SOFTIMAGE|3D scene data, including geometry, materials, textures, and animation.

For information on the mechanics of importing scene data, see Chapter 24: Importing and Exporting on page 515.

To make informed decisions about what you can and should import from SOFTIMAGE|3D for re-use in XSI, see Chapter 25: Considerations for Importing SOFTIMAGE|3D Scenes on page 525.

You can reuse models and animated characters from SOFTIMAGE|3D. The trick is learning what you should import to take full advantage of the new animation and rendering features in XSI.
Functionality, Productivity and Workflow

XSI offers innovative functionality and a host of ways to speed up your workflow so that more time is spent on actual 3D work and fine tuning—essentially boosting your productivity.

Architecture

Among all requirements needed to build any new 3D software, the most important one is a strong base architecture.

XSI has a node-based architecture that is modular and extensible. In XSI, everything is relational by default, operators are stacked and can be edited, and then frozen when desired. In addition, for much better editing capabilities, the operator architecture pulls data only when needed—a processed known as “lazy evaluation”—which was not possible in SOFTIMAGE|3D.

Projects and Databases

In SOFTIMAGE|XSI, you always work within the structure of a project. A project is a system of folders that contain the scenes that you build and any external files they may reference. Projects keep your work organized and provide a level of consistency that you can use to simplify production for a workgroup.

The very first time you run XSI, the Project Manager opens and prompts you to create a new project in which to store your XSI scenes. You can store an unlimited number of scenes within a project.

For more information, see Chapter 21: Projects on page 463.
XSI Scenes

A scene file contains all the information necessary to identify and position all the models and their animation, lights, cameras, textures, etc. for rendering. All the elements are compiled into a single file with an .scn extension. Scenes can also reference many external files such as external and referenced models, texture images, scripts, and audio clips. Some of these referenced files may be located outside of your project structure.

XSI Models

Models are a powerful way of organizing objects in your scenes and projects. They act as a container for objects, usually hierarchies of objects, and many of their properties. In the explorer, models are distinguished by special icons.

Each model maintains its own namespace. This means that each 3D object in a model’s hierarchy must have a unique name, but 3D objects in different models can have the same name. For example, two characters in the same scene can both have chains named left_arm and right_arm because they are in different models.

Moving and Sharing Objects between Scenes

Models are like “mini scenes” that can be easily reused in scenes and projects. In fact, exporting and importing models is how you can copy and share objects and object hierarchies between scenes.

To take full advantage of models, see Chapter 22: Models on page 473.
XSI Interaction Model

The interaction model controls how XSI interprets mouse and keystroke interaction. The interaction model sets the mapping of keyboard shortcuts to XSI commands, determines whether or not sticky keys are available, which tool is active by default, and how key and mouse buttons are used to select objects and components in 3D views.

You are asked to choose an interaction model the first time XSI is run. It is recommended that you choose the SOFTIMAGE|XSI interaction model because it is optimized for use with all XSI tools. Its use of the Ctrl and Shift keys is consistent with many other applications.

However, you may be more familiar (and therefore more productive) with the SOFTIMAGE|3D model. The model you choose is a matter of preference.

```
Interaction Model

Choose your preference for keyboard and mouse interactions:

- **Softimage | XSI** (Recommended)
  - Optimized for efficiency as well as compatibility with Softimage | 3D

- **Softimage | XSI with Extended Component Selection**
  - Hybrid interaction settings recommended for SOHO users.

- **Softimage | 3D**
  - Preserves most of the Softimage | 3D keyboard and mouse interactions

```

For information about changing the interaction model and customizing your keyboard shortcuts, see *Changing Interaction Preferences* on page 551.

The XSI Selection Model

Another important productivity design in XSI is the ability to work on multiple elements at once. We designed all services to work on multiple selections, such as opening property editors on multiple or shared properties. The text boxes allow for typing wildcards to quickly select series of objects. You can even quickly set multiple values following a linear or random distribution anywhere in the interface.

Single and Multi Selection Modes

There is no distinction between Single and Multi selection modes like there is in SOFTIMAGE|3D. Everything in XSI works equally well with single or multiple selections. You can always add objects to the selection with the Shift key. Operations are performed on all selected objects; if certain operations do not apply to certain selected objects, those objects are ignored.
To boost workflow productivity, you can use shortcut keys to work faster, and XSI makes sure that frequent operations have dedicated shortcut keys. Menus all come with mnemonics (displayed as underlined letters in menu and command names), allowing for more shortcuts that are easy to remember. For example, to create a surface sphere, you have to click the Primitive menu while pressing the s key twice.

**Sticky vs. Supra Mode**

You can use tools in supra (temporary) mode by pressing keys down as you work, or in sticky mode by quickly pressing and releasing. This is a big workflow change for SOFTIMAGE|3D users.

For more information, see *Using Shortcut Keys to Activate Tools* on page 72.

**Drag and Drop**

XSI supports the drag and drop working method for a wide variety of operations. You can perform these operations by clicking one item with your mouse and dragging it onto another item.

For example, you can drag an image file from the XSI browser, a net view page, or a Windows explorer onto an object to create a texture. Likewise, you can drag a model or scene file onto a 3D view background to merge it into your current scene, or drag a script file onto a toolbar to quickly create a button. You can also drag and drop within an explorer to create object hierarchies, copy objects and properties, re-order an operator stack, as well as add objects to a group, partition, or layer.

Drag and drop to create a hierarchy. Drag and drop from the browser to the custom toolbar.
**XSI is Non-modal**

XSI was designed to be as interactive as possible. One main difference with its predecessor is that it is non-modal. In SOFTIMAGE|3D, changes done in a dialog box have to be confirmed before being applied, and you cannot interact with the scene while a dialog window is open.

In XSI, updates happen as soon as you enter values in property editors: you do not need to click OK and exit a property editor to see your modifications. You can manipulate the camera or even change selection while property editors are open. You can even continue working while a playback is in progress, thanks to the multi-threaded nature of the XSI user interface.

**Properties and Property Editors**

All objects are defined by sets of parameters called *properties*, and can be edited using a property editor. Property editors are the primary tool for editing properties, but you can also use virtual sliders to change parameter values (see *Entering Values Using Virtual Sliders* on page 85.)

For more information, see *Modifying Properties in Property Editors* on page 77.
Global and Local Coordinate Systems

The location of an object in 3D space is defined by a point called its center. This location can be described in more than one way, or according to more than one frame of reference.

For example, the object’s global position is expressed in relation to the scene’s origin. The object’s local position is expressed in terms of the center of the object’s parent.

The center of an object is only a reference—it is not necessarily in the middle of the object because it can be relocated (as well as rotated and scaled). The position, orientation, and scaling (collectively known as the pose) of the object’s center defines the frame of reference for the local poses of its own children.

Transformations

Transformations are fundamental to working in 3D. They include the basic operations of scaling, rotating, and translating.

Local versus Global Transformations

There are two types of transformation: local and global.

- Local transformations are stored relative to an object’s parent.
- Global transformations are stored relative to the origin of the scene’s global coordinate system.

The global transformation values are the final result of all the local transformations that propagate down the object hierarchy from parent to child.

Animating Transformations

You can animate either the local or the global transformation values of an object. It’s usually better to animate the local transformations—this lets you branch-select an object’s parent and move it while all objects in the hierarchy keep their relative positions. When you activate a transformation tool, the corresponding local transformation parameters are automatically marked for animation.

If you animate both the local and the global transformations, the global animation takes precedence.

For specifics on how to animate transformations, see Animating Transformations in Chapter 2 of the Animation guide.
Manipulation Modes

When you transform interactively, you always do so using one of several manipulation modes. The mode determines which coordinate system is used for manipulation.

It is important to realize that the mode affects the interaction only. In particular, Local and Global manipulation modes control the frame of reference used for mouse movement and not whether the stored values are local or global.

For a full explanation of all issues related to transformations, see Chapter 16: Transformations on page 351.

XSI is Object-Oriented

Everything in XSI exists as an object or a structure of objects. The most common objects are geometric objects, but cameras and lights are also considered objects, as well as elements that serve as controls for other objects, such as waves and manipulators.

This modular and consistent approach lets objects be treated in similar ways. Each can be selected, transformed, animated, and edited according to the same rules. This approach is also very helpful when writing plug-ins for XSI because you do not need to worry about a lot of exceptions.

Standard Object Behaviors

The XSI architecture enforces consistent behaviors for objects and for the interface. For example, in SOFTIMAGE|3D some objects like lights and cameras cannot be parented, lattice are not real objects, etc.

In XSI, a relatively small but systematic set of nodes and behaviors was designed. For example, objects that can have a position in 3D space can be parented (thus their name 3D objects). All properties of objects live in similar property sets that can be dragged and dropped, propagated through hierarchies, etc.

Sensible Default Behaviors

A factor than can speed up workflow is the incorporation of sensible default behaviors to avoid unnecessary steps. For example:

- When an operator is applied on tagged points, a cluster is created automatically to track the points and serves as input to the operator.
- Creating a lattice when one or more objects are selected will size the lattice to the selection and apply it.
- When you apply a weight map-enabled deformation, if a weight map is already selected it will be connected automatically.
A Null is a Null

Nulls are points in space. Although simple, they have many uses, such as setting constraints, organizing objects in hierarchies, and so on. A null is displayed in the 3D views as three intersecting lines, and is not visible in a rendered scene.

A skeleton effector, camera interest, spot interest, model root, or cluster center are also nulls and behave like any other generic null in XSI.

3-Node Cameras and Lights

By default, cameras and certain lights have a 3–node structure consisting of the camera or light, its interest, and its root. The root is a null that is parented to the object and the interest. The camera or light object points to its interest by a standard direction constraint.

The 3–node structure provides an extra level of control when you are positioning and animating your cameras and lights. You can delete the constraint and manipulate your lights and cameras directly, removing the threat of camera flipping if you need to animate special moves.

A default camera and spotlight displayed in the schematic and explorer views.
Visual Feedback in 3D Views

XSI provides strong visual feedback on what is happening, so that you can understand how the data is set, what is being selected, etc.

Since the focus of an animator is typically on the 3D views, informational feedback is designed and integrated directly in these views. This includes drawing links in the views (and even using the link to access information about them, such as constraints and expressions), displaying useful information on the view boundaries (like on screen displays for airplane pilots), and providing you with the ability to customize what can be displayed on screen (such as custom display information property sets).

For high-quality visuals, our strong OpenGL display represents as closely as possible the final look (with particles or hair for example) to allow for faster and more accurate editing before a render region is even needed.

Explorer and Schematic Views

The explorer and the schematic views are both hierarchical representations of your scene's data (for this reason, they are referred to as data views). You will use these two views often to manipulate and analyze the relationships between the objects in your scenes.

The explorer displays the contents of your scene in a tree that shows all objects and their properties displayed as a list of nodes that expand from the scene root. The schematic view is a graph–like hierarchical structure that emphasizes the relationship between objects. Its links show the hierarchy of objects and how objects are constrained to each another. As well, material and texture nodes indicate how each object is defined.

For more information, see Chapter 4: Views on page 103.
Modeling

Modeling is the task of creating the objects that you will animate and render. Here are a couple of the concepts you should know when modeling in XSI.

**XSI is Operator-Based**

Every deformation or topology modification you make to an object is stored as an operator in the object’s construction history. At any time, you can go back in the history and change a parameter in an operator, or even delete an operator entirely. However, every operator increases the amount of stored data and can slow down performance. When you are satisfied with an object’s modeling, you can freeze the object to remove its history stack.

**Topology Operators and Deformations**

There is a difference between topology operators (things that create or destroy points or other object components) and deformations (things that move points around). For best results, you should finish all topology operations before applying animated deformations like envelopes or doing any texturing.

You can reorder operators in the history stack, but there are limitations.

**Polygon Meshes and NURBS**

XSI supports only polygon meshes and NURBS (curves and surfaces). Other types of geometry are converted when imported.

For more information, see the *Modeling & Deformations* guide.
XSI makes high-level animation easy for animators, as well as for more technical artists. The animation tools in XSI are designed to cope with an increasing amount of complexity in animation and allows the animator to use the best tool for the job, not forcing any one particular solution. On simple productions, basic keyframing can do the job. For larger productions, the nonlinear animation tools can be used to manage and reuse animation at a higher level.

In addition, technical directors can build better and more efficient rigs for animators, with more flexible IK control, constraints, expressions, but also using innovative interface concepts such as custom and proxy parameters, and web-enabled net views and synoptic views.

In XSI, there are different levels at which you can animate. For example, you can animate at the lowest level by keying a specific parameter, or you can animate at a high level by mixing together blocks of animation. Between these extremes are many other methods such as creating secondary animation driven by an initial animation, or by dynamically simulating natural phenomena.

Animatign at a low level means getting down to the parameters of an object and animating their values. And in XSI, you can animate almost every parameter.

Marking Parameters

An important part of the animation process is marking parameters. Marking allows you to select which parameters will be keyframed for an object, copied or removed from objects, or stored in an action to be used in the animation mixer. You can also mark parameters to be used when scaling or offsetting an animation, or with linked parameters or scripted operators.

By marking only the parameters you need, you can keep the animation information small. While you don’t need to mark parameters for keying, you’ll find it to be an efficient way of working.

You can also have XSI “remember” which parameters you marked on an object. For example, if you’re always keying the rotation of a certain bone, you can save a marking memory set with those parameters, and then just call up the set when you need it.

For more information on marking parameters and memory sets, see Chapter 2: Basic Animation Tasks in the Animation guide.

Animation Editor

The animation editor lets you control the animation of a selected element. You can have different types of animation editing tools in the view area of the animation: the function curve graph (the default), the dopesheet, the expression editor, or the scripted operator editor.
Chapter 1 • XSI Fundamentals

**Character Setup**

In XSI, you’ll find everything you need to build and bring your characters to life—from envelopes and skeletons to control rigs and weight painting, it’s all there.

**Skeletons**

Skeletons provide an intuitive way to pose and animate your model. You can build skeletons using chains, any kind of object, or a combination of both. The objects and chains of a skeleton are usually connected in a hierarchy.

**Effectors**

The effector is a null at the end of a chain. Moving the effector invokes inverse kinematics (IK), which modifies the angles of all the joints in the chain between the root and the effector.

In XSI, the effector is the child of the chain root. Transformations on the effector are in local space. You can place the effector anywhere in the chain’s hierarchy or even make it the child of an object outside of the chain.

Chains loaded from a SOFTIMAGE|3D scene retain their original hierarchical structure—the effectors’ orientation and position is global, not local (the effector is a child of the last bone in this case instead of being a child of the chain root, as is default in XSI.)

For more information, see the *Character Animation* guide.
Non-linear Animation

The powerful animation mixer lets you mix, transition, and combine function curves, expressions, constraints, shapes, audio, and images in a familiar non-linear environment.

Actions

Actions are “packages” of low-level animation, such as function curves, expressions, constraints, and linked parameters, that you define once and apply as many times as you like. You can create an entire library of actions, like walk cycles or jumps, and share them among any number of models.

After you create an action, you load it as a clip in the animation mixer, where you can modify the animation in a nonlinear and non-destructive way.

You can move an action around, squeeze or stretch its length as you like, apply one after another in sequences, and mix two or more actions together to create a new animation. Working with complex animation data becomes a simpler task than dealing with multiple function curves.

3D Actions in XSI are not the same as those in SOFTIMAGE|3D. In SOFTIMAGE|3D, actions are elements within an animation file. In XSI, actions are separate elements internal to the scene. You can import and export actions to and from SOFTIMAGE|3D animation files.

Before you delve into the world of actions, see Chapter 3: Actions in the Nonlinear Animation guide.
Chapter 1  •  XSI Fundamentals

**Shape Animation**

With shape animation, you can animate the geometrical structure of an object using clusters of points. You can use either surface (NURBS) or polygon objects to create shape animation; however, shape animation works only with clusters of points.

This means that you can create different clusters on an object and create shape keys for each of them; or you can treat a complete object as one cluster and save shape keys for it.

In XSI, shape keys correspond to what cluster keys are in SOFTIMAGE|3D. XSI has no equivalent to what are called shape keys in SOFTIMAGE|3D.

When you’ve created your shape keys, you can blend between them, changing their weighting against each other, adding new shapes, replacing shapes—all in the animation mixer.

Although the animation mixer calculates all shape animation, you don’t need to actually open it to do shape animation. You can set up different shapes, select shape keys to be applied to an object, and then create a slider panel using custom or proxy parameters.

For more information, see Chapter 4: Shape Animation in the Nonlinear Animation guide.
Shaders—Materials, Textures, and More

A shader is a miniature computer program that controls the behavior of the mental ray® rendering software during or immediately after (in the case of output shaders) the rendering process. Some shaders are invoked by mental ray to compute the color values of pixels, other shaders can displace or create geometry on the fly.

There are many different types of shaders: surface (material), texture, environment, volume, shadow, photon, light, lens, and so on.

Material Node vs. Material in SOFTIMAGE|3D

The Material node in SOFTIMAGE|XSI doesn’t have quite the same function as it does in SOFTIMAGE|3D. What were called material shaders are now more accurately named surface shaders.

The Material node acts like containers for all of the possible shaders that you can apply to an object, much like the Material Editor in SOFTIMAGE|3D.

Texturing

The texturing pipeline is completely open in SOFTIMAGE|XSI. A texture applied to an object consists of the actual texture image, a texture support, and a texture projection. The texture support controls how a 2D texture is applied to a 3D object, while the projection records where the texture appears on the object. A single support can hold multiple projections.

Texture supports are hard–wired to each texture assigned to an object in SOFTIMAGE|3D. In XSI, they are separate objects that can be animated, constrained, or placed in a hierarchy like any other object.
Chapter 1  •  XSI Fundamentals

**Image Clips and Sources**

Every time you select an image to use as a texture or for rotoscopy, an image clip and an image source of the selected image is created.

- A source image is the original image file copied into a folder.
- An image clip is a copy or instance of an image source file.

Each time you use an image source, its image clip is created. You can have as many clips of the same source as you wish. You can then edit, crop, or blur the image clip without affecting the original source image.

**SOFTIMAGE|3D Shaders**

Although you can import SOFTIMAGE|3D shaders into XSI scenes, you will not be able to extend or modify them in the render tree. These shaders act as self-contained units.

**Realtime Shaders**

You can use the render tree to create networks of Realtime shaders in the same way that you create networks of mental ray shaders. However, the process of building Realtime shader trees is somewhat different, since you are building the effect in several layers, each of which is drawn separately and then blended with the following layer. Realtime Shader trees connect to the material node's Realtime input, and you can connect them to objects that already have mental ray shaders attached.

For more information, see the *Shaders, Lights & Cameras* guide.
Rendering

Drawing upon mental ray's rendering technology, XSI offers full-resolution interactive photorealistic rendering, caustics, global illumination, and motion blur.

Render Passes

Render passes were introduced to answer real issues that productions faced with the creation of increasingly complex composites of rendered scene elements. Before passes were introduced, you would have to duplicate the scene data as many times as there were passes, and then set a number of rendering settings. Any changes to the scene or the animation meant redoing the render pass setup.

With passes, you can composite elements together by breaking the scene into smaller render passes (such as specular, shadow, highlight, caustic, matte)—all in a single scene. Each of these passes can then be edited non-destructively.

Interactive Render Region

One of the most innovative aspects of XSI in terms of interactivity is the render region, which allows you to select a portion of a 3D view to be rendered interactively using mental ray while you modify the values. You can achieve high levels of interactivity with what was usually seen as a very iterative process. XSI provides such interactivity, even when using high-end rendering functionality such as raytracing, caustics, etc.

Rather than setting up and launching a preview, you can simply draw a render region in any 3D view and render it interactively. Depending on its settings, the render region can render the scene in the same way as a final output render. This gives you a very accurate preview of what your final rendered scene will look like.

Each time you change properties that affect the appearance of objects in your scene, the region is automatically refreshed. You do not have to wait for the region to finish refreshing to make more changes to your scene—a change simply interrupts the current refresh and restarts it to include the updates you have just made. This allows you to do iterative adjustments on the properties.
Chapter 1  •  XSI Fundamentals

Render Tree
The render tree lets you connect shaders or nodes together to build a visual effect. Each node exposes a set of properties that can be dynamically linked by connecting the output of one property to the input of another. Building effects this way offers a tremendous amount of flexibility, but it may take some getting used to.

FX Tree
You can use the FX Tree to apply effects to clips in your scene. Keep in mind however, that the FX Tree is an operator in the scene and deleting it will also delete any associated effects.
XSI is Customizable

You can customize XSI to suit the way you work or optimize the workflow for a particular project’s demands. You can change the interface’s appearance (custom layouts and toolbars), default settings and paths (user preferences), and keyboard and mouse interaction (keyboard mapping). You can create property presets, custom views (synoptic views), and tools (scripting). You can also package many of these elements as add-ons and share them across a workgroup.

You can customize the user interface without coding. For example, you can build custom layouts and toolbars interactively. Functional customization such as building macros and simple scripts is easy for most users. You do not need to be a developer to create a repeatable macro or build a simple tool.

For more information, see the Customization guide.

Scriptable

XSI uses standard scripting languages. With the ActiveX technology, XSI can support any ActiveX compliant scripting engine, such as VBScript, JScript, ActivePerl and ActivePython. This is ideal because you are not forced to learn a proprietary language and it allows you to easily automate repetitive tasks, build macros, customize the interface, and interface with other ActiveX compliant applications, such as a database, a spreadsheet, e-mail, web pages, etc.

Do not be afraid of scripts! They are a powerful way of customizing and extending your toolset and workflow. Every command you issue through the XSI interface is logged in the command history. You can use this log as the basis for writing your own scripts, or you can write scripts from scratch using XSI’s object model API.

SOFTIMAGE|XSI SDK

XSI offers a comprehensive Software Developer’s Kit (SOFTIMAGE|XSI SDK) that lets you program custom effects, objects, and properties for an optimum level of pipeline customization.

There are in fact two levels of SDK in XSI: the scripting commands that get logged for each operation and that can be used to create macros and a variety of scripts, and the Object Model which is designed to allow access to any data element in a scene.

The Object Model defines a hierarchy of objects that can be used to create custom operators and plug-ins. One potential source of confusion is that both scripting commands and Object Model can be used with the standard scripting engines, however you can also write plug-ins based on the object model using C++ and compiled code.
This flexibility allows you to choose the best tool for your needs, such as writing an automation script for internal production use versus writing plug-ins for third-party development. In the case of plug-ins for sale, using compiled code is definitely a must.

For more information, see the SDK developer guides installed with XSI and available on the Documentation CD.

**Moving and Reusing 3D Data with dotXSI**

You may want to use XSI to create data to be used by some other external application in a next step, such as a web browser, a game engine, etc. To do this, you must take the desired aspects of the 3D scene and export them in some way that is compatible with the target platform. The Softimage games team designed a file format called dotXSI, which is based on the general principle of Microsoft Direct3D’s “X” files, but with many additional templates to store advanced 3D scene information such as IK, constraints, etc. The dotXSI format has gained a lot of popularity among Softimage users world-wide, especially as a “platform-independent” solution for 3D data interchange, allowing game companies to easily move and reuse 3D data for a game title that is being developed for multiple platforms.

The XSI Viewer application provides a means for designers to validate their work on the target platform.

To facilitate the use of dotXSI files, the FTK (File Transfer Kit), a free downloadable library which can be linked with any application to provide read and write capabilities for dotXSI files, allows developers to introduce XSI into any existing pipeline efficiently, and at minimal cost.
Chapter 2  Starting SOFTIMAGE|XSI
Chapter 2  •  Starting SOFTIMAGE|XSI

Starting SOFTIMAGE|XSI

The method you use to start SOFTIMAGE|XSI depends on which operating system you're using: Windows or Linux. Methods for starting on both operating systems are described in this section. Exiting the application is the same on the two operating systems (see Exiting XSI on page 64).

Starting XSI on Windows

There are several ways to start on a Windows system:

• Using the Start menu (see below).

• Using the command line (see Starting from the Windows Command Line on page 54).

• From a shortcut you create on your desktop or by double-clicking on the Windows batch file called xsi.bat. By default, the batch file is located in the C:\Softimage\XSI_4.0\Application\bin folder.

Starting with the Windows Start Menu

If you installed in the default configuration, you can start from the Windows Start menu in the lower-left corner of the Windows desktop. To do this:

• Choose Start > Programs > Softimage Products > SOFTIMAGE XSI 4.0 > XSI.

Starting from the Windows Command Line

Starting from the Windows command line lets you specify various startup options, such as the project you want to load.

To start from the Windows command line

1. Open a command-prompt window. If your Start menu is in its default configuration, you can choose Start > Programs > Softimage products > SOFTIMAGE XSI 4.0 > Command Prompt.

2. To start without any options, type:

   XSI

   If you use a standard command prompt to start XSI, type:

   xsi.bat

   To start and load a specific project list or scene file, type the startup option on the same line after the above command. For example, to start with a specific scene, type:

   XSI <scene_file_name.scn>

   Once XSI has started, you can exit the command prompt window at any time.

   For a list of command-line options you can use when starting XSI, type xsi -h.
Creating a Shortcut for Starting on Windows

To create a shortcut to XSI on the desktop

1. From the Windows Explorer, go to the directory where the XSI batch file (xsi.bat) resides. By default, this should be in `<Softimage\XSI_4.0\Application\bin`.
2. Right-click the xsi.bat file and choose Create Shortcut.
   A shortcut to the batch file is created.
3. Drag the shortcut icon to your desktop.
4. Start XSI by double-clicking the shortcut icon.
5. To change the name of the shortcut, click the icon’s name once and then type a new name.

To modify a shortcut by specifying startup options

1. Right-click the shortcut icon and choose Properties from the pop-up menu.
2. On the Shortcut tab of the Shortcuts dialog box, add any desired options to the command line in the Target text box. Make sure the entire command, including the options, are enclosed inside quotation marks.

For more information about the desktop, shortcuts, the Windows Explorer, and folder windows, please see your Windows operating system documentation.
Starting XSI on Linux

\texttt{xsi} (lower case letters) is a script that sources .\texttt{xsi\_4.0} (the environment script) and then executes the \texttt{XSI} (upper case letters) software.

You can choose to source the environment script first when you open a shell and then run \texttt{XSI} or you can change directories to \texttt{<XSI installation path>/Application/bin/} and run \texttt{xsi} (the script) directly.

\textit{To start XSI from a shell}

1. Open a terminal.
2. From your user account, type \texttt{source ~/.xsi\_4.0}
3. Type \texttt{XSI} at the prompt. The welcome screen appears.

   \textit{or}

   1. Open a terminal.
   2. Change directories to:
      \texttt{<XSI installation path>/Application/bin/}.
   3. Type \texttt{xsi} (lower case letters). The welcome screen appears.

\textit{To create a shortcut for starting XSI}

There are a number of window managers that you can choose to install on Linux, and therefore, there is no one particular way to create an icon on your desktop or add a menu item to start XSI. Refer to your window manager’s documentation for more information.

If you create a shortcut on the desktop or in the menu bar/task bar, make sure it runs the \texttt{xsi} script directly, which will automatically source the environment script before running XSI.
XSI and Window Management

XSI runs in its own window, which means that you can minimize, maximize, resize, and move it as you would any other window. You can also switch between it and any other open window (Alt+Tab for Windows). For more information about these tasks, refer to your operating system documentation.

On Linux, there are many window managers that can be used and the options they offer are all very different and quite customizable. By default, XSI does not obey any window manager keystrokes. For example, Alt+Tab is used to switch tasks in Gnome, but it does not work with XSI.

You can set an environment variable so that XSI uses your window manager’s windowing system. In a shell, enter the following lines to start XSI:

```bash
source .xsi_4.0
setenv MWWM allwm
XSI
```

Now Alt+Tab will switch windows.

In the case of Gnome and the Sawfish window managers, Alt+left-mouse-button is used to move windows around; however, this key binding is also used by XSI for another purpose.

To avoid this conflict, you can either install and use a different window manager or run XSI without a window manager. To do this:

- On the Red Hat log-in screen, choose **Session > Failsafe** and log in. An xterm opens where you can source and start XSI. See *Starting XSI on Linux* on page 56.

For more details, consult the documentation for your preferred window manager.
Chapter 2 • Starting SOFTIMAGE|XSI

XSI Startup Options

There are a number of startup options that can be used for starting XSI. These options allow you to perform a variety of tasks. For example, you can control which license token gets grabbed at startup, and which component of XSI to run, such as batch rendering or scripting. You can also specify a project list or scene to load, install and uninstall add-ons, and set workgroup paths: all at the command line.

To get a list of command-line options you can use when starting XSI, type:

\texttt{xsi -h}

\textbf{Usage}

\texttt{xsi [licensing options] <.scn file> [-projlist <projectlistfile>][-r <batchrenderoptions>] [-script <scriptname> <scriptoptions>][-i <.xsiaddon|.spdl file>] [-batchuni <pluginoptions>][-u <.xsiaddon|.spdl file> <pluginoptions>][-l <filteroptions>][-w <path>]

\texttt{[-migrate <previous user preferences path to migrate>]} [-auxiliary_data <auxiliary data file>]

\texttt{[-uilang <languageid>] [-helplang <languageid>]}

\textbf{Licensing Options}

- \textbf{academic} Only grab an academic license.
- \textbf{batchonly} When running in batch mode, XSI will not fall back to an interactive token.
- \textbf{batchuni} When running in batch mode, XSI will start license check with Batch Universal.
- \textbf{essential} When an interactive XSI session is launched, only grab an Essential token (do not fall back to a Foundation token).
- \textbf{foundation} When an interactive XSI session is launched, only grab a Foundation token.
- \textbf{nobatch} When running XSI in batch mode, XSI will not grab batch tokens; instead, it will only use interactive tokens.
- \textbf{nofallback} When an interactive or batch XSI session is launched, only try the default or specified token (don’t fall back).
- \textbf{processing} Will grab an Advanced Processing token or fall back to an Essential Processing token. Render is disabled with such tokens.
-thread <# MaxThread>

Specifies the maximum number of CPU intensive threads XSI will use (render, compositing, etc.)

If both -essential and -advanced are present, then -advanced is ignored. If both -batch and -nobatch are present, then the application will not start because no license will match. All other combinations are good.

Command Line Options

-projlist <projectlistfile>

Specifies the project list to be imported in the Project Manager.

-r <batchrenderoptions>

Batch render according to batch render options.

-i[install] file <pluginoption>

Install add-on file which can be specified as either a .spdl or .xsiAddon file. By default, add-ons are installed in the factory root location and others are installed in the user root location; use -dest to specify a different location. File name wildcards are not supported.

-u[ninstall] file <addonoptions>

Uninstall the given .spdl or .xsiAddon file.

-l <filteroptions>

List user add-ons according to the filter options.

-w <path>

Set the workgroup to a given path.

.<scn file>

Starts XSI and opens the specified scene.

-migrate <previous user preferences path to migrate>

The -migrate option takes as argument a path containing preferences to be migrated to the currently running XSI (the one executing the -migrate option).

-auxiliary_data <auxiliary data file>

Loads an auxiliary data file on startup. Data is automatically applied on post-load when the .scn file argument is also defined.

-script <scriptname> <scriptoptions>

Executes the specified script without launching the XSI user interface. This is useful for performing batch operations on scenes.

-uascript <scriptname> <scriptoptions>

Executes the specified script in the XSI user interface. This is useful for performing batch operations that
require the interface, for example, capturing realtime output in a custom display.

-uilang <languageid>
  Specifies the language of the XSI user interface: en for English or jp for Japanese.

-helplang <languageid>
  Specifies the language for the online help: en for English or jp for Japanese.

For more information about project lists and loading scenes, see Chapter 21: Projects on page 463.

Batch Render Options with -r

-continue
  Omit the continuation prompt (optional).

-h
  Get additional help on other batch render options.

For more information on batch rendering and the render options available, see Batch Rendering Basics (XSI -R) in Chapter 4 of the Rendering & Compositing guide.

Script Options with -script or -uiscript

-lang <language>
  Specifies desired scripting language (optional).

-main <function>
  Specifies function entry point (optional).

-continue
  Omit the continuation prompt (optional).

-args <argument list>
  List of function arguments specified as -<argname><argvalue> for each argument.

For more information, see Rendering with Scripts (XSI -Script) in Chapter 4 of the Rendering & Compositing guide.

Plug-in Options with -i or -u

-dest <factory | user>
  Specifies the installation destination (default destination is user for SPDL and factory for Add-ons).

-run
  Instructs XSI to continue execution once the Add-on operations are done (optional).

-silent
  Does not start a new shell to display the execution status.

-overwrite
  If the item (such as toolbar,spdl, etc.) already exists, it will be overwritten.
**For SPDL only**

- **-d name** Specifies the third-party installation directory (optional).

- **-n name** Specifies the plug-in name (optional, ignored if `-d` is not specified). The plug-in name can be used as a sub directory of the third party installation directory.

  **Example**
  
  xsi -i abc.spdl -d MyCompany -n TheABCPlugin
  
  This creates the following directory structure:
  
  `<InstallPath>\Addons\MyCompany\TheABCPlugin\Application\SPDL`

  For more information about add-ons and how to install and uninstall add-on elements from the command line, see *Chapter 11: Sharing and Managing Customizations* in the *Customization* guide.

**Filter Options**

The filter options are *all* (the default), **layout**, **tbar** (toolbars), **kmap** (keyboard mappings), **cmap** (command maps), **shader**, **cpset** (custom parameter sets), and **scriptop** (scripted operators). You can also combine these, such as: “layout,tbar” or “cpset,scriptop” with no space between tokens.

  **Example**
  
  xsi -l layout,tbar

**Migration Options with -migrate**

- **-copy_only** Specifies a copy-only migration (no registration) of the previous user’s preferences.

- **-register_only** Specifies a register-only (no copy) of the user’s preferences (administrative privileges required).

- **-overwrite** By default, the `-migrate` option fails if the user’s preferences already exist. Use this switch to force the migration process and overwrite any existing user preferences.

  Preferences migration can be done automatically during the XSI Setup process.
Once You’re Up and Running...

If you are starting XSI for the first time, you are prompted to choose an interaction model and then create a project from the Project Manager.

Interacting with XSI

The interaction model controls how mouse and keystroke interaction will be interpreted in XSI. The interaction model sets the mapping of keyboard shortcuts to XSI commands (key map), whether or not sticky keys are available, which tool is active by default, and how key and mouse buttons are used to select objects and components in 3D views.

It is recommended that you choose the SOFTIMAGE|XSI interaction model because it is optimized for use with all XSI tools.

For more information about changing your interaction preferences and customizing your keyboard shortcuts, see Changing Interaction Preferences on page 551.

See also Selecting Objects Using the Different Interaction Models on page 227 and page 233.
Creating the First Project

In XSI, you always work within the structure of a project. Projects exist as folders and contain scene information in the form of scene description files. Scene files are recognized by their .scn file extensions. A project can contain an unlimited number of scenes.

The first time you run XSI, you are automatically editing an empty new scene in the XSI_SAMPLES project.

- To create a new project in which to store your own XSI scenes, choose File > New Project.
- To add an existing project on your computer or network to your project list, choose File > Project Manager.

For more information, see Chapter 20: Scenes on page 441 and Chapter 21: Projects on page 463.
Exiting XSI

After you have completed your work session in XSI, save your work and exit. Depending on your preferences, any changes you made to your workspace layout are saved when you exit and are automatically recalled the next time you start XSI.

To exit XSI

1. Do one of the following:
   - Choose File > Exit from the main menu bar.
     or
   - Click the close icon (×) at the far right of the title bar.
     or
   - Press Alt+F4.
     or
   - Press Ctrl+q.

2. If you have made any changes to the scene or the layout, you are prompted to save them before exiting. Click one of the following:
   - Yes to save your changes. For more information about saving scenes in general, see Saving Scenes on page 450.
     or
   - No to exit without saving.
     or
   - Cancel to continue working.
Chapter 3  Interface—Commands and Tools
Chapter 3 • Interface—Commands and Tools

The SOFTIMAGE|XSI Interface

The XSI interface is composed of several toolbars and panels surrounding the viewports that display your scene.

**Viewports**
Let you view the contents of your scene in different ways. You can resize, hide, and mute viewports in any combination. See *Working with Views Docked in the Viewports* on page 105 for details.

**Title bar**
Displays the version of XSI, your license type, and the name of the open project and scene.

**Main menu bar**
Provides access to all the primary commands.

**Toolbar**
Displays one of four default toolbars used in modeling, animation, rendering, and simulation. Press 1, 2, 3, or 4 on the keyboard to switch between toolbars.

**Toolbar/Palette icons**
Switch between toolbar and other panels. You can also press Ctrl+1 for the toolbar panel, Ctrl+2 for the hair panel, Ctrl+3 for the weight paint panel, and Ctrl+4 for the palette panel.

**Context panel**
Select the context for adding operators to the geometry stack. See *Construction Modes and Regions* in Chapter 3 of the *Modeling & Deformations* guide.

**Lower interface controls**
(See page 68 for details.)

The image above shows the XSI Standard layout, which is the default. However, you can choose other layouts from the *Application > Layout* menu. You can even create your own layouts as described in the *Customization* guide.
Main Command Area

The main command area on the right side of the screen contains all the commands and tools you will use most frequently while working in your scene. Commands and tools that have a similar purpose are grouped into panels.

Layers panel
Organize objects in your scene by layer so they can be viewed and edited together.

Select panel
Select elements in your scene through menu commands, selection icons, filter buttons, and text boxes.

Transform panel
Scale, rotate, and translate elements in your scene through commands, transform tools, and text boxes.

Snap panel
Set the type of grid or object snap to use for modeling and positioning.

Constrain panel
Set up a number of different types of constraints between objects.

Edit panel
Edit objects, including duplicate, clone, instantiate, group, freeze, and delete.

You can collapse a panel by right-clicking on its label. Right-click on the label a second time to expand a collapsed panel. This can be useful when working at small screen resolutions.
Chapter 3 • Interface—Commands and Tools

See the following areas in this guide for information on each group of commands found in the main command area. You’ll also find a description of each individual command in the Online Help.

- **Layers** panel commands—see Chapter 14: Layers on page 331.
- **Select** panel commands and tools—see Chapter 8: Selecting on page 209.
- **Transform** panel commands and tools—see Chapter 16: Transformations on page 351.
- **Snap** panel commands and tools—see Chapter 18: Snapping on page 417.
- **Constrain** panel commands—see Chapter 8: Animating with Constraints in the Animation guide.

- **Edit** panel commands—see Chapter 9: 3D Objects on page 259, Chapter 12: Components and Clusters on page 309, Chapter 22: Models on page 473, Chapter 10: Properties on page 279, Displaying Scene Information on page 453, and Operator Stack in Chapter 3 of the Modeling & Deformations guide.

**Lower Interface Controls**

The controls in this area give you information, such as what each mouse button does or the last command that you used. There is also animation information, from the timeline and playback controls to the Animation menu and keyframe button in the Animation panel.

Refer to each item’s Online Help topic (Help > Contents and Index) for more information on the controls described in this section.
Floating Windows

In addition to the viewports, there are many other tools that are displayed in separate windows that float and can be moved around. You can open these windows from the Application > Views menu on the main menu bar. For more information about various views, see Chapter 4: Views on page 103.

Toolbars and Shelves

The Application > Toolbars menu contains various customizable toolbars and shelves.

- A custom toolbar is a floating toolbar that can contain buttons for menus and commands as well as property and material presets. You can click a preset button to apply it to selected objects, or drag and drop the preset button onto unselected objects.

- A shelf is a similar to a toolbar, but it can have multiple tabs that can contain toolbars, list the contents of folders on disk, or list other scene elements like clips. You can drag and drop a thumbnail or file name from a folder tab onto objects and views in your scene.

You can create your own shelves and toolbars as described in the Customization guide.

- If a tab in a shelf displays a directory, you can go to the parent directory by placing the mouse pointer over it and pressing Backspace.

- To use My Media Shelf and My Project Shelf, you must set the MYPROJECTPATH and MYMEDIAPATH environment variables. For information about setting environment variables, see the Setup & Licensing guide.
Chapter 3 • Interface—Commands and Tools

Accessing Commands and Tools

In XSI, there are many ways in which you can access commands. Many of the tools that are available depend on the context in which you’re working (such as the type of object you have selected or the type of view you’re working in). This section describes the different ways in which you get commands.

You can use the mouse for performing basic operations such as manipulating objects in a scene, choosing commands, and selecting options in dialog boxes and property editors. You must use a three-button mouse on all operating systems.

Using the Menus

You can access most commands from drop-down menus (on the main menu bar at the top of the interface), or from pop-up menus by clicking on a menu button like the ones found in the toolbars and the panels of the main command area. You can also access commands from context menus by right-clicking or Alt+right-clicking (Ctrl+Alt+right-clicking on Linux) on various elements.

- You can keep menus on the main command panel and the viewports open while performing several menu commands at once by holding the Shift key while choosing multiple commands.
- Middle-click the menu name in any toolbar or the main command area to repeat the last command you selected from that menu.

Context Menus

Some pop-up menus are displayed by Alt+right-clicking or just right-clicking on individual elements, such as geometric objects, cameras, and lights, in the 3D views, the explorer, and the schematic view, or from specific areas of the interface. These type of pop-up menus are also called context menus because they provide commands that are applicable (in context) to the object you have chosen.

In general, when you open a context menu:

- If the element under the mouse pointer is not selected, then only that element is affected by the menu command you choose.
- If the element under the mouse pointer is selected, then all selected elements are affected.
- The exception is when you use the context menu in the explorer to mute/unmute deformations or activate/deactivate constraints. These commands act like toggles, and affect only the deformation or constraint under the pointer. A check mark in the menu indicates whether the node is currently muted or active.

If you’re working on Linux, you can access context menus by pressing Ctrl+Alt while clicking instead of just Alt.
Using Access and Shortcut Keys

Keyboard shortcuts are specific key combinations that perform the equivalent of certain menu commands. There are two types of keyboard shortcuts:

- **Access keys**—The underlined letters you see in many menu names. Pressing **Alt+[underlined letter]** activates its associated command.

If you're using XSI on Windows, the underlined letters in the menus and menu commands are not displayed by default. To display them, open **Control Panel > Display > Effects** (Windows 2000) or **Control Panel > Display > Appearance > Effects** (Windows XP). Deselect the option called **Hide keyboard navigation indicators until I use the Alt key**.

- **Shortcut keys**—Commands that have been mapped to your keyboard. For example, pressing **Ctrl+[key]** activates an associated command.

In this guide, the shortcut keys mentioned are always the default ones. You can create your own keyboard shortcuts as described in Chapter 6: Key Maps in the Customization guide. You can also reset the key settings to their default values.
Chapter 3 • Interface—Commands and Tools

Default shortcut keys are listed to the right of many menu command names. Refer to Online Help for a list of all available default keyboard shortcuts.

Note that not every menu command has a shortcut or access key.

Shortcut keys...
...from the keyboard
Press the key that corresponds to a command. Key combinations are displayed to the right of their associated commands in the main menu.

Access keys...
...from the menu bar
Press Alt+underlined letter of the menu name to open a menu of commands.

...then, from the menu
Press a key that corresponds to an underlined letter of a command name to activate it.

Using Shortcut Keys to Activate Tools

Shortcut keys are mapped to most of the tools used in XSI, and pressing a key activates a specific tool. Once the key is pressed, the mouse pointer changes shape to identify the active tool. Any further actions you perform with the mouse are then related to that tool. For example, pressing the z key activates the pan and zoom tool so that holding down the right mouse button zooms out of the scene, and holding down the middle mouse button zooms in.

You can move back and forth between different tools quickly by using these shortcut keys. Only one tool can be active at a time.

Tools can be activated in one of two modes:

• Sticky—you do not need to hold the key down to activate the tool.
• Temporary—you must keep the key held down for the tool to remain active.
**Sticky Mode**

You can activate a tool in this mode by quickly pressing and releasing its supra key. Once the tool is active, you can click and drag the mouse to use the tool. The tool remains active until you choose another tool. To deactivate the tool, press a key a second time or press Esc—the default tool becomes activated.

Note that if you press and hold the key for too long, it does not get activated because XSI assumes that you meant to activate the tool in supra mode and changed your mind.

You can enable or disable sticky keys as well as set the delay in the Interaction preferences. For more information about preferences, see *Chapter 26: User Preferences* on page 545.

**Supra (Temporary) Mode**

You can activate a tool in supra, or temporary, mode by holding down its key while manipulating the mouse. When activated in this way, the tool temporarily overrides the current tool. As soon as you release the key, the previous tool is re-activated.

For example, you can press and release the t key to activate the Select Point tool in sticky mode. Select some points, then press and hold the o key while dragging the mouse to orbit the camera around the object in supra mode. As soon as you release the o key, Select Point is active again and you can select points on the other side of the object.

**Example: Activating Basic Tools**

Follow these steps for an example of how to activate and work with the commonly used interaction tools such as selection, transformation (scale, rotate, and translate), and camera manipulation (pan and zoom, orbit, dolly). This example assumes you are using the XSI interaction model.

1. Start XSI and load a scene.

2. By default, the Select icon (the large arrow button on the Select panel) is on and highlighted in green, indicating that you are now in selection mode. If the Select icon is not on, press the space bar to switch it on.

   Object-selection mode maps your left-, middle-, and right-mouse buttons to node, branch, and tree selection, respectively.

   If you select an object that is part of a hierarchy, left-clicking selects only the object, middle-clicking selects all objects in its branch, and right-clicking selects the entire tree (in the 3D views only).

You can select objects in the explorer at any time, regardless of the active tool.
3. Select an object in a User view by clicking on it.
   After you have selected the object, you can manipulate it, for example, by using a transformation tool such as scaling.

4. Click the Local manipulation mode button in the Transform panel.

5. Press the \texttt{x} key and drag the mouse while holding down the left, middle, or right mouse buttons to scale along the X, Y, or Z axes, respectively.
   The \texttt{S} button in the Select panel is highlighted and the pointer changes to indicate that you are using the scale tool. When you release the \texttt{x} key, the scale tool is deactivated and you return to the previous tool (in this case, the selection tool).
   For more information on selection and manipulation modes, see Chapter 8: Selecting on page 209 and Chapter 16: Transformations on page 351.

To get a different view of your work, you can change the camera viewpoint.

6. In a User view, press the \texttt{o} key while dragging with the left mouse button to orbit your scene.

7. Quickly press and release the \texttt{z} key. This activates the zoom and pan tool in sticky mode.

8. Left-click and drag to pan your scene, hold down the middle mouse button to zoom in, and hold down the right mouse button to zoom out.
   Notice that when you release the mouse button you are still in zoom and pan mode. This is because the tool was activated as sticky: if you quickly press and release the key, the tool is activated and remains that way until you select another tool.

9. To deactivate the zoom and pan tool, press the \texttt{z} key again or press \texttt{Esc}.
   For information on camera-manipulation tools, see Navigating in 3D Views on page 160.

10. Quickly press and release the \texttt{s} key. This activates the navigation tool:
    - The left mouse button lets you \textbf{pan} (track).
    - The middle mouse button lets you \textbf{dolly}.
    - The right mouse button lets you \textbf{orbit}.

11. To activate another tool, press any key or choose a tool from the main command panel. For example, you can switch to selection mode by pressing the space bar (the selection key) or by clicking the selection button on the main command panel.
Keeping Track of the Active Tool
You will often move back and forth between tools as you work. Here are a few ways to keep track of the tool you are working with:

- You can activate a number of tools from the main command area. If the Select icon (large arrow) is highlighted, for example, you know that your mouse is mapped to the selection tool. If one of the SRT buttons is selected, you are in transformation mode, and so on.
- In most cases, the mouse pointer changes to indicate the active tool. For example, when the orbit tool is active, the pointer turns into an orbit icon.
- The mouse line at the bottom of the interface displays which operation is mapped to each of the mouse buttons. Always check the mouse line for the current tool status.

Repeating Commands
You can repeat the last command in general, as well as repeat the last command from a specific menu button. For example, this lets you apply an operation to the selected object, then select a different object and apply the same operation again without digging through menus and submenus.

To repeat the last command
- Choose Edit > Repeat command name from the top menu bar. Alternatively, press the period key (.)

The name of the menu item indicates which command will be repeated. Certain categories of command cannot be repeated:
- Selection commands. This allows you to apply a command to selected elements, then select other elements and repeat the command.
- Interactive manipulation, for example, using the transform tools (v, c, x) or the Move Point tool (m). However, transformation values entered numerically in the Transform panel can be repeated.
- General commands, such as Tools > Devices > Disable All Devices on the Animate toolbar.
- Viewing commands, such as toggling the display of nulls in a 3D view.
- Playback and timeline commands, such as changing frames.
- Camera navigation and viewing commands, such as orbiting, zooming, and framing.
- Parameter changes made in a property editor.

When the last command can’t be repeated, Edit > Repeat will repeat the previous command instead.
To repeat the last command from a specific menu button

- Middle-click on a menu button in a toolbar or panel.

For example, select a grid and choose **Modify > Deform > Randomize** on the Model toolbar. Then, get a new grid using the **Get > Primitive** menu, and middle-click on the **Modify > Deform** menu button. A Randomize deformation is applied to the new grid, even though the last command overall was from the **Get > Primitive** menu.

Note that middle-clicking to repeat a command does not work in the top menu. In addition, it does not work across toolbars—if you choose **Get > Primitive > Null** in the Model toolbar and then switch to the Animate toolbar, the **Get > Primitive** menu button in the Animate toolbar does not remember the **Null** command.
Modifying Properties in Property Editors

Property editors are where you’ll find an element’s properties. They are a basic tool that you will use constantly to define and modify elements in a scene.

You can define how a property editor behaves as you work and select elements in XSI: it can follow your selection and display the properties of any selected element of the same type; it can recycle and display the properties of the selected element; or it can be locked so that it always displays the properties of the same element. For more information, see Locking, Recycling, and Focusing Property Editors on page 79.

Anatomy of a Property Editor

Not all of the options described above are available in every property editor.
To see the immediate effect of changes you make to an object’s material or texture properties, draw a render region (press q) over the object in a 3D view. For more information, see Previewing Interactively with the Render Region in Chapter 1 in the Shaders, Lights & Cameras guide.

The area in the upper-right corner (below the title bar) contains:

- **Load** and **Save** buttons for opening and saving presets (see Creating Presets of Property Settings on page 289).
- A **Revert** icon that lets you reset all controls to the values they had when you first opened the property editor.
- An **Online Help** icon that gives you information on all properties on that property page.

### Animation Controls

The upper-left corner of the property editor, just below the title bar, contains the following controls related to setting keyframes for properties:

- An **autokey** button that, when selected, automatically creates a keyframe each time you move to a new frame and set specific properties from the property editor.
- Two **arrow** icons that let you move to the previous keyframe and next keyframe.
- A **keyframe** icon that lets you set keyframes for the current settings of marked parameters on the property page.

For more information on keyframes, see Chapter 4: Animating with Keys in the Animation guide.
Locking, Recycling, and Focusing Property Editors

The three icons in the upper-right corner control how the property editor is updated as you work and select elements:

- The **Focus** icon updates the current property editor to show the properties of the element you select, but only if the element is the same type as was previously selected (hence “focusing” on the type of element). For example, if you display the property editor of a spotlight and then select a point light, that property editor is updated to display the properties of the point light because spotlights and point lights are both the same type of element. However, if you then select a geometric object, a blank page is shown, because lights and geometric objects are different types of elements.

- The **Recycle** icon keeps that property editor open and refreshes it to display the properties of any element you select. This is a convenient way of keeping only one editor open at all times. For example, if you select a cube, the property editor shows the cube’s properties. Then if you select a light, the same property editor is updated to show that light’s properties.

- The **Lock** icon keeps the property editor open for the selected element. You can open other property editors for other elements, but a locked property editor remains open until you close or recycle it.

Polymorphic Sliders

When you resize a property editor so that there is not enough room to display or use a slider effectively, the slider becomes an input box. When you enlarge the property editor, the input box becomes a slider again.
Displaying Property Editors

There is more than one way to access an element’s property editor: how you access an editor depends on your current work context:

- Select an object and:
  - Press Enter to display a property editor of the object.
  
or
  - Press Alt+Enter to display a property editor of the object, as well as those that belong to all its children.

- In the explorer, click the icon of an element or select an element, then click the Selection button on the Select panel to display a menu from which you can choose certain properties. Double-click on the property set you wish to view.

- Use shortcut keys to open a property editor. Pressing Ctrl+k, for example, opens the Local or Global Transform property editor of a selected object. You can also create your own shortcut keys to open a property editor of your choice. For more information on this, see Key Maps in Chapter 6 of the Customization guide.

Certain property editors are displayed in other ways:

- Move back and forth through previously opened property editors by pressing the Page Up and Page Down keys or choosing the Up, Previous, and Next icons in a property editor’s Inspected Nodes controls. (Right-click on the Previous or Next icons to display a selectable list of most recently viewed nodes.)

  You can use the Page Up and Page Down keys to view property editors even after all property editors have been closed.

- Right-click in a render region border and choose Properties from the pop-up menu. This displays the View Rendering Options property editor for the region.

- Choose Visibility Options from the eye icon menu or Display Options from the display types menu in a viewport. The property editor that displays lets you specify how elements and the viewports themselves are viewed.

- In many cases, after you choose a command, a property editor is displayed automatically. When you choose Get > Material and select a material shader from the menu, for example, the material shader’s property editor automatically displays.
Closing Property Editors

Property editors that display as floating windows can be closed by clicking the X on the right of their title bars.

They can also be closed (as can all other floating window views) by positioning the mouse pointer over the window and pressing Ctrl+` (left single quote). On most keyboards, the left single quote is found directly below the escape (Esc) key. If the pointer is not positioned over a property editor, the first property editor opened will be closed.

If you like, you can change this shortcut by choosing File > Keyboard Mapping and mapping the command to another key in the Keyboard Mapping dialog box.

Preventing Property Editors from Displaying

You can prevent property editors from displaying automatically whenever a new object or property is created. In addition, you can temporarily toggle the current behavior by pressing Ctrl while choosing a command.

To set your preference for automatically displaying property editors

1. Choose File > Preferences to open the Preferences window.
2. Click Interaction.
3. On the Property Editor/Views tab, toggle Popup Property Editors on Node Creation on or off.

To temporarily override the current preference

- Press Ctrl when choosing a command that creates an object or property.

If your preference is set to automatically open property editors, no property editor opens. If your preference is set to not open property editors automatically, a property editor opens for the newly created element.
Docking the Property Editor in a Viewport

By default, property editors display as floating windows but you can also dock them in a viewport. This makes it easy to always have a property editor for whatever object is selected (if you recycle it), or always keep a frequently used property editor handy (if you lock it). For information on recycling and locking, see Locking, Recycling, and Focusing Property Editors on page 79.

Controlling the Display of Property Editor Tabs

The Tab Style Property Editors preference controls how multiple property sets appear when they are displayed in a single property editor.
The tab-style property editors can be faster when displaying and updating information, particularly when working with large property sets. However, they may require more clicking to switch between property sets.

**To set tab-style property editors**
1. Choose File > Preferences to open the Preferences window.
2. Click Interaction.
3. On the Property Editor/Views tab, toggle Tab Style Property Editors on or off.
4. Exit and restart XSI.

Each time you multiple-select a number of elements and open their property editors, you can simultaneously edit their common parameters.

Here are a few techniques where property editors can be used to edit multiple objects:

**To edit multiple objects**
1. In a 3D view, explorer, or schematic view, select the elements in your scene to be edited.
2. Press Enter.
   - A property editor displays the common parameters of the selected elements.
3. Make your edits. All the selected elements are edited simultaneously.
Setting Values for Parameters

Object, shader, or operator parameter values can be edited directly by means of text boxes, check boxes, sliders, and virtual sliders located throughout the interface. You will change parameters mostly in property editors (as the one shown below). For more information on property editors, see Modifying Properties in Property Editors on page 77.

In addition to property editors, you can enter values in many of the text boxes in the main command area, and use virtual sliders to change values in the explorer.

You change the value of a parameter in a text box by typing in either text or numerical values (see page 86 for more information). If a slider is associated with the text box, you can also drag the sliders to raise or lower the numerical values (see page 85 for more information). Some sliders and text boxes, such as those that control color channels, are grouped together.

If the text box contains more characters than it can display, it automatically scrolls with the text cursor.

Any parameter that can be animated has a little green box beside it called the animation icon. You can set and remove keys for parameters using this icon, as well as a number of other things. See The Animation Icon in Chapter 1 of the Animation guide for more information.
Setting Values for Parameters

Enter Values Using Sliders

To change values using sliders
- Do one of the following:
  - Drag a slider to the right to raise the value or to the left to lower the value in the text box. Use the left mouse button for a continuous update as you drag; use the right button for an update only when you release the mouse.
  
    or
  
  - Drag a slider to the right or left while pressing the Shift key to make finer adjustments.
    
    or
  
  - Drag a slider to the right or left while pressing the Ctrl key to change the value of all the sliders in a color-control group simultaneously.
    
    or
  
  - Drag with the middle mouse button. When you use the middle mouse button, the scene updates only when you release the mouse button instead of refreshing continuously as you drag. This is especially useful when setting values on parameters that may take a long time to update.

Entering Values Using Virtual Sliders

You can change the values of marked parameters by using “virtual sliders.” This means simply activating a tool that lets you do the job of a slider without having to open up any property editors.

To use the virtual sliders
1. Select one or more objects, and mark the desired parameters. You can mark a parameter by:
   - Clicking on its name in an explorer.
   - Clicking on its name in a property editor.
   - Selecting it from the marked parameter list.

   Use the Shift key to add a parameter and the Ctrl key to toggle.

   For more information about marking parameters, see Marking Parameters for Animation in Chapter 2 of the Animation guide.

2. Press F4 and drag the mouse back and forth using the following as a guide. You can scrub horizontally using the entire screen width:
   - Middle-click and drag to the right to increase values, and to the left to decrease values. The default increments are proportional to the range of the parameter’s slider in its property editor.
   - Press Ctrl to make coarse adjustments (10 times the default increment).
   - Press Shift to make fine adjustments (1/10th the default increment).
Chapter 3 • Interface—Commands and Tools

- Press Ctrl+Shift to make ultra-fine adjustments (1/100th the default increment).
- Press Alt to extend beyond the range of the parameter’s slider in its property editor (if the slider range is smaller than its total range).
- Left-click to select other objects or mark other parameters while staying in the virtual slider mode.
- Press the Up and Down arrow keys to increment or decrement the values by 1 unit. Hold the Ctrl key while pressing the arrow keys to increment or decrement by 10, or hold the Shift key to increment or decrement by 0.1.

3. Right-click to exit the virtual slider mode.

**Entering Values in a Text Box**

There are many ways to enter information in a text box. You can enter information the conventional way by using your keyboard. For numeric input, you can also use gestural movements and key combinations to increase or decrease the parameter values.

- To move from one text box to the next one in the same dialog box or property editor, press the Tab key.
- To move back to the previous text box, press Shift+Tab.
- To cycle through the available options in a text box, use any of the arrow keys.

**To enter information by typing**

Move the mouse pointer inside the text box and click. The pointer shape becomes a text cursor (flashing vertical bar). Any existing text is selected and overwritten as soon as you begin typing.

If you click in the text box a second time, the text is deselected and the cursor is placed where you clicked. You can now:

- Use the left- and right-arrow keys on the keyboard to move the cursor to the appropriate place in the text box.
- Drag the cursor over the part of the contents you want to replace. The selected characters are highlighted. Now type in the text you want.
- Press Shift+left- or right-arrow key to select characters that are to the left or right of the cursor. You can delete or replace these characters.
- Double-click to select a word so that you can replace it completely with the text that you type.
- Right-click to open a pop-up menu and choose the command to undo, cut, copy, paste, delete, or select all the contents of the text box.
- Delete characters to the left of the cursor using the Backspace key, or delete characters to the right of the cursor using the Delete key.
• To cancel text box input, press the Esc key.

If you have problems entering decimal values, open the Windows Control Panel and make sure that the Regional Settings are set to English (United States).

To enter information by gestural input (scrubbing)

• Click and drag the mouse pointer in a circular motion over a text box that supports numeric values. This is known as scrubbing. To increase the value, scrub in a clockwise direction; to decrease the value, scrub in a counterclockwise direction.
  
  - Press the Shift key while scrubbing to increment or decrement values by a factor of 0.1.
  
  - Press the Ctrl key while scrubbing to increment or decrement values by a factor of 10.

To enter information by increments

• Click in the numeric text field and press the square bracket keys (][) and (][) to increment and decrement values as follows:

<table>
<thead>
<tr>
<th>Press this...</th>
<th>To do this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>]</td>
<td>Increment by 1</td>
</tr>
<tr>
<td>[</td>
<td>Decrement by 1</td>
</tr>
<tr>
<td>Ctrl+]</td>
<td>Increment by 10</td>
</tr>
<tr>
<td>Ctrl+{</td>
<td>Decrement by 10</td>
</tr>
<tr>
<td>Shift+]</td>
<td>Increment by 0.1</td>
</tr>
<tr>
<td>Shift+{</td>
<td>Decrement by 0.1</td>
</tr>
</tbody>
</table>

• Click in the numeric text field and press the arrow keys to increment or decrement values as follows:

<table>
<thead>
<tr>
<th>Press this...</th>
<th>To do this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+right-arrow</td>
<td>Increment by 10</td>
</tr>
<tr>
<td>Ctrl+left-arrow</td>
<td>Decrement by 10</td>
</tr>
<tr>
<td>Shift+Ctrl+right-arrow</td>
<td>Increment by 0.1</td>
</tr>
<tr>
<td>Shift+Ctrl+left-arrow</td>
<td>Decrement by 0.1</td>
</tr>
</tbody>
</table>

If you have a mouse wheel, click in the numeric text field, then roll the wheel forward to increment the value or backward to decrement the value.
Relative Input Using Math Operations

All text boxes allow you to input relative values by means of four basic math operations (addition, subtraction, multiplication, and division), as well as other operators such as linear and random.

To input relative values

1. Click in a text box to select the value it contains.
2. Enter the number to add, subtract, divide, or multiply.
3. Enter the symbol for the math operator (+, –, *, /). You can use only one math operator per text box.
4. Press Enter.

For example, if the selected value in the text box is 10 and you replace this value by 5+ and press Enter, the result is 15 because you added 5 to the existing value.

When you have multiple elements of similar parameter values, anything you enter in a text box is applied to all these parameters:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Results</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>value</strong></td>
<td>Sets all selected element properties to that value. For example, entering an X-axis rotation value of 5 sets all selected objects' rotational values to 5. This is also known as absolute input (see the following illustration).</td>
</tr>
<tr>
<td><strong>value+</strong></td>
<td>Increments all the selected elements by that value. For example, entering 2+ in an X-axis translation parameter shifts all selected objects by 2 Softimage units. Math operations are known as relative input.</td>
</tr>
<tr>
<td><strong>value-</strong></td>
<td>Decrements all the selected elements by that value.</td>
</tr>
<tr>
<td><strong>value</strong>*</td>
<td>Multiplies all the selected elements by that value.</td>
</tr>
<tr>
<td><strong>value/</strong></td>
<td>Divides all the selected elements by that value.</td>
</tr>
<tr>
<td><strong>l or L(min, max)</strong></td>
<td>Creates a linear range through the selection, according to the original selection order. For example, L(4,8) when applied to the X-axis translation parameter of a group of three cubes causes each object to move 4, 6, and 8 Softimage units along the X axis, respectively.</td>
</tr>
<tr>
<td><strong>r or R</strong></td>
<td>Creates a random value for each selected element, between 0 and 1.</td>
</tr>
<tr>
<td><strong>r(x) or r(-x)</strong></td>
<td>Creates a random value for each selected element between 0 and the value for (x). If r is followed by (-x), a random value between 0 and the negative value is inserted.</td>
</tr>
</tbody>
</table>
These illustrations describe the different ways in which elements can be transformed using text box input. For illustrative purposes, the example of translation is used, but the concepts apply to any parameter:

### Absolute Input
Entering a numeric value in an XYZ text box repositions all selected objects to the specified position on their X, Y, or Z axes.

This example: **Translation: Y = 3**
(spheres all repositioned to 3 on the Y axis)

### Relative Input
Entering (value)+ or (value)– in an XYZ text box increases/decreases the relative value of each selected object. You can also enter (value)* and (value)/ to multiply and divide the relative value.

This example: **Translation: Y = 3+**
(Y value of each selected sphere increased by three Softimage units)

### Random Input
Entering a value of R(min,max) in an XYZ text box randomly repositions each selected object anywhere between the specified minimum and maximum values.

This example: **Translation: Y = R(0,6)**
(spheres randomly repositioned between 0 and 6 on the Y axis)

### Linear Range
Entering a value of L(min,max) in an XYZ text box repositions each selected object on a linear path between the specified minimum and maximum values. The first selected object receives the minimum value and last selected object receives the maximum value.

This example: **Translation: Y = L(0,6)**
(spheres repositioned equally on a linear range between 0 and 6 on the Y axis)
Randomizing Values

You can randomize parameter values using commands on the Animate toolbar. The values become set to random values within a range centered about a pivot point.

- The relative commands use the parameter’s current value as the center of the range.
- The absolute commands use the midpoint of the slider’s range. Although you can set some parameters to values outside the slider range when typing values, it is the visible range of the slider in the interface that determines the center.

You can also set random parameters when typing values (see Relative Input Using Math Operations on page 88) as well as when sampling parameters (see Sampling and Bracketing Parameters on page 91).

To randomize values

1. Select one or more objects and mark the desired parameters. You can mark a parameter by:
   - Clicking on its name in an explorer.
   - Clicking on its name in a property editor.
   - Selecting it from the marked parameter list.

   Use the Shift key to add a parameter, and the Ctrl key to toggle.

   For more information about marking parameters, see Marking Parameters for Animation in Chapter 2 of the Animation guide.

2. Choose a command from the Create > Parameter > Randomize Marked Parameters menu on the Animate toolbar:

   - **10% Relative.** Generates random parameter values within a range +/-5% of the parameter’s slider range, centered on the current value.
   - **25% Relative.** Generates random parameter values within a range +/-12.5% of the parameter’s slider range, centered on the current value.
   - **50% Relative.** Generates random parameter values within a range +/-25% of the parameter’s slider range, centered on the current value.
   - **75% Absolute.** Generates random parameter values within a range +/-36.5% of the parameter’s slider range, centered on the slider’s midpoint.
   - **100% Absolute.** Generates random parameter values anywhere within the parameter’s slider range.
Sampling and Bracketing Parameters

Sampling parameters lets you automatically vary parameters and take a snapshot at different values. This technique is sometimes called bracketing, from the photographers' technique of shooting the same scene at different exposures.

You can sample parameters to quickly find the values for the effect you want, or to find a value that's close to the effect you want and then refine it further from there. This is especially useful for complex effects that may take a long time to compute—you can generate the samples over lunch or overnight, and then simply recall the desired settings.

The Parameter Sampling & Bracketing page in Net View allows you to interactively generate samples, view the results, and recall them.

Generating Parameter Samples

The first step is to generate samples for the desired parameters.

To generate parameter samples

1. Select a single object, and mark the desired parameters. You can mark a parameter by:
   - Clicking on its name in an explorer.
   - Clicking on its name in a property editor.
   - Selecting it from the marked parameter list.

   Use the Shift key to add a parameter, and the Ctrl key to toggle.

   For more information about marking parameters, see Marking Parameters for Animation in Chapter 2 of the Animation guide.

2. On the Animate toolbar, choose Create > Parameter > Sample/Bracket Parameter Values. The Parameter Bracketing page opens in a floating Netview window.

3. Set all the options under Parameter Sampling, as well as Capture Method and Capture Options under Capture and Display Results. See Parameter Sampling Settings on page 92 and Capture Settings on page 93.
4. Click Generate Samples. Thumbnails are generated for the different parameter values, and displayed in the Results section of the Net View page. You can click on a thumbnail to set the parameters in your scene to the corresponding values; for more information, see Displaying Sample Parameters on page 94.

Parameter Sampling Settings

The parameter sampling settings let you set the sampling method and other options.

**Sampling Method: Bracket Parameters**

When the Sampling Method is set to Bracket Parameters, the marked parameters are sampled at equal intervals within a range. The range is determined by either the parameter’s default slider range or its current value, as described in Relative Variation and Percentage of Variation on page 93. **Samples (per param)** under Bracket Options determines the number of intervals.

Be careful to keep Samples (per param) fairly low when using multiple marked parameters. The total number of samples grows exponentially with the number of marked parameters. This may result in a very large number of samples that takes a very long time to compute. For example, with five samples per parameter and two parameters, there are 25 samples in total; with three parameters, there are 125 samples in total; with four parameters, there are 625 samples in total, and so on.

You should also be careful when sampling color parameters because colors are sampled in each of their R, G, B, and A channels.

**Sampling Method: Randomize Parameters**

When the Sampling Method is set to Randomize Parameters, the marked parameters are set to random values within a range. The range is determined by either the parameter’s default slider range or its current value, as described in Relative Variation and Percentage of Variation on page 93. **Samples (total)** under Randomize Options determines the number of samples generated.

**Seed** is a seed for the random number generator. Using the same seed always produces the same results within the same range, which means that you can always go back and regenerate a result you liked by using the same values. If you don’t like any of the current samples, you can generate a new set within the same range by changing the seed.
Sampling and Bracketing Parameters

Relative Variation and Percentage of Variation

Relative Variation controls the range used for sampling: either based on a parameter’s normal slider range (off) or based on its current value (on). In either case, Perc. of Variation determines the size of the range as a ratio of the normal slider range.

- If Relative Variation is off, then the range is centered on the middle of the normal slider range of the parameter in a property editor. For example with the Bracket Parameters method, if a slider’s range is [-1.0, 1.0] and Samples (per param) is 5, and Perc. of Variation is 1.0 (full range), then the parameter will be sampled at -1.0, -0.5, 0.0, 0.5, and 1.0. Note that for some parameters, you can type in values outside the slider’s range; however, parameter sampling is limited to the slider range.

- If Relative Variation is on, then the range is centered on the parameter’s current value. If the maximum or minimum falls outside of the normal slider range, it is clamped and the parameter is sampled within the allowable portion of the range. For example, if a slider’s range is [0, 100], the current value is 60, and Perc. of Variation is 0.20, then the parameter will be sampled within the range [40, 80].

Relative Variation is useful to iteratively refine the parameter values: first sample with it off to see values across the entire range, then choose a value you like and resample with Relative Variation on. Repeat, reducing Perc. of Variation each time as you get closer to the desired values.

Capture Settings

The capture settings determine how the snapshot images are generated. Image files are always in JPEG format, with a .jpg file name extension.

Capture Method

The capture method determines what will be shown in the snapshot images. There are three choices:

- **Capture** performs a single-frame capture of viewport B using its current display settings. The marked parameters and values are overlaid on the image.

- **Capture w/o Displayed Values** is the same as Capture, but the marked parameters and values are not overlaid on the image. You can still recall the corresponding values automatically as described in Recalling Values on page 94.

- **Render** performs a render of the active camera of the current pass using the current render options (apart from size, file name, and path).
When using any of the Capture methods, it’s a good idea to turn off the display of the grid, the axes indicator, and other things that may clutter viewport B at small sizes. You can toggle the display of these elements from the Camera Visibility property editor—choose Visibility Options from the Show menu (eye icon) or press Shift+s while the mouse pointer is over viewport B.

**Capture Options**

You can set the following capture options:

- **File Name** is the base file name for the sampled images. For example, if this value is “test”, the images are named test1.jpg, test2.jpg, and so on.
- **File Path** is the directory location for the images. If you are running on Linux, you need to change the default value from C:\Temp.
- **Size** is the vertical size of the images in pixels. The horizontal size is calculated automatically from the picture ratio set in the camera’s property editor (if the capture method is Capture) or the render options (if the capture method is Render).

**Displaying Sample Parameters**

The snapshot images are automatically displayed as thumbnails under Results on the Parameter Bracketing page in Net View.

**Recalling Values**

To recall a set of sampled parameter values

- Do one of the following:
  - Click on the corresponding thumbnail image.
  - Enter the number displayed next to the snapshot in the Result to Recall box and then click Recall Result.

**Updating the Results**

You can change the Number of results to display and the Number of results per line, and then click Update Results Page to view the changes.
Defining Color Properties

There are a number of standard ways of defining color properties, from textures and materials to the background color used in a 3D view—it’s all done using the same tools.

**Defining Colors with Sliders**

To define a color using the color sliders

1. Select the color model that best suits your needs. Below the color box, you can click on the color model name to toggle between RGB, HLS, and HSV.

2. Do any of the following to set the color:
   - Click and drag the sliders to change the strength of each channel independently, or type a numerical value directly in the space provided.
   - To move all three sliders at once, hold the Ctrl key down while moving the sliders with the cursor.
   - For fine-tuning a single color value, hold down the Shift key while moving the cursor over a color slider bar.

As you use the color sliders, you will notice that each slider immediately updates to show you a gradient of the color you have selected. The slider shows you what color will result if you move the slider to a new position.

The specific channel corresponding to a slider depends on the color channel you selected; for example, if you selected RGB, the sliders correspond to the red, green, and blue channels. The values range between 0 and 1.

You can quickly copy a color by clicking a color box and dragging and dropping its “color chip” to another color box in the same property page or another one. This is especially useful when you want to match ambient or diffuse colors among objects.

As you use the color sliders, you will notice that each slider immediately updates to show you a gradient of the color you have selected. The slider shows you what color will result if you move the slider to a new position.

When you are defining materials, you can type values greater than 1 to compensate for transparency and reflectivity.

**Defining Colors with the Color Editors**

When defining or choosing colors, or to choose one from a 3D view, you can use one of the two color editors. In the full color editor, you can create and modify colors for your materials and lights. This can be useful for creating specific palettes to apply consistently to a group of materials. You can also use the color picker to pick a color displayed in any 3D view, including Rotoscope views or the Image Clip editor.
Chapter 3 • Interface—Commands and Tools

To select a color using the mini color editor

1. Click the color box next to the color sliders in a property editor.

2. The mini color editor (below) opens:

To select a color

- Click in the color spectrum. That color then appears in the color preview box (and in the color box of the property editor), while the current color remains in the current color box to use as a reference.

To edit a color

- Use the slider bar at the right or enter a numeric value in the text boxes below it. You can also change the color model from RGB to HLS to HSV by clicking the “>” button.

To pick a color

- Click the color picker button (the eye dropper) and click anywhere on the screen. The color picker takes the color you see on the screen rather than the true color of the objects. This tool can be especially useful when trying to match a color in the Image Clip editor.

If you wish to match a color of an object outside of XSI, you can load an image file using the Image Clip editor, and select it for viewing. Then you can pick the desired color once the file is visible.
Defining Color Properties

• Click on the browse (...) button to open the full color editor, where you can fine-tune and create custom colors.

3. Close the color editor to use the color you created.

**To fine-tune a color using the full color editor**

1. In the property editor, click the color box to open the mini color editor.

2. In the mini color editor, click the browse (...) button. The full color editor opens.

**To select a color**

• Click in the color area. You can define the color area by selecting a color view mode. Each mode offers a variety of spectrums and hues. Once a color is selected, the color appears in the preview color box, while the previous color remains in the current color box to use as a reference.

**To modify a color**

• Use the slider bar at the right of the color editor or enter a numeric value in any one of the RGB, HSV, or CMYK fields. As a color is modified, its corresponding values are updated.

**To pick a color**

• Use the color picker as described on page 96.
Chapter 3 • Interface—Commands and Tools

**Undoing and Redoing Edits**

You can undo most edits made from the XSI interface, such as scaling an object or deleting a camera.

To undo an edit

- Choose the **Edit > Undo** command or press Ctrl+z.

You can continue to undo actions as far back as the system memory can recall. This is limited by the number of undo levels that you have specified in your user preferences (see below for setting this).

Undo does not work on:

- Changes made to shaders
- Changes in viewport manipulations
- Changes to light ray properties

To redo an edit

- Choose the **Edit > Redo** command or press Ctrl+y. You can invoke one redo command for each undo action.

**Setting the Number of Undo Levels**

There’s enough space in the system memory to let you undo up to 1000 edits.

To set the number of undo levels

1. Choose **File > Preferences** to open the Preferences window.
2. Click **General**.
3. In the **Number of Undo Levels** text box, enter the number of edits that can be undone.

The higher number of levels you set, the more memory is required, which can slow down performance.
Synoptic Views

Synoptic views allow you to quickly access commands and data related to a specific object or model. They are custom, image-based toolbars that let you work in a natural and intuitive manner. One of their chief advantages is that they always apply to their associated scene element, whether or not it is currently selected.

Synoptic views consist of a simple HTML image map stored as a separate file outside of the XSI scene file. The HTML file is linked to a scene element by a Synoptic property. Clicking on a hotspot in the image either opens another synoptic view or runs a script. Through scripts, synoptic views let you accomplish anything in XSI—common uses include displaying custom properties, selecting elements on a character rig, setting keys on predefined lists of parameter, and so on.

This section describes how to work with synoptic views once they are set up. For information about setting up your own synoptic views, see Chapter 12: Synoptic Views in the Customization guide.

The name of the associated scene element appears in brackets.

The pointer becomes a hand when it is over a hotspot. Click to perform a predefined action: run a script or open a different synoptic view.

The name of the synoptic view appears on the title bar.
Displaying Synoptic Views

If a scene element is associated with a synoptic view, you can display it using keyboard commands or from a context menu. You can have one synoptic view open per object, but you can have multiple synoptic views open associated to different objects.

To display a synoptic view with the keyboard

1. Select an object with a Synoptic property, or a child of an object with a Synoptic property applied in branch mode.
2. Press F3, and the synoptic view opens. Press F3 again to close the synoptic view.

F3 is used to display either synoptic views or Annotation properties. If an object has both Synoptic and Annotation properties, the synoptic view takes precedence when you press F3. If the selected object has neither a Synoptic nor an Annotation property, a pop-up explorer opens showing the selection.

To display a synoptic view from a context menu

1. Do one of the following:
   - Alt+right-click on an object in a 3D view (Alt+Ctrl+right-click on Linux).
   or
   - Right-click on an object in an explorer or schematic view.
2. Choose Open Attachment from the context (pop-up) menu. The first synoptic view opens. If there are no Synoptic properties on the object, the first Annotation opens. If there are neither Synoptic nor Annotation properties, a pop-up explorer opens showing the object.

Navigating Synoptic Views

When an object has multiple synoptic views, you can navigate among them using the arrow keys.

- If there are multiple Synoptic properties, either applied directly on the object or inherited from an ancestor, use the up and down arrow keys to cycle among them.
- If you clicked on hotspots that open yet other synoptic views, use the left and right arrow keys to go back and forward. These keys behave similarly to the Previous and Next buttons in HTML browsers.

Make sure that the mouse pointer is over the synoptic view, or your keystrokes may be interpreted as commands in other XSI windows.
Working with Synoptic Views

You work with synoptic views simply by clicking on the hotspots. When you click on a hotspot, one of two things can happen:

- A second synoptic view opens, providing access to other hotspots.
- A script runs.

Synoptic views are custom properties, so exactly what happens is determined by the person who created the synoptic view.

Sample Synoptic Views

The Biped Rig and Quadruped Rig models available from the Get > Primitive > Model menu have synoptic properties applied in branch on the globalSRT controller. Simply get one of these models, select any part of the rig, and press F3.
Chapter 3 • Interface—Commands and Tools
Chapter 4  Views
SOFTIMAGE|XSI has a number of tools that let you examine your scene in varying degrees of detail. This chapter includes general information about displaying and working with views.

In addition, it describes the following general-purpose views in detail.

- The **Explorer view** is a hierarchical, tree-style display of the contents of your scene that expands from the root. You can perform a wide variety of tasks using the explorer. See page 110 for information.

- The **Schematic view** is a graphical representation of your scene that lets you analyze the way a scene is constructed and see the relationships between objects, material nodes, and texture nodes. See page 121 for information.

- The **Spreadsheet view** is a grid display of information about scene elements and their parameters. You can organize this information to show specific aspects of your scene, and perform operations on many elements or parameters at once. See page 132 for information.

- The **XSI Explorer** is a two-pane view, with an explorer on the left and another view on the right. Use the explorer pane to select an object to isolate in the right pane. See page 135 for information.

- The **Browser** is a file-management tool that lets you navigate through scene, project, and other directory structures. You can also use the browser to load scenes, presets, and so on. See page 137 for information.

- The **Net View** is a web browser that lets you view HTML pages on the Internet or your intranet. You can drag-and-drop images, models, scenes, and add-ons, as well as run scripts and so on. See page 143 for information.

When and where to use a particular viewing tool depends entirely on what you want to do. For example, if you want to move several objects into a group, you might use the explorer. On the other hand, if you want to change the diffuse shading parameter for 35 separate surface shaders, the spreadsheet is indispensable. To discover what you can do with the general data viewing tools, read on.

For information about using the 3D views to display your scene from different points of view, see Chapter 5: Viewing 3D Objects on page 147.

In addition, there are several special-purpose views that are described elsewhere in the SOFTIMAGE|XSI documentation. For example, the envelope weight editor is described in Chapter 3: Envelopes of the Character Animation guide.
Working with Views

Views provide a window into the current scene, whether they display a 3D view of the geometric objects such as in the Camera view or a hierarchical view of the data such as in the explorer.

This section provides some general information about views, such as how to open them docked in the viewports or floating in separate movable windows.

For information about working in certain general-purpose views, such as the explorer, schematic, spreadsheet, browser, or net view, see the sections that follow in this chapter.

For information about navigating and displaying objects in the 3D views, see the next chapter, Chapter 5: Viewing 3D Objects on page 147.

There are four viewports in the view manager at the center of the standard XSI layout. Each viewport is identified by a letter. When you start XSI, viewport A (top left) shows the Top orthographic view, viewport B (top right) shows the Camera perspective view, viewport C (bottom left) shows the Front orthographic view, and viewport D (bottom right) shows the Right orthographic view.

For information about navigating in 3D views, see 3D Views on page 149.

Displaying Views in Viewports

You can display many different views docked inside the viewports.

To display a view in a viewport

1. Click the arrow or the name of the current view displayed on any viewport menu bar to open the Views menu.

2. Select the desired view from the menu.
Chapter 4 • Views

To display the previous view in a viewport

• Middle-click the arrow or the name of the view on the viewport menu bar.

Maximizing and Restoring Viewports

You can maximize a single viewport so that it occupies the full space taken by all four viewports. Alternatively, you can maximize viewports horizontally or vertically to display two or three viewports at a time. Restoring a viewport returns it to the previous size.

To maximize or restore a viewport

Do one of the following:

• With the mouse pointer over the corresponding viewport, press F12.
  or
  • Click the viewport’s Resize icon.
  or
  • Right-click the viewport’s Resize icon, then choose Maximize or Restore.

To maximize or restore a viewport horizontally

Do one of the following:

• Middle-click the viewport’s Resize icon.
  or
  • Right-click the viewport’s Resize icon, then choose Horizontal or Restore.

To maximize or restore a viewport vertically

Do one of the following:

• Ctrl+middle-click the viewport’s Resize icon.
  or
  • Right-click the viewport’s Resize icon, then choose Vertical or Restore.

Resizing Viewports

You can change the relative sizes of the viewports, as well as reset them to their original sizes.

To resize viewports

Do one of the following:

• To resize horizontally, click and drag the vertical splitter bar that separates two viewports.
  or
To resize vertically, click and drag the horizontal splitter bar that separates two viewports.

or

To resize freely, click and drag the intersection of the splitter bars that separates all four viewports.

**To reset the viewport sizes**

Do one of the following:

- To reset the size horizontally, middle-click the vertical splitter bar that separates two viewports.

  or

- To reset the size vertically, middle-click the horizontal splitter bar that separates two viewports.

  or

- To reset the size both horizontally and vertically, middle-click the intersection of the splitter bars that separates all four viewports.

**Returning to the Default Viewports**

You can return to the original state of the viewports by doing one of the following:

- Right-click the viewport’s Resize icon, then choose **Reset Size**. All four viewports are restored and their sizes are reset.

  or

- Right-click the viewport’s Resize icon, then choose **Reset All**. All four viewports are restored, their sizes are reset, and the default views are displayed.

---

**Working with Floating Views**

When you open a floating view, it appears as a separate window. Depending on the type of view, you can have multiple windows of the same view type open at the same time.

**A Word about the Active Window**

The active window is always the one directly under the mouse pointer—it’s the one that has “focus” and accepts keyboard and mouse input even if it is not on top.

For example, you can move the mouse pointer over the script editor window, type commands, then move the pointer over the camera viewport and press `g` to toggle the grid display. If you pressed `g` while the pointer was still over the script editor, you would have typed the letter `g` into the editing pane.

Be careful that you don’t accidentally send commands to the wrong window.
Opening and Closing Floating Views

**To open a floating view**

Do one of the following

- Choose the desired view from the **Application > Views** submenu.

  or

- Press the shortcut key associated with that view. For example, press 8 (at the top of the keyboard) to open the explorer.

  Note that if there is a collapsed view of the corresponding type, then pressing the shortcut key will restore it.

**To close a floating view**

Do one of the following

- Click the Close icon on the right of the view’s title bar.

  or

- Move the mouse pointer over the view and press Ctrl+` (the key under Esc on most keyboards).

**To close all floating windows**

- Choose **Window > Close All** from the main menu.

Minimizing and Restoring Floating Views

You can minimize a floating view to get it out of your way without closing it. When you need to work with that view again, you can restore it.

Note that minimized views are completely hidden. They do not become icons or buttons in the interface.

**To minimize a floating view**

- Click the Minimize icon on the right of the view’s title bar.

**To minimize all floating views**

- Choose **Window > Minimize All** from the main menu.
Working with Views

**To cycle through floating views**
- Press Ctrl+Tab to cycle through all open or minimized floating views, or press Ctrl+Shift+Tab to cycle in reverse order.

- There is a preference that controls whether open windows become minimized when you cycle to the next one. In the Interaction preferences, click the Property Editors/Views tab and check or uncheck **Hide windows when switching**. For more information about preferences in general, see Chapter 26: User Preferences on page 545.

- On Linux, the Ctrl+Tab and Ctrl+Shift+Tab combinations may be used by your window manager. In that case, you should change your window manager’s settings to unmap these combinations.

**To restore a specific floating view**
- Select the desired view from the list of open views at the bottom of the Window menu.

**To restore all floating views**
- Choose Window > Restore All from the main menu.

**Collapsing Floating Views**
You can collapse a floating view by double-clicking on its title bar. When collapsed, only the title bar is visible and you can still move it around by dragging. To expand a collapsed view, double-click on the title bar again; the view is restored at its original location.

**Manipulating Floating Views**
You can adjust floating windows in the usual ways; for example:

- To move a window, drag its title bar.
- To resize a window, drag their outlines.
- To bring a window to the front and display it on top of other windows, click in it.
The Explorer

The explorer displays the contents of your scene in a hierarchical structure called a tree. This tree can show objects as well as their properties as a list of nodes that expand from the top root.

You normally use the explorer as an adjunct while working in XSI, for example, to find or select elements. Using the explorer, you can:

- Display and navigate among various elements.
- Selecting scene elements.
- Set the scope to determine the range of information shown.
- Set filters to determine the types of information shown.
- Find objects by name.
- Sort and reorder elements.
- Renaming scene elements.
- Creating parent/child relationships between objects by dragging and dropping.
- Add objects to groups, layers, and partitions by dragging and dropping.
- Duplicate elements by Ctrl+dragging.

Many options you set in the explorer are stored in your preferences and reused the next time you start XSI. For more information about preferences in general, see Chapter 26: User Preferences on page 545.
To open the explorer

Click on the arrow or label at the top left of any viewport and choose **Explorer** from the list. The explorer opens in that viewport.

or

Choose **Application > Views > Explorer** from the main menu bar. This opens the explorer in a floating window.

or

Press `8` at the top of the keyboard (not the numeric keypad).

Viewing the Element Tree

The explorer displays elements in a tree-like hierarchy of nodes.

You can pan the view by dragging up and down in an empty area within the explorer.

If your mouse has a wheel, you can also use it to scroll up and down in an explorer window (Windows only). Simply make sure the explorer has focus (click anywhere in the explorer) before using the wheel.
Navigating in the Tree

You can also use keyboard shortcuts to navigate in the project tree. These keys apply only to the explorer and cannot be used in the schematic view.

<table>
<thead>
<tr>
<th>Key</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up arrow</td>
<td>Moves the selection up one node.</td>
</tr>
<tr>
<td>Down arrow</td>
<td>Moves the selection down one node.</td>
</tr>
<tr>
<td>Right arrow</td>
<td>Expands the node or, if already expanded, selects the first child node.</td>
</tr>
<tr>
<td>Left arrow</td>
<td>Collapses the node or, if collapsed, selects the parent.</td>
</tr>
<tr>
<td>NumPad *</td>
<td>Expands all branches below the selected node.</td>
</tr>
<tr>
<td>Page Up</td>
<td>Scrolls the tree display upward.</td>
</tr>
<tr>
<td>Page Down</td>
<td>Scrolls the tree display downward.</td>
</tr>
</tbody>
</table>

Selecting Scene Elements in the Explorer

Selecting elements in the explorer is quite straightforward. In particular, you can select any element, even if it is unselectable or hidden in the 3D views.

- To select a scene element, simply click on its name in the explorer. Ctrl+click to multi-select individual nodes.

- To select a range of elements of a similar type, click on the first element’s name in the range, then Shift+click on the last element’s name in the range.

These two elements, plus all the elements of a similar type between them, become selected. Other types of elements in-between are not selected; for example, if you click on a 3D object and then Shift+click on another 3D object, then all visible 3D objects in-between become selected, but properties, shaders, and so on, remain unselected. When Shift+clicking in the explorer, models and 3D objects are considered to be one type, as are properties and materials (but not shaders).

Only the visible elements are selected; elements that are hidden under a collapsed node remain unselected.

You can only select ranges of elements that are of the same type. If the second node picked is not the same as the first one, it is simply added to the selection and all nodes in between remain unselected.
Keeping Track of Selected Elements in the Explorer

If you have selected objects in any 3D view, their nodes are also selected in the explorer. If their nodes are not visible in the explorer, choose View > Find Next Selected Node. The explorer scrolls up or down to display the first object node in the order of its selection. Each time you choose this option, the explorer scrolls up or down to display the next selected node. Once the end of the selection order is reached, the first object node is automatically selected.

Choose View > Track Selection if you want to automatically scroll the explorer so that the node of the first selected object is always visible.

Setting the Scope of the Explorer

The Scope button determines the range of elements to display. You can display specific parts of the scene, as well as layouts, commands, and other parts of the XSI application itself.

Locking onto a Selected Object

The Selection option in the explorer’s scope menu displays information associated with the currently selected object.

If you click the Lock button with the Selection option active, the explorer continues to display the property nodes of the currently selected objects, even if you go on to select other objects using other views. Click Lock a second time to switch off the lock feature.

When Lock is on, you can also select another object and click Update to lock on to it and update the display.
Chapter 4 • Views

Filtering the Display

Filters control which types of nodes are displayed in the explorer. For example, you can choose to display objects only, or objects and properties but not clusters or parameters, and so on. By displaying exactly the types of elements you want to work with, you can find things more quickly without scrolling through a forest of nodes.

The basic filters are available on the Filters menu (between the View menu and the Lock button). The label on the menu button shows the current filter. The filters available on the menu depend on the scope. For example, when the scope is Scene Root, the Filters menu offers several different preset combinations of filters, followed by specific filters that you can toggle on or off individually.

Finding Elements in the Explorer

The search box on the right of the explorer command bar lets you search for elements by name or by type.

When you perform a search, the matching elements are displayed in a flat list and the scope automatically changes to Custom. If there is no match, nothing happens.

If you perform a new search immediately, the previous scope is used automatically.

To display all elements again, click the triangle to the right of the search box and choose All Items. Alternatively, select another scope.

Finding Elements by Name in the Explorer

The search box lets you search for elements by name using wildcards and regular expressions.

To search by name

1. Set the explorer’s scope to the desired range (see Setting the Scope of the Explorer on page 113).
The scope of the explorer determines the range of the search. For example, you can search for any object in the scene if the scope is Scene Root. However, if the scope is Current Layer, then the search is restricted to objects in the current layer.

2. Type a string in the search box. For a list of wildcards that you can use, see Valid search patterns on page 115.

3. Press Enter or click outside the search box.

*To repeat a recent name search*

- Click the triangle to the right of the search box, and choose a previous search string from the Recent Name Search list.

<table>
<thead>
<tr>
<th>This pattern...</th>
<th>Matches these characters...</th>
</tr>
</thead>
<tbody>
<tr>
<td>?</td>
<td>Any single character.</td>
</tr>
<tr>
<td>*</td>
<td>Any string of 0 or more characters.</td>
</tr>
<tr>
<td>[abc]</td>
<td>Any one of the characters a, b, or c.</td>
</tr>
<tr>
<td>[!abc] or [^abc]</td>
<td>Any one character except a, b, or c.</td>
</tr>
<tr>
<td>[a-z]</td>
<td>Any one character in the range between a and z.</td>
</tr>
<tr>
<td>[!a-z] or[^a-z]</td>
<td>Any one character except those in the range between a and z.</td>
</tr>
</tbody>
</table>
Finding Elements by Type in the Explorer

The filters available on the name search box let you search for elements by type.

To search by name

1. Set the explorer’s scope to the desired range (see Setting the Scope of the Explorer on page 113).

   The scope of the explorer determines the types of element you can search for. For example if the scope is Scene Root, then you can search for nulls, curves, polygon meshes, and so on.

2. Click the triangle to the right of the search box, and choose an item from the Filters list.

   For information about adding custom filters to this list, see the XSI SDK Customization guide.

Sorting and Reordering Objects in the Explorer

You can sort the elements in the explorer according to various criteria using options in the View menu. In addition, you can reorder elements to change the default, or creation, order.

The sort orders are remembered for each scope and are saved in your preferences. For more information about preferences, see Chapter 26: User Preferences on page 545.

Sorting Basic Elements

To sort objects, sources, clips, and other basic elements, choose the desired option from the View > General Sort submenu of the explorer:

- **None (creation)** uses the default order, based on when an element was created or parented.

- **Alphabetical** sorts the elements alphabetically. Any numeric suffix is sorted in correct numerical order, so Object2 comes before Object10. The children of an object are always listed after any parameter sets of the object.
The Explorer

- **Type + Alphabetical** sorts the elements by type first, and then alphabetically within each type. The types depend on the scope. For example with the Scene Root scope, the explorer lists all the cameras in alphabetical order, then all the lights, models, referenced models, nulls, chains, curves, polygon meshes, NURBS surfaces, text, particle clouds, hair objects, control objects, forces, dynamic constraints, implicits, and geoshaders, each in alphabetical order. If the scope contains only one type of element, this option is equivalent to **Alphabetical**.

- **Used + Alphabetical** sorts the elements into used and unused groups, and then sorts alphabetically within each group. This option is available only with the Sources/Clips scopes.

**Sorting Parameters**

To sort parameters, choose the desired option from the **View > Parameter Sort** submenu of the explorer:

- **None (creation)** uses the default order based on when the parameter was created.

- **Alphabetical** sorts the parameters alphabetically. Any numeric suffix is sorted in correct numerical order, so Param2 comes before Param10.

- **Layout** uses the order in which the parameters appear in their property editor. If a parameter does not appear in the corresponding property editor, it is not listed.

**Reordering Scene Objects in the Explorer**

By default, objects in a scene are ordered according to when they were created or when they became children of their parent. This underlying order is reflected in the explorer and schematic views when objects are not sorted, and is also used when selecting the next or previous sibling using the buttons on the Select panel or the Alt-arrow keys.

You can change this underlying order in the explorer using the Reorder Tool.

**To reorder scene objects in the explorer**

1. Make sure the explorer’s scope is set to Scene Root.
2. Make sure that **View > General Sort > None (creation)** is checked.
3. Choose **View > Reorder Tool**.
   - The mouse pointer changes to show that the tool is active.
4. Drag a scene object above or below one of its siblings in the scene explorer.
   - Repeat to reorder more objects.
5. When you have finished, exit the tool by pressing Esc.
Using Context Menus in the Explorer

You can right-click on any element in the explorer to perform a variety of functions, such as expanding or collapsing hierarchies, renaming or deleting nodes, or opening property editors.

Right-clicking certain nodes provides specific options. For instance, you can use a constraint node's context menu to activate or deactivate the constraint. Right-clicking a container node (for example, the node that contains all of an object’s constraints) displays a menu for activating, deactivating, or deleting all the nodes in the container at once.

In general, when you open a context menu:

- If the element under the mouse pointer is not selected, then only that element is affected by the menu command you choose.
- If the element under the mouse pointer is selected, then all selected elements are affected.
- The exception is when you use the context menu in the explorer to mute/unmute deformations or activate/deactivate constraints. These commands act like toggles, and affect only the deformation or constraint under the pointer. A check mark in the menu indicates whether the node is currently muted or active.
Renaming Scene Elements

You can rename elements in your scene using the explorer. You can rename lights, cameras, geometric objects, render passes, and layers.

To rename scene elements

- Do one of the following:
  - Right-click on any element node in the explorer. Choose Rename from the menu and type a new name for the element.
  - or
  - Select the element you want to rename in the explorer and press F2. Then type a new name for the element.
  - or
  - Click the element you want to rename in the explorer and then click it again—but don’t double-click. Then type a new name for the element.

If you have multiple nodes selected, pressing F2 lets you rename the last node you selected.

Other Explorer Views

You can view other smaller versions of the explorer (pop-up explorers) elsewhere in the interface. They are used to view the properties of selected scene elements.

Select Panel Explorer

Explorer filter buttons in the Select panel offer a shortcut by instantly displaying filtered information on specific aspects of currently selected objects.

Example: Click the Selection filter button...

...to display a pop-up explorer showing all property nodes associated with the selected object.

The Explore button opens a pop-up menu of additional filters for specifying the type of information you wish to obtain on the scene.
Object Explorers

You can quickly display a pop-up explorer for a single object—just select the object and press Shift+F3. If the object has no synoptic property or annotation, you can press simply F3. Pressing those keys again closes the pop-up explorer.

Schematic View Explorer

Explorer filter buttons in the schematic view offer a shortcut by instantly displaying property information on a selected scene element.

To display information on an element in the schematic view, right-click on its node and choose Explore from the menu.

For more information on the schematic view, see the following section.
The Schematic View

The schematic view presents the scene in a hierarchical structure so that you can analyze the way a scene is constructed. It includes graphical links that show the relationships between objects, as well as material and texture nodes to indicate how each object is defined.

Many options you set in the schematic view are stored in your preferences and reused the next time you start XSI. For more information about preferences in general, see Chapter 26: User Preferences on page 545.
To display a schematic view

![Diagram of schematic view]

Click on the arrow or label to the left of any viewport and choose Schematic from the list. The schematic displays in that viewport.

or

Choose Application > Views > Schematic View from the main menu bar. This displays a schematic view in a floating window.

or

Press 9 on the keyboard.

Selecting Elements in the Schematic View

When the Select tool is active, you can select elements by clicking on them in the schematic view. Use the left mouse button for node selection, the middle mouse button for branch selection, and the right mouse button for tree selection.

You can also click a parent-child link to select the child. This is useful if you have located the parent but can’t find the child in a jumbled hierarchy. Again, use the left, middle, or right mouse buttons to select the child in node, branch, or tree modes.

When other types of link are displayed, you can click the link to select the corresponding operator.

To activate the selection tool

- Do one of the following:
  - Press the space bar.

  or

  - Choose Edit > Select.

Displaying Scene-Element Information

Scene elements in the schematic view are displayed as graphical nodes. You can use the filters in the Show menu to determine which types of object are visible in the schematic, as described in Using Filters to Further Define the View on page 125.

Objects that are visible in the 3D views are shown as solid rectangles in the schematic view. Objects that are hidden in the 3D views are shown as outlines and are selectable in the schematic view.

Relationships between elements are displayed as lines called links. You can display or hide links for different types of relationship as described in Displaying Links (Relationships) between Elements on page 124.
Showing Icons

Choose View > Show Icons to display icons representing the element types as in the explorer.

When the Select tool is active, you can click an icon to open the element’s property editor.

This setting is saved in your preferences and used for all scenes you work on.

Opening Property Editors for Elements

If icons are not visible, you can still open an element’s property editor by double-clicking on it with either the Selection tool or the Pick and Move tool.

You can also open an element’s property editor by selecting it and pressing Enter.

Displaying an Element’s Property Nodes

You can display an element’s set of property nodes in a pop-up explorer by right-clicking on the element and choosing Explore.
Displaying Links (Relationships) between Elements

You can display links between nodes that have a relationship, such as a constraint, operator dependency, or simulation (like forces). To toggle the display of a specific type of link, choose Show > [Link Type].

To toggle between displaying links for all objects and displaying links for only nodes that are selected, choose Show > Links on Selected Nodes Only. This option can simplify the view shown in the schematic, allowing you to concentrate on the links between specific objects.

Link types are generally drawn in a similar color to the corresponding toolbar, so operator links are purplish (Model toolbar), constraint and expression links are green (Animate toolbar), material links are blue (Render toolbar), and simulation links are horny salmon (Simulate toolbar).

You can select links by clicking and dragging across them. When a link is selected, you can press Enter to open the property editor related to the associated relationship (if applicable), or press Delete to remove a relationship like a constraint or expression.

The View > Parallel Links option controls whether parent-child links are drawn as straight lines or as vertical and horizontal segments. This option is saved in your preferences, and used for all scenes you work on.

If links do not display correctly, press F5 to refresh the display for the selected node. If nothing is selected, F5 refreshes all nodes in the scene.

Defining the View

You can choose which elements of the scene hierarchy to display by selecting an option from the schematic view menus:
Defining the Scope of the Hierarchy View

You can define which elements to display in the scene hierarchy by choosing an option in the scope menu:

- **Selection**: to view only the nodes of selected elements.
- **Scene**: to view the entire scene hierarchy.
- **Layer**: to view only the nodes that belong to the currently displayed layer.

Using Filters to Further Define the View

You can use the filter commands found in the Show menu to display or hide nodes based on their types. For example, you can display or hide geometric objects, kinematic chains, or material nodes. This lets you focus on the elements you want to work on, or simply reduce the amount of information displayed for easier selection.

To define the view using filters

- In the schematic view menu bar, choose **Show** and select the item to be shown or hidden from the schematic view.

Hold the Shift key to keep the Show menu open while you toggle multiple options.

Locking the View onto Selected Objects

The **Selection** option in the schematic view’s scope menu displays only the nodes of objects that are currently selected.

If you click the **Lock** button with the **Selection** option active, the schematic view continues to display the nodes of the currently selected objects, even if you go on to select other objects using other views. Click **Lock** a second time to switch off the lock feature.

When Lock is on, you can also select another object and click **Update** to lock on to it and update the display.

Specifying Object Node Colors

You can choose the color used to display unselected object nodes in the schematic view:

- Choose **View > Use Standard Colors** to display unselected objects in black.
- Choose **View > Use Wire Colors** to display unselected objects using their wire color. To specify an object’s wire color, see **Setting Object and Wireframe Color** on page 188.
- Choose **View > Diffuse Colors** to display unselected objects using the diffuse component of their material. Objects without their own material inherit the material of their parent or use the scene’s default material.
In all cases, selected objects, branch-selected objects, and owners of the subselection are displayed using the colors specified in the Scene Colors property. For more information about setting scene colors, see Setting Scene Colors on page 186.

The option you choose is saved in your preferences. It is used for all scenes you work on.

**Storing and Restoring the View**

The schematic view has four memory cameras (or *memo cams*), each of which can store the position and zoom:

- Click a memo cam icon to restore the saved view.
- Middle-click a memo cam icon to save the current view. The icon turns orange to show that a view has been saved.
- Right-click a memo cam to reset it and clear the saved view. You must clear a saved view before you can save a new view for the same icon.

**Navigating in the Schematic View**

The schematic view’s View menu contains a number of navigation commands:

**To pan across the schematic**

- Press `z` or choose *Edit > Pan and Zoom Tool*, then click and drag the left mouse button.

**To zoom in and out**

- Press `z` or choose *Edit > Pan and Zoom Tool*, then hold down the middle mouse button to zoom in and the right mouse button to zoom out.

**To create a region in which to zoom**

- Press `Shift+z` or choose *Edit > Rectangular Zoom Tool*, then drag diagonally to create the zoom region.

**To focus only on the selected objects in the hierarchy**

- Choose *View > Frame Selection*.
  
  Note that if the selected object is inside a collapsed hierarchy, nothing happens. For more information about collapsing and expanding hierarchies, see Expanding and Collapsing Hierarchies on page 129.

**To view all objects in the hierarchy**

- Choose *View > Frame All*.

**To revert to a one-to-one viewing ratio**

- Choose *View > Reset Zoom*.

You can also access these commands by Alt+right-clicking in an empty area (Ctrl+Alt+right-clicking on Linux) within the schematic view.
Arranging the Schematic View

You can move nodes around in the schematic view, for example, if you want to create patterns that visually indicate the relationship among elements. To change the underlying order of child nodes, see Reordering Child Nodes in the Schematic on page 131.

Moving Nodes Manually

You can use the Pick and Move tool to rearrange nodes changing the selection, or you can select the nodes you want to move first and then use the Translate tool.

When you move a node manually, its position becomes locked relative to the root of its hierarchy. This means that it is no longer affected when the hierarchy is rearranged manually or automatically. Before you can rearrange a position-locked node, you must reset its user position (see Resetting User Positions on page 128). Position-locked nodes are indicated with a 1-pixel border (although the border is not drawn when the view is zoomed very far out).

To move nodes using the Pick and Move tool
1. Press m or choose Edit > Pick and Move tool.
2. Do one of the following:
   - Left-click and drag a node to move it by itself.
   - Middle-click and drag a node to move it and all its descendants.
   - Right-click and drag a node to move an entire tree.

   The affected nodes are highlighted while the mouse button is pressed.

   While the Pick and Move tool is active, you can also:
   - Double-click on a node to open its property editor.
   - Double-middle-click on a node to expand or collapse it.

To move nodes by selecting and translating
1. Select a node in node, branch, or tree mode.
2. Press v or choose Edit > Translate Tool.
3. Click and drag to move the selection:
   - Use the left mouse button to move freely.
   - Use the middle mouse button to move vertically.
   - Use the right mouse button to move horizontally.
Chapter 4 • Views

Arranging Nodes Horizontally or Vertically

Two options on the View menu control the placement of child nodes relative to their parents:

- View > Vertical Layout places child nodes below their parents.
- View > Horizontal Layout places child nodes to the right of their parents.

When you choose either of these options, the entire schematic view is automatically rearranged. This option is saved in your preferences and is used for all scenes you work on.

Rearranging Hierarchies

Rearranging a hierarchy “cleans” it by automatically moving child nodes according to the current View setting (Vertical Layout or Horizontal Layout). Nodes that have been positioned manually are not moved unless you reset their positions first.

To rearrange the entire schematic view

- Choose View > Rearrange All.

To rearrange the hierarchy below a specific node

- Do one of the following:
  - Select the node and choose View > Rearrange Selection.
  - Alt+right-click on the node (Ctrl+Alt+right-click on Linux) and choose Rearrange from the pop-up menu.

Resetting User Positions

After you have moved a node manually, it becomes position-locked relative to the root of its hierarchy. This is indicated by a 1-pixel border.

Position-locked nodes are not affected when a hierarchy is rearranged. To rearrange a position-locked node, you must first reset its user position.

You can reset the user positions of specific nodes, or reset all nodes at once.

To reset the user positions of specific nodes

- Alt+right-click on a node, and choose Reset User Position(s) from the pop-up menu.
  - If the node you clicked on was selected, the user positions of all selected nodes (including branch-selected nodes) are reset.
  - If the node you clicked on was not selected, only its user position is reset.

The affected nodes are no longer position-locked and 1-pixel border is removed. The nodes will be affected the next time you rearrange the hierarchy.
To reset the user positions of all nodes

- Choose View > Reset All User Positions.

The nodes are no longer position-locked and 1-pixel border is removed.
All nodes will be affected the next time you rearrange the hierarchy.

Sorting Hierarchies

You can rearrange the hierarchies in the schematic view according to various criteria.

To sort hierarchies

- Choose one of the options from the View > Overall Sort submenu:
  - None (creation) does not sort the hierarchies at all. The default order is based on the order of creation of the root nodes.
  - by Type puts cameras first, followed by lights and then other 3D objects.
  - by Height/Width places the hierarchies in order of tallest to shortest.
    When two hierarchies have the same height, the one that is wider is placed before the other.
  - by Width/Height places the hierarchies in order of widest to narrowest.
    When two hierarchies have the same width, the one that is taller is placed before the other.

Expanding and Collapsing Hierarchies

You can expand or collapse any hierarchy or sub-hierarchy in the schematic diagram to simplify the view.

To collapse the hierarchy beneath a node

- Alt+right-click the node (Ctrl+Alt+right-click on Linux) and choose Collapse Node.

  The node displays lines at the bottom to indicate that there are hidden nodes beneath it.

To expand a collapsed node

- Do one of the following:
  - Alt+right-click the collapsed node (Ctrl+Alt+right-click on Linux) and choose Expand Node.
  - With the Select tool active, click the lines below the collapsed node.

The hierarchy below the node is displayed. If a lower node had been independently collapsed, it “remembers” and remains collapsed.
To toggle a node (collapse or expand)

- Do one of the following:
  - Select the node and press `n`.
  or
  - With the Select tool active, double-middle-click on a node. This also branch-selects the node.

The node expands if it is collapsed, and collapses if it is expanded.

Rearranging Automatically When Parenting or Cutting Children

The View > Clean Hierarchy Upon Structure Change option controls whether nodes in the schematic view get rearranged when you change a hierarchy by parenting or cutting children.

- If it is on, nodes in the affected hierarchy are automatically rearranged. The root of the hierarchy is not moved.
- If it is off, nodes are not moved automatically.

Rearranging When Displaying or Hiding Nodes

The View > Clean Hierarchy Upon Show Mode Change option controls whether nodes in the schematic view get rearranged when you display or hide different types of nodes using the options in the Show menu or context menu.

- If it is on, nodes are automatically rearranged when you display or hide different types of node. However, nodes are not moved when you display or hide links.
- If it is off, nodes are not moved automatically when you display or hide nodes and links.

Building Hierarchies in the Schematic View

In addition to creating parent-child relationships in the schematic view, you can reorder child nodes.

Creating Hierarchies in the Schematic View

For more information about hierarchies in general, see Chapter 13: Hierarchies on page 323.

To create a hierarchy in the schematic view

- Press Alt while dragging and dropping a node onto a new parent.
Reordering Child Nodes in the Schematic

By default, the child nodes are ordered according to when they became children of their parent. This order is reflected in the schematic view when rearranging nodes (if View > Overall Sort is set to None (creation)) as well as in the explorer view. The order is also used when selecting the next or previous sibling using the buttons on the Select panel or the Alt+arrow keys.

You can change this underlying order in two ways: by using the Reorder Nodes tool, or by arranging the hierarchy visually and then freezing the ordering.

To reorder siblings using the Reorder Nodes tool
1. Press i or choose Edit > Reorder Nodes Tool.
2. Drag and drop a node to a new position before, after, or between its siblings, either horizontally (if View > Vertical Layout is on) or vertically (if View > Horizontal Layout is on).

For example, if View > Vertical Layout is on and you drop a node to the left of all its siblings, it becomes the first child. Similarly, if View > Horizontal Layout is on and you drop a node above all its siblings, it becomes first.

Each time you drop a node, the hierarchy below its parent is automatically rearranged and cleaned.

To reorder siblings by freezing the order
1. Use the Pick and Move tool or the Translate tool to arrange the children of a node in the order you want from right to left (if View > Vertical Layout is on) or top to bottom (if View > Horizontal Layout is on). For more information, see Moving Nodes Manually on page 127.
2. Alt+right-click (Ctrl+Alt+right-click on Linux) on the parent node and choose Freeze Child Ordering from the pop-up menu.

The node's immediate children are reordered. User positions are reset and the hierarchy is cleaned.

To reorder hierarchy roots by freezing
1. Make sure that View > Overall Sort is set to None (creation).
2. Use the Pick and Move tool or the Translate tool to arrange the roots of hierarchies in the order you want from right to left (if View > Vertical Layout is on) or top to bottom (if View > Horizontal Layout is on). For more information, see Moving Nodes Manually on page 127.
3. Choose View > Freeze Root Node Ordering.

All root nodes (direct children of the scene root) are reordered. User positions are reset and the hierarchy is cleaned.
Chapter 4 • Views

The Spreadsheet

The spreadsheet view displays scene information about elements and their parameters in a grid. This information is filtered and organized by *queries* that you create to show specific aspects of your scene in combination with sorting operations you can perform based on object data. You can then perform operations on many elements or parameters at once.

The intersection between a row and a column is called a cell, each of which holds one value. You can select many cells at once and modify them all simultaneously.

For information on controlling the spreadsheet display, see the Online Help.

Each row represents a scene element. Click a row heading to select all of an element's properties. Right-click the row to select objects in your scene.

Each column represents a parameter. Click a column heading to select a parameter on all of the displayed objects. Right-click a heading to quickly sort elements and mark parameters for animation.

For information on controlling the spreadsheet display, see the Online Help.
Displaying a Spreadsheet View

To display the Spreadsheet view

Click on the arrow or label to the left of any viewport and choose Spreadsheet from the list. The spreadsheet displays in that viewport.

or

Choose Application > Views > Spreadsheet from the main menu bar. This displays a spreadsheet view in a floating window.

or

Press Alt+3 on the keyboard.

Using Queries

A query is a means of requesting information filtered a specific way for display in the spreadsheet. For example, you could query XSI for a list of local rotation values for only selected objects. Queries are text files with a .query extension; default queries are located in %SI_HOME%\Application\Queries.

You can execute a query by using one of the predefined queries found in the spreadsheet’s Query menu, or you can choose Query > Open to load a query file you have created. For more information about creating custom queries, see Creating Custom Spreadsheet Queries for XSI in the SOFTIMAGE|XSI SDK Case Studies guide on the Documentation CD.

Once you have executed a query and the spreadsheet displays the data you have requested, you can further organize the information by sorting the table. Right-click any column heading to sort the table entries based on the column’s entries. To return to the default sorting as defined in the .query file, choose Query > Sort from the spreadsheet menu.

Updating the Spreadsheet Display

The spreadsheet display is not updated as the scene or the current frame is modified in XSI. To update the spreadsheet to reflect current scene information, click Execute.

By default, the spreadsheet reruns the query when you click Execute. To update only currently listed elements, click the Update button.
Navigating within the Spreadsheet

You can highlight and edit spreadsheet cells using the keyboard or the mouse. Use the arrow keys to move the cursor within the spreadsheet, or click on a cell to highlight it. You can also highlight multiple cells using a variety of methods:

• Holding the Shift key while using the arrow keys extends the highlighted area as a rectangular region.

• Shift-clicking creates a highlighted rectangular region spanning from the first highlighted cell to the cell that was Shift+clicked. You can also create a rectangular region by dragging the mouse from one cell to another.

• Ctrl+clicking adds a single cell to the selection. Ctrl+dragging adds a rectangular region to the selection.

• Clicking a column heading or row title highlights the entire column or row. Use the Shift and Ctrl keys or drag the mouse to highlight multiple columns or rows, or add columns or rows to the selection.

• Clicking the upper-left corner of the spreadsheet highlights the entire spreadsheet's contents.

Highlighting a cell does not select the object or the parameter in the scene.

Editing Cell Contents

Generally, editing one cell changes all highlighted cells of the same type when you press Enter. That is, if you change a numeric cell, all highlighted numeric cells are also changed; any non-numeric highlighted cells remain unchanged. Cells with their contents in gray cannot be edited.

You can edit spreadsheet cells, depending on the mouse button you use:

• **Left-click** edits a highlighted cell.

• **Middle-click** or **right-click** edits a cell without changing the value of other highlighted cells.

Selecting Scene Elements from the Spreadsheet

**To select scene elements listed in the spreadsheet**

• Right-click the row header for the element that you want to select and choose **Select Item** from the menu.

**To select multiple scene elements**

• Multi-select their row headers, right-click one of them, and choose **Select Item** from the pop-up menu.

**To add a scene element to the current selection,**

• Right-click on its row header and choose **Add Item to Selection**.
The XSI Explorer

The XSI explorer presents a two-pane view of your scene. The left pane shows an explorer view that lets you quickly navigate through your scene and select an element. The right pane shows a different view of the selected element. You can set the right pane to show a schematic view, object view, texture editor, image clip viewer, property editor, render tree view, or another more finely detailed explorer view.

Choose which elements to list in the left pane.

Use the explorer on the left to select an element to view on the right.

Drag the splitter bar to resize the panes, or click the triangle to hide and unhide the left pane.

Many options you set in the XSI explorer are stored in your preferences and reused the next time you start XSI. For more information about preferences in general, see Chapter 26: User Preferences on page 545.
You can open an XSI explorer view in a viewport or as a floating window, the same as with most the XSI views.

When you first open an XSI explorer, the right pane is empty. Select an option from the Viewer menu first.

To open the XSI explorer in a viewport
- Click on a viewport’s View menu and choose XSI Explorer.

To open the XSI explorer in a floating window
- Choose Application > Views > XSI Explorer from the main menu.

Use the Viewer menu to choose what to display in the right pane. These other views are described elsewhere in the SOFTIMAGE|XSI documentation.

Most of the views add their own commands to the XSI explorer command bar. However, the explorer does not. Also, be aware that when an explorer is displayed in the right pane, the command bar affects only the explorer in the left pane.

In floating windows, the name of the current viewer is displayed in the title bar.

Use the explorer in the left pane to select an element to view in the right pane. You can use the command bar to control which elements are listed in the left pane—for more information see The Explorer on page 110.

The element displayed in the right pane changes only when you use the left pane to select something else. The right pane does not respond when you select a new element outside of the XSI explorer. This lets you use the XSI explorer to focus on a specific object without losing it while you work on something else.

If you want the XSI explorer to update automatically when you select something in another view, set the scope of the left pane to Selection. In this mode, you can still lock the view to prevent it from updating automatically, as well as update it manually when it is locked.
The Browser

The browser is a type of window specifically used to:

- Search (browse) through scene databases, project directories, preset libraries, and other repositories whose files are required to build a project.
- Import scene files from databases as well as load scene and project files.
- Perform file management tasks such as moving, copying, renaming, and deleting files.
Chapter 4 • Views

To open the browser

The browser’s tree view is a hierarchy of folders and subfolders that contain files belonging to the scenes, objects, properties, or presets that you use to build a project. When you select an item from the tree, its contents (if any) are displayed in the list view of the browser.

You can view items in the tree view by expanding or collapsing folders.

To move up a level in the browser tree view

• Do one of the following:
  - Click the Up button in the browser toolbar.
    or
  - Press the Backspace key.

To create a new folder

1. Click on the New Folder icon in the browser toolbar.
2. Type a name in the text box that appears and click OK.
Viewing Folder Contents

The browser’s contents view displays the files of a folder selected in the tree view. You can display these files either as thumbnails or in detail mode, which includes file name, size, and comments.

You may need to press F5 to refresh the browser display in order to see recently saved presets.

To view folder files in thumbnail mode

Click the Thumbnail icon to view folder files as thumbnails.

To view folder files in detail mode

Click the Details icon to view folder contents in detail mode.
Chapter 4 • Views

To edit the Contents view

Click this arrow to show/hide the Contents view.

Drag the split bar right or left to resize the browser's right and left panes.

In detail mode, right-click anywhere in the Contents view...

...to add, move and rearrange columns in the Add/Remove Columns dialog box (below).
Setting Favorites

Favorites give you quick access to a folder without having to remember where the file is located. The Favorites icon lets you mark a direct path to a folder of interest on any local, network, or external disk to which your workstation is connected.

To add a favorite to the list

1. In the browser tree, navigate to the folder that you want to add as a favorite.
2. Click the Favorites icon in the browser toolbar.
3. Choose the Add to Favorites command in the menu that appears.

The new favorite is added to the Favorites list at the bottom of the menu, and the browser updates to set the favorite folder at the top of the tree.

To select a favorite

- Click the Favorites icon and select a favorite from the list that appears at the bottom of the menu. Your selection is displayed in the browser.

To delete a favorite

- Click the Favorites icon, choose the Remove Favorite command, and select a favorite from the submenu that you want to delete. The favorite path is deleted from the list. The folders or files are not affected.

Accessing Files from the Browser Path Controls

The browser’s Paths controls let you access files by entering their folder directory path in a text box or by selecting a preset path from a pop-up menu.

To access files from the browser path controls

- Type the folder directory path in the Path text box.
- Click Paths and choose a preset path from the pop-up menu.

Once you have made your selection, the browser’s tree updates and displays the path’s folders.
Chapter 4 • Views

Using the Paths Option

The Paths pop-up menu lets you choose from a list of directory paths, including paths that point to available projects. The paths are divided into the following categories:

<table>
<thead>
<tr>
<th>Choose...</th>
<th>To...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application Data Paths</td>
<td>Access application files from the Factory path where SOFTIMAGE</td>
</tr>
<tr>
<td>Project Data Paths</td>
<td>Access files from the sample projects that were installed with SOFTIMAGE</td>
</tr>
<tr>
<td>Add-Ons Paths</td>
<td>Directly access the directory where factory add-ons that were installed by SOFTIMAGE</td>
</tr>
<tr>
<td>Projects</td>
<td>Access the files associated with the selected project. The list of available projects is maintained in the Project Manager dialog box. (For information on how to add and delete projects from project lists, see Maintaining Project Lists on page 470.)</td>
</tr>
</tbody>
</table>

Accessing Computers on a Network

When you want to find a file on a network, but don’t have the path to it set directly, use the Network Neighborhood to navigate directly to the computer where it’s stored.

To locate a computer on the network

1. Click the Network Neighborhood icon in the browser toolbar.
2. In the Browse for Computer dialog box that is displayed, select the computer that you want and click OK.

The path to the computer you selected is entered in the Path text box, and its files and folders are listed in the browser.
Net View

With Net View, you can browse Web pages on the Internet or your intranet from within SOFTIMAGE|XSI. The drag-and-drop feature makes Net View a powerful teaching or collaboration tool, allowing you to share resources within a workgroup that might be spread throughout several buildings or several countries.

Browse back and forth among previously displayed pages.

Display the home page as defined in Start > Settings > Control Panel > Internet Options or in Internet Explorer options.

Refresh the current page.

Stop loading a page, running a script, or playing an animated image.

Display the XSI Web start page as defined in your XSI preferences.

Display your list of favorites as defined in Internet Explorer.

Enter the address of a page.

The body pane displays HTML files. Click a link to open a new page, download a file, or run a script. Right-click to display the Internet Explorer context menu.

Hide or display the command bar.
Chapter 4  •  Views

Displaying Net View

Click on the arrow or label to the left of any viewport and choose Net View from the list. The Net View displays in that viewport.

or

Choose Application > Views > Net View from the main menu. This displays a Net View in a floating window.

or

Press Alt+5.

Configuring Net View

Before using Net View, you may need to configure some options, for example, if you intend to use a proxy server. The procedure depends on whether you are using XSI on Windows or Linux.

To configure Net View on Windows

On Windows, Net View uses the same configuration settings as Internet Explorer. You can set these options from within Internet Explorer (Tools > Internet Options) or from the Windows Control Panel (Internet Options). These settings affect all programs on your computer that access the Internet.

To set a proxy server for Net View on Linux

You can set the proxy server for Net View on Linux using the PROXY environment variable. For details, see Environment Variables in the Setup & Licensing guide.

To configure other options for Net View on Linux

On Linux, you must can use the MainWin Control Panel to configure other options for Net View.

1. Open a terminal or shell window.

2. Source the XSI environment script by typing:

   ```
   source ~/.xsi_3.5n
   ```

3. Launch the MainWin Control Panel by typing:

   ```
   mwcontrol
   ```

4. Double-click on the Internet Options icon. The Internet Properties dialog box opens.

5. Make any settings you require. For information about a specific option, click ? and then click on the option.
You can use Net View like any other HTML viewer, by clicking links to open HTML pages. Additionally you can:

- Drag and drop various recognized file types into XSI.
- Run scripts.

## Dragging and Dropping from Net View

You can drag images, as well as links to images and other file types, from HTML pages in Net View and drop them into XSI. The drag-and-drop rules are summarized in the following table:

<table>
<thead>
<tr>
<th>File Type</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image</td>
<td>- Drop onto an object to create a image source and clip. You are prompted for a texture projection.</td>
</tr>
<tr>
<td></td>
<td>- Drop into the Texture Editor or Image Clip Viewer to create a source and clip, and display the clip.</td>
</tr>
<tr>
<td></td>
<td>- Drop into the Render Tree to create a source and clip.</td>
</tr>
<tr>
<td></td>
<td>- Drop into the scene to create a source.</td>
</tr>
<tr>
<td>Preset (Any type)</td>
<td>Drop onto a custom toolbar to create a button.</td>
</tr>
<tr>
<td>Preset (Shader)</td>
<td>Drop onto an object to apply the shader.</td>
</tr>
<tr>
<td>Preset (Property)</td>
<td>Drop onto an object to apply the property.</td>
</tr>
<tr>
<td>Preset (Action)</td>
<td>- Drop onto an action track in the animation mixer to import the source and instantiate a clip.</td>
</tr>
<tr>
<td></td>
<td>- Drop onto an object to import the source in the corresponding model.</td>
</tr>
<tr>
<td>Preset (Shape)</td>
<td>Drop onto a shape track in the animation mixer to import the source and create a clip.</td>
</tr>
<tr>
<td>Audio</td>
<td>Drop onto an audio track in the animation mixer to create a source and clip.</td>
</tr>
<tr>
<td>Scene</td>
<td>Drop onto the background of a 3D view to open, or Ctrl+drop to merge with the current scene.</td>
</tr>
<tr>
<td>Exported Model</td>
<td>Drop onto the background of a 3D view to import into the current scene, or Ctrl+drop to create a referenced model (model source and clip).</td>
</tr>
<tr>
<td>Script</td>
<td>Drop into the editing pane of the script editor to open the file for editing.</td>
</tr>
<tr>
<td>Add-on</td>
<td>Drop onto the background of a 3D view to install. This also works with the older DSPrefs preferences format.</td>
</tr>
</tbody>
</table>
Running Scripts

You can run a script by clicking on a link to a script file on an HTML page.

See Setting Security in Chapter 13 of the Customization guide for information about setting security levels for scripts running in Net View.

**XSI Web**

When you display a Net View, the default start page is XSI Web. This is a collection of HTML pages that let you browse through a variety of gifts included with the XSI installation: presets, sample scenes, scripts, and others. You can find more goodies on the Internet at XSI Net:

http://www.softimage.com/xsinet/

Changing the XSI Web Start Page

You can change the start page that is displayed when you first open Net View. This is also the page that is displayed when you click the XSI logo on the Net View command bar.

*To change the XSI Web start page*

1. Open the Preferences window by choosing File > Preferences.
2. Expand the Editors node and click NetView.
3. Enter a new address for Default Home Page.

For more information about preferences in general, see Chapter 26: User Preferences on page 545.

Creating Your Own Intranet

You can create your own intranet to share scripts, presets, textures, and other data with your workgroup. For more information, see Creating an Intranet for Net View in Chapter 13 of the Customization guide.
Chapter 5  Viewing 3D Objects
Chapter 5  •  Viewing 3D Objects

Viewing in SOFTIMAGE|XSI

XSI offers a wide variety of ways in which to view your scene. Some viewing modes are more appropriate for certain tasks than others. Here are the most common ways to view the contents of your scene:

• View your scene's geometry in the 3D views. The many ways in which you can view scene geometry in the 3D views is the focus of this chapter.

• View the scene as a hierarchy of elements in the explorer (see The Explorer on page 110).

• View scene elements and the relationships between one another in the Schematic view (see The Schematic View on page 121).

• View scene contents in layers to focus on specific aspects of your scene or selectively render certain elements while excluding others (see Layers on page 331).

Viewing Animation

The Animation guide describes additional viewing techniques related specifically to animation. It shows you how to:

• View your scene's animation using playback controls (see Playing the Animation in Chapter 3 of the Animation guide).

• View your scene's animation as a flipbook in a viewport (see Previewing Animation in a Flipbook in Chapter 3 of the Animation guide).

Previewing Rendered Scenes

At various stages of your project, you can preview your work before final rendering using the following techniques:

• Preview a single frame of animation in its final rendered format (see Previewing Animation in a Flipbook in Chapter 3 of the Animation guide).

• Preview your scene interactively using the render region, which lets you render a scene directly in a viewport without saving it to a file. It uses a subset of the global-rendering options so that your scene is a fairly good approximation of the final look (see Previewing Interactively with the Render Region in Chapter 1 of the Shaders, Lights & Cameras guide).
3D Views

As the name suggests, 3D views are where you view, edit, and manipulate the elements of your scene. XSI has two types of 3D views: viewports and object views.

- Viewports are the four main windows of the XSI standard layout. They can have different geometry views (Top, Front, Right, and User) and display types (Shade, Wireframe, Texture, Hidden Line, etc.). They can also display other tools such as the animation editor, browser, and the explorer. Any viewport can display any type of view.

  For more information about viewports, see the following section, Viewports.

- Object views are similar to viewports, having the same geometry views and display types, but are designed to view only selected objects. To that end, object views have some unique settings not found in viewports. You can open an object view within a viewport or in a floating window.

  For more information about object views, see The Object View on page 151.

Viewports

The viewing area of the interface contains four windows, called viewports, where you can view and work on your scene. Each viewport can display different types of views. You can display up to four different views in the viewports.

Viewports can have different geometry views (Top, Front, Right, and User) and display types (Shade, Wireframe, Texture, Hidden Line, etc.). They can also display other tools such as the animation editor, browser, and the explorer. Any viewport can display any type of view.

A viewport’s menu bar contains a set of controls that allow you to perform various functions such as changing views and display types, setting scene visibility, and resizing the viewport.

Holding down the Shift key keeps the Eye icon menu open while you choose multiple commands.
Chapter 5 • Viewing 3D Objects

Muting and Soloing Viewports

When a viewport is muted, it is prevented from displaying its contents. Muting a viewport’s neighbors helps speed up its refresh rate.

To mute or solo viewports

- To solo (view just one viewport), left-click on its letter. Left-click a second time to redisplay all viewports.
- To mute a viewport, middle-click on its letter. Middle-click a second time to redisplay the viewport.
- Right-click a viewport’s letter to display a menu with mute and solo commands.
Using Viewport Memo Cams

Each viewport has four “memo cams” (memory cameras), each of which can store the viewport’s current perspective or orthogonal view settings for quick access.

- **Middle-click** a memo cam box to store the current view settings. If the memo cam already has defined view settings, the new settings are not saved. Ctrl+middle-click to overwrite the current view settings.
- **Left-click** a memo cam box to switch to its stored view settings.
- **Right-click** a memo cam box to clear its settings.

The Object View

The object view is a 3D view that displays only the selected scene elements. It has standard display and show menus, and works the same way as any 3D view in most respects. Selection, navigation, framing, and so on work as they do in any viewport. There are also some custom viewing options, available from the object view’s **View** menu, that make it easier to work with local 3D selections.

- **Show menu** (equivalent to the eye icon menu) Includes commands for specifying whether or not scene elements and their components are visible in the viewports.
- **View menu** Like the viewports’ Views menu, but includes special viewing controls for the object view.
- **Display Type menu** Specifies how visible items in the viewports are displayed.
- **Lock/Update Buttons** Locks the object view on the current selection and updates a locked view to the current selection, respectively.
- **XYZ Buttons** Switches the object view to top/bottom/front/back/left/right.
- **3D Viewing Area** Displays the selected objects according to the settings defined in the Display Type, View, and Show menus.
Chapter 5 • Viewing 3D Objects

To work with a selection in the object view

1. Select one or more objects.

2. Do one of the following:

   - From any viewport’s views menu, choose Object View. The object view is displayed in the viewport.

   or

   - From the main menu, choose Application > Views > Object View.

3. In the object view, adjust the selected object as you would in any other viewport.

4. If necessary, toggle any of the following options on or off in the object view’s View menu to improve interaction:

<table>
<thead>
<tr>
<th>Option</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cameras</td>
<td>Opens a sub-menu listing all of the cameras in your scene. Choosing a camera displays the selection in the object view from the camera’s viewpoint. You can also choose the Default camera to set the viewpoint to that of the default object view camera, which changes as you change the selection.</td>
</tr>
<tr>
<td>Spotlights</td>
<td>Opens a sub-menu listing all of the spotlights in your scene. Choosing a spotlight sets the view in the object view relative to the chosen spot light. The point of view is set according to the direction of the light cone defined for the chosen spotlight. You can look through the spotlight towards its interest.</td>
</tr>
<tr>
<td>Orthographic</td>
<td>Makes the object view orthographic rather than perspective.</td>
</tr>
<tr>
<td>Zoom 1:1</td>
<td>Resets the pixel zoom for this camera.</td>
</tr>
<tr>
<td>Top/Bottom/</td>
<td>Specifies the default camera view for alignment, and changes the camera to that setting. The X/Y/Z buttons on the object view menu bar provide quick access to these views. Left-click the buttons to choose a right/top/front view and middle-click to access the left/bottom/back views.</td>
</tr>
<tr>
<td>Front/Back/Right/Left</td>
<td></td>
</tr>
<tr>
<td>Display All Objects</td>
<td>All scene objects are displayed, rather than just the selection.</td>
</tr>
<tr>
<td>Local Camera View</td>
<td>Controls whether the top/bottom/front/back/left/right views are based on the reference object (that is, the first object in the display list) or whether they are global views.</td>
</tr>
<tr>
<td>Modify Scene Cameras</td>
<td>When the View is set to a scene camera or spotlight, changing the selection will modify the camera/light’s position based on changes in the object view.</td>
</tr>
</tbody>
</table>
Setting Object View Preferences

The object view has its own set of preferences that you can adjust to change the view's default behavior.

**To set object view preferences**

1. Choose File > Preferences from the main menu to open the Preferences view.
2. Select Editors > Object View in the explorer pane to open the Object View property editor.
3. Set the preferences as desired. For a complete description of object view preferences, consult the online help.

<table>
<thead>
<tr>
<th>Option</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto Frame Camera</td>
<td>The camera automatically frames the selection whenever the view is updated.</td>
</tr>
<tr>
<td>Auto Align Camera</td>
<td>The camera automatically aligns along the default view axis (see below) whenever the view is updated.</td>
</tr>
<tr>
<td>Auto Select View</td>
<td>Modifies the behavior of Auto Align Camera so that the camera alignment axis is controlled by the maximum area of the bounding box. In other words, the camera view is set to front/top/right based on the area of the bounding box in that view.</td>
</tr>
<tr>
<td>Camera Compensation</td>
<td>Controls whether the camera is adjusted to compensate for changes to the selection. In other words, when this option is on, the camera is locked to the selection while it is animated, transformed, and so on.</td>
</tr>
<tr>
<td>Compensate</td>
<td>Opens a sub-menu from which you can toggle camera compensation (when active) for scaling translation and rotation individually. For example, this is useful if you want to track an object, but you don’t want the camera to rotate with it.</td>
</tr>
</tbody>
</table>
Chapter 5 • Viewing 3D Objects

Customizing the Display in 3D Views

All 3D views have some common cosmetic attributes which you can modify to change their look. The following section describes how to modify two such attributes: the 3D view colors, and the reference grid.

Changing 3D View Colors

By default, the 3D views’ grid, background, and perspective background appear in shades of gray. You can modify them to display any color you wish.

The viewport color is saved with your scene. Each time you create a new scene, the viewports revert to their default set of colors.

To change the 3D view color

1. Choose Scene Colors from any viewport’s camera icon menu to display the Scene Colors property editor.

   Alternatively, you can open the scene color’s property editor in the Preferences view (from the main menu, choose File > Preferences) by selecting Scene Colors from the explorer pane.

2. Click the Geometry Views tab.

   - To change viewport background color, set an RGBA value using the Background color sliders.
   - To change the color of the viewport border region, set an RGBA value using the Viewport color sliders.
   - To change the color of the viewport grid, set an RGBA value using the Grid color sliders.

You can quickly change the 3D view background color to black or back to the default gray by choosing Set Background to Black or Set Background to Gray from any viewport’s camera icon menu.
**Customizing the Grid**

When you translate objects, such as lights and cameras, you can do so relative to the displayed grid; that is, the translation is restricted to take place within the plane of the displayed grid. This can be done in any 3D view displaying any perspective or camera view.

You can modify grid characteristics in the Camera Visibility property editor.

To modify a 3D view’s grid

1. Do one of the following:
   - From a viewport’s eye icon menu, choose **Visibility Options** to display the Camera Visibility property editor.
   - From an object view’s Show menu, choose **Visibility Options** to display the Camera Visibility property editor.

2. Click the **Visual Cues** tab to display the Visual Cues page, then click **Floor/Grid** to activate grid display in the viewport.

   The grid helps you position and orient the objects in your scene, but the grid itself is not rendered.

3. Set the **Floor/Grid Display Setup** and **Field Guide** options as required.
   - Choose a display grid with respect to the plane in which it is displayed.
   - Set the displayed grid size (Extent), which controls the actual cell size of the grid displayed in the viewport. This can only be set for finite grids.
   - Set the spacing between grid lines along the U and V axes. Measurements are in Softimage units.
   - Activate or deactivate snapping by grid amounts.
   - Set the snapping grid size using the UV Step options.
   - Set safe areas for titles and actions.

   For a description of each of these options, click ? in the Camera Visibility property editor.

   You can set grid options for all 3D views simultaneously in the Visibility Options of All Cameras property editor by choosing **View > Visibility Options (all Cameras)** from the main menu.
Chapter 5 • Viewing 3D Objects

Types of 3D Views

There are many ways to view your scene in the 3D views. These viewing modes are available from the Views menu in viewports and from the View menu in the object view. These menus have somewhat different options:

- The viewports’ Views menu lists the various camera, spotlight, and viewpoint views from which you can view your scene, as well as other views, like editors and data views, that you can open in viewports.
- The object view’s View menu lists the various camera, spotlight, and viewpoint views from which you can view your scene, as well as a number of viewing options that are unique to the object view (see The Object View on page 151 for more information).

The following sections describe the views available from both types of 3D view.

Camera Views

Camera views let you display your scene in a 3D view from the point of view of a particular camera. You can also choose to display the viewpoint of the camera associated to the current render pass.

The Render Pass view is also a camera view: it shows the viewpoint of the particular camera associated to the current render pass. Only a camera associated to a render pass is used in a final render.

Selecting a camera or the Render Pass item from a viewport’s Cameras menu switches the viewpoint to that of a “real” camera in your scene. All other views such as User, Top, Front, and Right are not associated to an actual camera.

The Default Camera View (Object View Only)

In addition to listing the cameras in your scene, the object view’s View > Cameras menu lists the Default camera. This camera is a special perspective view that the object view uses to view selected objects.

Spotlight Views

Spotlight views let you select from a list of spotlights available in the scene. Selecting a spotlight from this list switches the point of view in the active 3D view relative to the chosen spotlight. The point of view is set according to the direction of the light cone defined for the chosen spotlight.

To view the light cones of selected and unselected spotlights, choose Cones from the eye icon menu.

For more information about working with spotlights, see Chapter 13: Lights and Shadows in the Shaders, Lights & Cameras guide.
Viewpoints show you the geometry of objects in a scene. They can be viewed in the render region, but they cannot be rendered like camera views.

You can also choose different display types to change the visual appearance of the objects seen in viewpoints (see Setting Object Display on page 175).

**Top, Front, and Right Views**

The Top, Front, and Right views are parallel projection views, called such because the object’s projection lines do not converge in these views. Because of this, the distance between an object and the camera has no influence on the scale of the object. If one object is close to the camera, and an identical object is farther away, both appear to be the same size.

The Top, Front, and Right views are orthographic, which orients the camera so it is perpendicular (orthogonal) to specific planes:

- The Top view faces the XZ plane.
- The Front view faces the XY plane.
- The Right view faces the YZ plane.
**XYZ Viewpoint Buttons**

The X, Y, and Z buttons are displayed in the viewports’ and object view’s respective menu bars.

Once an X, Y, or Z view is enabled, you can do one of the following:

- Click the button again to reset the view to how it was before you clicked the X, Y, or Z button.
- Click another of the X, Y, or Z buttons to switch to another view. Once again, clicking the button a second time resets the 3D view to how it was before you clicked any of the X, Y, or Z buttons.
- Press Shift and click an X, Y, or Z button to switch to the corresponding view and frame the selection simultaneously.

You can tell which X, Y, Z view is active by looking at the buttons: the active view’s button appears depressed, so be nice to it.
Types of 3D Views

**User View (Viewports Only)**

The User view is a user-defined viewpoint that shows objects in a scene from a virtual camera's point of view. This view can be either perspective or orthographic.

- In the perspective view, objects appear to converge toward a central vanishing point, and objects closer to the camera appear larger than those farther away.
- In the orthographic view, objects remain in parallel projection with the view being perpendicular (orthogonal) to the XY plane in camera space.

The User point of view can be placed at any position and at any angle within the global 3D coordinate system. You can orbit, dolly, zoom, and pan in this view.

**Other Views (Viewports Only)**

In addition to displaying various views of your scenes' 3D geometry, viewports can display a variety of other views. Some of these are data views, like the explorer and schematic view, while others are editors, like property editors, the texture editor, the animation editor, and so on. Select any view from the menu to display it in the viewport.

**Custom Displays**

If you've created and installed custom displays, you can open them in viewports by choosing them from the Custom Displays sub-menu of the Views menu.

For more information about creating custom displays, see the SDK Customization guide.
Navigating in 3D Views

In 3D views, a set of navigation controls and shortcut keys lets you change the way in which you view your scene. You can use these controls and keys to zoom in to and out of a scene, frame objects within a viewport, and orbit, track, and dolly the scene among other things.

Activating Navigation Tools

Most navigation tools have a corresponding shortcut key so you can quickly activate them from the keyboard. However, some tools are only available from a viewport’s camera icon menu. In either case, activating a navigation tool makes it the current tool for all 3D views, including object views which do not have an equivalent to the camera icon menu.

Selecting navigation tools from the camera icon menu activates them for all 3D views.

The following sections discuss the available navigation tools, listing keyboard shortcut where applicable.

Framing Objects in 3D Views

Framing commands let you instantly zoom in to or out from selected objects in 3D geometry views. You can frame objects in two ways: framing selected objects or framing all objects in one or all 3D views.

To frame selected objects in a 3D view

- Do one of the following:
  - Position the mouse pointer over a 3D view and press a.
  - From the main menu, choose View > Frame All (All 3D Views).

To frame all visible objects in all 3D views

- Do one of the following:
  - Press Shift+a.
  - From the main menu, choose View > Frame All (All 3D Views).

To frame all selected objects in a single viewport

- Choose Frame Selection from the camera icon menu.
To frame all selected objects in all viewports

- Press f or choose View > Frame Selection (All 3D Views) from the main menu bar.

**Zooming**

You can zoom into and out of your scene or pan in all 3D views using the zoom controls.

**Panning and Zooming**

**To pan and zoom**

- Choose Pan & Zoom Tool from any viewport’s camera icon menu, or press the z supra key to activate the zoom tool. Then, in any 3D view, do any of the following:
  - Press the left mouse button and drag to pan.
  - Press the middle button to zoom in.
  - Press the right button to zoom out.
  - Press z again to deactivate zoom mode.

By default, XSI zooms into or out from the center of the view.

You can also zoom into or out from wherever the mouse pointer is located by activating the Zoom on Cursor feature: choose File > Preferences from the main menu to open the Preferences window, click the Tools > Camera icon in the explorer pane to open the Camera property editor, and activate the Pan/Zoom > Zoom On Cursor option.

Zooming in or out changes the view angle setting of the camera, the same as when you zoom with a real camera.

**Rectangular Zooming**

Rectangular zooming lets you define a rectangular area that becomes the new magnification factor.

**To zoom in an area**

- Choose Rectangular Zoom Tool from the camera icon menu or press Shift+z to activate the rectangular zoom tool. Then do either of the following:
  - Left-click+drag an area in the view to zoom in to that area.
  - Right-click to zoom out, and then drag diagonally to define the rectangle.
Chapter 5 • Viewing 3D Objects

**Tracking**

The track tool allows you to pan at varying speeds in any 3D view.

*To track*

- Choose **Track** from any viewport’s camera icon menu to activate the track tool. Then do any of the following:
  - Press the left mouse button and drag to track normally.
  - Press the middle button and drag to track slowly.
  - Press the right button and drag to track quickly.

**Orbiting and Pivoting**

Orbiting and pivoting are only possible in the perspective views (camera, user, and so on).

**Orbiting**

Orbiting rotates a camera, spotlight, or user viewpoint around its point of interest. This lets you study your scene’s overall “look” in any angle in any view.

*To orbit*

- Choose **Orbit Tool** from any viewport’s camera icon menu, or press the o supra key while in User view.

  When you orbit, the left mouse button allows free rotation, the middle mouse button allows vertical rotation, and the right mouse button allows horizontal rotation.

**Pivoting**

Pivoting is like orbiting in reverse; the point of interest rotates around its camera, spotlight, or user viewpoint. This is convenient when you want to precisely adjust the interest’s position.

*To pivot*

- Choose the **Pivot Tool** from any viewport’s camera icon menu.

  When you pivot, the left mouse button allows free rotation, the middle mouse button allows vertical rotation, and the right mouse button allows horizontal rotation.

**Dollying and Rolling**

You can dolly toward the camera interest in a perspective view or toward the center of the 3D view in an orthogonal view. Rolling is only possible in the perspective views.

*To dolly*

- Choose **Dolly Tool** from any viewport’s camera icon menu or press the p supra key. Then, in any 3D view, do any of the following:
  - Press the left mouse button and drag to track normally.
- Press the middle button and drag to track slowly.
- Press the right button and drag to track quickly.

To roll the camera about its Z axis

- Choose Roll Tool from any viewport’s camera icon menu or press the I (I) key. Then, in any 3D view, do any of the following:
  - Press the left mouse button and drag to roll normally.
  - Press the middle button and drag to roll slowly.
  - Press the right button and drag to roll quickly.

Walking and Flying

The walk and fly tools are first-person walkthrough camera tools that combine mouse movement with a custom key map to help you navigate precisely in perspective views. When you use the walk or fly tool, the mouse pivots the camera, while the custom key map controls camera movement.

The key commands are:

<table>
<thead>
<tr>
<th>Key</th>
<th>Movement</th>
</tr>
</thead>
<tbody>
<tr>
<td>q</td>
<td>Move down</td>
</tr>
<tr>
<td>w</td>
<td>Move forward</td>
</tr>
<tr>
<td>e</td>
<td>Move up</td>
</tr>
<tr>
<td>a</td>
<td>Move left</td>
</tr>
<tr>
<td>s</td>
<td>Move back</td>
</tr>
<tr>
<td>d</td>
<td>Move right</td>
</tr>
</tbody>
</table>

You must first hold down a mouse button for any of the key commands to work.

To activate the walk tool

1. Choose Walk Tool from any viewport’s camera icon menu.
2. Then, in any 3D view, do any of the following:
   - Press the left mouse button to walk normally.
   - Press the middle button to walk slowly.
   - Press the right button to walk quickly.

When you use the walk tool, movement is parallel to the ground.
Chapter 5  •  Viewing 3D Objects

To activate the fly tool

1. Choose *Fly Tool* from any viewport’s camera icon menu.
2. Then, in any 3D view, do any of the following:
   - Press the left mouse button to fly normally.
   - Press the middle button to fly slowly.
   - Press the right button to fly quickly.
   When you use the fly tool, movement is toward the camera’s interest.

To set Walk/Fly tool options

1. From the main menu, choose *File > Preferences* to open the Preferences window. Then click the *Tools > Camera* icon in the explorer pane to open the Camera property editor.
2. Set the following *Walk/Fly* options:
   - **Look Speed (units/sec)** sets the speed at which the Walk/Fly tool “looks” when you move the mouse.
   - **Forward/Sideways (units/sec)** sets the speed at which the Walk/Fly tool moves forwards and backwards (w and s keys), or left and right (a and d keys).
   - **Slow/Fast Multiplier** specifies the factor by which speed is adjusted when you use fast (right mouse button) and slow (left mouse button) interaction.

Driving

The drive tool is a first-person walkthrough camera tool that is similar to the walk and fly tools, but has more versatile mouse controls and additional visual feedback.

When the drive tool is active, left-clicking or middle-clicking anywhere in the view displays a guide icon, which delineates the different movement zones. Dragging the mouse into any of those zones moves the camera in the corresponding direction and changes the mouse pointer to indicate the type and direction of the movement. As you move the mouse further from the center, the movement speed increases and the guide icon fades to transparency.
The type of movement depends on which mouse button you press: the left-mouse button is for turning movements and the middle-mouse button is for sliding movements, as shown below:

**Left Mouse Button (Turn Mode)**

- Forward + Turn Left
- Rotate Left
- Reverse + Turn Left
- Slide Back

**Middle Mouse Button (Slide Mode)**

- Forward + Slide Left
- Slide Left
- Reverse + Slide Left
- Slide Back

In addition to the mouse commands, you can use a custom keymap to move the camera. The key commands are:

<table>
<thead>
<tr>
<th>Key</th>
<th>Movement</th>
</tr>
</thead>
<tbody>
<tr>
<td>q</td>
<td>Move down</td>
</tr>
<tr>
<td>w</td>
<td>Look up</td>
</tr>
<tr>
<td>e</td>
<td>Move up</td>
</tr>
<tr>
<td>a</td>
<td>Look left</td>
</tr>
<tr>
<td>s</td>
<td>Look down</td>
</tr>
<tr>
<td>d</td>
<td>Look right</td>
</tr>
</tbody>
</table>

The right-mouse button pivots the camera but does not display the guide icon or activate the custom keymap.

**To activate the drive tool**

- Choose **Drive Tool** from any viewport’s camera icon menu.
Chapter 5 • Viewing 3D Objects

To set Drive tool options

1. From the main menu, choose File > Preferences to open the Preferences window. Then click the Tools > Camera icon in the explorer pane to open the Camera property editor.

2. Set the following Drive options:
   - Speed sets the speed of Drive tool mouse interaction.
   - Turn (deg/sec) sets the speed at which the Drive tool “turns” when you use the mouse to turn or rotate.
   - Up/Down (units/sec) sets the speed at which the Drive tool moves up and down (e and q keys).
   - Show Guide specifies whether the Drive tool guide is displayed in the viewports when the tool is activated.

Combination Mode

The Navigation tool combines a number of different viewport navigation tools into one.

To activate the navigation tool

- Choose Navigation Tool from the camera icon menu or press the s supra key in a viewport perspective view. Then do any of the following:
  - Left-click to track (pan).
  - Middle-click to dolly.
  - Right-click to orbit.

- Press Shift and click as follows:
  - Left-click to track (pan) horizontally/vertically.
  - Middle-click to roll.
  - Right-click to orbit horizontally/vertically.

- Press Ctrl and click as follows:
  - Left-click to zoom in using the rectangular zoom tool.
  - Middle-click to zoom out using the rectangular zoom tool.
Setting an Alternate Mouse Mapping

You can set an alternate mouse mapping for the navigation tool from the Tool Options property editor.

To set an alternate mouse mapping for the Navigation tool

1. From the main menu, choose File > Preferences to open the Preferences window. Then click the Tools > Camera icon in the explorer pane to open the Camera property editor.

2. Activate the Use Alternate Mouse Mapping option from the Nav/Dolly options.

When the alternate mapping is set, the mouse controls change to the following:

- Right-click to orbit.
- Left-click to track (pan).
- Middle-click to dolly.

Press Shift and click as follows:

- Right-click to orbit horizontally/vertically.
- Left-click to track (pan) horizontally/vertically.
- Middle-click to roll.

Press Ctrl and click as follows:

- Left-click to zoom in using the rectangular zoom tool.
- Middle-click to zoom out using the rectangular zoom tool.

Resetting Coordinates

You can reset the camera and other 3D views so that their global point of origin (X = 0, Y = 0, Z = 0) is in the center of the 3D view.

To reset the camera and view coordinates

- Choose Reset from the camera icon menu or press r.
Setting Object Visibility

Each camera in the scene has a set of visibility controls that determine whether objects, object attributes, or components are visible in the 3D views and in the rendered image. An additional set of visibility controls exist for each object in its Visibility property editor.

Setting Visibility for All Objects in All 3D Views

You can set object visibility for all cameras, which in turn determine how objects are viewed and rendered in all viewports.

Besides showing and hiding objects and components, you can also choose to display or hide object attributes such as centers, points, and normals. Object attributes are useful visual cues when performing certain rendering tasks. For example, to verify in Wireframe whether a surface is correctly oriented for rendering purposes, you would display the object’s normals.

Showing or hiding object attributes affects the scene’s refresh rate but does not affect the object information that is saved with a scene. Even if object attributes are displayed on objects in the 3D views, they do not appear in the final render.

To set object visibility for all cameras in all viewports

- From the main menu, choose View > Visibility Options (All Cameras) to display the Visibility Options of All Cameras property editor.

From this editor, you can choose the types of objects, object components, and object attributes to display or hide in all 3D views. In addition, you can set a number of grid display options.

See the Online Help for a description of the options available in this property editor.

Setting Visibility for All Objects per Viewport

You can set object visibility on a per camera basis, which determines how objects are viewed and rendered in individual 3D views.

To set object visibility per camera in a specific 3D view

1. If required, change viewing modes in the 3D view and select the camera to which to apply the visibility settings.

2. Do one of the following:

   - Click the eye icon in a viewport’s menu bar, or the Show menu in an object view’s menu bar, and choose an object type to show or hide from the menu.

   or

   - Click the eye icon on a viewport, or the Show menu in an object view, and choose Visibility Options to display the viewport’s Camera Visibility property editor. From this editor you can choose additional
types of objects, object components, and object attributes to display or hide in the 3D views. In addition, you can set a number of grid display options.

Each object in the scene has its own set of visibility controls that determine whether the objects appear in the 3D views and rendered image.

For example, you may wish to temporarily exclude objects from a render but retain them in the scene. This can come in handy when you are working with complex objects and want to reduce lengthy refresh times.

You can also choose to render only an object’s shadow and reflection. Each geometric object’s property editor has a variety of options that can be selected individually or combined with others to achieve the desired effect.

To set object visibility for a selected object

1. In a 3D view, select the object whose visibility options you want to set.
2. Click the Selection button in the Select panel to display the selected object’s property nodes.
3. Click the Visibility node to open the object’s Visibility property page.
4. In the General options, activate or deactivate any of the following:
   - **View Visibility**: displays the selected object in the 3D views. This is useful if you want to clean the area around the render region in a view. Turning off View Visibility will not affect the rendered image.
   - **Render Visibility**: displays the object in the rendered image. This overrides all other settings in the Rendering controls.
   - **Selectability**: determines whether the object can be selected in the 3D views.
5. In the Rendering options, activate or deactivate any of the following to control which attributes of the selected object are visible when the scene is rendered.

   - **Primary Rays**: makes the object visible for viewing and rendering. A reflection of the object, however, may not be visible unless Secondary Rays are also selected.

   - **Secondary Rays**: shows an object's reflection in a mirrored surface; also shows its refraction and transparency.

   - **Shadows**: shows an object's shadow. A shadow is cast if the lights and rendering options are properly set. For instructions on creating shadows, refer to *Creating Shadows* in Chapter 13 in the Shaders, Lights & Cameras guide.

6. Set the Animation options to control ghosting for the object, if the object is animated. For a full description of ghosting options, see Ghosting Animated Objects in Chapter 2 in the Animation guide.

7. Set the Caustic and Global Illumination options for including photons for creating caustic effects or global illumination when rendering. For more information on caustics and global illumination, see Chapter 15: Global Illumination, Caustics, and Final Gathering of the Shaders, Lights & Cameras guide.

**Example: Setting an Object’s Visibility Parameters**

Let’s say you created two characters (a real mouse and a computer mouse). You can set the object’s visibility parameters so that only the real mouse’s shadow is visible to the camera while no shadow is visible for the computer mouse. To do this, select only the Secondary Rays and Shadows options for the real mouse and only the Primary Rays option for the computer mouse.

![Image of two mice]

**About Visibility and Model Instances**

Because model instances are treated as single objects, you cannot control the visibility of individual objects within an instance. You can only set visibility options for the instance itself. Toggling visibility on or off affects the entire instance.
You can change the visibility options of individual objects within the master model's hierarchy. Toggling any object's visibility on or off affects the corresponding object in each instance.

**Hiding and Unhiding Objects**

You can quickly hide and unhide selected objects in the 3D views using menu commands or the h shortcut key. This is a quick way to set the viewing visibility of a selected element.

Hiding objects eliminates their visibility both in the 3D views and in the rendered output.

To hide and redisplay selected objects in the viewports

1. Do one of the following:
   - In any viewport, select the object you want to temporarily hide, and press h.
   - From the main menu, choose View > Hide/Unhide Selection.

   The selected object is hidden in all geometric views but remains visible in the explorer (an H will appear on the icon of the hidden node). Hidden elements are not rendered in the render region nor do they appear in the final output.

2. Pressing h or choosing View > Hide/Unhide Selection again redisplays the hidden object.

   If you selected another element or modified the scene after you hid the object, pressing h or choosing View > Hide/Unhide Selection again has no effect. In this situation, the hidden object can only be redisplayed by selecting its node in the explorer and pressing h or choosing View > Hide/Unhide Selection again.

To hide and deselect selected objects in the viewports

- From the main menu, choose View > Hide and Deselect.

   The selected object is deselected and hidden in all geometric views but remains visible in the explorer (an H appears on the icon of the hidden node).

To hide unselected objects in the viewport

- From the main menu, choose View > Hide Unselected Objects/Polygons.

   Any unselected objects are hidden in all geometric views but remain visible in the explorer (an H appears on the icons of the hidden nodes).

To unhide all hidden objects in the viewports

- From the main menu, choose View > Unhide All Objects.
Setting Visibility for Selected Polygons

You can show and hide both polygon clusters and selections of polygons on an object.

Setting Visibility for Polygon Clusters

You can apply a visibility property to a polygon cluster to control whether the cluster appears in the viewports and rendered image. This is useful when you want to animate the cluster’s visibility settings.

To set visibility for a polygon cluster

1. In a 3D view, select a polygon cluster.
2. From any toolbar, choose Get > Property > Polygon Cluster Visibility to apply a visibility property to the polygon cluster.
   
   When you apply the visibility property, the cluster’s view and render visibility is automatically disabled.

3. With the cluster still selected, click the Selection button in the Select panel and click the Visibility node’s icon in the pop-up explorer.
4. In the Visibility property editor that opens, select or deselect visibility for the cluster as required:
   
   - **View Visibility** for showing the selected object in the 3D views. This is useful if you want to clean the area around the render region in a 3D view. Turning off View Visibility does not affect the rendered image.

   - **Render Visibility** for showing the object in the rendered image. This overrides all other settings in the Rendering controls.
Setting Visibility for Selected Polygons

You can control the visibility of selected or unselected polygons by making them "Invisible" rather than creating a cluster and applying a visibility property to it. The hidden polygons are invisible for both viewing and rendering.

This is useful for temporarily hiding selections of polygons. For example, if you have one object inside of another, you can hide some of the outer object’s polygons, rather than hiding the object outright, and place the inner object properly.

You can also display invisible polygons in the viewports without unhiding them. Though they are partially visible for viewing, they are not rendered.

To hide selected/unselected polygons

1. Select a group of polygons on an object.

2. Do one of the following:

   - Press \texttt{h} or choose \texttt{View > Hide/Unhide Selection} from the main menu bar to hide the selected polygons.

   or

   - Choose \texttt{View > Hide and Deselect} from the main menu bar to hide the selected polygons and deselect them.

   or

   - Press Ctrl+Shift+h or choose \texttt{View > Hide Unselected Objects/Polygons} from the main menu bar to hide all unselected polygons.

The selected polygons are hidden in all geometric views but remain visible in the explorer (an \texttt{H} appears on the icon of the node to which the polygons belong). Hidden polygons are not rendered in the render region nor do they appear in the final output.

To unhide invisible polygons

- Do one of the following:

  - If the polygons are selected, press \texttt{h} or choose \texttt{View > Hide/Unhide Selection} from the main menu bar.

    or

  - If the polygons are not selected, press Ctrl+h or choose \texttt{View > Unhide All Polygons} from the main menu bar.
To display invisible polygons

- From the eye icon menu in any viewport, or the Show menu in an object view, choose Invisible Components. The hidden polygons are displayed with the following visual cues to identify them as invisible:
  - The wireframe of invisible polygons is a dashed line instead of a solid line.
  - In shaded viewing modes, the invisible polygons’ shading is half-tone.

When invisible polygons are displayed this way, you can select them in the 3D views, which is handy if you want to make them visible again.

In wireframe mode, the visible polygons’ wireframe is a solid line, while the invisible polygons’ wireframe is a dashed line.

In shaded mode, the visible polygons’ have solid shading, while the invisible polygons’ have half-tone shading.
Setting Object Display

Once you have decided which objects, attributes, and components are visible in your 3D views, you can choose how to display them. Some display types provide less detail but are less computationally intensive than others—and this speeds up your screen refresh.

You can define display types for:

- **All cameras**: how objects are displayed in all 3D views.
- **Individual cameras**: how all objects in a specific 3D views are displayed.
- **Individual objects**: how individual objects are displayed in all 3D views.

### Display Types

This section summarizes the different ways in which you can display objects.

By default, all objects are displayed in Wireframe mode.

**Wireframe**

Shows the geometric object made up of its edges, drawn as lines resembling a model made of wire. This image displays all edges or contour lines without removing invisible or hidden parts or filling surfaces. This is the default display type in the viewport.

You can alter this view by changing the color of the wireframe of a specified object.—see *Setting Object and Wireframe Color* on page 188.

**Bounding Box**

Reduces all scene objects to simple cubes. This speeds up the redrawing of the scene because fewer details are calculated in the screen refresh.

**Depth Cue**

Applies a fade to visible objects, based on their distance from the camera, in order to convey depth. You can set the depth cue range to the scene, selection, or a custom start and end point. Objects within the range fade as they near the edge of the range, while objects completely outside the range are made invisible. You can also display depth cue fog to give a stronger indication of fading. For more information about the depth cue options, see *Depth-Cue Fog* on page 182.
Chapter 5  •  Viewing 3D Objects

Hidden Line Removal

Shows only the edges of objects that are facing the camera. Lines that are usually hidden from view by the surface in front of them are not displayed because they are in a “see through” wireframe.

Constant

This type ignores the orientation of surface normals and instead considers them to be pointing directly toward an infinite light source. All the object’s surface triangles are considered to have the same orientation and be the same distance from the light. This results in an object that appears to have no shading.

This mode is useful when you want to work in textures because there are no attributes to interfere with the texture’s definitions. This mode is also useful for previewing rotoscoped images.

Shaded

Provides an OpenGL hardware shaded view of your scene that closely approximates its realistic “look” but does not show shadows, reflections, or transparency. Wireframes of geometric objects are superimposed over their shaded surfaces showing you most display options, such as lines, points, tags, and centers. This makes it easy to manipulate points, lines, tagged points, etc. You can also view light (point and spot) and camera icons.

Textured

Displays textures, lighting and basic surface effects like transparency. When objects are selected, their wireframes are superimposed on their textured surfaces, showing you most components (lines, points, tags, centers, and so on). This makes it easy to manipulate points, lines, tagged points, and so on.
Textured Decal

This is like the textured, viewing mode, but textures are displayed with constant lighting. The net effect is a general “brightening” of your textures and an absence of shadow. This allows you to see a texture on any part of an object regardless of how well that part is lit.

Realtime Shaders

This displays all realtime shader attributes for objects that have been textured using realtime shaders. In the example shown here, a different texture is used to control the object’s OpenGL realtime rendering, so the result is different from what it would be in the textured or textured decal viewing modes.

Three realtime shaders display modes are available:

- **OpenGL**: displays realtime shader attributes for objects that have been textured using OpenGL realtime shaders.
- **Cg**: displays realtime shader attributes for objects that have been textured using Cg realtime shaders as well as XSI’s Cg-compatible MetaShaders.
- **DirectX9**: displays realtime shader attributes for objects that have been textured using DirectX realtime shaders.

For more information, see Chapter 19: Realtime Shaders as well as MetaShaders in Chapter 2 of the Shaders, Lights & Cameras guide.

Setting the Display Types for Individual Objects

To quickly set display types for individual objects

1. At the bottom of the toolbars, click the Palette icon.

This displays a toolbar containing a group of display type icons where:

- **B** = bounding box
- **W** = wireframe
- **H** = hidden line
- **C** = constant
- **S** = shaded
- **T** = textured
- **D** = reset the object to its default display type
Chapter 5 • Viewing 3D Objects

2. Click an icon, then pick the objects to receive the associated display type. Right-click to end the picking session.

If the selected object does not change display types, your 3D view is probably set to override object properties. Choose **Override Object Properties** from the view’s Display Type menu.

Display options selected from a viewport or object view’s **Display Type** menu determine how all objects in that particular view are displayed.

The object view’s Display Type menu has fewer options than the viewports’. For example, it does not include any of the Ghosting or Rotoscopy options.

**To set the display type for a specific 3D view**

1. Click the **Display Type** menu to choose a display type from its menu.

2. Choose **Display Options** if you wish to further define your viewport display.

You can toggle between the previous and current display type by middle-clicking the **Display Type** name displayed in the viewport or object view menu bar.

**Overriding Individual Display Types**

The **Override Object Properties** option in the **Display Type** menu, when selected, overrides any display type settings that may have been set for individual objects in the viewport.
Setting Object Display

Setting Display Options for All Cameras

You can specify how cameras view objects in the Display Options for All Cameras property editor. See the online help for a description of each option.

To specify how all cameras view objects in 3D views

1. From the main menu, choose View > Display Options (All Cameras).
   The Display Options of All Cameras property editor opens.

2. On the Display Options property page, set the options described in the following sections.

Wireframe Mode

The Wireframe options on the Display Options tab allow you to control two basic wireframe attributes.

- **Show Simplified Subdivision Wireframe** toggles visibility of a simplified version of an object’s subdivision wireframe in any wireframe view in a viewport.

  - **Show Simplified Subdivision Wireframe on**
    Only the edges corresponding to the hull polygons are displayed.

  - **Show Simplified Subdivision Wireframe off**
    All edges are displayed. The edges corresponding to the hull polygons are darker.

- **Wireframe Color** sets the color of the wireframe of unselected objects. Specify either the default wireframe color, or the object’s diffuse color.

See the Online Help for a description of the Depth-Cue/Fog options available in this property editor.

Shaded Mode

The Shaded Mode options on the Display Options tab allow you to control the display of objects viewed in shaded and/or textured display modes. These options include:

- X-ray mode is a viewing option that lets you see through objects in Constant, Shaded, and Textured viewing modes. This is very useful when working with envelopes because you can see and select the underlying deformers while still seeing the shaded surface of the envelope.
Two X-ray shading types are available—overlay mode and screen mode. For more information about X-ray shading, see X-Ray Shading in Chapter 2 of the Character Animation guide.

• The Enable Transparency option toggles OGL transparency on and off. When transparency is on, objects that have transparency enabled in their surface shader properties appear transparent in the Constant, Shaded, Textured, Textured Decal, and Realtime Shaders viewing modes.

OGL transparency only works when you are using non-alpha channels to control transparency (RGB in RGBA mode, HLS in HLSA mode, and so on).

• The Sort Transparent By option determines how transparent objects are sorted before they are drawn in shaded views: minimum or maximum depth, average depth, or no sorting at all. Objects are always drawn from back to front, as determined by the sort order.

The Sort Transparent By option determines how transparent objects are sorted before they are drawn in shaded views: minimum or maximum depth, average depth, or no sorting at all. Objects are always drawn from back to front, as determined by the sort order.

• The Hidden Line Surface Color options set the color of hidden lines. Specify either the background color, the object’s diffuse color, or the viewport color.

• The Vertex Color Property Display option toggles the display of painted vertices in shaded view. For more information about painting colors at vertices, see Chapter 12: Working with Vertex Colors in the Shaders, Lights & Cameras guide.
When a 3D view’s display mode is set to Textured Decal, the **Blend Using Alpha in Texture Decal** option blends any given material’s currently displayed texture with the surface of the object to which the material is applied according to the texture’s alpha channel. For more information about displaying textures in shaded viewing modes, see *Chapter 6: Clips & Sources* in the *Shaders, Lights & Cameras* guide.

See the Online Help for a description of the Shaded Mode options available in this property editor.

**Shaded Mode Wireframe Highlight**

The **Shaded Mode Wireframe Highlight** options allow you to control the display of object wireframes in 3D views set to any shaded or textured display mode.

- **Show Wireframe on Selected Objects**
  toggles selected objects’ wireframe visibility in any shaded or textured view in a viewport.

- **Show Wireframe on Unselected Objects**
  toggles unselected objects’ wireframe visibility in any shaded or textured view in a viewport.

- **Show Transparent Selected Wireframe**, in any shaded or textured view mode, makes a selected object’s display transparent, letting you see the entire wireframe through the object.

- **Show Simplified Subdivision Wireframe**
  toggles visibility of a simplified version of an object’s subdivision wireframe in any shaded or textured view in a viewport.
Chapter 5  •  Viewing 3D Objects

**Depth-Cue Fog**

The **Depth-Cue/Fog** options on the Display options tab allow you to control depth fading in Depth-Cue display mode, as well as the display of non-renderable OpenGL-based fog in other display modes. For example, when you set the range options, they specify the range of the Depth fading effect in Depth-Cue mode, and the density of the fog, if activated, in other display modes.

See the Online Help for a description of the Depth-Cue/Fog options available in this property editor.

**Realtime Shaders - OpenGL**

The **Realtime Shaders-OpenGL** settings on the Display options tab allow you to display OpenGL based shadow maps in 3D views set to **Realtime Shaders > OpenGL** display mode. For shadow maps to display properly, several conditions must be met:

- Scene lights must have shadows toggled on to be involved in the shadow calculation.
- The lights must be spot lights or point lights.

Show Simplified Surface when Hull Visible
toggles an object's subdivision wireframe visibility, when polygon hull visibility is enabled, in any shaded or textured view in a viewport.

Wireframe Highlight Line Width controls the width of the highlighted lines of selected objects in any shaded or textured viewing mode.
Setting Object Display

- The **Realtime Shadows** display option must be activated.
- 3D views must be set to the **Realtime Shaders > OpenGL** mode to display the shadows.

Realtime shadows are P-Buffer based, so the resolution of the buffer controls the quality of the shadows.

![P-Buffer resolution = 128x128](image1)

![P-Buffer resolution = 512x512](image2)

See the Online Help for a description of the Realtime Shaders-OpenGL options available in this property editor.

**Head Light**

The **Headlight** options on the Display Options tab control the headlight tool. The headlight is a virtual light shining into the scene from the position of the camera. It is visible in any shaded OGL display mode (Shaded, Textured, Textured Decal, and so on), and when activated, temporarily disables all other scene lights. This is useful when you want to preview the shadowed parts of scene objects.

![This object is lit from the bottom, creating a number of shadowed areas that are difficult to see.](image3)

![Activating the headlight lights the object from the camera’s position, making the shadowed areas more visible.](image4)

The headlight is for display purposes only and is not renderable.

See the Online Help for a description of the Headlight options available in this property editor.
Mixed Viewing

Activating the Mixed Viewing Mode options on the Display Mode tab allows you to set individual display modes for selected and unselected scene objects. You can further refine the display options by specifying display modes to use when objects are static, during interaction, and during playback.

For example, you could specify that selected objects be displayed in textured display mode when static, but in wireframe mode during playback and interaction. You could further speed up interaction by having unselected objects always be displayed in wireframe mode.

Mixed-viewing mode

To take all object display types into account, choose Mixed Viewing Mode. Settings for individual objects are set in their own Display property editors (see page 187).

See the Online Help for a description of the Mixed Viewing options available in this property editor.

Performance

The options on the performance offer various tools to help you speed up the playback of your scene.

- The culling options allow you to limit what is drawn in the viewports, in order to increase playback and interaction performance.
  - Backface Culling: specifies whether to cull (not draw) back faces of objects
  - View Frustum Culling: specifies whether to draw only objects that are within the cameras view (frustum culling).

- The Fast Playback options speed up the redrawing of your scene by temporarily hiding the grid and drawing objects in wireframe during playback of an animated scene. These options are fully described in Playing Back All Frames or Playing in Real Time in Chapter 3 of the Animation guide.
Ghosting

The options on the Ghosting tab allow you to control the display of both mixer ghosting and animation ghosting.

- Mixer ghosting is used when an object is driven by two or more clips at a time (the clips overlap in time). Ghosting allows you to see the contribution of each clip’s animation on the object as a ghost in the viewport.

The Mixer ghosting options are fully described in Ghosting Clips in Chapter 2 of the Nonlinear Animation guide.

- Animation ghosting, also known as onion-skinning, is a viewing mode that lets you display a series of snapshots of animated objects at frames or keyframes behind and/or ahead of the current frame. This lets you easily visualize the motion of an object, which can help you improve its timing and flow.

The Animation ghosting options are fully described in Ghosting Animated Objects in Chapter 2 of the Animation guide.
Setting Scene Colors

Different colors are used to indicate the status of displayed scene elements. For instance, by default a selected object is displayed in white and an unselected object is displayed in black. Points are displayed in blue, knots are displayed in pink, and so on. You can modify these colors to suit your project.

To change scene colors

1. Do one of the following:
   - In the explorer, choose Application in the scope menu (or press a). Open the Scene Colors node, located directly beneath the Preferences node to display the Scene Colors property editor.
   - Choose Scene Colors from any viewport’s camera icon menu to display the Scene Colors property editor.

   Click the Objects, Components or Geometry tab, depending on which elements you want to modify.

To change the wireframe color of a specific object, see Setting Object and Wireframe Color on page 188.
You can control how individual objects are displayed in a 3D view.

Giving an object or objects different display characteristics is particularly useful for heavily-animated scenes. For example, if you want to tweak a static object within a scene that has a complex animated character, you could set the character in wireframe display mode while adjusting the lighting of your static object in shaded mode.

**Setting display options for individual objects**

1. Select an object.

2. Click the **Selection** button in the Select panel and click the object’s Display node to open its Display property editor.

   ![Display property editor](image)

   In this property editor, you can select different display types as well as apply them, depending on the state of the object (selected, unselected near, unselected far). The distance at which an object is considered to be near is set in the **Near Distance to Output Camera** controls. For complete details on each control in this property page, see Online Help.

   ![Near Distance to Output Camera controls](image)

   You can also set display options by choosing **Get > Property > Display** from any of the default toolbars. However, as with all **Get > Property** commands, this resets existing display settings for the selected object. This also overrides shared or inherited display properties.
Chapter 5 • Viewing 3D Objects

Setting Object and Wireframe Color

You can change the color of unselected objects displayed in wireframe in the 3D views. Assigning wireframe colors to objects can be useful if your scene is complex and you want to make certain elements stand out for easy identification.

You can easily set object wireframe colors using the Palettes toolbar. This toolbar contains a default set of 12 colors. The black chip on the bottom Wire Colors row is the object's default color.

To change an object’s wireframe color using the Palettes toolbar

1. Click on the Palettes icon (bottom of the default toolbars) to display the Palettes toolbar.

2. Click a color box, then pick one or more wireframe objects. Click the black chip to assign the object its default wireframe color.

3. Right-click to end the picking session.

To change an object’s wireframe color using the Wireframe Color control

• Set wireframe colors using the Wireframe Color control in the object’s Display property editor.

  Its slider can be set to any one of over 1000 colors. The color index goes from 0 to 1023. Each number represents a color, except for 0, which is a “special” value that means “use object-type color”.

• To calculate RGB (0-255) color values based on the wireframe index color, use the following formula:

  \[
  R = \left( \frac{\text{index}}{2} \right) \mod 8 \times 32 \\
  G = \left( \frac{\text{index}}{16} \right) \mod 8 \times 32 \\
  B = \left( \frac{\text{index}}{128} \right) \mod 8 \times 32 
  \]

• To calculate the wireframe index color based RGB values, use the following formula:

  \[
  \text{index} = \left( \frac{B}{32} \right) \times 128 + \left( \frac{G}{32} \right) \times 16 + \left( \frac{R}{32} \right) \times 2
  \]
Improving Scene Display Performance

When you interact with your scene by transforming objects, changing camera views, and so on, SOFTIMAGE|XSI must redraw the scene in the viewports, which can sometimes slow down performance. There are several methods you can use to speed up the display.

**Muting and Soloing Viewports**

When you interact with scene elements, the scene is redrawn in all camera views. Muting unessential viewports speeds up redrawing in the other viewports. See *Muting and Soloing Viewports* on page 150 for more information.

**Camera Display**

You can change the display type of static, interacted, selected, and unselected objects by choosing *Display Options* from a viewport’s *Display Types* menu.

You can also set these options for all cameras by choosing *View > Display Options (All Cameras)* from the main menu bar. See *Setting Display Options for All Cameras* on page 179 for more information on the options available in the Camera Display property editor.

**Fast Manipulation and Fast Playback**

The Constant, Shaded, Textured, and Rotoscope display types require considerable time to redraw. If you are using these display types, choose *Fast Manipulation* from the *Display Type* menu to speed up the redrawing of your scene so that it switches to wireframe when you interact with an object.

**Fast manipulation**

- **Static Select:**
  - *Textured*
  - Static object displays in textured mode for full detail.

- **Interactive Select:**
  - *Wireframe*
  - During interaction the selected object, is displayed in wireframe to minimize image processing time.
Similarly, choosing **Fast Playback** from the **Display Type** menu speeds up the redrawing of your scene by temporarily hiding the grid and drawing objects in wireframe during playback of an animated scene.

**Interaction User Preferences**

Choose **File > Preferences** to open the Preferences window and select **Display** from explorer pane. You can then set the Performance Options and Display Options such as:

- Deselecting **Update All Views During Interaction** refreshes the view you are interacting with first, while other views will lag behind.
- Selecting **Display Options Use Coarse Step by Default for Interaction and Playback** displays the UV coordinates of NURBS-type objects in coarse mode (only one step is calculated and displayed between knots).

**Surface Approximation**

By modifying a NURBS-type object or a model’s display geometry approximation, you can simplify object display for faster redrawing without affecting the rendered image.

**To change the hardware display geometry approximation**

1. In an explorer, click the **Geometry Approximation** node for the object or model you want to affect.

2. In the **Hardware Display** tab of the property editor that opens, modify the **Surface U**, **Surface V**, **Curve**, and **Surface Curve** steps to the desired settings. The lower the value, the less precise the image and the faster the object will redraw.

**OGL Triangulation Update**

The OGL triangulation update options in the Geometry Approximation property editor control the balance between accuracy and speed when drawing polygons in the OpenGL display modes such as Hidden Line, Constant, Shaded and Textured. Less accurate settings are faster while more accurate settings are slower.
Improving Scene Display Performance

To change the OGL triangulation update setting

1. In an explorer, click the Geometry Approximation node for the object or model you want to affect.

2. In the Polygon Mesh tab of the property editor that opens, set the OGL Triangulation Update setting to one of the following:
   - **Recreate at each refresh** is the most accurate and always recalculates triangulation. Playback and interaction are slowest in this mode.
   - **Skip during interaction** does not recompute triangulation of polygons while you are working, and waits for you to pause before retriangulating. The display updates faster as you modify objects, but you may see some artifacts in the OpenGL views, for example, when a polygon becomes concave while manipulating points. Triangulation is still recomputed when required during playback.
   - **Skip during interaction and playback** does not recompute triangulation of polygons while you are working nor while animation is playing back. This mode is faster but you may see some artifacts in the OpenGL views.
   - **Update only when topology changes** never retriangulates unless you modify the topology, for example, by adding or removing points. This mode is the fastest but potentially creates the most artifacts in the OpenGL views.
Outputting XSI Views to an Avid Mojo

Avid Mojo™ is a portable Digital Nonlinear Accelerator that allows you to output hardware and software rendered effects from XSI to a monitor in real-time.

When you have an Avid Mojo connected to your XSI workstation, you can output content from XSI to a monitor using the Mojo to accelerate the display of effects. You can choose a view to output from the Digital IO Output (MOJO) tab of the Display Options property editor.

For more information about configuring XSI to output to a Mojo, see Configuring XSI to Output to an Avid Mojo (Windows Only) in Chapter 5 of the Setup & Licensing guide.

To output XSI views to a monitor

1. From the main menu, choose File > Preferences to open the preferences window. Click the Display icon to open the Display options property editor.

2. From the Digital IO Output (MOJO) tab, choose the Monitor Type to which you're outputting content. This can be either NTSC or PAL.

3. Choose an XSI view to output via the Mojo by setting the View Output to one of the following:
   - Disabled: nothing is output to the monitor.
   - 3D View A: the display in viewport A is output to the monitor.
   - 3D View B: the display in viewport B is output to the monitor.
   - 3D View C: the display in viewport C is output to the monitor.
   - 3D View D: the display in viewport D is output to the monitor.
   - 3D Auto A/B/C/D: the viewport that has focus is output to the monitor. Click a viewport to give it focus.
   - Render View: outputs the rendered image from the Render Preview or, the Render View when rendering an image to disk. The image/frame is not displayed on the monitor until the last tile is rendered.
   - FX View: the content of the FX Viewer is output to the monitor. If no operator is being previewed, no image is output.
   - Image Clip View: the image clip view, as seen in the Image Clip Viewer or the RV Image Clip Viewer is output to the monitor.
Troubleshooting

The following will help you troubleshoot common display problems.

*My display performance is poor with multiple OpenGL views open*

If your OGL views (viewports in shaded display modes, animation mixer, animation editor, and so on) seem sluggish or exhibit poor performance, it is possible that you have not turned off the Vertical Sync option for your graphics card.

If this option is not disabled, then the maximum refresh rate is the "vertical retrace frequency" divided by the "number of OpenGL views open". For example, if you have a refresh rate of 85Hz and five OGL views are open, the best refresh rate you could get is 17Hz.

In the Advanced Display settings for your graphics card, turn off the option to synchronize buffer swap to the Vertical Sync. It should be set to something like "Always off" or "Off by default". You will have to restart XSI.
Chapter 6  Rotoscopy
Rotoscoping

Rotoscoping is a technique in which video or film images are placed in the background of a scene, one frame at a time. You can use these reference images to create your own animation by tracing objects from the images or matching your objects with the images’ motion, or to match your camera’s point of view with that of the images. You can zoom and pan the scene while maintaining perfect registration with the imported background.

You can rotoscope in any 3D view using any display type. Furthermore, you can use different rotoscoped images for each viewport.

Tips for Rotoscoping

- You can easily create a flipbook of the rotoscoped and background images to check live-action footage with your animation in real time—see Capturing Animation in a Viewport in Chapter 3 of the Animation guide.
- You can use rotoscoped images for many purposes, such as to help you set up a character’s basic movements to match a walk cycle sequence.
If you're capturing the rotoscoped and background images in a render region, make sure the region is set to RGB and Alpha (default) so that the background image is captured exactly as you see it in the viewport.

- If you want to set a realistic ambient color for a scene, match a color from the rotoscoped image that you are using as the background. You can do this using the color picker as described in Setting a Realistic Ambient Color in Chapter 13 of the Shaders, Lights & Cameras guide.

When you load an image sequences into XSI for rotoscopy, the frame rate set in the Playback Options property editor is used, not the default frame rate set in the Time Preferences property editor. While these two frame rates are often the same (setting the default frame rate automatically sets the Playback Options frame rate), make sure that the frame rate set in Playback Options is correct before importing images for rotoscopy.

For more information, see Chapter 3: Playing Animation in the Animation guide.

To display rotoscoped images

1. From any viewport, choose Rotoscope or Rotoscopy Options from the display type menu to open the Camera Rotoscopy property editor.

   - If you choose Rotoscope, the image you select in the Camera Rotoscopy property editor will be immediately displayed in the viewport.

   - If you choose Rotoscopy Options, you will need to activate Rotoscope in the viewport after you've set up the image in the Camera Rotoscopy property editor.

2. In the Camera Rotoscopy property editor, do one of the following:

   - In the Image Name text box, specify the path and file name of the image or image sequence you want to load in a viewport background as a reference. When using an image sequence, each frame advances as the frames increment in the timeline.

   or

   - Click the New button and choose New from File to browse for files on your system, or choose New from Source to load an existing image.

If the image is too large to fit completely in the viewport, a message appears in the viewing pane in this property editor. Once you load the image, it is scaled to fill the Rotoscope viewport as much as possible.
3. Set the other rotoscopy options as shown here:

Use the play, pause, stop, and loop buttons to preview image sequences.

**Scales** the rotoscoped images before caching at the value you select. The smaller the images, the less memory is required per frame.

The number of **Frames** from the source image sequence to cache. Rotoscope images are cached based on the number of frames in the source sequence. Set this parameter to the same number of frames as the source for good performance. The more frames cached, the faster the playback.

**Uses a 1.0 pixel ratio** which prevents images from looking squashed.

**Uses either the Camera or Image Pixel Ratio.** If you select the image ratio, the image format must support this. On the Image Source property page, image sources display a read-only parameter showing the pixel ratio, if supported.

View any **Channel** of the rotoscoped images: all channels, or the red, green, blue, or alpha channels separately.

4. When you’re satisfied with the image in the property editor, choose **Rotoscope** from the display type menu in the viewport (if you haven’t already) to display the rotoscoped images behind the objects and background in the viewport.

3D dog in shaded display flying through the clouds of the rotoscoped image.
You can always modify the rotoscope settings later in the Rotoscope Options property editor.

Use the play, loop, forward, and backward arrows in the Playback panel (below the timeline) to advance the sequence of your rotoscoped background along with any animated objects in your scene.

Navigating in a Rotoscoped View

You can zoom, pan, dolly, etc. the scene objects as usual while keeping the rotoscoped image the same size. However, to zoom the scene objects and the rotoscoped image together, the process is a little different.

To navigate the scene objects and rotoscoped image together

1. Do one of the following:
   - Click the Rotoscope Lock icon in the Rotoscoped viewport’s menu bar.
   or
   - Use the rectangular zoom (press Shift+z) to define the zoom area (left or middle-click to zoom in, right-click to zoom out).

2. You can then do any of the following:
   - Use the zoom option (press z) to pan, zoom in, and zoom out on the defined area. When you pan, it has the effect of moving the snapshot in front of a still camera.
   - Use the multi-purpose navigation tool (press s) to track and dolly the scene objects and rotoscoped image.
   - Choose Track Tool from the camera menu in the viewport to pan the current camera while rotoscope lock is on (the rotoscoped image is not tracked along with the scene).
Rotoscopy in the Render Region

You can also view your rotoscoped scene and background in a render region.

To view in a render region

1. Choose View > Render > Region > Region Tool from the Render toolbar or press q.
2. Draw a render region in the viewport containing the rotoscoped scene and background (see Previewing Interactively with the Render Region in Chapter 1 of the Shaders, Lights & Cameras guide). The region renders the scene composited over the background.

Compositing the Alpha Channel

You can also use the render region to composite the alpha channel of objects in your scene over the rotoscoped background.

To composite over the rotoscoped background

Do one of the following:

- Choose View > Render > Region > Show Alpha on the Render toolbar to activate the alpha channel of the scene in the render region. This is useful to quickly check the accuracy of a particularly complex alpha channel.
- or
- Choose View > Render > Region > Show Alpha + RGB to use the alpha channel of your scene and composite over the background. This allows you to view motion blur and check the registration of shadows composited directly over the imported background. These shadows must have alpha channels defined, such as those created by a shadow shader.
Section II • Working with Scene Elements
Chapter 7  Basic Scene Elements
What Are the Elements in XSI?

**Objects**

There are many different types of objects in XSI, but the most common type you will use is a 3D object. Basically, these are objects that have geometry and can be modeled and rendered. The two types of 3D objects are polygons and NURBS surfaces.

For more information on these, see *Chapter 9: 3D Objects* on page 259.

**Components of Objects**

All 3D objects have components that create them. Components are elements that define the shape of 3D objects, such as points, edges, and polygons. Clusters are named groups of components. You can select and manipulate different types of components to change the shape of objects.

For more information on components, see *Chapter 12: Components and Clusters* on page 309.

**Selecting Elements**

As you work, you constantly select and manipulate objects and their components. There are a number of tools you can use to select these elements, as well as a number of views in which your selections can be made.

In XSI, you can select any object, component, property, group, cluster, operator, pass, partition, source, clip, and so on; in short, just about anything that appears in the explorer.

For more information on selecting, see *Chapter 8: Selecting* on page 209.

**Organizing Objects into Structures**

There are four different ways in which you can organize the objects in your scene, depending on what you need the grouping to do:

- A hierarchy describes the relationship between objects, usually using a parent-child or tree analogy. The main reason to organize elements into a hierarchy is to allow for different properties to propagate from parent to child. For more information, see *Chapter 13: Hierarchies* on page 323.

- Models are a very important way of organizing objects in XSI. You can think of them as containers for objects, acting like “mini scenes.” Models allow you to easily work with hierarchies and other features in XSI, such as the animation mixer. And importantly, they let you copy objects between scenes in XSI. For more information, see *Chapter 22: Models* on page 473.
What Are the Elements in XSI?

- Grouping objects simply puts objects into groups for easy selection and manipulation. Again, there is no hierarchical relationship involved for propagation—grouping simply lets you organize your objects however you like. For more information, see *Grouping Objects* on page 265.

- Layers allow you create groupings for objects as well, usually for the purpose of viewing, selecting, and rendering different objects. For more information, see *Chapter 14: Layers* on page 331.

**Properties for Anything**

Every element in your scene has properties. Properties are the characteristics of an element that distinguish it from other elements. They are often grouped together by their similarities and defined by a series of parameter values.

Properties can also be applied to elements directly, or they can be applied at a higher level and passed down (propagated) to the children elements in a hierarchy.

Properties like to live in property editors: this is where you can set their parameters’ values.

For more information on properties, see *Chapter 10: Properties* on page 279.

**Weight Maps for Modulating Parameter Values**

Weight maps let you modulate the values of certain parameters across the geometry of an object. You adjust a value at a location on an object using the Paint tool. For example, you can paint weight strokes on an object to vary the strength of a deformation across its surface, almost like sculpting.

For more information on weight maps, see *Chapter 11: Weight Maps* on page 295.
Element Names

All elements have a name. For example, if you choose Get > Primitive > Polygon Mesh > Sphere, the new sphere is called sphere by default, but you can rename it if you want.

Element names appear as labels on nodes in the explorer and schematic views. They are used to identify elements in scripting commands, as well as to select element by typing in the boxes on the Select panel.

Valid Names

XSI restricts the valid characters in element names to a–z, A–Z, 0–9, the hyphen (-), and the underscore (_) to keep them variable-safe for scripting. Invalid characters are automatically converted to underscores. In addition, element names cannot start with a digit; XSI automatically adds an underscore at the beginning.

Namespaces and Unique Names

Namespaces define the scope in which an element name is unique. Names must be unique within the appropriate namespace in order to specify an element unambiguously.

No two elements can have the same name if they are in the same namespace. For example, if there is already an object named sphere under the scene root and you get a second sphere, it is automatically named sphere1 to keep the names different.

Different types of elements have different namespaces:

- The scene is the namespace for models. All models within a scene must have unique names, even if one model is nested in the hierarchy of another model.

  The scene is also the namespace for passes and layers, as well as image sources and clips.

- The model is the namespace for objects. Two separate models, Fluffy and Sparky, can each have an object called LeftPaw. However, a single model cannot have two objects called LeftPaw. The combination of model name and object name uniquely identifies an object in a scene, for example, Fluffy.LeftPaw or Sparky.LeftPaw.

  The model is also the namespace for groups, as well as action, shape, and audio sources and clips.

  Objects and groups that are not in any other model are in the namespace of the scene root model.

- The object is the namespace for clusters, custom parameters sets, and weight maps. For example, two objects called LeftPaw and RightPaw can each have a custom parameter set called KineControls.
The custom parameter set is the namespace for custom parameters. Parameter names must be unique within a given set, but two sets can each have parameters with the same name.

The pass is the namespace for partitions. For example, two different passes can each have a partition called `Background_Objects_Partition`.

### Renaming Elements

You can rename certain types of elements in your scene. These types include:

- Objects, including geometric objects, control objects, lights, cameras, and so on.
- Models.
- Passes.
- Groups, layers, and partitions.
- Clusters.
- Weight maps.
- Custom parameter sets. Note that to rename a custom parameter, you must edit its definition—see Editing Custom Parameters in Chapter 7 of the Customization guide.
- Sources and clips. However, be aware that if you rename a source, any clips based on that source are automatically renamed as well.
- Materials and shaders.

You cannot rename other types of elements, such as operators and constraints.

### To rename an element

Do one of the following:

- Select an element, press Enter to open its general properties in an editor, and change the **Name** parameter.
  
  *or*

- Select an element, press F2 in an explorer, and enter a new name.
  
  *or*

- In an explorer, click twice on an object (don’t double-click it) and enter a new name.
  
  *or*

- In an explorer, right-click on an element, choose **Rename**, and enter a new name.
  
  *or*
Chapter 7 • Basic Scene Elements

In a 3D view, Alt+right-click (Ctrl+Alt+right-click on Linux) on an object and choose Rename. Its general properties opens in an editor, where you can change the Name parameter.

If the new name is not unique in its namespace, a number is appended automatically.

Some elements are referenced by name by other elements in the scene. When you rename these elements, a dialog box opens that allows you to update references.

Viewing Object Names in 3D Views

You can display object names in the 3D views. Object names appear to the right of the object’s center.

To display or hide the names of selected objects in 3D views

Do one of the following:

- To affect a single 3D view, click its eye icon (Show menu) and toggle Name on or off.

or

- To affect all open 3D views, choose View > Name from the main menu.

To display or hide the names of selected or unselected objects in 3D views

1. Do one of the following:
   - To affect a single 3D view, press Shift+s while the mouse pointer is over it or click its eye icon (Show menu) and choose Visibility Options.

   or

   - To affect all open 3D views, choose View > Visibility Options (All Cameras) from the main menu.

   The Camera Visibility property editor opens.

2. On the Attributes tab, toggle Name for selected and unselected objects.
Chapter 8  Selecting
Selecting

Selecting is fundamental to any software program. In XSI, you select objects, components and other elements to modify and manipulate them. There are many ways to select elements, and this chapter describes them all in detail.

- Different selection tools allow you to select in different ways.
- You can select objects, components, and properties using different filters, tools, and modes in the 3D and schematic views.
- You can select any node directly in the explorer.
- You can modify the selection using a number of commands.
- You can select elements by name.
- You can define whether objects are selectable.

If you are familiar with SOFTIMAGE|3D, then you are probably familiar with its Single and Multi modes. There are no similar modes in SOFTIMAGE|XSI. You can always add objects to the selection with the Shift key. Operations are performed on all selected objects; if certain operations do not apply to certain selected objects, those objects are ignored.
About Selection

As you work, you constantly select and manipulate objects and their components. There are a number of tools you can use to select these elements, as well as a number of views in which your selections can be made.

The Select Panel

The Select panel is located in the main command area on the right of the default layout.

What You Can Select

In XSI, you can select any object, component, property, group, cluster, operator, pass, partition, source, clip, and so on; in short, just about anything that can appear in the explorer.

The only thing that you can’t select are individual parameters—parameters are marked for animation instead of selected. For more information about marking, see Marking Parameters for Animation in Chapter 2 of the Animation guide.
Feedback on What’s Selected

Selected elements are highlighted in the 3D, schematic, and explorer views. In addition, the name of the selected element appears in the Object Selection box on the Select panel. If multiple objects are selected, the word “Multi” appears with the number of selected objects in parentheses.

Selected components are highlighted in red in the 3D views, and are listed by their component indices in the Sub-object Selection box. If the type of the selected components is not the same as the current selection filter, then the component type is indicated in the Sub-object Selection box as well. See Selecting Components on page 230.

If an object is branch-selected, the letter “B:” appears before the name. For more information on branch selection, see Selection and Hierarchies on page 214.

If the object is part of a model, the model’s name appears as a prefix to the object name. For more information about models in general, see Chapter 22: Models on page 473.

You can also select elements by typing directly in these boxes: see Selecting by Name on page 252.

Selection Filters, Tools, Modes, and Interaction Models

When you use the mouse to select elements in the 3D and schematic views, the current selection filter determines what type of elements you can select. The selection tool determines the mouse interaction in the 3D views. XSI also offers several selection modes, which are predefined pairs of the most commonly-used combinations of filter and tool. The specific mouse buttons and modifier keys that you use to select, add to the selection, toggle, and deselect elements are determined by the interaction model. These concepts are described in the following sections.
Selection Filters

Selection filters determine what you can select in the 3D and schematic views. They allow you to restrict the selection to a specific type of object, component, or property, which makes it easier to select the desired elements in the views. The selection filters are located below the Select icon on the Select panel.

For more information about specific types of selection filters, see Object Selection Filters on page 226, Component Selection Filters on page 232, and Property Selection Filters on page 241. You can also filter the current selection as described in Modifying the Selection with Filters on page 246.

Selection Tools

To select something in the 3D views, a selection tool must be active. XSI offers a choice of several selection tools, each with a different mouse interaction: Rectangle, Lasso, Raycast, and others. For a complete description of how to activate and use these tools, see Using Selection Tools on page 219.

Selection Modes

Selection modes are preset combinations of a selection filter and a selection tool. They allow you to activate the most common combinations with a single key press. For more information, see Object Selection Modes on page 225 and Component Selection Modes on page 231.

Selection Interaction Models

The interaction model determines which specific mouse buttons and modifier keys that you use to perform different actions—like selecting, adding to the selection, toggling, and deselecting.

The initial interaction model depends on the choice you made in the Interaction Model dialog box the first time you started XSI. However, you can change it at any time and your change is remembered the next time you start XSI.

For more details, see Selecting Objects Using the Different Interaction Models on page 227 and Selecting Components Using the Different Interaction Models on page 233.
You can select objects in hierarchies in several ways: node, branch, and tree.

**Node Selection**

Node selection is the simplest way in which an object can be selected. When you node-select an object, only it is selected. If you apply a property to a node-selected object, that property is not inherited by its descendants. If you transform a node-selected object, its descendants are not affected (although they will update if they have animation on their local transformations).

*To node-select objects*

* Left-click an object. This works with any interaction model.

**Branch Selection**

When you branch-select an object, its descendants “inherit” the selection status and are highlighted in light gray. You would branch-select an object when you want to transform it and its children as a single unit, or when you want to apply a property that gets inherited by all the object’s descendants.

*To branch-select objects*

* Middle-click an object. This works with any interaction model.
Tree Selection

You can also tree-select objects. This selects the object's topmost ancestor in branch mode. There is no fundamental difference between branch and tree selection; the only difference is which node is the topmost selected one. Tree selection is simply a convenience that lets you select an entire hierarchy by clicking on any of its objects.

To tree-select objects

- Right-click on an object. This works with any interaction model.

When you tree-select an object, by default the model node is not selected even if there is one. This makes it easier to animate and set keys on only those parameters that are within the model's namespace (the model itself is in the scene root's namespace). If you want to select the model, you can either click its node directly or use a command to modify the selection as described in Converting Hierarchy Selection on page 247. Alternatively, you can change your Selection preferences to select the model when right-clicking.

Note that right-clicking on a kinematic chain element always branch-selects the corresponding chain root even if the chain is part of a larger tree. If you want to select the whole tree, you can then press Ctrl+t or choose Select > Select Tree.

Other Useful Tools for Selection

You can select objects in the explorer, schematic, and spreadsheet views at any time, as long as no other tool like Parent or Delete is active. You do not need to activate a selection tool first.
Overview of Selection

This section presents a brief summary of selection in XSI—enough to get you up and running quickly. There are many more nuances to selection, but these are described in later sections.

Overview of Selecting Objects

This is a brief summary of selecting objects in the 3D, schematic, and explorer views. When you select an object, the previously-selected objects become deselected unless you press the Shift key.

To select an object in the 3D views

- Use the space bar in supra or sticky mode and click on an object. Use the left mouse button for node selection, the middle mouse button for branch selection, and the right mouse button for tree selection.

  For more details about using object filters, interaction models, and other options, see Selecting Objects on page 225.

To select an object in the schematic view

- Click on an object, or click and drag a rectangle around multiple objects. Use the left mouse button for node selection, the middle mouse button for branch selection, and the right mouse button for tree selection.

  For more details about using object filters, interaction models, and other options, see Selecting Objects on page 225.

To select an object in explorer

- Click on an object. Use the left mouse button for node selection, and the middle mouse button for branch selection.

  For more details about using the explorer to select objects and other elements, see Selecting in the Explorer on page 243.

To select all objects

Do one of the following:

- Choose Select > Select All Objects.

  or

- Press Ctrl+Shift+a.
Overview of Selecting Components

You can select components interactively only in the 3D views.

**To select components interactively**

1. Select one or more geometric objects.

2. Activate a component selection filter and a selection tool. Alternatively, you can use a component selection mode that sets the most frequent combinations of filter and tool automatically. See the next section, *Selection Keyboard Shortcuts* on page 217.

3. Use the mouse in the 3D views.

For more complete details, see *Selecting Components* on page 230.

Selection Keyboard Shortcuts

There are several keyboard shortcuts for selecting elements. The default keys are shown in this table:

<table>
<thead>
<tr>
<th>Key</th>
<th>Tool or action</th>
</tr>
</thead>
<tbody>
<tr>
<td>space bar</td>
<td>Select objects with the Rectangle selection tool, in either supra or sticky mode.</td>
</tr>
<tr>
<td>e</td>
<td>Select edges with the Rectangle selection tool, in either supra or sticky mode.</td>
</tr>
<tr>
<td>t</td>
<td>Select points with the Rectangle selection tool, in either supra or sticky mode.</td>
</tr>
<tr>
<td>y</td>
<td>Select polygons with the Rectangle selection tool, in either supra or sticky mode.</td>
</tr>
<tr>
<td>u</td>
<td>Select polygons with the Raycast selection tool, in either supra or sticky mode.</td>
</tr>
<tr>
<td>i</td>
<td>Select edges with the Raycast selection tool, in either supra or sticky mode.</td>
</tr>
<tr>
<td>' (apostrophe)</td>
<td>Select hair tips with the Rectangle selection tool, in either supra or sticky mode.</td>
</tr>
<tr>
<td>F7</td>
<td>Activate Rectangle selection tool using current filter.</td>
</tr>
<tr>
<td>F8</td>
<td>Activate Lasso selection tool using current filter.</td>
</tr>
<tr>
<td>F9</td>
<td>Activate Freeform selection tool using current filter.</td>
</tr>
<tr>
<td>F10</td>
<td>Activate Raycast selection tool using current filter.</td>
</tr>
<tr>
<td>Shift+F10</td>
<td>Activate Rectangle-Raycast selection tool using current filter.</td>
</tr>
<tr>
<td>Ctrl+F8</td>
<td>Activate Point filter with current selection tool.</td>
</tr>
<tr>
<td>Ctrl+F9</td>
<td>Activate Edge filter with current selection tool.</td>
</tr>
<tr>
<td>Ctrl+F10</td>
<td>Activate Polygon filter with current selection tool.</td>
</tr>
<tr>
<td>Alt+space bar</td>
<td>Activate last-used selection filter and tool.</td>
</tr>
</tbody>
</table>
Extending the Selection

No matter which interaction model you are using, you can always add elements to the selection by pressing the Shift key while you select them.

Deselecting

You can deselect specific objects and components, as well as deselect all elements (objects, components, and other things).

To deselect an object

- With a selection tool active, Ctrl+Shift+click on the object. This works with all interaction models.
  
  Use the left mouse button to deselect nodes, the middle mouse button to deselect branches, and the right mouse button to deselect trees.

To deselect components

Do one of the following:

- If both Select > Softimage|3D Selection Model and Select > Extended Component Selection are off, Ctrl+Shift+click on the components.
  
  or
  
  - If either option is on, middle-click on the components.

To deselect all elements

Do one of the following:

- Choose Select > Deselect All.
  
  or
  
  - Press Ctrl+Shift+a.
  
  or
  
  - With a selection tool active, click in an empty area of a 3D view. This works for deselecting objects with all interaction modes. This also works for components if both Select > Softimage|3D Selection Model and Select > Extended Component Selection are off.

Activating the Last-used Selection Tool and Filter

Certain combinations of selection tool and filter are not available as a single selection mode. However, you can still activate the last-used tool and filter without the need to activate each one separately.

To activate the last-used selection tool and filter

Do one of the following:

- Click the Select icon.
  
  or
  
  - Press Alt+space bar.
Using Selection Tools

As you would expect, the selection tools let you select and deselect elements. The different selection tools determine how you select in the 3D views. Each tool has a slightly different interaction. The choice of selection tool is partly a matter of personal preference, and partly a matter of what is easiest or best to use in a particular situation.

As an alternative to setting the selection tool and filter manually, you can use a selection mode that automatically sets both the selection tool and filter—see Object Selection Modes on page 225 and Component Selection Modes on page 231.

The sections that follow describe the different tools and their interaction. The specific mouse buttons and modifier keys that you use to perform different actions—like selecting, adding to the selection, toggling, and deselecting—depend on the selection interaction model.

For more complete details, see Selecting Objects Using the Different Interaction Models on page 227 and Selecting Components Using the Different Interaction Models on page 233.

The selection tools, and the differences between them, apply only in the 3D views. You can select at any time in the explorer simply by clicking, and in the schematic by clicking or by drawing a rectangle.

To activate a selection tool

Do one of the following:

- Choose an item from the Select > Tools menu.
  
  or

- Press one of the following keys:
  
  - F7 for the Rectangle selection tool.
  
  - F8 for the Lasso selection tool.
  
  - F9 for the Freeform selection tool.
  
  - F10 for the Raycast selection tool.
  
  - Shift+F10 for the Rectangle-Raycast tool.
  
  - F11 for the Paint selection tool (points, edges, and polygons only).
Chapter 8 • Selecting

**Rectangle Selection Tool**

Rectangle selection is sometimes called *marquee selection*. You select elements by dragging diagonally to define a rectangle that encompasses the desired elements.

The behavior of the Rectangle select tool depends on **Raycast in Shaded Mode** under **Rectangle Select: Options** in your Tools\Select preferences.

- If it is on, the Rectangle tool ignores elements that are occluded (hidden behind other elements) in Hidden Line Removal, Constant, Shaded, Textured, and Textured Decal display modes.

  In this mode, the Rectangle tool is actually the same as the Rectangle-Raycast tool.

- If it is off, the Rectangle tool uses a faster and simpler algorithm that does not consider whether an element is occluded. As a result, you may select elements that you cannot see because they are obscured by others in the views.

  This mode is useful in some situations, for example, when you are working with assembled surface meshes and need to select overlapping rows of boundary points. On the other hand, it’s much less useful in other situations, for example, when you are working with closed polygon meshes and do not want to select components on the opposite side.

This option is also used by the Move Point tool. It is ignored if **Override Object Properties** is off in the Display type menu of a 3D view.

**To use the Rectangle selection tool**

- Click and drag the mouse pointer diagonally in the 3D view to define a rectangle around any set of elements in the scene.

  - When selecting objects in Wireframe views, you must enclose at least part of the “wires.”

  - When selecting polygon components, the polygons must be completely enclosed.

  - When selecting edge components, the behavior is controlled by **Surround Edges** under **Rectangle Select: Options** in your Tools\Select preferences. If this option is off, the tool selects all edges that are wholly or partly enclosed; if it is on, the tool selects only those edges that are wholly enclosed.
Lasso Selection Tool

The Lasso tool lets you select one or more elements by drawing a free-form shape around them. This is especially useful for selecting irregularly shaped sets of components.

The Lasso tool does not select elements that are occluded by others. However, you can still select components on the “other side” of the active objects in Hidden Line Removal, Constant, Shaded, and Textured viewing modes if Show Transparent Selected Wireframe is on (to set this and other Camera Display options, see Setting Object Display on page 175). However even with this option, the Lasso tool still selects only the topmost component when two or more components are directly on top of each other.

To use the Lasso selection tool

- Click and drag the mouse pointer to draw a shape around any set of elements in the scene. You do not need to close the shape: XSI automatically connects the endpoints when you release the mouse button.
  - When selecting objects in Wireframe views, you must enclose at least part of the “wires.”
  - When selecting polygon components, the polygons must be completely enclosed.
  - When selecting edge components, the behavior is controlled by Surround Edges under Rectangle Select: Options in your Tools\Select preferences. If this option is off, the tool selects all edges that are wholly or partly enclosed; if it is on, the tool selects only those edges that are wholly enclosed.
Chapter 8 • Selecting

**Freeform Selection Tool**

The Freeform tool lets you select elements by drawing a line across them. This is particularly useful for selecting a series of edges when modeling with polygon meshes, or for selecting a series of curves in order for lofting or creating hair from curves, as well as in many other situations.

![Selecting edges with the Freeform tool.](image)

The Freeform selection tool never selects elements that are occluded, even if they are partially visible through other objects when Show Transparent Selected Wireframe is on in the Camera Display options.

*To use the Freeform selection tool*

- Drag the mouse pointer across the elements you want. As you drag, a visible line indicates the path. When you release the mouse button, the elements are affected.

**Raycast Selection Tool**

The Raycast tool casts rays from under the mouse pointer into the scene—elements that get hit by these rays are affected. Like the Freeform tool, Raycast never selects elements that are occluded, even if they are partially visible through other objects when Show Transparent Selected Wireframe is on in the Camera Display options. Unlike Freeform, elements are highlighted while the mouse button is held down.

*To use the Raycast selection tool*

- Click on the desired element, or drag across multiple elements.
Using Selection Tools

**Rectangle-Raycast Tool**

The Rectangle-Raycast selection tool behaves like a mixture of the Rectangle and the Raycast tools. You select by dragging a rectangle to enclose the desired elements, just like the Rectangle tool. Elements that are occluded behind others in Hidden Line Removal, Constant, Shaded, Textured, and Textured Decal display modes are ignored, just like the Raycast tool.

*To use the Rectangle selection tool*

- Click and drag the mouse pointer diagonally in the 3D view to define a rectangle around any set of elements in the scene.

**Paint Selection Tool**

The Paint selection tool lets you use a brush to select components. It is limited to selecting points (on polygons meshes and NURBS), edges, and polygons. By modifying the paint tool’s brush size, you affect the way in which components are selected.

The brush’s radius controls the size of the area selected by each stroke, which you can adjust interactively or by using the Brush Properties editor. The brush’s surface coverage controls how much the brush wraps around the active object, allowing you to select components around corners. You can set the surface coverage in the Brush Properties editor.

The Paint selection tool ignores the Extended Component Selection option. The function of the mouse buttons are similar to other paint tools in XSI:

- Click and drag with the left mouse button to select.
- Click and drag with the middle mouse button to change the brush radius.
- Click and drag with the right mouse button to deselect.
- Ctrl+click and drag with the left mouse button to toggle-select.

When using the Paint tool on NURBS, you can increase performance by reducing the geometry approximation settings. The Paint tool uses the triangulation of the object to follow its surface. For more information, see Surface Approximation on page 190.

*To use the Paint selection tool*

- Click and drag to define a paint stroke across the active object. The affected components are highlighted as you drag.
To change the brush radius interactively

- Do one of the following while the Paint tool is active:
  - Middle-click and drag to the right to increase the radius, or to the left to decrease it. Alternatively if the middle mouse button is a wheel, roll it forward or back.
  
  or

  - Press r and drag to the left or right.

The current radius size in Softimage units is displayed at the bottom of the 3D view.

To increase or decrease the brush radius by increments

- With the Paint tool active, press the up arrow key to increase it by 10%, or press the down arrow key to decrease it by 10%.

To display the Brush Properties

- Press Ctrl+w.

Only the Radius and the Surface Coverage parameters have any effect when using the Paint selection tool. The other parameters are used when using the Paint tool for other purposes such as painting weights.
Selecting Objects

This section describes how to select objects interactively in the 3D and schematic views.

As an alternative, you can also select objects using the explorer (see Selecting in the Explorer on page 243) or by name (see Selecting by Name on page 252).

The simplest way to select objects is to use the space bar to activate Object Rectangle selection in either supra or sticky mode. But there's more to it than that, and the sections that follow describe all the details.

Object Selection Modes

Selection modes are preset combinations of a selection filter and a selection tool. They allow you to activate the most common combinations of filters and tools with a single key press.

There is only one selection mode for objects: Object Rectangle combines the Object filter and the Rectangle tool.

To activate Object Rectangle selection mode

Do one of the following:

- Press the space bar.
  
  or

- Click the Object filter button on the Select panel.
  
  or

- Choose Select > Modes > Object.

Object (Extended) mode is similar to Object mode. The difference is that when you activate Object (Extended) mode, any components you have already selected are not removed from the selection. This lets you select a mixture of objects and components at the same time.

Note that you must also press Shift while clicking to add components to the selection. If you do not press Shift, the newly-selected objects replace the old selection.
Chapter 8 • Selecting

Object Selection Filters

The selection filters determine what you can select when using the mouse in the 3D and schematic views. The Object filter lets you select any object. In addition, there are a variety of filters that restrict the selection to specific types of object. These specific filters are useful when you want to select nulls, chain elements, or other control objects in a crowded scene. For information about the different object types available in XSI, see Chapter 9: 3D Objects on page 259.

When you activate a different object-type selection filter, it does not change the status of any objects that are already selected: it simply changes what you can select or add to the selection when using a selection tool.

You can also use filters to modify the current selection list as described in Modifying the Selection with Filters on page 246.

There are additional filters on this menu that allow you to select objects with specific properties, for example, objects with annotations. These are examples of custom filters. For information about creating your own filters, see the SDK documentation.
Selecting Objects

Using the Different Interaction Models

When selecting objects in the 3D and schematic views, XSI can use either of two interaction models:

- The SOFTIMAGE|XSI selection model uses modifier keys like Shift and Ctrl to extend the selection, toggle, deselect, and so on. In this respect, it is more consistent with other Windows applications.
- The SOFTIMAGE|3D selection model uses the different mouse buttons to toggle nodes, branches, and trees just as in SOFTIMAGE|3D. It is intended for people who are familiar with and prefer this style of interaction.

The initial interaction model depends on the choice you made in the Interaction Model dialog box the first time you started XSI. However, you can change it at any time and your change is remembered the next time you start XSI.

To set the selection interaction model

- Toggle the Softimage|3D Selection Model option on the Select menu.
  When this option is off, the SOFTIMAGE|XSI selection model is used:
  when this option is on, the SOFTIMAGE|3D selection model is used.

When you toggle this option, Select Single Object in Region on the Select menu is also affected. However, you can also set that option independently—see Single versus Multiple Selection on page 228.

To select objects using the SOFTIMAGE|XSI interaction model

If Select > Softimage|3D Selection Model is off, use the following mouse and keyboard combinations:

- Use the left mouse button to node-select objects.
- Use the middle mouse button to branch-select objects and their descendants.
- Use the right mouse button to tree-select objects, or branch-select the chain roots of chain elements. However, there are couple of Selection preferences that can affect this behavior.
- Use the Shift key in combination with the left, middle, or right mouse buttons to add objects, branches, or trees to the selection.
- Use the Ctrl key in combination with the left, middle, or right mouse buttons to toggle the selection of objects, branches, or trees.
- Use the Ctrl+Shift keys in combination with the left, middle, or right mouse buttons to deselect objects, branches, or trees.

To select objects using the SOFTIMAGE|3D interaction model

If Select > Softimage|3D Selection Model is on, use the following mouse and keyboard combinations:

- Use the left mouse button to toggle the selection of objects.
- Use the middle mouse button to toggle the selection of branches.
Chapter 8 • Selecting

- Use the right mouse button to toggle the selection of trees, or toggle the branch-selection of chain roots of chain elements. However, there are couple of Selection preferences that can affect this behavior.
- Use the Shift key in combination with the left, middle, or right mouse buttons to add objects, branches, or trees to the selection.
- Use the Ctrl key in combination with the left, middle, or right mouse buttons to toggle the selection of objects, branches, or trees in the case of multiple selection.
- Use the Ctrl+Shift keys in combination with the left, middle, or right mouse buttons to deselect objects, branches, or trees.

**Single versus Multiple Selection**

If Select > Select Single Object in Region is on, then only one object is selected when you drag the mouse across an area in a 3D view.

If this option is off, then all objects that match the object filter criteria are selected.

This option is automatically toggled when you toggle Select > Softimage|3D Selection Model, but you can also toggle it independently.

**Select Single Object in Region** is not equivalent to Single mode in SOFTIMAGE|3D. When Select Single Object in Region is on, you can still select multiple objects by using the Shift key to add to the selection or by using the Ctrl key to toggle.

**Selecting Groups of Objects**

Groups are named sets of objects. You can select groups in the 3D and schematic views using the Group selection button or the = key. Note that the Group button changes to the Cluster button when a component filter is active.

As an alternative, you can also use the Explore button on the Select panel to list all groups in the scene.

Once a group is selected, you can select it members.

**To select groups**

1. Do one of the following:
   - Activate the Group selection button on the Select panel with any selection tool.
     or
   - Press the = key while performing the next step.
2. Use the mouse to select any member of the group in the 3D or schematic views.
   - If an object is a member of a group, the group is selected.
   - If an object is a member of multiple groups, all groups are selected. You can use the Selection button to refine the selection further (see Refining the Selection with the Selection Explorer on page 246).
   - If an object is not a member of any group, the object itself is selected.
   - You can use the different mouse buttons and modifier keys to select, add to the selection, toggle, and deselect according to the selection interaction model you are using. See Selecting Objects Using the Different Interaction Models on page 227.
   - If a hierarchy is a member of a group then you must select the root of the hierarchy rather than a descendant, even if the hierarchy was added to the group as a branch or tree.

To explore all groups in the scene

• Choose Explore > Groups from the Select panel. A pop-up explorer opens showing all groups in the scene.

  You can use this pop-up explorer to select one or more groups just as in an explorer window. See Selecting in the Explorer on page 243.

To select the members of a group

• With a group selected, choose Select > Select Members/Components. The members of the group are selected as multiple objects.
Selecting Components

This section describes how to select components interactively in the 3D views. With components, selecting is sometimes also called *tagging*.

As an alternative to selecting interactively, you can select components using character strings (see Selecting by Name on page 252).

Some component selection techniques apply only to specific types of components, and are described in other sections:

- **Select > Grow Selection** and **Select > Select Adjacent** apply only to polygon mesh components, as well as points on NURBS curves and surfaces. See Selecting Polygon Mesh Components in Chapter 7, Selecting Curve Components in Chapter 11, and Selecting Surface Components in Chapter 12 of the Modeling & Deformations guide.

- **Select > Select U/V Row** applies only to rows of points on NURBS surfaces. See Selecting Surface Components in Chapter 12 of the Modeling & Deformations guide.

You cannot select an object and components on the same object at the same time.

Overview of Selecting Components

Selecting components is a three-stage process:

1. Select one or more objects with components. These include polygon meshes, curves, surfaces, lattices, particle clouds, and hair.

2. Activate a component selection filter and a selection tool. Alternatively, you can use a component selection mode that sets the most frequent combinations of filter and tool automatically.
   - The component selection filters are described in Component Selection Filters on page 232.
   - The selection tools are described in Using Selection Tools on page 219.
   - The component selection modes are described in Component Selection Modes on page 231.

   The selected objects are displayed in orange to show that they are active for component selection. You can select components only on active objects.

3. Use the mouse in the 3D views. The specific mouse buttons and modifier keys that you use to perform different actions—like selecting, adding to the selection, toggling, and deselecting—depend on the selection interaction model. For more complete details, see Selecting Components Using the Different Interaction Models on page 233.

Selected components are highlighted in red by default.

Using the Shift key and the selection modes, you can select different types of component at the same time.
Component Selection Modes

Selection modes are predefined pairs of the most commonly used combinations of selection filter and tool. They are all assigned to keys for quick and easy access.

To activate a component selection mode

Do one of the following:

- Choose one of the items from the Select > Modes menu.
- or
- Press one of the following keys:
  - t for Rectangle Point mode.
  - e for Rectangle Edge mode.
  - i for Raycast Edge mode.
  - y for Rectangle Polygon mode.
  - u for Raycast Polygon mode.
  - ' (apostrophe) for Rectangle Tip mode (for hair objects)

With any of the above keys, you can also use the Shift key for extended mode.

The extended modes are similar to the non-extended ones. The difference is that when you activate an extended mode, the components you have already selected are not removed from the selection. This lets you select different types of components at the same time.

If both Select > Softimage|3D Selection Model and Select > Extended Component Selection are off, then you must also press Shift while clicking to add components to the selection. If you do not press Shift, the newly-selected components replace the old selection.
Component Selection Filters

Component selection filters determine what type of component you can select on the active geometric objects. The most commonly-used filters are available as buttons on the Select panel, while more filters are available from the Filter menu below the buttons.

The component selection filters are context-sensitive: they change depending on what type of object is active. For example, if a polygon mesh object is selected, then the available filters include Edge, Polygon, and others; if a NURBS surface is selected, then the available filters include Subsurface, Isoline, and others. For a description of all the different component types, see Types of Components on page 312.

There are additional filters on these menus that allow you to select, for example, border points or edges. These are examples of custom filters. For information about creating your own filters, see the SDK documentation.

Selecting a component filter restores the last-selected components of that type on the active objects. For example, if you select the Point filter, the most recently selected points on the active objects are automatically selected and highlighted.
To select two or more types of components at the same time, first select some components of one type and then press the Shift key while changing filters. The components you have already selected are not removed from the selection.

If both Select > Softimage|3D Selection Model and Select > Extended Component Selection are both off, then you must also press Shift while clicking to add components to the selection. If you do not press Shift, the newly-selected components replace the old selection.

When selecting components in the 3D views, XSI can use either of two interaction models:

- The SOFTIMAGE|XSI selection model uses modifier keys like Shift and Control to extend the selection, toggle, deselect, and so on. In this respect, it is more consistent with other Windows applications. In addition, the right mouse button displays a context menu, so that you can keep the selection tool active and still have quick access to many commonly used commands.

- The SOFTIMAGE|3D selection model uses the different mouse buttons to select (tag), deselect (untag), and toggle components just as in SOFTIMAGE|3D. It is intended for people who are familiar with or prefer this style of interaction. To display a context menu for components, you must use Alt+right-click on Windows, or Ctrl+Alt+right-click on Linux.

The interaction model for components is controlled by two options on the Select menu: SOFTIMAGE|3D Selection Model and Extended Component Selection. The first one implies the second one, so it is possible to use the SOFTIMAGE|3D selection model for just components with Extended Component Selection on, or for both objects and components with SOFTIMAGE|3D Selection Mode on.

The initial interaction model depends on the choice you made in the Interaction Model dialog box the first time you started XSI. However, you can change it at any time and your change is remembered the next time you start XSI.

To activate the SOFTIMAGE|XSI selection model for components

- Make sure that both Select > SOFTIMAGE|3D Selection Model and Select > Extended Component Selection are off.

To select components with the SOFTIMAGE|XSI selection model

If both SOFTIMAGE|3D Selection Model and Extended Component Selection are off in the Select menu in the main command area, use the following mouse and keyboard combinations to select components:

- To select new components and deselect any that are currently selected, don’t press any modifier keys.
- To add components to the selection, press the Shift key.
Chapter 8 • Selecting

- To toggle-select, press the Ctrl key.
- To deselect, press Ctrl+Shift.
- To deselect all, click or click+drag over an empty area of a 3D view.
- With any of the above key combinations, use the left mouse button for
  components or the middle mouse button for clusters. You can also use the
  Cluster filter on the Select panel or press =. For more about cluster
  selection, see Selecting Clusters on page 238.
- To display a context menu showing commands that are applicable to the
  selection, right-click anywhere on the object with selected components.

To activate the SOFTIMAGE|3D selection model for components
- Make sure that one or both of the Select > SOFTIMAGE|3D Selection
  Model and Select > Extended Component Selection options are on.

To select components with the SOFTIMAGE|3D selection model
If either the SOFTIMAGE|3D Selection Model or the Extended Component
Selection options are on in the Select menu in the Select panel, use the
following mouse and keyboard combinations to select components:
- To add components to the selection, use the left mouse button.
- To deselect components, use the middle mouse button.
- To toggle-select components, use the right mouse button.
- To select clusters, use the Cluster filter on the Select panel or press =.
- To display a context menu showing commands that are applicable to the
  selection, Alt+right-click anywhere on the object with selected
  components in Windows (Ctrl+Alt+right-click on Linux).

Selecting Ranges and
Loops of Components
Using the Alt (or Ctrl) key, you can select ranges or loops of components. XSI
tries to find a path between two components that you pick. In the case of
ranges, it selects all components along the path between the picked
components. In the case of loops, it extends the path, if possible, and selects
all components along the entire path.
- For polygon meshes, you can select ranges or loops of points, edges, or
  polygons. Several strategies are used to find a path, but priority is given to
  borders and quadrilateral topology.
- For NURBS curves and surfaces, you can select ranges or loops of points,
  knots, or knot curves. Points and knots must lie in the same U or V row.
  In addition, paths and loops stop at junctions between subsurfaces on
  assembled surface meshes.
The procedure for selecting ranges and loops depends on the component selection model you are using. Each procedure is described in the sections that follow. For more information about the component selection models in general, including how to activate them, see Selecting Components Using the Different Interaction Models on page 233.

You cannot use the Paint selection tool to select ranges and loops.

**Range Selection**

You can select a range of components using the Alt key. This allows you to select the interconnected components that lie on a path between two components you pick.

To select component ranges with the SOFTIMAGE|XSI selection model

1. Select the first “anchor” component.
2. Alt+click on the second component. Note that the anchor component is highlighted in light blue as a visual reference while the Alt key is pressed. All components between the two components on a path become selected.
3. Use the following key and mouse combinations to further refine the selection:
   - Use Shift to add to the selection. The last selected component becomes the anchor for any new range. If you want to start a new range anchored at the end of the previous range, you must reselect the last component by Shift+clicking or Alt+Shift+clicking. Once you have selected a new anchor, you can Alt+Shift+click to add another range to the selection.
   - Use Ctrl to toggle-select. Once you have selected a new anchor, you can Alt+Ctrl+click to toggle the selection of a range.
   - Use Ctrl+Shift to deselect. Once you have selected a new anchor, you can Alt+Ctrl+Shift+click to deselect a range.
To select component ranges with the SOFTIMAGE|XSI selection model
1. Select the first “anchor” component.
2. Alt+click on the second component. Note that the anchor component is highlighted in light blue as a visual reference while the Alt key is pressed. All components between the two components on a path become selected.
3. Use the following mouse buttons to further refine the selection:
   - Use the left mouse button to add to the selection. The last selected component becomes the anchor for any new range. If you want to start a new range anchored at the end of the previous range, you must reselect the last component by clicking or Alt+clicking. Once you have selected a new anchor, you can Alt+click to add another range to the selection.
   - Use the middle mouse button to deselect. Once you have selected a new anchor, you can Alt+middle-click to deselect a range.
   - Use the right mouse button to toggle-select. Once you have selected a new anchor, you can Alt+right-click to toggle the selection of a range.

Loop Selection
When you select a loop of components, XSI finds a path between two components that you pick. It then extends the path in both directions, if it is possible, and selects all components along the extended path.

To select component loops with the SOFTIMAGE|XSI selection model
1. Do one of the following:
   - Select the first “anchor” component, then Alt+middle-click on the second component. Note that the anchor component is highlighted in light blue as a visual reference while the Alt key is pressed.
- Alt+middle-click to select two adjacent components in a single mouse movement.

All components on an extended path connecting the two components become selected.

Note that for edges, the direction is implied so you only need to Alt+middle-click on a single edge. However, for parallel edge loops, you still need to specify two edges as described previously.

2. Use the following key and mouse combinations to further refine the selection:

- Use Shift to add to the selection. The last selected component becomes the anchor for any new loop. Once you have selected a new anchor, you can Alt+Shift+middle-click to add another loop to the selection.

- Use Ctrl to toggle-select. Once you have selected a new anchor, you can Alt+Ctrl+middle-click to toggle the selection of a loop.

- Use Ctrl+Shift to deselect. Once you have selected a new anchor, you can Alt+Ctrl+Shift+middle-click to deselect a loop.

To select component loops with the SOFTIMAGE|3D selection model

1. Do one of the following:

- Select the first “anchor” component, then Ctrl+click on the second component. Note that the anchor component is highlighted in light blue as a visual reference while the Ctrl key is pressed.

  or

- Ctrl+click to select two adjacent components in a single mouse movement.

All components on an extended path connecting the two components become selected.

Note that for edges, the direction is implied so you only need to Ctrl+click on a single edge. However, you still need to specify two edges for a parallel edge loop.

2. Use the following mouse buttons to further refine the selection:

- Use the left mouse button to add to the selection. The last selected component becomes the anchor for any new loop. Once you have selected a new anchor, you can Ctrl+click to add another loop to the selection.

- Use the middle mouse button to deselect. Once you have selected a new anchor, you can Ctrl+middle-click to deselect a loop.

- Use the right mouse button to toggle-select. Once you have selected a new anchor, you can Ctrl+right-click to toggle the selection of a loop.
**Selecting Clusters**

A cluster is a named set of components of a given type on a single object. You can select clusters in a variety of ways. Also, once a cluster is selected, you can select its member components.

Using the Shift key, you can select a combination of components and clusters at the same time.

**To select clusters in the 3D views**

1. Do one of the following:
   - With a select tool and component filter active, click the **Cluster** button on the Select panel. Note that the **Cluster** button changes to the **Group** button when an object-type filter is active.
   
   **or**

   - With a component filter active, press the = key.
   
   **or**

   - If both **Select > SOFTIMAGE|3D Selection Model** and **Select > Extended Component Selection** are off, use the middle mouse button when a select tool and component filter are active.

2. Use the mouse to select components.
   - If a component is a member of a cluster, the cluster is selected.
   - If a component is a member of multiple clusters, all the clusters are selected. You can use the **Selection** button to refine the selection further (see *Refining the Selection with the Selection Explorer* on page 246).
   - If a component is not a member of any cluster, nothing is selected.
   - You can use the different mouse buttons and modifier keys to select, add to the selection, toggle, and deselect according to the selection interaction model you are using. See *Selecting Components Using the Different Interaction Models* on page 233.

**To explore all clusters on the active object**

- Click the **Clusters** button at the bottom of the Select panel. A pop-up explorer opens, showing all clusters on the active objects.

  You can use this pop-up explorer to select one or more clusters just as in an explorer window. See *Selecting in the Explorer* on page 243.

**To select the member components of a cluster**

- With a cluster selected, choose **Select > Select Members/Components**. The components that make up the cluster are selected as multiple components.
Selected components and clusters are highlighted in the 3D views. You can specify the color to use for the highlight in the Scene Colors property. In addition, you can choose to display selected ("tagged") points on selected objects even if the selection filter is not Point, as well as on unselected objects.

To set the highlight color for selected components and clusters

1. Open the Scene Colors property editor by choosing Scene Colors from the Camera menu of any viewport.
2. On the Components tab, adjust the color swatches for Selected Component and Cluster.

For more information about scene colors in general, see Setting Scene Colors on page 186.

To show or hide tagged points

1. Do one of the following:
   - To affect the display of a single 3D view, press Shift+s while the mouse pointer is over that 3D view or choose Visibility Options from the 3D view's Show menu (eye icon).
   - To show or hide tagged points in all open 3D views, choose View > Visibility Options (All Cameras) from the main menu bar.
2. On the Components tab, toggle Tag Points for selected or unselected objects:
   - When Tag Points is on for selected objects, selected points are highlighted on selected objects or active geometry even if the current selection filter is not Points.
   - When Tag Points is on for unselected objects, selected points on unselected objects are highlighted.

You can also change the color used to highlight tagged points in the Scene Color property editor.
Chapter 8 • Selecting

Selecting Properties in the 3D and Schematic Views

For most purposes, you would select properties in the explorer window (see Selecting in the Explorer on page 243). However it is possible to select certain types of properties in the 3D and schematic views, and this section tells you how to do exactly that.

When a property is selected, you can display its editor by pressing Enter and you can delete the property by pressing Delete.

When objects and constraint properties are selected, you can quickly select the constraining objects using Constrain > Select Constraining Objs.

Displaying Properties

In general in XSI, you can select only things that are visible. The same holds true for properties: to select properties, they must be visible.

Displaying Properties in the 3D Views

This section briefly summarizes how to display properties in the 3D views. Only certain types of properties can be displayed in the 3D views: constraints, linked parameters and expressions on transformations, modeling relations, and so on. When visible, relations are represented by dotted lines between the objects involved.

To toggle display of properties of selected elements in a 3D view

- Click the eye icon and choose Relations.

To toggle display of properties of selected elements in all 3D views

- From the main menu, choose View > Relations.

To toggle display of more properties

1. Do one of the following:
   - To adjust a specific 3D view, click its eye icon (Show menu) and choose Visibility Options. Alternatively, press Shift+s while the 3D view has focus.
   - To adjust all open 3D views, choose View > Visibility Options (All Cameras) from the main menu.

   The Camera Visibility property editor opens.

2. On the Attributes tab, set the options as desired. For example, you can display Relations and Relation Info for Selected Objects and Unselected Objects independently.
Selecting Properties in the 3D and Schematic Views

Displaying Properties in the Schematic View

This section briefly summarizes how to display properties in the schematic view. For more complete details about using the schematic view, see The Schematic View on page 121.

As in the 3D views, properties are represented by lines between the objects involved. Different colors represent different types of property.

To toggle display of properties in the schematic view

- Activate or deactivate the various Links items in the Show menu of the schematic view.

  Hold the Shift key to keep the menu open and toggle several items at once.

Property Selection Filters

Property selection filters determine what type of property you can select using the mouse in the 3D and schematic views. The Filter menu button has some options for a few specific property types.

- **Joint** lets you select the joint properties of bone elements in kinematic chains. Chains must be visible in 3D views.

- **Constraints** let you select constraint properties. Relations must be visible in 3D views, and Show > Constraint Links must be on in the schematic view.

- **Operator** lets you select operators that are involved in a modeling relation, for example, between a lofted surface and its input generator curves. Relations must be visible in 3D views, and Show > Operator Links must be on in the schematic view.
Selecting Properties

If a property is visible as a link in the 3D or schematic views, you can select it with the mouse.

To select properties in the 3D and schematic views

- Click on the line representing the property (not the label that describes the property).

Note that you cannot select multiple properties in this way—pressing the Shift key has no effect. If you need to select multiple properties, see Selecting in the Explorer on page 243.
Selecting in the Explorer

The explorer view shows the logical structure of the current scene as a tree with expandable and collapsible nodes. The rules for selecting in the explorer are different from the 3D and schematic views, and are described in this section.

Selected nodes are highlighted in white in the explorer, and the children of a branch-selected node are highlighted in gray.

Different Types of Explorers

You can use the explorer in a viewport or a floating window, or you can use the buttons on the Select panel to quickly open pop-up explorers from which you can select.

What You Can Select in the Explorer

You can select any node at any time in the explorer, including objects, properties, groups, passes, partitions, and so on. The selection filters on the Select panel are ignored when selecting in the explorer.

Note that selecting parameters has the effect of marking them for animation. In addition, you cannot select components in the explorer.
Selecting Nodes in the Explorer

You can select nodes in explorer views simply by clicking on them. You do not need to activate a selection tool first.

Selecting a Single Node in the Explorer

To select any node in the explorer

- Click on its name.

Note that clicking on its icon opens the corresponding property editor without selecting the node.

To branch-select any object in the explorer

- Middle-click on its name.

Multi-selecting Nodes in the Explorer

You can use the Shift key to select multiple objects in the explorer. When you Shift+click to add a second node to the selection, the rules are as follows:

- If the both first and second nodes are of the same type (3D object, property, group, pass, partition, etc.), then all nodes of that type between them are added to the selection.

Other types of elements in-between are not selected; for example, if you click on a 3D object and then Shift+click on another 3D object, then all visible 3D objects in-between become selected, but properties, shaders, and so on, remain unselected. When Shift+clicking in the explorer, models and 3D objects are considered to be one type, as are properties and materials (but not shaders).

- If the two nodes are of different types, the second one is simply added to the selection.

Only visible nodes are selected. Nodes that are under a collapsed node remain unaffected.
To multi-select nodes in the explorer

1. Select any node by clicking on its name in the explorer. Note that a single node can appear multiple times in the explorer, so if you select the first node outside of the explorer then there is no “anchor point” for subsequent clicks. In these cases, Shift+click simply adds nodes to the selection and not select nodes in-between.

2. Shift+click on the name of any other node.
   - Use the left mouse button to add nodes to the selection.
   - Use the middle mouse button to add branches to the selection.

Toggle-selecting Nodes in the Explorer

Use the Ctrl key to toggle a node between selected and unselected.

To toggle selection in the explorer

- Ctrl+click on the name of any node.
  - Use the left mouse button to toggle nodes.
  - Use the middle mouse button to toggle branches.

Deselecting Nodes in the Explorer

Use Ctrl+Shift to deselect nodes individually in the explorer.

To deselect nodes in the explorer

- Ctrl+Shift+click on the name of any node.
  - Use the left mouse button to deselect nodes.
  - Use the middle mouse button to deselect branches.
Modifying the Selection

Once you have selected something using any method in any window, you can use the commands available on the Select panel to modify the selection.

Refining the Selection with the Selection Explorer

When selecting objects in the 3D views, it’s common to accidentally select more than you intended, particularly in crowded scenes. A useful tool in these situations is the Selection button, found at the bottom left of the Select panel. Click it to display a pop-up explorer showing the selected objects. You can then select, toggle, and deselect elements within the selection. For details, see Selecting in the Explorer on page 243.

Modifying the Selection with Filters

Normally, the selection filters determine what you can select with the mouse in the 3D and schematic views. However, you can also use filters to modify what is currently selected. In particular, you can:

- Select all elements of a given type using a filter. For example, you can select all chain elements in a scene, or all points on a geometric object.
- Invert (toggle) the selected elements of a given type using a filter.
- Deselect elements of a given type using a filter. For example if the selection contains a mixture of object types, you can deselect all geometric objects, or if the selection contains a mixture of points and polygons, you can deselect all polygons.

For each command, the following rules apply:

- For object-type filters, the selection is relative to the entire scene.
- For component-type filters, the selection is relative to the active objects.
- These commands do not work with property-type filters.

To select all elements using the current filter

Do one of the following:

- Choose Select > Select All Using Filter.
  or
- Press Ctrl+a.

To invert (toggle) selected elements using the current filter

- Choose Select > Invert Using Filter. Selected elements that match the current filter become unselected, unselected elements that match the filter become selected, and other elements are unaffected.
Modifying the Selection

To deselect all elements using the current filter
Do one of the following:
  • Choose Select > Deselect All Using Filter.
  or
  • Press Ctrl+Shift+f.

Converting Hierarchy Selection

When objects in hierarchies are selected, you can convert the selection to branch, tree, or model. You can also convert a branch selection into multiple node selections.

To convert the selection to branch
1. Select one or more objects.
2. Choose Select > Select Branch. The descendants of node-selected objects become branch-selected.

To convert the selection to tree
1. Select one or more objects.
2. Do one of the following:
   - Choose Select > Select Tree.
   or
   - Press Ctrl+t.

The roots of selected objects become selected in branch. The root is the highest node under a model node or under the scene root—this method does not select models.

To convert the selection to model
1. Select one or more objects.
2. Do one of the following:
   - Choose Select > Select Model.
   or
   - Press Ctrl+Shift+t.

If a selected object is part of a model, the model becomes branch-selected. Otherwise if a selected object is not part of any model other than the scene root, its root becomes selected in branch.

To branch-select kinematic chains
1. Select any element of a kinematic chain, such as an effector or bone.
2. Choose Select > Select Chain.
The root of the corresponding chain becomes branch-selected. Note that if you have reparented the effector so that it is no longer part of the chain hierarchy, it is not included in the selection.

**To convert a branch selection to multiple nodes**

1. Branch-select one or more objects.
2. Choose Select > Select Child Nodes.

All descendants selected in branch become node-selected, and the root of the original branch selection remains selected as well. If a child node is not branch-selected, it remains unselected.

**Navigating Hierarchies**

You can navigate hierarchies of objects and their properties using the arrow buttons on the Select panel or using keyboard shortcuts. The difference is that the arrow buttons work only with a single selection, while the keyboard shortcuts work with multiple selections. On the other hand, the arrow keys also work with properties, while the keyboard shortcuts only allow you to select the owner of a property.

In all cases, the order for next and previous siblings is determined by the internal order. You can modify this order using the schematic view (see Reordering Child Nodes in the Schematic on page 131).

**Selection Navigation Arrows**

The selection navigation arrows on the Select panel let you select the parents or siblings of objects and properties. They work only with a single selection—if multiple elements are selected then only the last one added to the selection is considered.

You can use the arrows in combination with modifier keys, as well as set some options, as described in the next sections.

**To navigate hierarchies using the arrow buttons**

- Use the mouse and button combinations shown in the table below.

<table>
<thead>
<tr>
<th>Use this...</th>
<th>To do this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up</td>
<td>Select the parent of an object, or the owner of a property.</td>
</tr>
<tr>
<td>Next</td>
<td>Select the next sibling object or property.</td>
</tr>
<tr>
<td>Shift+Next</td>
<td>Add the next sibling object or property to the selection.</td>
</tr>
<tr>
<td>Ctrl+Next</td>
<td>Select the last sibling object or property.</td>
</tr>
<tr>
<td>or Right-click &gt; Select Last Sibling</td>
<td></td>
</tr>
<tr>
<td>Previous</td>
<td>Select the previous sibling object or property.</td>
</tr>
</tbody>
</table>
To set the navigation arrow options

- Right-click on the Previous or Next arrow, then turn any of the following options on or off:

  - **Same Type of Objects** restricts the navigation to objects of the same type. For example, if a geometric object is selected, then the arrow buttons ignores nulls, control objects, and so on.

  - **Same Type of Clusters** restricts the navigation to clusters of the same type of components. For example, if a cluster of points is selected, then the arrow buttons ignores polygon, edge, and sample clusters.

  - **Loop** cycles through siblings so that if the last sibling is selected, then Next selects the first; if the first is selected then Previous selects the last.

**Selection Navigation Shortcut Keys**

You can navigate among selected objects in hierarchies using keyboard shortcuts. These key combinations work with both single and multiple selections.

<table>
<thead>
<tr>
<th>Use this...</th>
<th>To do this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift+Previous</td>
<td>Add the previous sibling object or property to the selection</td>
</tr>
<tr>
<td>Ctrl+Previous or Right-click &gt; Select First Sibling</td>
<td>Select the first sibling object or property.</td>
</tr>
</tbody>
</table>

### Use this... To do this...

<table>
<thead>
<tr>
<th>Alt+up-arrow</th>
<th>Select the parents of selected objects or the owners of selected properties.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt+down-arrow</td>
<td>Select the first child objects of the selected objects.</td>
</tr>
<tr>
<td>Alt+left/right-arrow</td>
<td>Select the previous/next sibling objects.</td>
</tr>
<tr>
<td>Alt+Home</td>
<td>For a bone or effector, select its chain root.</td>
</tr>
<tr>
<td></td>
<td>For any other object, select the first ancestor that is a chain root.</td>
</tr>
<tr>
<td></td>
<td>If no chain root is found, select the root of the hierarchy.</td>
</tr>
<tr>
<td>Alt+End</td>
<td>For a bone or chain root, select its end effector.</td>
</tr>
<tr>
<td></td>
<td>For any other object, follow the path down the first child of any parent and select the first effector or, if no effector is encountered, select the bottom-most child.</td>
</tr>
<tr>
<td>Shift+Alt+up-arrow</td>
<td>Add the parents of selected objects or the owners of selected properties to the selection.</td>
</tr>
<tr>
<td>Shift+Alt+down-arrow</td>
<td>Add the first child objects of the selected objects to the selection.</td>
</tr>
</tbody>
</table>
### Navigating Component Selection

When point, edge, or polygon components are selected, you can use keyboard shortcuts to navigate among them. The order is based on the internal indices of the components; this is particularly useful for points on curves, where the index corresponds exactly to the position of the point along the curve.

<table>
<thead>
<tr>
<th>Use this...</th>
<th>To do this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift+Alt+left/right-arrow</td>
<td>Add the previous/next sibling objects to the selection.</td>
</tr>
<tr>
<td>Ctrl+Alt+up-arrow</td>
<td>Select the parents of selected objects or the owners of selected properties in branch.</td>
</tr>
<tr>
<td>Ctrl+Alt+down-arrow</td>
<td>Select the first child objects of the selected objects in branch.</td>
</tr>
<tr>
<td>Ctrl+Alt+left/right-arrow</td>
<td>Select the previous/next sibling objects in branch.</td>
</tr>
</tbody>
</table>
| Ctrl+Alt+Home               | For a bone or effector, select its chain root in branch.  
|                             | or For any other object, select the first ancestor that is a chain root in branch. If no chain root is found, select the root of the hierarchy in branch. |
| Ctrl+Alt+End                | For a bone or chain root, select its end effector in branch.  
|                             | or For any other object, follow the path down the first child of any parent and select the first effector in branch or, if no effector is encountered, select the bottom-most child. |
| Ctrl+Shift+Alt+left/right-arrow | Add the previous/next sibling objects to the selection in branch.          |

<table>
<thead>
<tr>
<th>Use this...</th>
<th>To do this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt+up-arrow or Alt+right-arrow</td>
<td>Select the next component.</td>
</tr>
<tr>
<td>Alt+down-arrow or Alt+left-arrow</td>
<td>Select the previous component.</td>
</tr>
<tr>
<td>Alt+Home</td>
<td>Select the first component.</td>
</tr>
<tr>
<td>Alt+End</td>
<td>Select the last component.</td>
</tr>
<tr>
<td>Shift+Alt+up-arrow or Shift+Alt+right-arrow</td>
<td>Add the next component to the selection.</td>
</tr>
<tr>
<td>Shift+Alt+down-arrow or Shift+Alt+left-arrow</td>
<td>Add the previous component to the selection.</td>
</tr>
<tr>
<td>Shift+Alt+Home</td>
<td>Add the first component to the selection.</td>
</tr>
<tr>
<td>Shift+Alt+End</td>
<td>Add the last component to the selection.</td>
</tr>
</tbody>
</table>
Navigating Constraint Relationships

If the selected object is a constraint, you can quickly select the objects it constrains. Similarly if an object is constrained, you can quickly select the objects that constrain it.

To select the objects constrained by the selection

1. Select an object that serves as a constraint.
2. Choose Constrain > Select Objects Constrained. All objects that are constrained by the original object become selected.

The Select Objects Constrained command is also available from context menus in the 3D views (Alt+right-click on an object on Windows, Ctrl+Alt+right-click on Linux), explorer (right-click on an object), and schematic view (Alt+right-click on an object on Windows, Ctrl+Alt+right-click on Linux).

To select the objects constraining the selection

1. Select an object that has a constraint.
2. Choose Constrain > Select Constraining Objects. All objects that constrain the original object become selected.

The Select Constraining Objects command is also available from context menus in the 3D views (Alt+right-click on an object on Windows, Ctrl+Alt+right-click on Linux), explorer (right-click on an object), and schematic view (Alt+right-click on an object on Windows, Ctrl+Alt+right-click on Linux).
Chapter 8 • Selecting

Selecting by Name

All objects in scenes have names, and if you know an object’s name then you can use it to select the object. More generally, all elements in scenes can be referenced by character strings, and you can use these strings to select the elements.

Typing in the Selection Name Boxes

You can enter an object’s name, as well as wildcards and other special characters, directly into the Object Selection and Sub-object Selection boxes on the Select panel.

To select objects by name

• Type the name directly in the top box.

Use this... To mean this...
---
nname Object or model called “name”.
B:name Object or model called “name” in branch mode.
model.object The object called “object” in the model called “model”.
obj1, obj2 Both objects called “obj1” and “obj2”.

To select components by name

1. Select the desired objects.
2. Set the selection filter to the desired component type.
3. Enter the indices of the desired components in the bottom box.
Selecting by Name

**Fundamentals**

To select clusters, properties, or operators by name

1. Select the desired objects.
2. Enter the name of the cluster, property, or operator in the bottom box.
   - You must use the scripting name of the element. For example, `kine` instead of `Kinematics`.
   - You must enter the complete path. For example, to select the cluster called `HardEdges` you can enter `polymsh.cls.HardEdges` (but `*.HardEdges` is quicker to type).

- You can enter the entire string in the top box using a period to separate the model and object names as well as to separate the object name and component/property reference.
- If one of the component filters is active as well as the Cluster filter, any text you type in the Sub-object Selection box is matched against the clusters of that component type. For example, you can quickly select all polygon clusters on an object by setting the selection filter to Polygon, activating the Cluster filter, and then typing `*` in the sub-object selection box.

<table>
<thead>
<tr>
<th>Use this...</th>
<th>To mean this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Component 2.</td>
</tr>
<tr>
<td>3,6,8</td>
<td>Components 3, 6, and 8.</td>
</tr>
<tr>
<td>3-8,10</td>
<td>Components 3 to 8 and 10.</td>
</tr>
<tr>
<td>*</td>
<td>All components.</td>
</tr>
<tr>
<td>3-LAST</td>
<td>Components 3 and higher.</td>
</tr>
<tr>
<td>(1,2)</td>
<td>The point (1, 2) on the surface called “object”, or point 2 on subcurve 1 of a curve.</td>
</tr>
<tr>
<td>(1,2,3)</td>
<td>The point (1, 2, 3) on the lattice called “object”, or point (2,3) on subsurface 1 of an assembled surface mesh.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Use this...</th>
<th>To mean this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>object.property</td>
<td>The property called “property” of the object called “object”.</td>
</tr>
<tr>
<td>.property</td>
<td>The property called “property” of the currently selected objects.</td>
</tr>
<tr>
<td>*.property</td>
<td>All properties called “property”.</td>
</tr>
<tr>
<td>[obj1,obj2].property</td>
<td>The property called “property” of objects called “obj1” and “obj2”.</td>
</tr>
</tbody>
</table>
To select elements by type

- Use the # character to select elements by type.

<table>
<thead>
<tr>
<th>Use this...</th>
<th>To mean this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>#3dobject</td>
<td>All 3D objects in the scene.</td>
</tr>
<tr>
<td>name.#3dobject</td>
<td>The first child of the object called &quot;name&quot; that is a 3D object.</td>
</tr>
<tr>
<td>name.#3dobject*</td>
<td>All children of the object called &quot;name&quot; that are 3D objects.</td>
</tr>
</tbody>
</table>

You can use the following element types:

<table>
<thead>
<tr>
<th>To do this...</th>
<th>Use this...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify overrides</td>
<td><em>override</em></td>
</tr>
<tr>
<td>Specify models</td>
<td><em>model</em></td>
</tr>
<tr>
<td>Specify 3D objects</td>
<td><em>3dobject</em></td>
</tr>
<tr>
<td>Specify passes</td>
<td><em>pass</em></td>
</tr>
<tr>
<td>Specify groups</td>
<td><em>group</em></td>
</tr>
</tbody>
</table>

Using Wildcards and Regular Expressions in Names

You can use a subset of regular expressions (regex) in name selections. You can include multiple wildcards in the same string. Search strings are not case-sensitive.

For example, *left* selects FrontLeftLeg, BackLeftLeg, FrontLeftPaw, and BackLeftPaw.

<table>
<thead>
<tr>
<th>This pattern...</th>
<th>Matches these characters...</th>
</tr>
</thead>
<tbody>
<tr>
<td>?</td>
<td>Any single character.</td>
</tr>
<tr>
<td>*</td>
<td>Any string of 0 or more characters.</td>
</tr>
<tr>
<td>[abc]</td>
<td>Any one of the characters a, b, or c.</td>
</tr>
<tr>
<td>![abc]</td>
<td>Any one character except a, b, or c.</td>
</tr>
<tr>
<td>[a-z]</td>
<td>Any one character in the range between a and z.</td>
</tr>
<tr>
<td>![a-z]</td>
<td>Any one character except those in the range between a and z.</td>
</tr>
</tbody>
</table>
Defining Selectability

You can define whether specific objects and groups can be selected in the 3D and schematic views. This can come in handy and speed up your workflow if you are working in a very dense scene and there are one or more objects that you don’t wish to select.

About Selectability

Selectability is a setting that determines whether you can select an object using the mouse in a 3D or schematic view. For objects, it is a parameter on the Visibility property editor, while for groups it is a parameter on the Group property editor.

Unselectable objects are displayed in dark gray in the wireframe and schematic views.

Regardless of whether an object’s Selectability is on or off, you can always select it using the explorer or using its name.

If an object is not selectable, you cannot select (“tag”) components on it, even after you select it in the explorer.

In addition to the Selectability parameter itself, there are a couple of other factors that affect whether you can select objects: visibility, groups and layers.

Selectability and Visibility

You cannot select an object in a view if it is not visible in that view (that is, if it is actually hidden rather than merely occluded by other elements). Hidden objects are not displayed in the 3D views, so they cannot be selected in those views. However, hidden objects are displayed as outline boxes in the schematic, so they can still be selected in that view.

For more details about visibility, see Setting Object Visibility on page 168.

Selectability, Groups, and Layers

The selectability of an object can also be affected by its membership in groups and layers. Groups and layers let you control the selectability (as well as the visibility) of all their members. You can make all members of a group or layer selectable, make them all unselectable, or make them selectable or not depending on their individual Selectability parameters.

For more details about using groups and layers, see Grouping Objects on page 265 and Chapter 14: Layers on page 331.
Setting Object Selectability

Object selectability is controlled by a parameter in the Visibility property. This property exists on every 3D object in XSI and cannot be deleted.

To set an object’s selectability

1. Select one or more objects.

2. Display the Visibility property editor by clicking the Selection button on the Select panel, then clicking the Visibility node icon in the pop-up explorer.

3. Turn Selectability in the General area on or off.
Selection Tips

This section presents some miscellaneous tips about selection.

Combining Selection Techniques

The selection techniques are very flexible, and you can use them to their full potential by combining several selection techniques.

Example—Selecting All Objects with Annotations

For example, suppose you want to quickly select all objects that have Annotation properties applied to them. You could do this in the spreadsheet, or you can do it directly in the interface as described here.

1. Select all Annotation properties by name:
   
   `*.Annotation`

2. Navigate by pressing Alt+up-arrow to select all objects that own the Annotation properties.

Running Commands Automatically When the Selection Changes

You can run a command, including a custom command, automatically whenever the selection changes. This can be useful in a number of situations, such as automatically switching between control rigs for forward and inverse kinematics.

For more information about the OnSelectionChange option, see Running Commands Automatically in Chapter 3 in the Customization guide.

Selecting Points That Overlap Others

Polynode bisectors can be useful when selecting or moving points that overlap others on a polygon mesh object.

To select or move a point that overlaps others

1. Open the Camera Visibility property editor of a 3D view, for example, by pressing Shift+s.

2. On the Components tab, set Show Polynode Bisectors to Show While Drawing Points.

   With this option, bisectors are displayed as small purple lines at the corners of polygons whenever points are visible.

3. Activate point selection (for example, press t for Rectangle Point Selection) or the Move Point tool (press m).

4. Click on a bisector to affect the corresponding point.
Chapter 8 • Selecting
Chapter 9  3D Objects
What’s an Object in XSI?

There are several different types of objects found in an XSI scene. While you don’t model or render all of them, they all have specific purposes.

When you create an object in XSI, you can give it a name in its property editor. To rename objects, however, it’s often easier to use the explorer than going back into the object’s property editor. For more information on doing this, see Renaming Scene Elements on page 119.

Geometric Objects

Geometric objects are objects that have points (geometry) and can be modeled and rendered. There are several different types of geometric objects in XSI.

See Geometric Objects on page 263 for a full description of each available type.

Nulls

Nulls are simply locations in space that cannot be modeled or rendered. However, they have many uses, such as for setting constraints and organizing objects in hierarchies. Nulls are sometimes called locators or point objects.

Implicit Objects

Implicits are basic shapes defined by a mathematical formula. By themselves, they are not renderable but can be used, for example, to define bounding boxes when setting weights for envelopes, or as control objects for a character rig. Implicit objects are sometimes called helper objects or dummies.

You can scale, rotate, and translate implicit objects, but you cannot deform them because they have no points. Note that implicit objects are not exported to the IGES format.

Control Objects

Control objects are the objects that represent waves and natural forces like gravity and wind that are used to affect particles and other simulations. The control objects themselves do not render; instead, they exist to define the properties of deformations and other effects.

Chain Elements: Roots, Bones, and Effectors

Roots, bones, and effectors form kinematic chains that you can use to create and animate characters. You can animate chains using inverse kinematics (IK) or forward kinematics (FK).

For more information on kinematic chains, see the Character Animation guide.
What's an Object in XSI?

Lattices
Lattices are like a three-dimensional scaffolding that can be used to deform objects.
They are described in more detail in Lattices in Chapter 6 in the Modeling & Deformations guide.

Waves
Waves define an animated deformation that you can use to create ripples in geometric objects.
They are described in more detail in Waves in Chapter 6 in the Modeling & Deformations guide.

Texture Controls
Texture supports (sometimes called texture controls) are 3D objects that define and control how a texture is projected onto a geometric object.
They are described in more detail in Chapter 7: Projections and Supports of the Shaders, Lights & Cameras guide.

Forces
Forces are control objects that define natural effects like gravity, turbulence, and wind. You can use them to influence simulations like particles, hair, cloth, and soft bodies.
Forces are described in Chapter 2: Natural Forces in the Simulation guide.

Volume Deformers
Volume deformers are 3D objects that you can use to shape and sculpt geometric objects. They influence the points inside their volume, with a proportional falloff from their center to their limit.
They are described in more detail in Manipulating Points by Volume in Chapter 5 of the Modeling & Deformations guide.
Chapter 9 • 3D Objects

**Cameras**

The camera in XSI is analogous to a physical camera in the real world. It defines the view that you can render. You can add as many cameras as you want in a scene.

For more information on cameras, see *Chapter 14: Cameras* in the *Shaders, Lights & Cameras* guide.

![Camera represented by icon pointing at objects.]

**Lights**

As in the real world, lights make everything in your 3D scene visible. Each light in a scene contributes to the scene's illumination and affects the way all objects' surfaces appear in the rendered image. You can dramatically change the nature and mood of your images by modifying lights and their properties.

For more information on using lights, see *Chapter 13: Lights and Shadows* in the *Shaders, Lights & Cameras* guide.

![A spot light]
There are several types of geometric objects that you can add to your scenes. The set of points belonging to an object is called its geometry, while the number of points and how they are connected is called its topology. In addition, geometric objects have attributes like centers and normals.

SOFTIMAGE|XSI offers several types of geometry: polygon meshes, subdivision surfaces, curves, surfaces, and surface meshes.

**Polygon Meshes**
Polygon meshes are quilts of polygons joined at their edges and vertices. Because their geometry is mathematically simple and quick to calculate, they are particularly useful when modeling for games and other real-time environments where speed is important. You can subdivide specific polygons in areas where you need more detail, and remove them where you require less detail.

For more information, see Chapter 8: Modeling Polygons & Polygon Meshes in the Modeling & Deformations guide.

**Subdivision Surfaces**
Subdivision surfaces, also known as subdees or subdivs, are low-resolution polygon mesh hulls that control a higher-resolution polygon mesh object. They provide many of the benefits of polygon meshes, plus the ability to approximate smooth surfaces without the need for heavy geometry in the control hull.

You can animate and texture the control hull for greater speed and interaction while you work, and then let the hull drive the high-resolution version for your final output.

Subdivision surfaces are described in more detail in Chapter 9: Subdivision Surfaces in the Modeling & Deformations guide.

**Curves**
Curves are one-dimensional NURBS (non-uniform rational B-splines) of linear or higher degree. They have points but they are not renderable because they have no thickness. Curves serve as the basis for constructing surfaces, paths for objects to move along, controlling deformations like deform by curve and deform by spine, and so on.

For more information, see Chapter 11: Curves in the Modeling & Deformations guide.
Chapter 9 • 3D Objects

Surfaces
Surfaces are two-dimensional NURBS patches defined by intersecting curves in the U and V directions. In a cubic NURBS surface, the surface is interpolated between the control points, resulting in an accurately smooth shape. Surfaces are always four-sided, and unlike polygon meshes, they do not support different textures on different areas of the object.

For more information, see Chapter 12: Surfaces in the Modeling & Deformations guide.

Surface Meshes
Surface meshes are quilts of NURBS subsurfaces acting as a single object. They overcome the limitation that surfaces must be four-sided: with surface meshes, you can create complex objects and characters with holes, legs, and so on. You can control the continuity at the junctions between subsurfaces to create complex yet seamless objects.

For more information, see Chapter 13: Surface Meshes in the Modeling & Deformations guide.

Clouds and Particles
Clouds are icons that control the emission and simulation of particles from a geometric object. You can use them to create a variety of particle effects, such as fire, water, and smoke.

For more information, see Section II • Particle-based Simulations in the Simulation guide.

Hair
Hair objects let you use guide hairs to control a full head of render hairs. You can style the hairs manually as well as apply a dynamic simulation.

For more information, see Section III • Hair and Fur Simulations in the Simulation guide.
Grouping Objects

You can organize 3D objects, cameras, and lights into groups for the purpose of selection, applying operations, assigning properties and shaders, and attaching local materials and textures. Creating groups means that you don’t need to reselect the same set of objects each time you want to work with them.

Similarly, you can group object components such as polygons and points into clusters to apply operations, assign properties, etc. For more information on this, see Chapter 12: Components and Clusters on page 309.

Besides being able to organize objects into groups, you can also create a group of groups. An object can be a member of more than one group. Groups, however, can’t be added in hierarchies. They can only live immediately beneath the scene root or a model (technically, the scene root is a model).

Even if an object is in a group, it can still be individually selected and manipulated.

For information on duplicating groups, see Duplicating and Cloning Objects on page 269.

Groups in XSI are the equivalent of named selections in SOFTIMAGE|3D. However groups cannot contain fcurves, but you can store a list of parameters as a marking set—see Remembering Marked Parameters with Marking Sets in Chapter 2 of the Animation guide.

Creating Groups

Any parameter values or operations applied to a group of objects are shared by each member of the group. Parameter values are stored at a group level and override any existing values previously assigned to any members within the group. Original values are kept for each object or component in a group.

To create a group

1. Select one or more objects you want in the group; you can also select multiple groups.

2. Do one of the following:
   - Click the Group button in the Edit panel or press Ctrl+g.
   - In the explorer, right-click on the selected objects and choose Create Group.
3. In the Group property editor, enter a name for your group and select the different View and Render Visibility, Selectability, and Animation Ghosting options.

You cannot animate these options. To animate the visibility or selectability of objects in a group, you must apply an override to the group. For more information about overrides, see Overriding Properties on page 291.

All selected objects are grouped together. In the explorer, you can see the group with all its members within it.

To select a group, click the Group button in the Select panel, then click any member of the group. For more information, see page 228.
Adding and Removing Elements from Groups

You can add items to or remove individual items from groups.

**To add items to a group**

1. Select the group to which you want to add objects.
2. Add the desired objects to the selection.
   
   In the case of groups of groups, everything will be added to the first group you selected in step 1.
3. Do one of the following:
   
   - In the Edit panel, click the + button (next to the **Group** button).
   - In the Edit panel, choose **Edit > Add to Group**.
   - In the explorer, right-click on the group and choose **Add to Group**.
   - Drag the objects and drop them onto the group node in an explorer.

   With this method, you do not need to select the group first.

**To remove objects from a group**

1. If the objects to be removed are members of more than one group, first select the group that contains them.
2. Select the objects to be removed from the group.
3. Do one of the following:
   
   - In the Edit panel, click the – button (next to the **Group** button).
   - In the Edit panel, choose **Edit > Remove from Group**.
   - Go to node of the desired group in the explorer, right-click the icon of the object to be removed, and choose **Remove from Group**.

   With this method, you do not need to select the group first (in the case of multiple groups).
Deleting Groups

When you delete groups, only the relationship between the objects is deleted, not the objects themselves.

When you delete an element that contains other groups, the “parent” group is removed and the “child” groups are preserved.

To delete a group
1. Select the group you want ungrouped.
2. Do one of the following:
   - Choose Edit > Remove Group from the Edit panel or press Ctrl+Shift+g.
   - In the explorer, right-click on the group and choose Remove Group.

You can search for all groups in a scene using the Groups (All) query in the spreadsheet. It lists all of the groups, their name and number of members, and the list of members. For each member, there is also some visibility information. See The Spreadsheet on page 132 for more information.
Duplicating and Cloning Objects

There are two ways to copy objects in your scene: you can make *duplicates* or *clones*. These methods of copying can also be applied to groups, models, and hierarchies.

**Duplicating Objects vs. Cloning**

When an object is **duplicated**...

... the original and its duplicates can be modified separately with no effect on each other.

When an object is **cloned**, editing the original object affects all the clones...

... but editing only one clone has no effect on the others.

In addition to duplicating and cloning, models can be instantiated. For more information about instances, see *Instantiating Models* on page 497.

- You cannot duplicate or clone an object if its parent is locked. For more information about locks, see *Chapter 23: Locking and Tagging Scene Elements* on page 501.
- In XSI version 2.0X and previous, *cloning* was called *instantiating*. The new Instantiate command applies only to models.
Duplicating Objects

When you create a copy of an object, you create an independent duplicate of the original, similar to photocopying. The copy bears some or all the characteristics of the original at its moment of duplication, but from that moment on any changes to the original has no effect on the copy. Which characteristics of the original are copied depend on the settings you specify in the Duplicate Options property editor.

Any materials or textures on the original object are also duplicated.

To duplicate one or more objects

1. Select the object(s) to be copied.
   - If you're duplicating a group, see page 271.
   - If you're duplicating a whole hierarchy, branch-select the parent object (see Selecting Objects in a Hierarchy on page 326 for more information).
   - If you're duplicating a model, select the model node in the explorer (see What Are Models? on page 474 for more information).
   - To duplicate a model source, select the referenced model.
   - When you duplicate an object that was generated from others, the new object shares its inputs with the original object. However, if you select both the object and its inputs, and duplicate them together, the duplicate of the generated object has a modeling relation with the duplicates of the inputs. For example, if surface was generated by revolving curve and you duplicate surface, then modifying curve affects both surface and surface1. If you duplicate curve and surface together, then modifying curve affects surface and modifying curve1 affects surface1.
   - When duplicating objects with texture supports, the Duplicate Options property editor contains settings for controlling how the texture support is copied or shared. See Texture Supports and Duplicated Objects in Chapter 7 of the Shaders, Lights & Cameras guide for more information.

2. If you want to specify only certain characteristics of the original to be copied, choose Edit > Duplicate/Instantiate Options from the Edit panel and make your selections.

Refer to Online Help for a description of the duplicate controls available from this editor.

Make sure to check the Duplicate Options property editor before you duplicate objects—it may have settings from a previous duplication session that you don’t want to apply. If you're duplicating a single copy, press Ctrl+Alt+d to duplicate without using the options (as described next).
For a single duplicate

- Do one of the following:
  - Press Ctrl+d.
  - Choose Edit > Duplicate/Instantiate > Duplicate Single from the Edit panel in the main command area.
  - Press Ctrl+Alt+d or choose Edit > Duplicate/Instantiate > Duplicate Single without Options to duplicate the object without using any of the options that are set in the Duplicate Options property editor.
  - Right-click on the selected object in the explorer and choose Duplicate.

For multiple duplicates

- Do one of the following:
  - Press Ctrl+Shift+d.
  - Choose Edit > Duplicate/Instantiate > Duplicate Multiple and specify the number of copies required.
  - Choose Edit > Duplicate/Instantiate > Duplicate Tool (or press d), then click in a 3D view at the spot where you want a duplicate object to appear. Right-click to deactivate the duplicate tool.

Duplicating Groups

While the process for duplicating a group is similar to any object, you must be careful about what you select before duplicating. For example, if you select the group container in the explorer and duplicate, you only duplicate the group container but not the members of the group.

To duplicate a group

- Choose Select > Select Members/Components from the Select panel, then one of the Duplicate/Instantiate commands.

However, the duplicated objects are not in a group. For more information on selecting, see Selecting Groups of Objects on page 228; for information on grouping, see page 265.
Transforming While Duplicating

If you duplicate an object and transform it, the same transformations are applied to the object created by the next Duplicate command. This gives you a way of having the duplicated objects in the correct position or correct size as soon as they’re created.

To include transformations in duplicated objects

1. Select the object(s) to be copied.
2. Choose Edit > Duplicate/Instantiate Options from the Edit panel and make your selections from the Duplicate Options property editor.
   Refer to the Online Help for a description of the duplicate controls available from this editor.
3. For a single transformed copy, press Ctrl+d or choose Edit > Duplicate/Instantiate > Duplicate Single. The duplicated object is scaled, translated, and/or rotated using the same factor/offset values with respect to the previous duplicated object.
   For multiple transformed copies, press Shift+Ctrl+d or choose Edit > Duplicate/Instantiate > Duplicate Multiple and specify the number of copies required from the pop-up dialog box.
   The specified number of duplicated objects appears, with each one being scaled, translated, and/or rotated using the same factor/offset values with respect to the previous object generated by the command.

If you need to make a duplicate without using the transform options but don’t want to lose your duplicate options, duplicate your object using Edit > Duplicate/Instantiate > Duplicate Single without Options.
Duplicating and Cloning Objects

Example: Applying multiple transformations to duplicated objects

1. Select the object (a step) to be duplicated and transformed.

2. Specify the Scaling, Rotation, and Translation values on the Duplicate Options > Transform page.

3. With the step selected, choose Edit > Duplicate/Instantiate > Duplicate Multiple and specify to make 5 copies.

Result: Five copies of the original step are generated, with each duplicate translated, rotated and scaled to give the appearance of a flight of spiral stairs. (Note: the center of the step was repositioned to the right so that the step could be rotated along its right edge.)

Duplicating Symmetrically

You can duplicate objects and hierarchies (including chains) using the Duplicate Symmetry command.

To duplicate and mirror an object

1. Select the objects you want to duplicate.

2. Choose Create > Skeleton > Duplicate Symmetry from the Animate toolbar or Edit > Duplicate/Instantiate > Duplicate Symmetry. The Duplicate Symmetry dialog box opens.

3. Set the options as desired:

   - Duplicate Constraints copies the constraints that exist on the objects you're duplicating. For example, if there's an up-vector constraint on an arm or leg, you may want to use it on your new chain as well.
If you are duplicating both the constrainee and constrainer, then the duplicated constrainee becomes constrained to the duplicated constrainer.

If you are duplicating just the constrainee, then the duplicated constrainee becomes constrained to the original constrainer.

- **Share Parent** makes the duplicated objects children of the same parents as the original objects. If this option is off, the new objects will be a children of the scene root.

- **Freeze Negative Scaling** controls how symmetrical objects are scaled.

  When on, there is no negative scaling on duplicated objects. This is the same as the behavior in SOFTIMAGE|3D.

  When off, the scaling for duplicated objects is negated, switching the handedness. For example, if the original chain is right-handed, the duplicated chain will have a left-handed coordinate system. Note that negative scaling may not be compatible with other applications such as game engines or motion capture systems. In addition, mixed handedness can cause problems in hierarchies of kinematic chains.

- **Plane of Symmetry** determines the plane to mirror across: XY, YZ, or XZ.

4. Click OK. The selected objects are duplicated.

**Duplicating Objects from Animation**

You can also create duplicates based on an object’s existing animated transformations. Duplicating an animated object creates “snapshots” of the object at specified intervals, with each duplicated object taking on the scaling, orientation, and position of the original object at each interval.

**To create duplicates from animation**

1. Select the animated object(s) to be copied.

2. Choose **Edit > Duplicate/Instantiate > Duplicate/Instantiate from Animation** from the Edit panel.

3. In the Duplicate from Animation dialog box, set the start and end frames of the animation to use for the duplicates, as well as the step values. For example, if the **Start Frame** is 10, the **End Frame** is 40, and the **Step Value** is 15, the duplicates are created based on the object’s state at frames 10, 25, and 40.

   The **Instance** option creates instances instead of duplicates and works only with models. For more information about models in general, see *Chapter 22: Models* on page 473.
Duplicating and Cloning Objects

Duplicating Objects along a Curve Path

Creating duplicates along a curve path is similar to creating duplicates from animation, but with a key difference: the original object’s transformations are ignored. However, the benefits of paths (modifying object position by modifying the path, tangency, etc.) provide you with a variety of new options.

For more information on creating path animation, see Chapter 7: Animating along Paths and Trajectories in the Animation guide.

To create duplicates along a path

1. Select the animated object(s) to be copied.

2. Choose Edit > Duplicate/Instantiate > Duplicate Multiple or press Ctrl+Shift+d and specify the number of copies required. The original object is deselected, and the duplicated objects are selected.

3. With the duplicated objects still selected, choose Constrain > Curve (Path), then pick the curve to be used as the path.

4. In the PathCns property editor, set the Path Percentage to $L(n)$, where $n$ is the percentage of the path along which you want to spread the duplicate objects. Modify any other path options as necessary.

The objects are spread along the curve at even intervals over the percentage you specified.
Cloning Objects

Creating a clone of an object allows you to keep a link between the original (master) object and its clone. Any change you make to the geometry of the master object is reflected in all clones of it. However, transformations (scaling, rotation, translation) and any change you make to the clone affect only it, and not the master nor other clones.

Any materials or textures on the original object are also be copied to the clones. You can further define how the original is cloned in the Duplicate/Instantiate Options property editor.

Clones are displayed in the explorer with a cyan superimposed on the model icon. In the schematic view, they are represented by trapezoids with the label Cl.

- In XSI versions 2.0X and previous, the Clone commands were called Instantiate. The new Instantiate commands work only with models; see Instantiating Models on page 497.

  The old script command Instance is still available for backwards compatibility, but it has been deprecated in favor of the new synonym Clone. A new script command Instantiate is used for the new instantiation behavior on models.

- If there are clusters and cluster properties on the source, then modifying the topology of the source will not update the clusters on the clones. For example, if there are materials or textures on polygon clusters and you add polygons to the source, then the materials and textures will be on different polygons on the clones. Similarly, vertex colors do not interpolate properly on clones if you modify the topology of the source.
To clone objects, groups, or hierarchies

1. Select the item(s) to be cloned.
   - If you're cloning a group, see Duplicating Groups on page 271.
   - If you're cloning a whole hierarchy, branch-select the parent object (see Selecting Objects in a Hierarchy on page 326 for more information).
   - If you're cloning a model, select the model node in the explorer (see What Are Models? on page 474 for more information).

2. If you want to specify only certain characteristics of the original to be cloned, choose Edit > Duplicate/Instantiate Options from the Edit panel and make your selections.

For a single clone

• Do one of the following:
  - Choose Edit > Duplicate/Instantiate > Clone Single.
    or
  Choose Edit > Duplicate/Instantiate > Clone Single without Options to clone the object without using any of the options that are set in the Duplicate Options property editor.
    or
  Right-click on the selected object in the explorer and choose Clone.

For multiple clones

• Choose Edit > Duplicate/Instantiate > Clone Multiple and specify the number of clones.
Chapter 9 • 3D Objects

Deleting Objects

After creating all sorts of objects in XSI, you're eventually going to have to delete something.

To delete objects

Do one of the following:

- Select one or more objects in the scene, then choose **Edit > Delete Selected** or press the Delete key.

  or

- Press the Backspace key to activate the Delete tool, then select the objects you want deleted. Press Backspace again to deactivate the tool.

  or

- In the explorer, right-click on any object's name and choose **Delete**.

To delete all the objects in a scene

- Choose **Edit > Delete All**

  or

- Press Shift+Delete.

Because this has the same effect as starting a new scene, you are asked if you want to save the current scene first.
Properties

A property is a set of related parameters that controls some aspect of objects in a scene.

You can:

- Apply properties like Annotation and others to objects.
- Save and load presets of the parameter values in a property.
- Use overrides to control a specific parameter on different objects.

Specific properties, like Geometry Approximation and Display, are described in context in other sections of the XSI user guides.
What Are Properties?

Every element in your scene has properties. Properties are the characteristics of an element that distinguishes it from other elements. Properties are often grouped together by their similarities and defined by a series of parameter values.

Properties can also be applied to elements directly or they can be applied at a higher level and passed down. Properties can be propagated to the children elements in a hierarchy in the same way that genetic traits are passed down through the generations.

Property Editors

Properties like to live in property editors: this is where you can set their parameters' values. Property editors are interactive: as you make changes to individual parameters, the scene is updated to reflect these changes. If you select a different scene element or change frames, the property editor updates to show the values for the modified parameter(s) at the current frame.

For more information on using property editors, see Modifying Properties in Property Editors on page 77.

Properties Viewed in Hierarchies

Each object, shader, or operator in a scene is represented as a node in the scene hierarchy, which is viewed in an explorer. Each node is made up of default properties that are displayed and edited in a property editor.

Types of Properties

There are many different types of properties that apply to many different elements in a scene or even the XSI interface. For example, you can set different properties that apply to a single object or you can set properties that apply to what you see in a 3D view.

The following is a description of the basic properties that you can set for most objects in an XSI scene. For each one, you can click on the node's icon in the explorer to open its property editor.

Geometry

If the object is a 3D object, it has either a Polygon Mesh or Surface node, which contains the geometry properties of the object. If the object is a camera or light, there is no geometry for it. For more information on polygon mesh or surface objects, see the Modeling & Deformations guide.

Kinematics (Animation)

These properties define the transformations (the movements) of an object, not to be confused with forward or inverse kinematics on a skeleton. Transformations to an object can be either global or local.
You can set the position, rotation, and scaling coordinates of an object’s X, Y, and Z axis in global or local space. You can also activate and deactivate any transformation constraints that may have been applied to the object, or set positional and rotational limits for the object.

For more information on transformations, see Chapter 16: Transformations on page 351.

Visibility

These properties basically set how an object is viewed in a 3D view. On a per-object basis, you can determine whether an object is visible, renderable, or selectable.

You can also set some rendering properties that determine whether the object itself, its reflection, or its shadow is rendered, as well as if the object is a caustic or global illumination transmitter or receiver. For more information on the rendering options, see Chapter 3: Rendering Options in the Rendering guide.

Ambient Lighting

A scene’s ambient color is multiplied with an object’s ambient color. If the scene ambience is set to black, nothing can alter the ambient color of an object except, of course, a light.

Editing the value of this node affects the ambient lighting of the whole scene, not just the object. For more information, see Chapter 13: Lights and Shadows in the Shaders, Lights & Cameras guide.

Display

These properties define how individual objects are displayed in the 3D views in terms of speed. Some display types provide less detail and therefore speed up the refresh rate, while others provide more detail, and as such, require more time to redraw.

Objects can be displayed differently, depending on whether they are selected, unselected, and/or interacted upon.

Geometry Approximation

These properties let you specify how polygons, surfaces, and curves should be tessellated (divided into triangles at rendering time). The various methods of approximation let you reduce the number of triangles in the geometry of an object and still render a very smooth surface.

For more information on using geometry approximation for modeling, see page 33 in the Modeling & Deformations guide. For information on using it for viewing/rendering, see page 190.
What Are Properties?

Material

Every renderable object has a material that determines its appearance. A material has several aspects (such as surface, environment, and shadow) to which you can attach different shaders to control the total look of the object.

For more information on this, see The Default Scene Material in Chapter 3 in the Shaders, Lights & Cameras guide.

How Properties Are Propagated

Objects can inherit properties from many different sources. This inheritance is called propagation.

For some properties, such as Display and Geometry Approximation, an object can have only one at a time. If it inherits the same property from more than one source, the source with the highest “strength” is used.

In increasing order of strength, the possible sources of property propagation are:

- **Scene Default:** This is the weakest source. If an object does not inherit a property from anywhere else, it uses the scene’s default values. For example, if an object has never had a material applied to it, it uses the scene default material.

- **Branch:** If a parent has a property applied when it is branch-selected, its children all inherit the property.

- **Local:** If a child inherits a branch property from its parent, but has the same property applied directly to it, it uses its local values.

- **Cluster:** Materials, textures, and other properties applied to a cluster take precedence over those applied to the object.

- **Group:** If an object is a member of a group, then any properties applied to the group take precedence over local and branch properties. Similarly, if a cluster is a member of a group, any properties applied to the group take precedence over those applied directly to the cluster.

- **Layer:** Any properties applied to an object’s layer take precedence over group, local, and branch properties.

- **Partition:** Properties applied to a partition of a render pass have the highest priority of all when that render pass is current.

For other types of properties, an object can have many at the same time. For example, an object can have several local annotations as well as several annotations inherited from different ancestors, groups, and so on.

Overrides provide a way to impose properties and parameter values outside of ordinary propagation. For more information, see Overriding Properties on page 291.
Chapter 10 • Properties

Simple Propagation
In this sphere hierarchy, each sphere is parented to the one above it. Because the larger sphere was branch-selected when the texture was applied, every sphere beneath it inherits the checkerboard texture.

Branch Propagation
One sphere was branch-selected and given a cloud texture. The remaining sphere retains the checkerboard texture because it is on another branch.

Local Material/Texture Application
One sphere was single-selected and given a blue surface. This applies a local material/texture that is in turn applied to the selected object only—and none of its children; the sphere’s children still inherit the checkerboard texture, despite assigning a local texture to their parent.

Reverting to the Scene’s Default Material
The larger sphere was single-selected and has had its material deleted. Since other spheres can no longer inherit their texture from the parent (because it’s been deleted), they revert back to the scene’s default gray (or another color you’ve defined).
Viewing Propagation in the Explorer

The explorer is useful not only for viewing your scene's elements and their properties, but also for viewing how they are propagated through various hierarchies.

You can also set the following options in the explorer’s View menu:

- **Local Properties** displays only those properties that have been applied directly to an object.
- **Applied Properties** shows all properties that are active on an object, no matter how they are propagated.

Viewing Propagation in the Schematic View

The schematic view offers a hierarchal representation of how an object’s properties relate to one another.

Sphere2 has a branch material applied to it, which is propagated to Sphere6 and 7.

Sphere6 has its own local material applied. Sphere7 doesn’t display a material node because it is inheriting the one from Sphere2.
What are PropertyFixup Groups?

PropertyFixup groups are created automatically by XSI when it loads a scene and discovers that the same unshared property or material is applied locally on two or more objects. Although this situation should never happen, certain operations in previous versions of XSI could cause it.

When this situation is discovered, XSI creates a group called PropertyFixup, adds the objects to the group, and applies the property to the group.

If you load a scene and find a PropertyFixup group, you can:

- Reapply the property the way you want it and delete the group.
- Keep the group (maybe rename it) if you want to share the property.
Applying Properties

You can apply properties using the Get > Property menu of any toolbar. This menu is the same in the Model and Animate toolbars, while there are some extra items specific to rendering in the Render toolbar and some items specific to simulation in the Simulate toolbar.

Most of these properties are described in context in other sections of these guides. However, Annotation is a general-purpose property and is described in the section below.

To apply a property
1. Select the element on which you want to apply the property.

   You can select an object, branch, model, group, layer, or partition. For some properties, you can also select clusters.

2. Choose an item from the Get > Property menu on any toolbar.

   A new property is applied to the element. If only one such property can be applied at a time (for example, Geometry Approximation or Display), and the element already had a locally applied of that type, the existing property is removed and replaced by the default preset.

Adding Annotations to Elements

You can add comments and keywords to objects, groups, models, or clusters by using annotations. An annotation contains a text comment, key words, and two flags.

You can use annotations to share notes among a workgroup, or as a basis for spreadsheet queries. For example, you could assign a specific keyword to certain lights to easily select them from the Annotation query in the spreadsheet. For more information on spreadsheet queries, see The Spreadsheet on page 132.
To add annotations

1. Select one or more objects, clusters, groups, or models and choose **Get > Property > Annotation** from a toolbar.

2. Type in your comments.

3. Enter key words that you want to use to identify the object. You can open the spreadsheet and select the Annotation query to see the key words listed in the object’s annotation.

4. Select one or both flags to simply flag the object for any purpose. You can then use scripting to search them or use the Annotation query in the spreadsheet to see which objects are flagged.

To view or modify annotations

- In the explorer, click the object’s Annotation node’s icon to open the Annotation property editor. In any 3D view, an annotated element is marked with an "A."

  If the object has no synoptic property, then you can also select the object and press F3.

To rename the annotations

- In the explorer, right-click on the Annotation node and choose **Rename**, then enter the new name, or click twice on the name and enter a new name.
Creating Presets of Property Settings

Each time you edit properties in a property editor, you have the option of saving your settings as a preset. Presets are simply data files with a .preset file extension that contain property information.

Presets let you work more efficiently because you can save the modified properties and reuse them as needed. As well, presets serve the important function of allowing you to transport information between scenes.

In the DSPresets folder in a project, there are subfolders, each of which contain the existing default presets for objects, shaders, and operators.

For quick access, you can also place presets on a toolbar. For example, you could create three buttons that each apply different surface materials to an object. For more information on commands in toolbars, refer to Creating Custom Toolbars in Chapter 4 of the Customization guide.

Presets do not contain any animation. When you save a preset, only the current parameter values are stored.

Where Are Presets Stored?

Although you can save preset files anywhere, it is recommended that you use a standard location. This makes it easier to keep track of your presets. The default location is the Data\DSPresets subdirectory of your user path.

The Paths button in the Open and Save Script File browsers lets you quickly choose between various base locations, including:

- **Installation (Factory)** is the location where the XSI program files are installed. Presets saved here are available to any user on the local machine. You will need to copy these presets if you install XSI to a new location.

- **Workgroup** lets you share scripts, presets, and other data with members of your team. For more information about workgroups, see Setting a Workgroup on page 436.

- **User** is your user path, for example, C:\users\username\Softimage\XSI_4.0. Presets saved in this location are available to you whenever you are logged in as the same user on that installation of XSI.

- **Sample Project** is a project with sample scenes included with XSI. It is NOT recommended to save your presets here.

- **Current Project** is the project that contains the open scene. You could use this folder if your preset is specific to that project.

- **Factory Add-ons** is the Addons\ subdirectory of the location where the XSI program files are installed. For more information about add-ons, see Chapter 11: Sharing and Managing Customizations in the Customization guide.
User Add-ons is the Addons\subdirectory of your user path.

Other projects in your Projects List are listed under Projects.

**Saving Presets**

Once you have modified properties in a property editor, you can save them as a preset for later use.

To save a preset

1. In the property editor, click the **Save** preset button.
2. In the Save Preset browser, select the folder in which you wish to save the preset. It is recommended that you do not save your presets in the DSPresets folder.
3. In the **File Name** text box, enter the name you wish to give the preset, then click OK.

The saved preset contains values for only the parameter set currently selected on the property set tabs at the top of the property editor. In the case of materials and shaders, it also contains parameter settings for any connected shaders.

**Loading Presets**

You load or open presets from property editors that define existing objects, shaders, or operators. If, for example, you wish to load a camera preset, you must first open an existing camera property editor. Presets for constraints are loaded from constraint property editors, and so on.

To load a preset

1. Open an object, shader, or operator property editor from the toolbar, explorer, or render tree.
2. In the property editor, click the **Load** preset button.
3. In the Load Preset browser, select the preset you wish to load and click OK.

The list of files is filtered to show only presets of the same family. For example, if you are browsing for a shader preset, presets of custom parameters are not listed.

All parameter values stored in the preset are loaded into the current property. In the case of custom properties, where the number and names of parameters might not be the same, only parameters with the same name as those in the current property are loaded from the preset.

You may need to press **F5** to refresh the browser display in order to see recently saved presets.
Overriding Properties

Overrides are used to temporarily replace the current values of parameters. They are useful for controlling one or more specific parameters of a group, layer, or partition, without losing each object’s individual parameter values.

For example, suppose you have a group of polygon mesh objects, each of which has different subdivision levels applied in its Geometry Approximation property. Suppose you want to control all their OGL Level parameters together, but leave their individual Render Level parameters unchanged. If you apply a Geometry Approximation parameter to the group, it will affect all Geometry Approximation parameters through propagation. However, by using an override you can pick out just the parameter you want and modify it alone.

Overrides can be applied to individual objects, hierarchies (in branch mode), models, groups, and layers. However, they are especially useful for rendering passes because you can control specific properties (for example, transparency, shadow settings, or even the entire material) of all objects in a partition at once.

Overrides can contain individual parameters or entire property sets and materials.

- Parameter overrides can be applied to objects, branches, groups, layers, and partitions, as well as with models.
- Property set and material overrides can be applied to models—for example, you can transfer changes you made on one model to another version of the same model.

Property set and material overrides rely on object names within the model to determine which property on which object to override. For example, if you create an override for `body.geomapprox` on Model and transfer it to Model1, it will override the geometry approximation property of the object named `body` in Model1.

For information about using overrides to modify multiple materials at once, see Editing Multiple Objects in Chapter 4 of the Shaders, Lights & Cameras guide. For information about using overrides on partitions in render passes, see Applying Shaders Using Overrides in Chapter 2 of the Rendering & Compositing guide.

Overrides follow the same propagation rules as properties. For example, a local property on an object will take precedence over an override of a branch property. For more information about propagation, see How Properties Are Propagated on page 283.
Chapter 10 • Properties

To create an override

1. Select the element on which you want to apply the override. You can select an object, branch, model, group, layer, partition, or even the scene root.

2. Choose Get > Property > Override from any toolbar.

An override is created, but has no parameters at this point. You need to add parameters or properties to the override to control them.

To add parameters or properties to an override

1. Open the override's property editor.

2. Click Add Parameters. A pop-up explorer opens.

3. Do any of the following:
   - Click to select a single parameter or property set and deselect any others.
   - Shift+click to add a parameter or property set to your selection.
   - Ctrl+click to toggle a parameter or property set.
   - Ctrl+Shift+click to deselect a parameter or property set.

Selected parameters and property sets are highlighted in a light purplish blue.

4. When you have finished picking, click outside of the pop-up explorer. The selected parameters or property sets are added to the override.

   - For parameters, you can use the sliders in the override property editor to control the values of the parameters in the scene.

   - For property sets, you must open the property under the override in the explorer to control the values in the scene.

In property editors, the animation icon of parameters that are controlled by overrides show a black triangle on a cyan background. Right-click the icon and choose Inspect Override to open the override's property editor.

Using overrides can bypass the maximum and minimum values allowed for parameters. Setting a value outside the allowable range can cause unpredictable results.

You can still set the value of the object's parameter but it has no effect as long as the parameter is overridden.
To remove parameters and property sets from an override

1. Open the override’s property editor.
2. Mark the parameter or property set to remove (click its name in the property editor). Shift+click to mark additional items.
3. Click Remove Marked Parameters.

To create an override for specific property sets

Certain property sets are commonly used in overrides, and there are special commands for creating overrides that contains exactly these properties.

1. Select or branch select a model.
2. Choose one of the following commands from the Get > Property > Store in Override submenu of any toolbar:
   - Materials. Creates an override containing the model’s materials.
   - Visibility. Creates an override containing the model’s Visibility property.
   - Geometry Approximation. Creates an override containing the object’s Geometry Approximation property.

To create an override for selected property sets

1. Create an override on a model.
2. Multi-select the override and the property sets you want to add.
3. Choose Get > Property > Store in Override > Selected Properties from any toolbar.
To transfer properties from a model to another version
1. Create an override on a model containing the parameters and property sets you want to transfer.
2. Save a preset of the override if you intend to transfer the properties to a model in another file.
3. Do one of the following:
   - Open a scene containing another version of the same model.
   or
   - Delete the model, and then import another version of it.
   or
   - Import another version of the model into the same scene.
4. Transfer the properties by doing one of the following:
   - Open a browser and drag the saved preset override onto the other version of the model.
   or
   - Drag and drop the override from one model to the other in the explorer. Press Ctrl while dragging to copy the override instead of moving it.

You do not need to transfer properties when you update a referenced model. Any changes you made are automatically reapplied.

To delete an override
- Select the override property and press Delete.

To delete all overrides on an element
- Select the element and choose Get > Property > Delete Override from any toolbar.

If you select a child node, this will also remove any overrides applied in branch mode on its parents. Similarly, if you select a member of a group, layer, or partition, this will remove any overrides on all groups, layers, and partitions to which the object belongs.
Chapter 11  Weight Maps
Weight Maps

Weight maps let you paint parameter values across the surface of an object. For example, you can use weight maps to vary deformations or particle emissions. This chapter describes how to:

- Create weight maps and edit them by painting.
- Use weight maps by connecting them to parameters, as well as mixing multiple weight maps.
- Paint weights symmetrically.
About Weight Maps

Weight maps let you modulate certain parameters across the geometry of an object. You adjust a value at a location on an object using the Paint tool. For example, you can paint weight strokes on an object to vary the strength of a deformation across its surface, almost like sculpting.

What are Weight Maps?

Weight maps are properties of point clusters on geometric objects. Each cluster can have multiple weight maps, so you can modulate different parameters on different operators in different ways.

Weight Map Operator Stack

Each weight map has its own operator stack. When you create a weight map, a WeightMapOp operator sets the base map, which can be constant or one of a variety of gradients. Then when you paint on the weight map, the strokes are added to a WeightPainter operator on top of the WeightMapOp in the stack. Like other elements with operator stacks, you can freeze a weight map to discard its history and simplify your scene data.

What You Can Control With Weight Maps

Only certain parameters can be controlled by weight maps. Parameters that support weight maps have a connection icon to the right of their sliders in their property editors.

Weight maps can be used to control the following:

- Parameters like Amplitude, Displacement, and Strength in many deformation operators. For more information about deformations in general, see Chapter 6: Deformations in the Modeling & Deformations guide.

- Various simulation parameters like Speed, Spread, and others for particles. For more information about using weight maps with simulation parameters, see Chapter 4: Mappable Parameters of the Simulation guide.

- Shapes in the animation mixer. For more information about painting a shape on top of another shape, see Painting Shapes Using Weight Maps in Chapter 4 of the Nonlinear Animation guide.

Weight Map Limitations

Weight maps have certain limitations:

- You cannot apply a weight map on a lattice.

- You can apply a weight map on a curve, but you cannot display it or paint on it. You can only use the constant or gradient base map generated by the WeightMapOp operator.

- Some deformations like Randomize and Curve Deform have multiple parameters with connection icons. However you cannot connect these individually to weight maps. They are either all disconnected or all connected to the same weight map.

- You cannot animate paint strokes.
Weight Map Workflow

This section presents a quick overview of the workflow for using weight maps. The sections that follow later in this chapter will fill in the details.

1. Start with an object.

![Image of a hat with a weight map applied](image)

2. Optionally, select some points or a cluster.

![Image of a selected cluster](image)

3. Apply a weight map using **Get > Property > Weight Map**.

![Image of a blank weight map ready for painting](image)
4. Press \texttt{w} to activate the Paint tool, then use the mouse to paint on the weight map.

![A spot of paint and it's as good as new!]

5. Connect the weight map to drive the value of a parameter—for example in the image below, it is driving the Amplitude of a Push deformation.

![A slight Push is all that's needed.]

6. You can reselect the weight map and continue to paint on it to modify the effect further.
Creating and Editing Weight Maps

This section describes how to create weight maps, display them in the 3D views, select them, paint on them, set various options, and freeze them.

Creating Weight Maps

When you create a weight map, a WeightMapOp operator is applied. This operator creates the base weight map, which can be a constant value or a gradient.

To create a weight map

1. Select the element to which you want to apply a weight map:
   - If you select a cluster, the weight map will be applied to it.
   - If you select an object, a cluster will be created for all the points on the object and the weight map will be applied to the cluster.
   - If you tag (select) points, a cluster will be created and the weight map will be applied to the cluster.

2. Choose Get > Property > Weight Map from the Model toolbar. A weight map is applied and its property editor opens.

   To see your weight map while you are setting options, you can either change your view settings as described in the next section or press w to activate the Paint tool and move the mouse pointer over a 3D view.

3. Set the options you want for your base map on the Weight Map Generator page. For example, if you set the Weight Map Type to Constant and the Base Weight to 0, you start with a blank map for painting weights. You can also choose from a selection of linear and radial gradients, and so on.

   When you create a weight map it is automatically selected, so you can immediately paint on it as described in Painting Weights on page 301 or apply a deformation as described in Deforming with Weight Maps in Chapter 6 of the Modeling & Deformations guide.

Displaying Weight Maps

Weight maps are visible in the 3D views only when certain display options are on. You can set these options manually using the procedure below.

Note that these display options are also temporarily toggled on when the Paint tool is active and you move the mouse pointer over a 3D view. When this happens, the previous display settings are automatically restored when you exit the Paint tool.
Creating and Editing Weight Maps

**To display weight maps in a 3D view**

1. Click on the Display Type menu, and set it to **Constant** or **Shaded**.
   Constant mode shows the weight maps more clearly than Shaded.

2. Click the eye icon on the menu bar to make sure that **Weight Maps** is on.
   If the weight map is on a subdivision surface, also make sure that **Polymesh Hulls** is on and **Subdivision Surfaces** is off. Note that you can press and hold Shift to keep this menu open while toggling multiple items.

**Selecting Weight Maps**

Weight maps are stored under the clusters to which they belong.

**To select a weight map**

1. Select the object.
2. Choose **Explore > Property Maps** from the Select panel. A pop-up explorer opens.
3. Select the desired weight map by clicking on its name.

**Painting Weights**

To paint weights, you first activate the Paint tool. You can then add weight, remove weight, smooth weights, or change the brush radius, opacity, and other brush properties.

**Overview of Painting Weights**

This section provides a quick overview of painting weights on weight maps. Each step is described in more detail in the sections that follow.

1. Select the weight map. If you omit this step, painting is performed on the last active weight map by default.
2. Activate the Paint tool by pressing **w**.
3. If desired, open the Brush Properties editor by pressing Ctrl+w and set the paint mode. The default mode is normal (additive).
4. If desired, adjust the other brush properties:
   - Press **r** to change the brush radius interactively.
   - Press **e** to change the opacity interactively.
   - Set other options in the Brush Properties editor.
5. Click and drag to paint. In normal (additive) paint mode:
   - To add weight, use the left mouse button.
   - To remove weight or paint negative weights, either use the right mouse button or press Shift while using the left mouse button.
   - To smooth weights, press Alt while using the left mouse button.
Activating the Paint Tool

To activate the Paint tool
Do one of the following:

- Press w.

  or

- Choose Get > Property > Paint Tool from any toolbar.

Setting Paint Modes

The mode controls the action that is performed when you click and drag the mouse while the Paint tool is active. The paint mode can be set in the Brush Properties editor.

To set the paint mode

1. Open the Brush Properties editor by doing one of the following:
   - Press Ctrl+w.
   
     or

   - Choose Get > Property > Brush Properties from any toolbar.

2. On the Weight Painting tab, set the Weight Paint Mode:
   - Normal (Add) adds weight with the left mouse button. Use the right mouse button or press Shift with the left mouse button to remove weight. Press Alt to smooth.
   - Set Weight (Abs) sets weight to the current Opacity value.
   - Smooth blends the weight values between nearby points.
   - Reveal scratches away the previous paint operator to reveal the weight “underneath” it.
Setting Brush Properties

You can set the brush radius and opacity interactively while you are painting. In addition, you can set these and other options in the Brush Properties editor.

To change the brush radius interactively

- Do one of the following while the Paint tool is active:
  - Middle-click and drag to the right to increase the radius, or to the left to decrease it. Alternatively if the middle mouse button is a wheel, roll it forward or back.
  - Press r and drag to the left or right.

The current radius size in Softimage units is displayed at the bottom of the 3D view.

To change the opacity interactively

- Press e while dragging back or forth with the left mouse button: a number at the bottom of the 3D view indicates the current opacity setting.

The opacity controls how much weight is added or removed with each stamp of the brush.

To set other brush options

1. Open the Brush Properties editor by doing one of the following:
   - Press Ctrl+w.
   - Choose Get > Property > Brush Properties from any toolbar.

2. Change options as desired. For a complete description of every parameter, refer to Online Help by clicking on the ? in the property editor. In particular:
   - Spacing controls the frequency of the brush stamps in a brush stroke.
   - Surface Coverage controls the degree to which the brush reaches around the sides of a 3D object.
   - The Refresh options determine how the weight map display is refreshed.

   On Mouse Up refreshes only when you release the mouse button to finish a paint stroke; this gives better performance but makes it harder to visualize your stroke.

   Interactive refreshes continuously as you drag, which may slow down your computer.
Tips for Painting Weights

Here are some quick tips to consider when painting weights:

- To paint weights on a subdivision surface created with the geometry approximation method, click the eye icon (Show menu) on a 3D view’s menu bar and make sure that Polymesh Hulls is on.
  
  To see the weight maps on the hull, make sure that Subdivision Surfaces is off.

- When painting, you can increase performance by reducing the object’s geometry approximation settings. The Paint tool uses the triangulation of the object to follow its surface. For more information, see Surface Approximation on page 190.

- You can set the paint mode and certain other brush properties on the weight paint panel. However, the weight paint panel is designed for use with envelope weights and most of its tools are not useful for weight maps.

Setting Weight-Map Properties

You can modify weight-map properties. For example, you can change the name or display color—this is useful if you need to easily distinguish between several weight maps on the same cluster.

To display a Weight Map property editor

1. Select the object.
2. Choose Explore > Property Maps from the Select panel. A pop-up explorer opens.
3. Click on the icon of the weight map.
4. Set the options to change the weight map name or display color.

Freezing Weight Maps

Weight maps can be frozen to simplify your scene’s data. Freezing collapses the weight map generator (the base constant or gradient map you chose when you created the weight map) together with any strokes you have applied.

After you have frozen a weight map, you can still add new strokes but you cannot change the base map or delete any strokes you performed before freezing.

To freeze a weight map

1. Select the weight map.
2. Click the Freeze button on the Edit panel.
Connecting and Mixing Weight Maps

This section describes how to connect and disconnect weight maps and parameters. It also describes how to mix weight maps to obtain an additive blend.

Connecting Parameters to Weight Maps

Any parameter that has a connection icon to the right of its slider can be connected to a weight map. If you have already applied a deformation, you can connect its parameters to weight maps later or connect them to different maps.

To connect a weight map to an operator like a deformation, the weight map must exist before the operator is applied. Connecting to a weight map created later is not allowed because it can cause data evaluation cycles.

For most deformations, there is an easy alternative to the process of manually connecting weight maps: select the weight map first and then apply the deformation.

This automatically connects the weight map to the appropriate parameters. And since the weight map is automatically selected when you first create it, the process is quick and easy. For more information about deformations in general, see Chapter 6: Deformations in the Modeling & Deformations guide.

To connect a weight map manually

1. Open the deformation’s property editor.
2. Click on the connection icon of a parameter. A menu pops up.
4. Navigate through the explorer and pick a weight map. The selected weight map turns purple.
5. Click outside the pop-up explorer to close it.

The connection icon changes to show that a weight map is connected. When a map is connected, you can click on this icon to open the weight map’s property editor.

To disconnect a weight map

1. Open the deformation’s property editor.
2. Right-click on the connection icon of a connected parameter. A menu pops up.
3. Choose Disconnect.
Mixing Weight Maps

You can mix multiple weight maps additively on the same parameter.

To mix weight maps

1. Open the deformation’s property editor.
2. Disconnect any weight maps that are currently connected.
3. Click on the connection icon of a parameter. A menu pops up.
5. Navigate through the explorer and Ctrl+click to toggle-select multiple weight maps. The selected weight maps turn purple.
6. Click outside the pop-up explorer to close it. A new MappingNode weight map is created to hold the result of the blended maps.
7. Use the parameters on the Weight Maps Mixer Op page to control the blend. There are three parameters for each weight map in the blend:
   - Use the Multiplier and Offset parameters to map weight values from [0, 1] to the desired range using the formula $(Multiplier * Weight) + Offset$. For example, to obtain a range of $[-1, 1]$, use a Multiplier of 2 and an Offset of –1.
   - Use the Weight parameter to set the mix weight of the corresponding weight map relative to the others in the blend.
Weight Maps and Symmetry

You can paint weights symmetrically using symmetry maps, an object's local center, or both.

Applying Symmetry Maps

You can apply different symmetry maps on different clusters on your object, allowing you to have different planes of symmetry in different areas.

To apply a symmetry map
1. Select an object, cluster, or points.
2. Choose Get > Property > Symmetry Map from any toolbar. A property editor opens.
3. On the Symmetry Map Generator property page, set the Symmetry Plane to the desired value: YZ (X = 0), XZ (Y = 0), or XY (Z = 0).
   The symmetry map uses the object's local center and the chosen plane to establish a correspondence between points.

Brush Options for Symmetry

To set the brush's symmetry options
1. Open the brush's property editor (press Ctrl+w).
2. Set the options on the Symmetry Options tab:
   - Use Local Object Symmetry Plane uses the object's local center and whichever symmetry plane is currently active to determine symmetry.
     To set the active symmetry plane, right-click on Sym in the Transform panel and choose an option.
   - Use Symmetry Maps uses any symmetry map applied on the object to determine symmetry.
     - If both options are on, symmetry maps take precedence. This allows you to symmetry maps wherever they exist and the object's local symmetry plane wherever there are no clusters with symmetry maps.

Activating Symmetrical Painting

You can activate Sym to paint symmetrically.

To activate or deactivate symmetry
- Click Sym on the Transform panel.

To set the local symmetry plane
Do one of the following:
- Right-click on Sym and choose YZ, XZ, or XY.
  or
- Right-click on Sym and choose Symmetry Properties, then set Symmetry Plane to the desired value in the Symmetry Options property editor.
Chapter 12  Components and Clusters
Components and Clusters

Components are elements, like points and edges, that define the shape of 3D objects, while clusters are named groups of components. This chapter describes:

- The different types of components that are available for various geometry types, and a quick summary of how to display and select them.
- How to create, select, and work with clusters.

Many modeling commands are available on the context menu that appears when you right-click on an object with selected components in the 3D views (Ctrl+Alt+right-click on Linux).
Components

Components are sub-objects like points, polygons, and edges of geometric objects.

Displaying Components

You can display the various component types in a specific 3D view using the individual options available from its eye icon (Show menu) or in all open 3D views using the options on the View menu on the main menu bar.

Alternatively, you can set the visibility options in the Camera Visibility property editor: click a 3D view’s eye icon (Show menu) and choose Visibility Options, or View > Visibility Options for all open 3D views.

Note that when you activate a component selection filter, the corresponding components are automatically displayed in the 3D views.

Selecting Components

You select components using the selection filters, tools, and modes available on the Select panel. The process of selecting components is quickly summarized here—for a complete description of how to select components or anything else, see Selecting on page 209.

The specific mouse buttons and modifier keys that you use to perform different actions—like selecting, adding to the selection, toggling, and deselecting—depend on the selection interaction model.

For more complete details, see Selecting Components Using the Different Interaction Models on page 233.

Summary of selection filters

Component selection filters determine what type of component you can select on the active geometric objects. The most commonly-used filters are available as buttons on the Select panel, while more filters are available from the Filter menu below the buttons.

The component selection filters are context-sensitive; they change depending on what type of object is active.

You can set a 3D view to display tagged (selected) points on unselected objects. See Viewing Selected Components and Clusters on page 239.
Chapter 12 • Components and Clusters

Summary of selection tools

The selection tools determine the mouse interaction used to select objects. You can activate a selection tool with the items on the Select > Tools menu. Alternatively, you can press one of the following keys:

- F7 for the Rectangle selection tool.
- F8 for the Lasso selection tool.
- F9 for the Freeform selection tool.
- F10 for the Raycast selection tool.
- Shift+F10 for the Rectangle-Raycast tool.
- F11 for the Paint selection tool (points, edges, and polygons only).

Summary of selection modes

Selection modes are combinations of a filter and tool mapped to a single key for convenience:

- t for Rectangle Point mode.
- e for Rectangle Edge mode.
- i for Raycast Edge mode.
- y for Rectangle Polygon mode.
- u for Raycast Polygon mode.
- ’ (apostrophe) for Rectangle Tip mode (for hair objects).

Types of Components

Different geometry types have different types of components.

Points

Points are the most fundamental type of component. They are the vertices of polygon meshes as well as the control points of NURBS curves, NURBS surfaces, and lattices. Points are sometimes called control vertices (CVs).

Each point defines a location in space. The collection of points determines the shape of an object.
**Edges**

Edges are components of polygon meshes only. Each edge joins two points and form the border of one or more polygons.

**Polygons**

Not surprisingly, polygons are components of polygon meshes. They are the closed, flat shapes that make up the "tiles" of the mesh and are bounded by edges.

**Knots**

Knots lie on NURBS curves and surfaces. Mathematically every group of four successive control points of a cubic NURBS defines a segment, and the knots are the locations where these segments are joined.
Chapter 12  •  Components and Clusters

**Knot Curves**

Knot curves are components of surfaces. They are a collection of knots with constant U or V; essentially they are the "wires" displayed in wireframe mode.

**Subsurfaces**

Subsurfaces are the individual NURBS surfaces that are components of assembled surface meshes.

**Subcurves**

Subcurves are individual NURBS curves that make up curve objects. While primitive curves like a circle are composed of a single subcurve, text and imported EPS curves may be composed of many subcurves.

**Isopoints**

Isopoints are arbitrary locations on a curve or surface. You can select them for use with certain modeling operations, such as Extract Segment, but you cannot manipulate them directly.

**Curve Boundaries**

Curve Boundaries are the endpoints of curves (U = 0 and U = 1). You can select them for use with certain modeling operations such, as Blend Curves, but you cannot manipulate them directly.
Boundaries

Boundaries are the minimum and maximum U and V knot curves on a surface. Like knot curves, you can select boundaries for use with certain modeling operations such as Loft, but you cannot manipulate them directly.

Surface Curves

Surface Curves are the projections of NURBS curves onto NURBS surfaces. You can select surface curves for use with certain modeling operations such as Loft or Extract Curve, but you cannot manipulate them directly.

Trim Curves

Trim Curves are projected curves that have been used to trim NURBS surfaces. You can select trim curves for use with certain modeling operations, such as Loft or Extract Curve, but you cannot manipulate them directly.

U and V Isolines

U and V Isolines are arbitrary lines of constant V or U, respectively, on a surface. You can select them for use with certain modeling operations such as Loft or Extract Curve, but you cannot manipulate them directly.

Samples

Samples are used to adjust textures on objects. You can select them in the 3D views and manipulate them in the texture editor. For more information, see Chapter 8: The Texture Editor in the Shaders, Lights & Cameras guide.
Clusters

A cluster is a named set of components that are grouped together for a specific modeling, animation, or texturing purpose. By grouping and naming components, it makes it easier to work with those same components again and again. For example, by grouping all points that form an eyebrow, you can easily deform the eyebrow as an object instead of trying to reselect the same points each time you work with it. You can also apply operators like deformations or Cloth to specific clusters instead of an entire object.

You can define as many clusters on an object as you like, and the same component can belong to a number of different clusters.

You can define clusters for points, edges, polygons, subsurfaces, and other components. Each cluster can contain one type of component. For example, a cluster can contain points or polygons, but not both.

Clusters may shift if you edit an operator in an object’s construction history and add components before the position where the cluster was created.

In SOFTIMAGE|3D, objects have a “current” cluster that you can set using the Clusters button on the Info Selection dialog box.

In SOFTIMAGE|XSI, there is no notion of a current cluster—you select or pick the cluster you want directly.
**Viewing Clusters**

You can toggle the display of clusters in the 3D views, change cluster display colors, and display cluster reference frames.

*To display clusters*

You can change how clusters are displayed in each of the 3D views by doing one of the following:

- To quickly toggle the display of clusters on selected objects, click the eye icon (Show menu) on a 3D view's menu bar and choose **Clusters**, or choose **View > Clusters** from the main-menu bar to set all open 3D views.
- For more options, display the Visibility Settings property editor by clicking the eye icon (Show menu) on a 3D view’s menu bar and choosing **Visibility Options**, or by choosing **View > Visibility Options** from the main menu to set all open 3D views. Modify the settings on the Clusters property page.

**Selecting Clusters**

You can select clusters in a 3D view or by using the explorer. Selected clusters are displayed in white by default. The process of selecting clusters is quickly summarized here—for a complete description of how to select clusters or anything else, see Chapter 8: Selecting on page 209.

*To activate cluster selection in the 3D views*

- Do one of the following:
  - With a select tool and component filter active, click the **Cluster** button at the top of the Select panel. Note that the **Cluster** button changes to the **Group** button when an object-type filter is active.
  - With a component filter active, press =.

The specific mouse buttons and modifier keys that you use to perform different actions—like selecting, adding to the selection, toggling, and deselecting—depend on the selection interaction model. For more complete details, see Selecting Components Using the Different Interaction Models on page 233.

*To explore all clusters on the active object*

- Click the **Clusters** button at the bottom of the Select panel. A pop-up explorer opens, showing all clusters on the active objects.

You can use this pop-up explorer to select one or more clusters just as in an explorer window. See Selecting in the Explorer on page 243.
Creating Clusters

In addition to creating a cluster, you can create a cluster constrained to a null (cluster center) or you can create non-overlapping clusters. Non-overlapping clusters are particularly useful when applying local materials and textures to polygons.

Clusters are also created automatically when you apply deformations, apply materials, or perform other operations on selected components.

**To create a cluster**

1. Select some components.
   - If you select different types of components like edges and polygons, a separate cluster will be created for each type.
   - If you select components on different objects, separate clusters will be created per object.
2. Choose Edit > Create Cluster from the Edit panel. A cluster is created and automatically selected.
3. If desired, press Enter to open the cluster's property editor and change the default name. You can also change the default display color for unselected clusters—this is useful if you have many clusters on the same object.

**To create a cluster and a center**

1. Select components on an object.
2. Choose Edit > Create Cluster with Center from the Edit panel. A cluster and a null are created, with a Cluster Center deformation already applied. The null center is automatically selected.
3. Modify and animate the scaling, rotation, and translation of the null to affect the cluster.
   
   For more information about cluster center deformations, see *Cluster Centers* in Chapter 5 of the *Modeling & Deformations* guide.

**To create non-overlapping clusters**

1. Select components on an object.
2. Choose Edit > Create Non-Overlapping Cluster from the Edit panel. A new cluster is created, but any components that are already in a cluster are omitted.
Adding and Removing Components from Clusters

After you have created a cluster, you can still add and remove members.

To add components to clusters
1. Select a cluster.
2. Add one or more components of the same type to the selection.
3. Do one of the following:
   - In the Edit panel, click the + button (next to the Cluster button).
   - Choose Edit > Add to Cluster from the Edit panel.

When you add components to an object, any new components that are completely surrounded by similar components in a cluster are automatically added to the cluster.

However if you manually add components to a cluster after applying a topology operator, any components you subsequently add to the cluster will not be affected by operators previously applied to the cluster.

For example, if you apply a Twist deformation to a point cluster on a surface and then add a knot curve to the surface, any points you add to the cluster will not be affected by the Twist.

To remove components from clusters
1. Select a cluster.
2. Add one or more of the components in the cluster to the selection.
3. Do one of the following:
   - In the Edit panel, click the – button (next to the Cluster button).
   - Choose Edit > Remove from Cluster from the Edit panel.

Changing Cluster Display Colors

By default, components in clusters are displayed in green. If you have many clusters on an object and need to distinguish them easily, you can set their display color.

You can also change the default color for newly created clusters.
For more information, see Setting Scene Colors on page 186.

To change cluster display colors
1. Select a cluster and press Enter. The Cluster property editor opens.
2. Use the sliders to adjust the red, green, and blue components of the cluster’s display color.
Chapter 12 • Components and Clusters

**Cluster Reference Frames**

Like objects, selected components and clusters have a local center. Unlike objects, this reference frame is computed dynamically; it is the average local reference frame of all the selected components. You can display this reference frame as a visual guide, which is useful when setting tangency and normal parameters for object to cluster constraints.

The displayed cluster reference frame is not necessarily the same as the reference frame used for manipulating components in Local mode. The displayed cluster reference frame is a single average, while non-adjacent components use their own reference frames for manipulation.

To enable multiple visual cues when transforming non-adjacent components, turn on **Show Multiple Transform Axes** in your Transform preferences. For more information about transforming components and clusters, see Chapter 5: Manipulating Components in the Modeling & Deformations guide.

**To display or hide cluster reference frames**

1. Do one of the following:
   - For a single 3D view, press Shift+s or click the eye icon (Show menu) and choose **Visibility Options**.
   - Or
   - For all open 3D views, choose **View > Visibility Options (All Cameras)** from the main menu.

   The Camera Visibility property editor opens.

2. On the Attributes tab, change the following options (under Selected Objects):
   - **Cluster Reference Frame** displays an axes indicator for the selected clusters or components.
   - **Cluster Reference Frame Info** displays the XYZ position of the reference frame.

**Local Materials and Polygon Clusters**

When you apply a material or texture to selected polygons or a polygon cluster, XSI creates a local material on the cluster. For more information about local materials and textures in general, see Assigning Materials to Polygon Selections and Polygon Clusters in Chapter 3 of the Shaders, Lights & Cameras guide.
Sharing Local Materials on Polygon Clusters

You can share local materials on polygon clusters in the same way that you share materials on objects: by putting the clusters in a group and applying the material to the group. For more information on groups, see Grouping Objects on page 265.

Viewing Local Material Information

The Spreadsheet includes two predefined queries for getting information about local materials:

- The **Surface Shaders** query shows information about all the surface shaders applied to the selected object, including local materials on polygon clusters.
- The **Surface Shaders (All)** query shows information about the surface shaders applied to all objects in the scene, including local materials on polygon clusters.

For more information about using the Spreadsheet, see *The Spreadsheet* on page 132.

Materials and Overlapping Polygon Clusters

When you apply a material or texture to selected polygons or a polygon cluster, or add polygons to a cluster with a local material or texture, and if some of those polygons already belong to one or more clusters with a local material, then by default you are prompted to specify what you want to happen:

- Remove the overlapping polygons from the selected cluster or polygons.
- Remove the overlapping polygons from the other clusters.
- Let the clusters overlap. Some polygons will have more than one local material, but only the most recently applied material is used.

You can set the default behavior by specifying When Local Materials Overlap under Misc in your Rendering preferences.

Removing Clusters

Removing a cluster removes the group, but does not remove the individual components from the object.

*To remove a cluster*

1. Select a cluster.
2. Click the **Uncluster** button or choose **Edit > Remove Cluster** from the Edit panel.

Alternatively, you can delete a cluster using the explorer view by pressing Delete.
Manipulating Components and Clusters

Not every type of component or cluster can be directly manipulated in XSI.

Transforming Components and Clusters

You can transform points, edges, and polygons in 3D space. This is a fundamental part of modeling an object's shape. For more information, see Chapter 5: Manipulating Components in the Modeling & Deformations guide.

In addition, you can adjust sample texture points in the texture editor. For more information, see Chapter 8: The Texture Editor in the Shaders, Lights & Cameras guide.

Deforming Components and Clusters

You can apply deformations to deform points, edges, and polygons in the same way that you apply them to objects. For more information, see Chapter 6: Deformations in the Modeling & Deformations guide.

Animating Components and Clusters

You cannot animate component and cluster transformations directly. Instead, you can use a deformer such as a cluster center or volume deformer and animate it, or you can use shape animation. For more information, see the Modeling & Deformations guide or Chapter 4: Shape Animation in the Nonlinear Animation guide.
Chapter 13  

Hierarchies
What Are Hierarchies?

Hierarchies describe the relationship between objects, usually using a combination of parent-child and tree analogies, as you do with a family tree. Objects can be associated to each other in a hierarchy for a number of reasons, such as to make manipulation easier, to propagate applied properties, or to animate children in relation to a parent. For example, the parent-child relationship means that any properties applied to the parent (in branch mode) also affect the child.

In a hierarchy there is a parent, its children, its grandchildren, and so on. The combination of links that can be created is almost infinite.

• A root is a node at the base of either a branch or the entire tree.
• A tree is the whole hierarchy of nodes stemming from a common root.
• A branch is a subtree consisting of a node and all its descendants.
• Nodes with the same parent are called siblings.

For information about hierarchies and transformations, see Transformations and Hierarchies on page 401

For more information on hierarchies specific to skeletons, see Chapter 2: Building Skeletons in the Character Animation guide.

Parent-child links act like constraints in many ways. If you want to have objects move together without them being in a hierarchy, you can use constraints. For more information, see Chapter 8: Animating with Constraints in the Animation guide.
Creating Hierarchies

When creating a hierarchy, you should first analyze how you want the properties in the hierarchy arranged so that you can parent the objects appropriately.

You can pick a parent from different elements to create a hierarchy. In a hierarchical structure, properties are propagated from a parent to a child.

To cut the links in a hierarchy, see page 329. To reorder the children of a parent, use the schematic view as described in Reordering Child Nodes in the Schematic on page 131.

To create a hierarchy with the parent first
You can create a hierarchy by having either the proposed children or parent objects selected first, but sometimes it’s easier to have the parent object selected first.

1. Select the object you wish to be the parent.
2. Click the Parent button in the Constrain panel or press the / key.
3. Pick each of the children with the left mouse button.
4. Right-click or press the Esc key to end the parenting mode.

To create a hierarchy with the children first
1. Select the objects you wish to be the children.
2. Click the Parent button in the Constrain panel or press the / key.
3. Middle-click to pick the parent object.
4. Right-click or press the Esc key to end the parenting mode.

To create a hierarchy in the explorer

- Drag and drop the child node onto the node that you want to be the parent. If multiple nodes were selected first, they all become children of the new parent.

To create a hierarchy in the schematic view

- Press Alt while dragging and dropping a node onto a new parent.
Chapter 13 • Hierarchies

**Selecting Objects in a Hierarchy**

When objects are in a hierarchical relationship, you can use the different mouse buttons to select a single object in a hierarchy, a branch of the hierarchy, or an entire tree. In addition, the Select menu in the Select panel contains commands that let you select different members of a hierarchy in different ways.

Selecting objects in a hierarchy is different from selecting multiple individual objects because it respects the hierarchical relationships you created between objects in your scene.

The type of selection matters for propagation and transformation. For example, when you branch-select the parent and translate it, all elements in the tree move; however, if you node-select that parent and translate it, the children do not move unless their local position parameters are animated. This is because local transformations are stored relative to the parent’s center. You can make unanimated children follow the parent with the Constrain > Child Transform Compensation option. For more information on this, see Transformations and Hierarchies on page 401.

For more information in general about hierarchies and selecting, see Selection and Hierarchies on page 214.

To delete the root of a hierarchy, you must either cut its children first or branch-select it and press Delete. If you node-select the root and delete it, it gets replaced by a stand-in null.

**To select objects in a hierarchy**

1. Make sure you are in selection mode by clicking the Select icon or pressing the space bar.

2. Click on any object in the scene hierarchy as follows:

   - **Node selection:** Left-click to select an object at the node level. Only that object is selected, not the rest of the branch.
     
     or
     
     Select the parent object, then choose Select > Select Child Node from the Select panel.

   - **Branch selection:** Middle-click on any object to select the whole branch—the object as well as its descendants. (If you middle-click on a node with no children, only the node is selected.)
     
     or
     
     Select the parent object, then choose Select > Select Branch from the Select panel.

When a branch is selected, the branch root is highlighted in white and the children are highlighted in gray.
- **Tree selection:** In a 3D view, right-click on any object in the hierarchy to select the entire tree that it belongs to.

  or

In a schematic view or the explorer, right-click on any object in the hierarchy and choose **Select Tree.**

![Right-click any object to select its tree (branch-select the root).](image)

or

In any view, select any object in the tree and choose **Select > Select Tree** from the Select panel or press Ctrl+t.

When you select tree-select a node inside a model, the model root is not selected. However, you can branch-select the entire model by pressing Ctrl+Shift+t or choosing **Select > Select Model.**

Note that right-clicking on a kinematic chain element always branch-selects the corresponding chain root even if the chain is part of a larger tree. If you want to select the whole tree, you can then press Ctrl+t or choose **Select > Select Tree.**
Navigating in Hierarchies

You can use the Alt key plus your keyboard arrow keys to move up and down hierarchies in all views:

- Alt+up arrow goes to the parent.
- Alt+down arrow goes to the first child.
- Alt+left arrow goes to the previous sibling.
- Alt+right arrow goes to the next sibling.

Holding the Shift or Ctrl keys while using any of the above keys will add to the selection:

- Holding Shift adds to the selection.
- Holding Ctrl selects a branch.
- Holding Shift+Ctrl adds a sibling’s branch to the selection.

You can also use the hierarchy navigation buttons on the Select panel:

Selects the current object’s parent.

Selects the previous sibling.

Selects the next sibling.

For more information on navigating hierarchies in the explorer, refer to Viewing the Element Tree on page 111.
Cutting Links in a Hierarchy

You will often need to cut the hierarchical links between a parent and its child or children in a hierarchy of objects. If the child is also a parent, the links to its own children are not affected.

A cut object becomes a child of its model. If an object is cut from its model, it becomes a child of the parent model.

To cut an object from its parent
1. Select the object you want to detach from its parent.
2. Do one of the following:
   - Click the Cut button in the Constrain panel.
     or
   - Press Ctrl+/
     or
   - In the explorer, drag and drop the child to another node.
Chapter 13 • Hierarchies
Layers

A large and complex scene can significantly slow down the refresh rate and clutter the display with many objects. Creating scene layers is useful when you wish to concentrate on only a few objects in a crowded scene or to save time refreshing the display when applying rendering options and effects.

Layers help you organize, view, and edit the contents in your scene, but they do not affect the final render (unless you want them to) because they are not associated with render passes. You can put different objects into each layer and you can hide a particular layer if you don’t want to see that part of your scene. You can also make a layer’s objects unselectable. Layer definitions are saved with the scene file.

Layer Attributes

Each layer has four main attributes: viewport visibility, rendering visibility, selectability, and animation ghosting. You can enable or disable each these attributes for every layer in the scene.

Viewport Visibility

Viewport visibility determines whether a layer is visible in the viewports or not. An object in a layer whose viewport visibility is disabled is neither visible nor selectable in the viewports, but you can still select it from the explorer.

Objects in layers that are not viewport-visible will still render if the layer’s rendering visibility is enabled.

Rendering Visibility

Rendering visibility determines whether a layer is rendered or not. Objects are not rendered if they are in a layer whose rendering visibility is disabled.

In the viewports, you can still see and select objects in render-invisible layers if their viewport visibility and selectability are enabled.

Render visibility applies to both the render region and the final render.

Selectability

Selectability determines whether a layer can be selected in the viewports. None of the objects in a layer are selectable in the viewports if the layer’s selectability is disabled. They are, however, selectable from the explorer.
Ghosting

Ghosting determines whether animated objects in a layer are ghosted or not. Animation ghosting, also known as onion-skinning, is a viewing mode that lets you display a series of snapshots of animated objects at frames or keyframes behind and/or ahead of the current frame. This lets you easily visualize the motion of an object, which can help you improve its timing and flow.

For more information about ghosting, see Chapter 2: Basic Animation Tasks in the Animation guide.

The Default Layer

Every new scene contains a single layer named Layer_Default. This layer is set to display every object in your scene. It is also the current layer for the scene. You cannot delete the default layer until you’ve created at least one other layer. If you delete the default layer, the least recently created (oldest) layer in the scene becomes the new default layer. Objects from the deleted default layer are moved into the new default layer.
Chapter 14 • Layers

Accessing Layers

There are several ways to control layers, some more flexible than others. You can control layers from the explorer, the Layers panel, the Layers menu, and the Layer Control.

Accessing Layers from the Explorer

Layers are displayed in the explorer as subnodes under the project. The Layers node is a container for all the layers defined for the scene. To see layers in the explorer, select Layers from the scope menu.

Accessing Layers from the Layers Panel

You can choose additional layer options from the Layers menu in the Layers panel. The panel gives you access to the Layers menu, as well as a list box that displays and sets the current layer.

To open the Layers menu from the Layers panel

• Click on the word Layers.

The Layers menu in the main menu bar is identical to the Layers menu in the Layers panel.
Accessing Layers from the Layer Control

The Layer Control property page provides a single, convenient location in which to set layer visibility, object selectability and animation ghosting for one or more layers. The Layer Control shows a grid which lists your layers, and indicates whether their objects are visible in the viewports, visible when rendering, or selectable.

To display the Layer Control

- Choose Layers > Layer Control or press 6.
Working with Layers

Working with layers is straightforward—you can create and delete layers, set the current layer, add objects to layers, and perform other tasks from the various layer controls.

Creating a Scene Layer

There are a couple of ways to create a new layer. By default, new layers are set as visible and selectable.

To create a new layer

Do one of the following:

- Choose Layers > New Layer from the main menu bar.
- Choose Layers > New Layer in the Layers panel.
- Open an explorer, set the scope to Layers, and expand the List node (right below the Layers node). Right-click any of the listed layers and choose New Layer from the menu.

Setting the Current Layer

Before you add objects to a layer, you must specify it as the current layer. The current layer is the layer to which all layer operations are applied. When you create new objects, they are automatically assigned to the current layer.

When you select a layer, its name appears in the Current Layer display box in the Layers panel.

When you import a scene into XSI, it contains a single layer named Layer_Default. This layer is set to display every object in your scene. It is also the current layer for the scene.

To set the current layer

- Click the arrow button next to the Current Layer text box to display the drop-down list.

  The list contains all available layers defined for the scene. Choose the layer you want to set as current.

- Open the Layer Control (press 6). Right-click the row heading cell to the left of a layer’s Name and choose Set as Current Layer.
• Open an explorer, set the scope to Layers, and expand the List node (right below the Layers node). Right-click any of the listed layers and choose Set as Current Layer.

Moving Objects to a Layer

You can move objects from one layer to another using the Layers menu or an explorer.

Each object in your scene can belong to only one layer at a time. It is possible for different objects within a given hierarchy or group to be assigned to different layers.

To move objects to a layer using the Layers menu
1. Click the arrow button next to the Current Layer text box and choose the layer you want to set as current. This is the layer to which you want to add objects.
2. In the viewport, select the objects that you want to move to the current layer.
3. Do one of the following:
   - Choose Layers > Move Selection to Current Layer from the main menu bar. The selected objects are assigned to the current layer.
   or
   - Choose Layers > Move Selection to Current Layer in the Layers panel.

To move objects to a layer using the explorer
1. In an explorer, select Layers from the scope menu.
2. Expand the List folder to display all of the layers in the scene.
3. Expand the layer that contains the objects to be moved.
4. Select the objects that you want to move and drag+drop them on a new layer.

Setting Layer Attributes

While you’re working, you can set and change all of a layer’s attributes. For example, you can choose which layers you want to view while working. Or, if your workspace is cluttered, you can make some layers unselectable to avoid unwanted selections.

To enable or disable attributes for one layer
1. Click the arrow button next to the Layer Control text box and choose the layer you want to set as current. This is the layer whose attributes you want to set.
2. Do one of the following:

- Choose an attribute (Viewport Visibility, Rendering Visibility, Selectability, or Ghosting) from the Layers menu in the main menu bar or from the Layers menu in the Layers Panel.

  or

- Press 6 to open the Layer Control. All of the layers and their attributes are listed in a grid. Click a cell to enable or disable a particular attribute for a layer. A checkmark indicates that the attribute is selected.

**To enable or disable an attribute for all layers**

1. Press 6 to open the Layer Control.

2. Right-click the column heading of the attribute that you want to enable or disable.

3. Do one of the following:

- To enable the attribute for every layer, choose Check All from the pop-up menu.

  or

- To disable the attribute for every layer, choose Uncheck All from the pop-up menu.

**Using the Layer Property Editor**

You can use the Layer property editor to set each layer’s attributes. This is especially useful when, for example, you want one or more of the layer’s settings not to override its member objects’ local settings.

**To set attributes for a layer using the layer property editor**

1. In an explorer, select Layers from the scope menu.

2. Expand the List folder to display all of the layers in the scene.
3. Right-click the layer whose attributes you want to edit and choose **Properties**. The Layer property editor is displayed.

![Layer property editor](image)

4. Set the View Visibility and/or Render Visibility attributes to one of the following:
   - **Hide members**: objects are not displayed. The layer’s setting overrides the View Visibility settings in the objects’ individual Visibility properties.
   - **Show members**: objects are displayed. The layer’s setting overrides the View Visibility settings in the objects’ individual Visibility properties.
   - **No effect on members**: objects are displayed or not displayed according to the View Visibility settings in their individual Visibility properties. The layer’s setting does not override the visibility of members.

5. Set the Selectability attributes to one of the following:
   - **Do not allow selecting members**: objects are not selectable. The layer’s setting overrides the Selectability settings in the objects’ individual Visibility properties.
   - **Allow selecting members**: objects are selectable. The layer’s setting overrides the Selectability settings in the objects’ individual Visibility properties.
   - **No effect on members**: objects are selectable or not selectable according to the Selectability settings in their individual Visibility properties. The layer’s setting does not override the selectability of members.

6. Set the Animation Ghosting attributes to one of the following:
   - **Do not ghost members** prevents ghosting for the animated objects. This overrides the Animation Ghosting settings in the members’ individual Visibility properties.
   - **Ghost members** displays ghosts for the animated objects. This overrides the Animation Ghosting settings in the members’ individual Visibility properties.
- **No effect on members**: members are ghosted or not according to the Animation Ghosting settings in their individual Visibility properties. This does not override the members’ Visibility properties.

### Selecting Layers

You can select an entire layer, whether it is the current layer or not. When you select a layer, all of its members are branch-selected as well.

**To select a layer using the layer control**

1. Open the Layer Control (press 6).
2. Click the row heading cell to the left of a layer’s name.

### Selecting the Objects in a Layer

You can select all of the objects in any layer, whether it is the current layer or not.

**To select all of the objects in a layer**

1. Open the Layer Control (press 6).
2. Right-click the row heading cell to the left of a layer’s name and choose Select All Objects.
Deleting a Layer

When the current layer is deleted, the preceding layer in the list becomes the new current layer. Objects in the deleted layer are moved to the default layer (see page 333).

- You cannot delete a layer when it’s the only one in the scene.
- If you delete the default layer, the least recently created (oldest) layer in the scene becomes the new default layer. Objects from the deleted default layer are moved into the new default layer.

To delete a scene layer from the Layers menu
1. Set the layer that you want to delete as the current layer.
2. Choose Layers > Delete Current Layer from the main menu bar or from the Layers panel.
   The current layer is deleted and the objects it contained are automatically reassigned to Layer_Default.

To delete a scene layer from the explorer
1. In an explorer, select Layers from the scope menu.
2. Expand the List folder to display all of the layers in the scene.
3. Click any layer to select it, and press Delete.
Section III • Working in 3D Space
Chapter 15  

Coordinate Systems
Coordinate Systems

This chapter provides some background for those who are not familiar with 3D modelling. In particular, it introduces the notion of coordinate systems. Coordinate systems allow any point in three-dimensional space to be represented by a triplet of numbers (X, Y, Z).

**Cartesian Coordinates**

One essential concept that a first-time user of 3D computer graphics should understand is the notion of working within a virtual three-dimensional space using a two-dimensional user interface.

To represent pictorial reality, 3D computer software uses the classical Euclidean/Cartesian mathematical representation of space. To represent the geometry of an object, the software uses the Cartesian coordinate system based on three perpendicular axes, X, Y, and Z, intersecting at one point. This reference point is called the *origin*. You can find it by looking at the center of the grid in any of the 3D windows.

**XYZ Axes**

To remember the direction of the X, Y, Z axes, use the “right-hand” rule: hold up your right hand so that your palm is facing you, then extend your thumb to the right, hold your index finger up, and point your middle finger towards you. Your thumb is pointing in positive X, your index finger in positive Y, and your middle finger in positive Z. The opposite directions represent negative X, Y, and Z.

A small icon representing the three axes and their directions is shown in the corner of 3D view. The icon’s three axes are represented by color-coded vectors: red for X, green for Y, and blue for Z.

An easy way to remember the color coding is RGB = XYZ. This mnemonic is repeated throughout XSI: object centers, visual cues for transformations, axis controls on the Transform panel, and so on.

**XYZ Coordinates**

With the Cartesian coordinate system, you can locate any point in space using three coordinates. Positions are measured from a point called the *origin*, which is (0, 0, 0). For example, if X = +2, Y = +1, Z = +3, a point would be located to the right of, above, and in front of the origin.
**XZ, XY, YZ Planes**

Since you are working with a two-dimensional interface, spatial planes are used to locate points in three-dimensional space.

The perpendicular axes extend as spatial planes: XZ, XY, and YZ. In the 3D views, these planes correspond to three of the parallel projection windows: Top, Front, and Right.

Imagine that the XZ, XY, and YZ planes are folded together like the top, front, and right side of a box.

This helps you keep a sense of orientation when you are working within the parallel projection windows.
Global and Local Coordinate Systems

The location of an object in 3D space is defined by a point called its center. This location can be described in more than one way or according to more than one frame of reference. For example, the global position is expressed in relation to the scene’s origin. The local position is expressed in terms of the center of the object’s parent.

The center of an object is only a reference—it is not necessarily in the middle of the object because it can be relocated (as well as rotated and scaled). The position, orientation, and scaling (collectively known as the pose) of the object’s center defines the frame of reference for the local poses of its own children.
Softimage Units

Throughout XSI, lengths are measured in Softimage units. How big is a Softimage unit? It is an arbitrary, relative value that can be anything you want: a foot, 10 cm, or anything else.

However, it is generally recommended that you avoid making your objects too big, too small, or too far from the scene origin. This is because rounding errors can accumulate in mathematical calculations, resulting in imprecisions or even jittering in object positions.

As a general rule of thumb, an entire character should not fit within 1 or 2 units, nor exceed 1000 units.

The Softimage units used for objects also matters for creating dynamic simulations where objects have mass or density and are affected by forces such as gravity. For more information, see Size Does Matter in Chapter 15 in the Simulation guide.

SOFTIMAGE|XSI has more precision than SOFTIMAGE|3D. You should expect few, if any, problems with inaccuracy and jittering unless your objects are unreasonably small, large, or far away from the scene origin.
Chapter 15  •  Coordinate Systems
Transformations

Transformations are fundamental to 3D. They include the basic operations of scaling, rotating, and translating. This chapter describes the details of transforming objects, including:

- Translating, rotating, and scaling objects in various manipulation modes.
- Using 3D manipulators to transform objects.
- Manipulating object centers.
- Setting the pivot for animated scaling and rotation.
- Freezing and resetting transformations.
- Matching and aligning transformations.
- Setting up preferred transformations for individual objects.
- Propagating transformations in hierarchies.
- Calculating velocity and acceleration.

For information about transforming components like point, edges, and polygons, see Chapter 5: Manipulating Components in the Modeling & Deformations guide.
Transformations include three basic types of operations that manipulate an element in 3D space: scaling affects an element’s size, rotation affects an element’s orientation, and translation affects an element’s position. Transformations are sometimes called SRTs.

**Local versus Global Transformations**

There are two types of transformation values: local and global. Local transformations are stored relative to an object’s parent, while global ones are stored relative to the origin of the scene’s global coordinate system. The global transformation values are the final result of all the local transformations that are propagated down the object hierarchy from parent to child.

You can animate either the local or the global transformation values. It’s usually better to animate the local transformations—this lets you branch-select an object’s parent and move it while all objects in the hierarchy keep their relative positions.

When you activate the Scale, Rotate, or Translate tools, the corresponding local transformation parameters are automatically marked for animation. However, the **Transform > Automark Global Transform** preference allows you to automatically mark the global parameters when the manipulation mode is Global.

If you animate both the local and the global transformations, the global animation takes precedence.

For more information in general about animation and transformations, see Animating Transformations in Chapter 2 of the Animation guide.

**Manipulation Modes**

When you transform interactively, you always do so using one of several modes. The mode determines which coordinate system is used for manipulation.

It is important to realize that the manipulation mode affects the interaction only. For example, if you translate an object along only the X axis in Ref mode, the object may be moving along the X, Y, and Z axes in both the local and global reference frames. In particular, Local and Global manipulation modes control which axes are used for mouse movement and not whether the animated values are local or global.

The Translate, Rotate, and Scale tools each have different manipulation modes. See Translation Modes on page 368, Rotation Modes on page 373, and Scaling Modes on page 379.
Chapter 16 • Transformations

Manipulation Methods

There are two main ways to transform objects interactively when a transformation tool is active in the 3D views:

- If you are using the SRT manipulators, click and drag on different parts of the displayed transformation axes to transform an object in different ways. For more information about the SRT manipulators, see Transforming Interactively with the SRT Manipulators on page 362.

- If you are not using the SRT manipulators, click and drag anywhere in the 3D views. Use the different mouse buttons to transform an object in different ways. The specific effect of each mouse button depends on the manipulation mode—check the mouse/status line at the bottom of the XSI window for details.

Using the SRT manipulators or not is a matter of personal preference. You can turn them on or off using Transform > Enable Transform Manipulators.

A third way to transform objects interactively is to use the bounding-box manipulator—see Transforming with the Bounding-Box Manipulator on page 385.

You can also transform objects non-interactively by setting numerical values—see Setting Values Numerically on page 365.

Hierarchies

Transformations are propagated down hierarchies from parent to child. Objects in hierarchies behave differently when they transformed, depending on whether the objects are node-selected or branch-selected. See Transformations and Hierarchies on page 401.

Centers

All geometric objects have a center. The center defines the object’s position in space. The object’s points are stored as offsets from the center, and the local transformations of a child are relative to the parent’s center.

You can display centers in a specific 3D view, or in all open 3D views at once. In addition, centers are automatically displayed when you transform centers as described in Center Manipulation on page 387. Centers are displayed as a set of axis indicators with a white circle at the origin.

To show or hide centers of selected objects in a 3D view

- Click the eye icon (Show menu) on a 3D view and turn Centers on or off.

To show or hide centers of selected objects in all open 3D views

- Choose View > Centers from the main menu.

To show or hide centers for selected and/or unselected objects in a specific 3D view

1. Open the view’s Camera Visibility property editor by doing one of the following:
   - Press Shift+s while the mouse pointer is over the view.
or

- Choose **Visibility Options** from the view’s Show menu (eye icon).

2. On the Transforms tab, check or uncheck the **Centers** options. The option on the left controls selected objects and the option on the right controls unselected objects.

### Useful Tools for Transformation

Useful tools for transformations in XSI include the Transform panel, the Kinematics property editor, and the snapping feature.

**Transform Panel**

The Transform panel is located in the middle of the main command area on the right of the main window.

Most of these options are described in this chapter, with a couple of exceptions:

- The **Prop** option at the bottom of the panel activates proportional modeling for points and is discussed in more detail in *Using Proportional Modeling* in Chapter 5 of the *Modeling & Deformations* guide.

- The **Sym** option activates symmetrical manipulation for several different features. See *Weight Maps and Symmetry* on page 307, *Manipulating Components Symmetrically* in Chapter 5 and *Drawing Curves Symmetrically* in Chapter 11 of the *Modeling & Deformations* guide, as well as *Creating Chains* in Chapter 2 of the *Character Animation* guide.
Kinematics Property Editor

Each object has a set of transformation controls found in its Kinematics property editor. The Kinematics property editor shows both the Local and Global Transform properties, and can be used to modify an object’s scaling, rotation, and translation in X, Y, and Z, as well as other options. You can also quickly open an object’s Local Transform property editor by itself.

To open the Kinematics property editor

Do one of the following:

- Click an object’s Kinematics node in an explorer.
  or
- Select an object, then right-click on the Selection button on the Select panel and choose **Kinematics**.
  or
- Select an object and then choose **Transform > Kinematics**.
  or
- Select an object and then choose **Edit > Properties > Kinematics**.
  or
- Right-click on any object in the explorer or schematic view and choose **Kinematics**.
  or
- Alt+right-click on any object in a 3D view (Ctrl+Alt+right-click on Linux) and choose **Kinematics**.
To quickly open the Local Transform property editor

- Select an object and press Ctrl+k.

**Snapping**

Snapping lets you position objects interactively with precision. The snapping feature of XSI is described in *Chapter 18: Snapping* on page 417.

**Transformation Preferences**

There are several preferences that affect the display, interaction, and other options of the transformation tools.

*To display the Transform preferences*

- Choose **Transform > Transform Preferences** from the Transform panel.

  For information about all the available options, click ? to open the online help.
Transformation Basics

This section provides some basic information that is common to all transformation tools. More details about each specific type of transformation is provided in the sections that follow.

Transforming Interactively

The Scale, Rotate, and Translate tools let you transform objects interactively using the mouse in the 3D views.

To transform objects interactively

1. Select the objects to transform, and activate a transformation tool:
   - To translate, press v or click the t button on the Transform panel.
     or
   - To rotate, press c or click the r button on the Transform panel.
     or
   - To scale, press x or click the s button on the Transform panel.

   The corresponding local transformation parameters are automatically marked for animation.

2. If necessary, change the manipulation mode. Each tool remembers the last mode used. For a description of each mode, see Translation Modes on page 368, Rotation Modes on page 373, and Scaling Modes on page 379.

3. If desired, you can restrict the interaction to specific axes. See Specifying Axes on page 359.

4. If desired, you can set the manipulation pivot. The pivot defines the position around which elements are rotated or scaled. When translating with snapping, the pivot is the position that snaps to the target. See Setting the Manipulation Pivot on page 360.

5. Manipulate the objects using the mouse in the 3D views:
   - If you are using the SRT manipulators, click and drag on different parts (handles) of the displayed transformation axes to transform the objects in different ways.

   For general information about the SRT manipulators, see Transforming Interactively with the SRT Manipulators on page 362.

   For specific information about each manipulator, such as the handles used by different tools, see Using the Translate Manipulator on page 370, Using the Rotate Manipulator on page 374, or Using the Scale Manipulator on page 380.
If you are not using the SRT manipulators, click and drag the mouse anywhere in the 3D views. The function of the left, middle, and right mouse buttons depends on the tool, mode, and other options—check the mouse/status line at the bottom of the main window for details. You can also drag while pressing multiple mouse buttons simultaneously.

You can change manipulation modes even while you work with a transformation tool in supra mode. Simply keep the key pressed while clicking buttons on the Transform panel.

### Specifying Axes

When transforming interactively, you can specify which axes are active using the x, y, and z icons in the Transform panel. For example, you can activate rotation in Y only, or deactivate translation only in Z. Active icons are colored, and inactive icons are gray.

- Click an axis icon to activate it and deactivate the others.
- Shift+click an axis icon to activate it without affecting the others.
- Ctrl+click an axis icon to toggle it.
- Click the All Axes icon to activate all three axes.
- Ctrl+click the All Axes icon to toggle all three axes.

If **Allow Double-click to Toggle Active Axes** is on in the Transform preferences, then you can also specify transformation axes by double-clicking in the 3D views while a transformation tool is active:

- If you are using the SRT manipulators:
  - Double-click on a single axis to activate it and deactivate the others.
  - If only one axis is currently active, double-click on it to activate all three axes.
  - Shift+double-click on an axis to toggle it on or off individually. (If it is the only active axis, it will be deactivated and both of the other two axes will be activated).
- If you are not using the SRT manipulators:
  - Double-click a mouse button to activate a single axis and deactivate the others: use the left mouse button for the X axis, the middle mouse button for the Y axis, and the right mouse button for the Z axis.
  - Double-click a different mouse button to activate only the corresponding axis.
  - Double-click the same mouse button to reactivate all three mouse buttons.
By default, the marked parameters do not change when you specify axes (except in Par mode for translations and Add mode for rotations). For example, if you activate only the X axis while translating, the posx, posy, and posz parameters all remain marked for animation. This is because the active axes affect interaction only. For example, if you interactively translate along X in Local mode, the object’s local Y and Z parameters may change if its orientation is different from its parent. In such a case, if you set a keyframe for only the local posx parameter, then you may get unexpected results when you play back the animation. However for translations in Par mode and rotations in Add mode, the axes of interaction correspond exactly to the local values stored for animation.

If desired, you can force the marked parameters to reflect the active axes in all manipulation modes by turning Transform > Automark Active Transform Axes on—but remember that the reference frame for interactive manipulation does not correspond to the reference frame used for storing local animation unless you are translating in Par mode or rotating in Add mode.

**Setting the Manipulation Pivot**

When transforming elements interactively, you can set the pivot used for manipulation using the Alt key. The pivot defines the position around which elements are rotated or scaled. When translating with snapping, the pivot is the position that snaps to the target.

The same pivot is used for all selected elements. The pivot is normally reset when you change the selection. However, you can lock and reset the pivot position manually.

- On Linux, Alt+click may not work if that combination is used by your window manager for another purpose. In these cases, you can modify your window manager to use a different combination. For more information, see the documentation for your window manager.

- The pivot set with the Alt key is used for interactive manipulation, not animation. When you move the pivot from its default location and then scale or rotate objects, the position values change as well.

If you want to change the pivot used for animated rotation and scaling, set the center pivot values in the object’s Local Transform property editor. This method also allows you to animate the pivot as well. For more information about the center pivot, see Setting the Center Pivot on page 388.
To set the manipulation pivot

- With a transformation tool active, do one of the following:
  - Alt+click in a 3D view. The pivot snaps to the closest point, edge midpoint, polygon midpoint or object center among the selected objects.

  If Ref or Plane manipulation mode is active, the current reference plane is automatically updated. For information about reference planes, see Chapter 17: Reference Planes on page 405.

  or

  - Alt+middle-click to place the pivot freely in the view plane of a 3D view. You can drag the mouse before releasing the middle mouse button to adjust the pivot’s location.

  You can also activate snapping to snap the pivot to any available target type. For more information, see Chapter 18: Snapping on page 417.

To lock the manipulation pivot

1. With a transformation tool active, press and hold Alt. The pivot’s icon appears.
2. Click on the triangle below the pivot’s icon.
3. In the menu that opens, choose Lock.

   The pivot remains at its current location until you reset it, even if you change the selection or activate another tool.

To reset the manipulation pivot

1. With a transformation tool active, press and hold Alt. The pivot’s icon appears.
2. Click on the triangle below the pivot’s icon.
3. In the menu that opens, choose Reset.

   The pivot returns to the default location for the current manipulation mode.
Transforming Interactively with the SRT Manipulators

The SRT manipulators let you transform elements interactively by clicking and dragging on different parts (handles) of the displayed transformation axes. You can also use gestural manipulation or choose the behavior when clicking outside of a manipulator.

The SRT manipulators do not work well in the Object view unless you deactivate View > Camera Compensation.

**To enable or disable the SRT manipulators**

- Do one of the following:
  - Choose Transform > Enable Transform Manipulators.
  
  or
  
  - Open the Transform preferences by choosing Transform > Transform Preferences, and then toggle Use 3D Manipulators on the Transform tab.

**To use the manipulator handles directly**

1. Move the mouse pointer over the manipulator handle you want. Different tools have different handles:
   - For a description of the Translate manipulator handles, see Using the Translate Manipulator on page 370.
   - For a description of the Rotate manipulator handles, see Using the Rotate Manipulator on page 374.
   - For a description of the Scale manipulator handles, see Using the Scale Manipulator on page 380.

   The pointer updates to reflect the axes or plane of manipulation.

2. Click and drag.

**To use gestural manipulation**

- Middle-click and drag anywhere in a 3D view.

   The axis that most closely matches the mouse movement over the first few pixels is used for the transformation.

Gestural manipulation works only if Click Outside Manipulator is set to No Interaction or Simple Transform in the Transform preferences. See the next section, To choose the behavior when clicking outside of the manipulators, for more information about these options.
To choose the behavior when clicking outside of the manipulators

You can choose how the transform tools behave when you click outside of the manipulators.

1. Open the Transform preferences by choosing Transform > Transform preferences.
2. On the Transform tab, set Click Outside Manipulator to one of the following options:
   - **No Interaction**: There is no effect when you click outside the manipulator.
   - **Select Tool**: Clicking outside the manipulator performs a selection using the current selection filter and the last-used selection tool.
   - **Simple Transform**: Clicking outside the manipulator performs a transformation using a default manipulation mode: View for the Translate and Rotate tools, or Uni for the Scale tool.
   - **SI3D-style Transform**: Clicking outside the manipulator performs a transformation as if Enable Transform Manipulators is off. The left, middle, and right mouse buttons transform the selected elements differently, depending on the current manipulation mode set on the Transform panel.

To change options

When an SRT manipulator is active, you can open a context menu by right-clicking on the manipulator in a 3D view. This lets you change the manipulation mode and set other options without moving the mouse pointer over to the Transform panel.

Transforming interactively without the SRT Manipulators

When you are transforming objects interactively without using the SRT manipulators (that is, when Transform > Enable Transform Manipulators is off), the different mouse buttons manipulate the object in different ways. The exact way depends on the manipulation mode, as well as other options, but you can always look at the mouse/status line at the bottom of the XSI window to see what each button will do. Usually, the different mouse buttons transform the object along different axes or planes, but if a single axis is active they transform at a slow, medium, or fast rate.
Setting the Interaction Speed

You can set the relative speed of the interactive Scale, Rotate, and Translate tools. For example, you can slow down the interaction for precise, detailed work.

To set the interaction speed

1. Choose Transform > Transform Preferences from the Transform panel.
2. On the Transform tab of the Transform preferences, set the SRT Increments. Values are relative.
   - The Scale, Rotate, and Translate values are used with the SRT manipulators, as well as when multiple axes are active when you are not using the SRT manipulators.
   - The Slow, Medium, and Fast values are used by the left, middle, and right mouse buttons when a single axis is active and you are not using the SRT manipulators.

Transformation Axes

When you select a transformation tool for a selected object or component, XSI displays an icon corresponding to the transformation axes at the active pivot position.

- If you are using the SRT manipulators, you can click and drag on different parts of these icons to manipulate the object.
- If you are not using the SRT manipulators, these icons are simply visual cues that indicate the X, Y, and Z axes as defined by the current transformation mode.
As an alternative to transforming objects interactively, you can enter numerical values in the boxes on the Transform panel:

- In Global mode, values are relative to the scene origin.
- In Ref mode, values are relative to the active reference plane.
- In View mode, values can be either global or relative to the object’s parent. This depends on a preference; see Choosing the Reference Frame for Numerical Transformations in View Mode on page 366.
- In all other modes, values are relative to the object’s parent.

Alternatively, you can enter local or global transformation values directly in the Kinematics property editor.

Like other input boxes, you can enter specific or relative values for one or more selected objects. For multiple objects, you can also use random values or specify a range of linear values. See Entering Values in a Text Box on page 86 for more information.
Choosing the Reference Frame for Numerical Transformations in View Mode

When View mode is active, you can choose whether the rotation and translation values displayed in the Transform panel are global (relative to the scene) or local (relative to the parent’s center). This affects not only the displayed values, but also the effect of new values that you type into the boxes.

To specify the reference frame for numerical transformations in View mode

1. Choose Transform > Display Global Coordinates in View Mode.
2. When this option is on, the translation and rotation values displayed in the Transform panel are relative to the scene origin (global). In addition, if Transform > Automark Global Transforms is also on, then global transformation parameters are automatically marked when you activate the Translate or Rotate tool in View mode.
3. When this option is off, the translation and rotation values displayed in the Transform panel are relative to the object’s parent (local).

This setting is saved in your preferences and restored the next time you start XSI. The setting is not saved in your scene.

Editing Multiple Parameters in the Transform Panel

You can edit multiple parameters in the Transform panel simultaneously. This lets you quickly set the same value for all selected parameters.

To edit multiple parameters on the Transform panel simultaneously

1. Select the transformation parameters that you want to edit simultaneously:
   - To select or deselect a specific transformation and axis, Shift+right-click on the corresponding axis icon.
   - To toggle each all the axes individually for a specific transformation, Shift+right-click on the corresponding All Axes icon.

   The parameters that you select are highlighted in blue to indicate that they are active for multi-editing. In addition, the keyboard focus is set to the boxes so that you can begin typing immediately.

2. Enter a new value. The value is applied to all highlighted parameters. You can also enter relative values, linear ranges, and random values—see Relative Input Using Math Operations on page 88.

Transforming Hidden Objects

You cannot transform objects interactively if they are hidden (although you can still enter values numerically). This prevents you from accidentally making modifications that you cannot see. For more information about hiding and unhiding objects, see Setting Object Visibility on page 168.
Translating Objects

Translation changes an object's position in space. There are several different translation modes that control the reference frame and interaction—that is, how the object moves when you move the mouse.

To translate objects
1. Select the objects to translate.
2. Activate the Translate tool by doing one of the following:
   - Press v.
   or
   - Click the t button on the Transform panel.
3. If necessary, change any options:
   - The translation modes control the axes used. The last-used mode is automatically activated. For a description of each mode, see Translation Modes on page 368.
   - You can restrict the translation to specific axes. See Specifying Axes on page 359.
   - Set the pivot as described in Setting the Manipulation Pivot on page 360. When snapping, the pivot defines the point that snaps to the target.
4. Translate the objects using the mouse in the 3D views:
   - If you are using the SRT manipulators, click and drag on different parts (handles) of the displayed transformation axes to translate the objects in different ways.
     
     For general information about the SRT manipulators, see Transforming Interactively with the SRT Manipulators on page 362. For specific information about the Translate manipulator, see Using the Translate Manipulator on page 370.
   - If you are not using the SRT manipulators, click and drag the mouse anywhere in the 3D views.
     
     The function of the left, middle, and right mouse buttons depends on the tool, mode, and other options—check the mouse/status line at the bottom of the main window for details. You can also drag while pressing multiple mouse buttons simultaneously.
Chapter 16 • Transformations

Translation Modes

The translation modes control the axes used when you translate elements. When the Translate tool is active, you can set the transformation mode using the buttons below the SRT boxes on the Transform panel. The transformation modes are divided into two groups, based on their interaction when you are not using SRT manipulators:

- The View and Plane modes use the left mouse button to drag across the corresponding plane.
- The Global, Local, Object, and Ref modes use the different mouse buttons to translate along the separate X, Y, and Z axes.

Global

Global translations are performed along the scene’s global axes.

Local

Local translations are performed along the axes of the object’s local coordinate system as defined by its center.

For components, Local mode uses the components’ averaged reference frame. For more information, see Basics of Transforming Components and Clusters in Chapter 5 of the Modeling & Deformations guide.
Translating Objects

View

View translations are performed with respect to the 3D view. The plane in which the object moves depends on whether you are manipulating it in the Camera, Top, Front, Right, or other view.

Object is transformed using the axes of the 3D view as the reference.

If you are using the SRT manipulators in a perspective view like Camera or User, View mode uses the global scene axes.

Par

Par, or parent, mode translates along the axes of the object’s parent. This is the only mode where the axes of interaction correspond exactly to the coordinates of the object’s local position for the purpose of animation. When you activate individual axes on the Transform panel, the corresponding local position parameters are automatically marked.

Object is transformed...

...using the local space of its parent as the reference.

Par translation mode is not available for components. In its place, Object mode uses the local coordinates of the object that “owns” the components.
Ref

Ref, or reference, mode lets you translate an object along the X, Y, and Z axes of another element or an arbitrary reference plane. For more information, see Chapter 17: Reference Planes on page 405.

Object is transformed...

...using the local space of a picked object as its reference.

Plane

Plane mode lets you drag an object along the XZ plane of another element or an arbitrary reference plane. For more information, see Chapter 17: Reference Planes on page 405.

Object is transformed...

...using the local space of a user-defined plane in space.

Using the Translate Manipulator

When using SRT manipulators to translate, there are seven handles that you can click and drag:

Click and drag on a single axis to translate along it.

Double-click to toggle between a single active axis and all three axes, or Shift+double-click to toggle activeness of a single axis (If Allow Double-Click to Toggle Active Axes is on in Transform preferences).

Click and drag between two axes to translate along the corresponding plane.

Click and drag on the center to translate in the viewing plane.
In addition to dragging the handles, you can:

- Middle-click and drag anywhere in the 3D views to translate along the axis that most closely matches the drag direction.

- Click and drag anywhere in the 3D views (except on the manipulator) to perform different actions, depending on the setting for **Click Outside Manipulator** in the **Tools > Transform** preferences. See *To choose the behavior when clicking outside of the manipulators* on page 363.

- Right-click on the manipulator to open a context menu, where you can set the manipulation mode and other options.

For information about using the SRT manipulators in general, see *Transforming Interactively with the SRT Manipulators* on page 362.

### Imposing Limits to Translations

You can set maximum and minimum limits to an object’s position in local space.

**To limit an object’s position**

1. Open the object’s Kinematics property editor. For details, see *Kinematics Property Editor* on page 356.

2. Click the **Pos. Limit** tab of the **Local Transform** page.

3. Toggle the minimum or maximum position box for the object’s X, Y, or Z axis.

4. For each check box you toggle, a corresponding control displays, allowing you to set the minimum position and maximum position for that axis in SOFTIMAGE units.

### Snapping Multiple Objects

The **COG** (center of geometry) option on the Transform panel controls how multiple objects snap when you translate them. When COG is on, the objects preserve their positions relative to each other, and their combined center of geometry snaps to the target. When COG is off, each object in the selection snaps individually to the target.

If, instead of the center of geometry, you want to snap a specific point to a target while keeping the relative positions of the objects, then first set the pivot to that point. For more information, see *Setting the Manipulation Pivot* on page 360.

For more information about snapping, see *Chapter 18: Snapping* on page 417.
Chapter 16 • Transformations

**Rotating Objects**

Rotation changes the orientation of an object. All possible orientations can be set with a combination of three angles of rotation: X axis, Y axis, and Z axis. There are several different rotation modes that control the axis and center of rotation.

**To rotate objects**

1. Select the objects to rotate.

2. Activate the Rotate tool by doing one of the following:
   - Press `c`.
   - Click the `r` button on the Transform panel.

3. If necessary, change any options:
   - The rotation modes control the axis of rotation. The last-used mode is automatically activated. For a description of each mode, see *Rotation Modes* on page 373.
   - You can restrict the rotation to specific axes. See *Specifying Axes* on page 359.
   - You can activate COG to rotate about the center of geometry. Alternatively, set the pivot manually as described in *Setting the Manipulation Pivot* on page 360. When rotating, the pivot defines the center of rotation. For more information about the center of rotation, see *Setting the Center of Rotation* on page 375.

4. Rotate the objects using the mouse in the 3D views:
   - If you are using the SRT manipulators, click and drag on different parts (handles) of the displayed transformation axes to rotate the objects in different ways.

   For general information about the SRT manipulators, see *Transforming Interactively with the SRT Manipulators* on page 362. For specific information about the Rotate manipulator, see *Using the Rotate Manipulator* on page 374.

   - If you are not using the SRT manipulators, click and drag the mouse anywhere in the 3D views.

     The function of the left, middle, and right mouse buttons depends on the tool, mode, and other options—check the mouse/status line at the bottom of the main window for details. You can also drag while pressing multiple mouse buttons simultaneously.
Rotation Modes

The rotation modes control the axis and center of rotation. When the Rotate tool is active, you can set the mode using the buttons below the SRT boxes on the Transform panel. You can also change the center of rotation by setting the pivot as described in Setting the Manipulation Pivot on page 360.

**Global**

Global rotations use one of the global axes, regardless of the object’s current orientation.

**Local**

Local rotations use one of the object’s own axes.

**View**

View rotations use an axis perpendicular to the viewing plane of the 3D view in which you are manipulating the object.

If you are using the SRT manipulators in a perspective view like Camera or User, View mode uses the global scene axes. With the Rotate manipulator, you can always perform a View rotation in any manipulation mode (except Add) by clicking and dragging on the manipulator’s silhouette.
Chapter 16 • Transformations

Add

Add, or additive, mode lets you directly control the object’s local X, Y, and Z rotations as stored relative to its parent. This mode is especially useful when animating bones and other objects in hierarchies.

This is the only mode where the axes of interaction correspond exactly to the coordinates of the object’s local orientation for the purpose of animation. When you activate individual axes on the Transform panel, the corresponding local position parameters are automatically marked.

Par

Par, or parent, mode uses one of the object’s parent’s axes. To use Par mode, activate Add and press the Ctrl key while rotating.

Ref

Ref, or reference, mode lets you rotate an object using the X, Y, or Z axis of another element or an arbitrary reference plane. For more information, see Chapter 17: Reference Planes on page 405.

Plane

Plane mode lets you rotate an object using an axis (by default, Y) of another element or an arbitrary reference plane. For more information, see Chapter 17: Reference Planes on page 405.

Using the Rotate Manipulator

When using SRT manipulators to rotate, there are five handles that you can click and drag:

Click and drag on a single ring to rotate around that axis.

Double-click to toggle between a single active axis and all three axes, or Shift+double-click to toggle activeness of a single axis (if Allow Double-Click to Toggle Active Axes is on in Transform preferences).

Click and drag on the silhouette to rotate about the viewing axis. This does not work in Add mode.

Click and drag on the ball to rotate freely. This does not work in Add mode.

In addition to dragging the handles, you can:

• Middle-click and drag anywhere in the 3D views to rotate about the axis that most closely matches the drag direction.

• Click and drag anywhere in the 3D views (except on the manipulator) to perform different actions, depending on the setting for Click Outside Manipulator in the Tools > Transform preferences. See To choose the behavior when clicking outside of the manipulators on page 363.
Rotating Objects

- Right-click on the manipulator to open a context menu, where you can set the manipulation mode and other options.

For information about using the SRT manipulators in general, see Transforming Interactively with the SRT Manipulators on page 362.

Setting the Center of Rotation

There are several possibilities for the center of rotation of an object:

- By default, the center pivot is the center of rotation. The center pivot is normally the same as the object’s center, but you can change it and even animate as described in Setting the Center Pivot on page 388.

- If Pivot Control - Active is off on the Pivot tab of the object’s Local Transform property editor, then rotations are performed about the object’s center rather than the center pivot. Usually, an object’s center is located in the middle of its geometry. However, this is not always the case, particularly if you freeze the transformations or manipulate the center directly. This has an effect on how the object rotates.

- In Ref mode, the object rotates about the origin of the reference frame. Ref mode takes precedence over the object center and center pivot. For more information, see Chapter 17: Reference Planes on page 405.

- When COG is on in the Transform panel, objects rotate about the center of geometry (the average position of all points). You can also use COG to rotate multiple objects about their common center of geometry. The COG option takes precedence over Ref mode, the object center, and the center pivot.

Groups of objects are transformed...
You can temporarily change the center used for rotating interactively as described in *Setting the Manipulation Pivot* on page 360. The manipulation pivot takes precedence over all other centers of rotation.

**Imposing Limits to Rotations**

You can set maximum and minimum limits to an object’s rotation in local space. You can, for example, specify that a sphere used in a model of a head can rotate no more than 45 degrees to either side of its current position. By setting limits to its rotation, the sphere is prevented from exhibiting awkward or unnatural movement.

*To limit an object’s rotation*

1. Open the object’s Kinematics property editor. For details, see *Kinematics Property Editor* on page 356.
2. Click the *Rot. Limit* tab of the *Local Transform* page.
3. Toggle the minimum and maximum rotation box for the object’s X, Y, or Z axis.
4. For each check box you toggle, a corresponding control appears, allowing you to set the minimum rotational angle and maximum rotational angle for that axis.

These options have no effect on kinematic chain elements, which have their own rotation limits. For more information see *Setting Rotation Limits* in Chapter 4 of the *Character Animation* guide.

**Setting the Rotation Order**

You can set the order in which an object is rotated about its parent’s X, Y, and Z axes. For example, this is useful for helping to control gimbal lock when setting up character rigs. If you align the root with the first bone and set the bone’s rotation order to ZXY or YXZ, then the middle rotation which causes gimbal lock is on the least used rotation, that is, twisting along the length of the bone.

Setting the rotation order is also useful in other situations. For example, suppose you wanted to implement your own camera setup that behaves more like a traditional cinematic camera. In this case, a rotation order of ZXY corresponds to the correct order of Pan/Tilt/Roll. This camera setup will gimbal-lock in the mechanically correct position: when you tilt 90 degrees up or down, panning and rolling mean the same thing.

*To set the rotation order*

1. Open the object’s Kinematics property editor. For details, see *Kinematics Property Editor* on page 356.
2. On the SRT tab of the *Local Transform* page, set the Rotation Order.
Here are a couple of things to keep in mind when animating the rotation values of an object:

- For best results, use Add mode while manipulating an object. Add mode directly reflects the local Euler rotations that are stored, and gives you a better sense of potential problems like gimbal lock that may occur during playback.

- If desired, you can use quaternion keys instead of keying the Euler values. Quaternions solve problems like gimbal lock, and also provide smoother and more direct interpolation from one pose to the next. For more information, see Quaternion Function Curves for Rotation in Chapter 5 of the Animation guide.
Scaling Objects

Scaling changes the size of an object. Unlike translation and rotation values which are absolute, scaling values are multipliers. A cube created at a length of 5 and scaled with a factor of 2 has a length of 10. Negative scaling turns an object inside-out.

When an object is created, its scale is automatically set to 1.0.

To scale objects

1. Select the objects to scale.
2. Activate the Scale tool by doing one of the following:
   - Press \text{x}.
   - Click the \text{s} button on the Transform panel.
3. If necessary, change any options:
   - The scaling modes control which axes the object is scaled along. For a description of each mode, see Scaling Modes on page 379.
   - You can restrict the scaling to specific axes. See Specifying Axes on page 359.
   - Activate COG to scale about the center of geometry.

   Alternatively, set the pivot manually as described in Setting the Manipulation Pivot on page 360. When scaling, the pivot defines the center of scaling. For more information about this, see Setting the Center of Scaling on page 380.
4. Scale the objects using the mouse in the 3D views:
   - If you are using the SRT manipulators, click and drag on different parts (handles) of the displayed transformation axes to scale the objects in different ways.

   For general information about the SRT manipulators, see Transforming Interactively with the SRT Manipulators on page 362. For specific information about the Scale manipulator, see Using the Scale Manipulator on page 380.
   - If you are not using the SRT manipulators, click and drag the mouse anywhere in the 3D views.

   The function of the left, middle, and right mouse buttons depends on the tool, mode, and other options—check the mouse/status line at the bottom of the main window for details. You can also drag while pressing multiple mouse buttons simultaneously.
Scaling Modes

For objects, there is only one coordinate system used: Local. This is because objects are always scaled along their own local axes. Uni and Vol are actually modifiers that change the behavior of the scaling somewhat, but do not change the axes. When the Scale tool is active, you can set these modes using the buttons below the SRT boxes on the Transform panel.

For components, there are more scaling modes. See Basics of Transforming Components and Clusters in Chapter 5 of the Modeling & Deformations guide.

Local

Local mode scales objects along their local axes. If both Uni and Vol are off, you can use the mouse buttons to scale along each axis independently.

Uni

Uni, or uniform, mode scales along all active local axes at the same time with a single mouse button. This avoids the annoyance of trying to drag the mouse while pressing two or three buttons. You can activate and deactivate axes as described in Specifying Axes on page 359. You can also temporarily turn on Uni by pressing Shift while scaling.

When using manipulators to scale in Uni mode, the mouse pointer does not reflect all the axes that are affected. This is because the direction in which you must drag the mouse depends on which axis the pointer is over.
Vol

Vol, or volume, mode scales along one or two local axes, while automatically compensating the other axes so that the volume of the object’s bounding box remains constant.

Using the Scale Manipulator

When using SRT manipulators to scale, there are seven handles that you can click and drag:

- Click and drag on a single axis to scale along it.
- Double-click to toggle between a single active axis and all three axes, or Shift+double-click to toggle activeness of a single axis (if Allow Double-Click to Toggle Active Axes is on in Transform preferences).
- Click and drag along the diagonal between two axes to scale both those axes uniformly.
- Click and drag the center left or right to scale all active axes uniformly.

In addition to dragging the handles, you can:

- Middle-click and drag anywhere in the 3D views to scale along the axis that most closely matches the drag direction.
- Click and drag anywhere in the 3D views (except on the manipulator) to perform different actions, depending on the setting for Click Outside Manipulator in the Tools > Transform preferences. See To choose the behavior when clicking outside of the manipulators on page 363.
- Right-click on the manipulator to open a context menu, where you can set the manipulation mode and other options.

For information about using the SRT manipulators in general, see Transforming Interactively with the SRT Manipulators on page 362.

Setting the Center of Scaling

There are several possibilities for the center of scaling—the position that points move away from or towards as you scale up or down:

- By default, the center pivot is the center of scaling. The center pivot is normally the same as the object’s center, but you can change it and even animate as described in Setting the Center Pivot on page 388.
If Pivot Control - Active is off on the Pivot tab of the object’s Local Transform property editor, the object scales about its center rather than its center pivot. Usually, an object’s center is located in the middle of its geometry. However, this is not always the case, particularly if you freeze the transformations or manipulate the center directly. This has an effect on how the geometry appears to move when scaled, even if the center does not actually move.

In Ref mode, the object scales about the origin of the reference frame. Ref mode takes precedence over the object center and center pivot. For more information, see Chapter 17: Reference Planes on page 405.

When COG is on in the Transform panel, objects scale about the center of geometry (the average position of all points). You can also use COG to scale multiple objects about their common center of geometry. The COG option takes precedence over Ref mode, the object center, and the center pivot. Be aware that object centers may move if you scale with COG on.

You can temporarily change the center used for scaling interactively as described in Setting the Manipulation Pivot on page 360. The manipulation pivot takes precedence over all other centers of rotation.
Shearing (Scaling Orientation)

You can shear an object by changing the orientation of the axes used for scaling. This distorts the shape of the object when you scale it.

To shear by scaling

1. Open the object's Local Transform or Global Transform property editor. It makes no difference which one you use because they share the same shearing values.

2. On the Scaling tab, set the orientation of the axes used for scaling by modifying the Scaling Orientation (Shear) X, Y, and Z values. These are angular offsets from the object's local axes.

3. Scale the object in one or more axes. Note that there is no shearing effect if you scale uniformly.
Hierarchical (Softimage) Scaling versus Classic Scaling

Hierarchical (Softimage) scaling uses the local axes of child objects when their parent is branch-selected and scaled. This maintains the relative shape of the children without deformation. Hierarchical scaling is recommended if you are importing and exporting scenes and other data for use with SOFTIMAGE|3D.

When the hierarchical scaling option is turned off, the result is called classic scaling—children are scaled along their parent’s axes and may be sheared with non-uniform scaling. Classic scaling is recommended if you are exchanging data with other applications, such as game engines, motion capture systems, or 3D applications that do not understand Softimage scaling.

You specify which method to use for each child in its Local Transform property. You can also set the default value used for all new objects.

In SOFTIMAGE|3D, Classic Scaling is a preference that affects the entire scene. In SOFTIMAGE|XSI, it is a property of individual objects.

To specify hierarchical or classic scaling
1. Select one or more child objects and open their Local Transform property editor.
2. On the Scaling tab, turn Hierarchical (Softimage) Scaling off or on. If it is off, classic scaling is used.

To set the default scaling mode used for all new objects
1. Open the Preferences window by choosing File > Preferences from the main menu bar.
2. Click General.
3. Toggle Use Classical Scaling for Newly Created Objects.
How Hierarchical and Classic Scaling Work

This section describes the technical details of hierarchical versus classic scaling, in case you need to write converters or process transformation data in the same way as SOFTIMAGE|XSI.

### Hierarchical scaling

Suppose that object B is the direct child of object A, and define the following:

- $M_{gscI_B} = M_{lscl_B} \times M_{gscI_A}$
- $M_{gsco_B} = M_{lsco_B} \times M_{gsco_A}$
- $M_{grot_B} = M_{lrot_B} \times M_{grot_A}$

$M_{gtrs_B}$ is the standard translation matrix constructed from the vector $V_{gtrs_B}$ as follows:

- $V_{gtrs_B} = V_{ltrs_B} \times M_{gmat_A}$

For hierarchical scaling, the global transformations of B can be calculated recursively as follows:

$$M_{gmat_B} = M_{gsco_B}^T \times M_{gscI_B} \times M_{gsco_B} \times M_{grot_B} \times M_{gtrs_B}$$

Hierarchical scaling cannot be represented as a simple matrix product because of the way $M_{gtrs_B}$ is computed.

### Classic scaling

Again, suppose that object B is the direct child of object A. For classic scaling, the global transformations of B can be calculated recursively as follows:

$$M_{gmat_B} = M_{lsco_B}^T \times M_{lscl_B} \times M_{lsco_B} \times M_{lrot_B} \times M_{ltrs_B} \times M_{gmat_A}$$
Transforming with the Bounding-Box Manipulator

As an alternative to using the transformation tools, you can use the bounding box manipulator to scale, rotate, and translate objects. The bounding-box manipulator has a set of handles that let you interactively manipulate objects in the 3D views.

Bounding box manipulators do not work well in the Object view unless you deactivate View > Camera Compensation.

To activate the bounding-box manipulator

1. Select the object.
2. Press b or choose Manipulate Tool from the eye icon menu on a viewport.
3. Press the Tab key to alternate between the two types of manipulator handles, each of which let you perform different types of operations (see the illustration below).

Manipulator mode 1: Scaling, rotating, and translating

- Drag corner manipulator to scale the object.
- Drag a bounding box plane to translate the object along that plane.
- Drag bounding-box edge to rotate the object on a given axis.

Manipulator mode 2: Rotating only

- Drag the arrow manipulator to rotate the object freely along its three axes.
Chapter 16 • Transformations

Mode 1: Scaling
Position the mouse pointer over one of the manipulator’s corners:
- To scale uniformly about the object’s center, click a corner and drag.
- To scale non-uniformly relative to the opposite corner, Shift+click and drag.
- To scale uniformly relative to the opposite corner, Ctrl+click and drag.

Mode 1: Rotating
Position the mouse pointer over one of the manipulator’s edges:
- To rotate about an axis parallel to the picked edge passing through the object’s center, click an edge and drag.
- Press the Shift key to rotate relative to the opposite edge.
- Press the Ctrl key to rotate the edge freely.

Mode 1: Translating
Position the mouse pointer over one of the manipulator’s sides:
- To translate in any direction along the plane, click the plane and drag.
- To translate along the picked plane’s normals, Shift+click and drag.
- To translate freely in any direction, Ctrl+click and drag.

Mode 2: Rotating
- Drag the arrow manipulator to rotate the object freely along its three axes.
Center Manipulation

Center manipulation lets you move the center of an object without moving its points. This changes the default pivot point used for rotation and scaling. You can transform the center interactively, or you can move it to the geometric center of selected points.

It’s important to note that center manipulation is actually a deformation. As the center is moved, the geometry is compensated to stay in place. In the explorer, you can see a Center deformation in the object’s operator stack. For this reason, it is sometimes necessary to freeze an object’s operator stack after moving its center in certain situations, such as if you want to use it as a cage deformer.

Because it is a deformation, you cannot manipulate the center of non-geometric objects. This includes nulls, bones, implicit objects, control objects, and anything else without points.

- For non-geometric objects, Center mode is ignored. The object is transformed as if in Object mode.
- You cannot animate the center. However, you can animate the center pivot which is used for playing back animated scaling and rotations. See Setting the Center Pivot on page 388.

To transform an object’s center
1. Select an object.
2. Activate Center on the Select panel.
3. Scale, rotate, or translate the center as needed.
4. When you have finished, turn off center manipulation mode by clicking it again, or by activating another filter on the Select panel.

To translate an object’s center to the center of selected points or cluster
1. Select one or more points or a cluster.
   If you select an object, its center moves to the geometric center of all points.
2. Choose Transform > Move Center to Vertices.
   The object’s center moves to the geometric center of the selected points or cluster.

To translate an object’s center to the center of its bounding box
1. Select an object, one or more points, or clusters.
2. Choose Transform > Move Center to Bounding Box.
   The object’s center moves to the center of the bounding box of the object, points, or clusters.
Chapter 16 • Transformations

Setting the Center Pivot

The center pivot is the position about which objects are scaled and rotated when playing back animation. You can change and even animate the center pivot—for example, this lets you create a rolling cube.

By default, the center pivot is the same as the object’s center. You change the pivot by setting an offset from the object’s center.

The pivot pose is not only used for animation, but it can also be used for manipulation. When manipulating, the pivot is the default center of transformation, but it can be overridden by explicitly setting the manipulation pivot, by transforming in Ref mode, or by activating COG. The axes used for manipulation are determined by the manipulation mode (for example, Local, View, Par, etc.) and are not affected by the pivot’s scale and orientation.

Unlike the manipulation pivot, the center pivot is not used when transforming components. It is also not used when translating with snapping.

Modifying the Pivot’s Pose

You can modify the pivot’s pose using the controls on the Pivot tab of an object’s Local Transform property editor. You can open this property editor quickly by selecting the object and pressing Ctrl+k.

When you change the pivot’s pose, any pre-existing animation of the local scaling or rotation values is interpreted around the new pose. This may give unexpected results when you play back the animation. You should set the pivot pose before setting keys on the scaling or rotation values at any given frame.
When you set the center pivot or neutral pose, the local transformation no longer reflects the position of the object center with respect to its parent. The position of the object center is a composite of the local transformation, center pivot, pivot compensation, and neutral pose.

**To set the pivot’s pose**

- On the Pivot tab of an object’s Local Transform property editor, adjust the **Pivot Scaling**, **Rotation**, and **Translation** parameters.

  All values are offsets from the object’s center.

  You should not modify the **Compensation** values directly. For more information, see *A Word About Pivot Compensation* on page 389.

**To reset the pivot’s pose**

- On the Pivot tab of an object’s Local Transform property editor, click **Reset Pivot**.

  The **Pivot Scaling**, **Rotation**, and **Translation** parameters are reset to their default values, and the pivot returns to its default pose at the object’s center.

**To activate or deactivate the pivot**

- On the Pivot tab of an object’s Local Transform property editor, toggle **Active** on or off.

  When the pivot is active, the local scaling and rotation values are interpreted about the pivot’s pose. When it is not active, they are interpreted about the object’s center.

  When you select or deselect **Active**, the object does not immediately jump to a new pose because the local transformation values are automatically adjusted to keep the object in place. However, if the transformations have been keyed, you will notice that the keyframe icon of the local transformations turn yellow to indicate that the current values are different from the keyed values. The transformations will return to the fcurve values if you change frames without setting new keys.

**A Word About Pivot Compensation**

The **Compensation** values on the Pivot tab of an object’s Local Transform property editor are calculated automatically. They ensure that the object does not move in global space if you change the pivot pose more than once. For this reason, you should not modify these parameters directly.

If you are absolutely certain that you will not change the pivot pose more than once, you can unset **Compensate Pivot** in the Pivot Control area. This simplifies the transformation calculations. However, it is safe to leave **Compensate Pivot** on.
Chapter 16  •  Transformations

**Animating the Pivot**

If you set keys on the pivot’s transformations, you must also set keys on the corresponding **Compensation** values. For example, if you set keys on any of the **Pivot Rotation** parameters, you must also set keys on all three of the **Compensation Rotation** parameters, and so on.

Most of the time, you will want to use constant interpolation for the pivot and compensation fcves, as in the example of the rolling cube where the pivot suddenly jumps from one edge to another. Spline interpolation does not give mathematically correct results because the interpolated values do not compensate properly.

The **Pivot Keying** buttons in the Local Transform property editor are a convenient way to set keys on all the required parameters with a single click. These buttons use constant interpolation.

**Displaying Pivots**

You can display pivots in the 3D views. The pivot appears as a set of axis indicators with a white circle. The black bull’s-eye in the middle of the circle distinguishes the pivot from the center. When the pivot has been deactivated, the colors of the axis indicators are less saturated.
Setting the Center Pivot

To toggle the pivot display for a single 3D view

1. Open the Camera Visibility property editor for a particular view by doing one of the following:
   - Click the eye icon to open the Show menu, and choose Visibility Options.
   - Press Shift+s while the mouse pointer is over the view.

2. On the Transforms tab of the Camera Visibility property editor, turn the Center Pivots options on or off.

To toggle the pivot display for all open 3D views

1. Choose View > Visibility Options (All Cameras) from the main menu.

2. On the Transforms tab of the Camera Visibility property editor, turn the Center Pivots options on or off.
Freezing Transformations

Freezing an object’s transformations resets its size, orientation, or location to the default values without moving the object’s geometry in global space. For instance, freezing an object’s translation moves its center to (0, 0, 0) in its parent’s space without visibly displacing its points.

Like center manipulation, freezing transformations is actually a deformation. As the center is transformed, the geometry is compensated to stay in place. In the explorer, you can see a Center deformation in the object’s operator stack. For this reason, it is sometimes necessary to freeze an object’s operator stack after freezing its transformations in certain situations, for example, if you want to use it as a cage deformer.

Because it is a deformation, you cannot freeze the transformations of non-geometric objects. This includes nulls, bones, implicit objects, control objects, and anything else without points.

In SOFTIMAGE|3D, you can use the Effect > Freeze > Transformations command on nulls and other non-geometric objects. However in these cases, the transformations are actually reset instead of frozen. In SOFTIMAGE|XSI, use the Reset commands on the Transform menu as described in Resetting Transformations on page 393.

To freeze transformations

1. Select one or more objects.

2. Choose one of the following commands from the Transform menu:
   - Freeze All Transforms freezes the scaling, rotation, and translation.
   - Freeze Scaling sets the scaling of the objects’ centers to (1, 1, 1) in the parents’ coordinate system without moving its geometry in global space.
   - Freeze Rotation sets the rotation of the objects’ centers to (0, 0, 0) in the parents’ coordinate system without moving its geometry in global space.
   - Freeze Translation sets the translation of the objects’ centers to (0, 0, 0) in the parents’ coordinate system without moving its geometry in global space.

If a neutral pose exists when you freeze an object’s transformations, the object’s center moves to the neutral pose instead of to the origin of its parent’s space. If you want the object’s center to be at the origin, you should remove the neutral pose in addition to freezing the transformations. You can perform these two operations in either order. For information about removing the neutral pose, see Removing Neutral Poses on page 395.
Resetting Transformations

When you reset an object’s transformations, its local scaling, rotation, and translation return to the default values. It effectively removes transformations applied since the object was created or parented, or since its transformations were frozen.

If you want an object to return to a pose other than the origin of its parent’s space when you reset its transformations, set its neutral pose as described in Setting Neutral Poses on page 394.

To reset transformations

1. Select one or more objects.
2. Choose one of the following commands from the Transform menu:
   - **Reset All Transforms** resets the scaling, rotation, and translation.
   - **Reset Scaling** sets the objects’ local scaling values to (1, 1, 1).
   - **Reset Rotation** sets the objects’ local rotation values to (0, 0, 0).
   - **Reset Translation** sets the objects’ local translation values to (0, 0, 0).
   - **Reset Active Transform** resets whichever transformation is active. For example, if the Translate tool is active, this command resets the translation.
Chapter 16 • Transformations

Setting Neutral Poses

You can set the neutral pose to “zero out” an object’s transformations. This is useful if you want an object to return to a pose other than the origin of its parent’s space when you reset its transformations. For example, you can set the neutral pose of a chain bone so that it returns to a “natural” position when you reset it. Neutral poses are also useful for visualizing the transformation values—it’s easier to imagine a rotation from 0 to 45 degrees than from 78.4 to 123.4 degrees.

The neutral pose acts as an offset for the object’s local transformation values, as if there was an intermediate null between the object and its parent in the hierarchy. The neutral pose values are stored in the object’s Local Transform property, and can be viewed or modified on the Neutral Pose tab of that property editor.

Setting Neutral Poses

You can set neutral poses using commands on the Transform menu or with an object’s Local Transform property editor.

When you set the neutral pose, any existing animation of the local transformation values is interpreted with respect to the new pose. This may give unexpected results when you play back the animation. You should set the neutral pose before animating the transformations of an object.

To set neutral poses with menu commands

1. Select one or more objects or branches.

2. Choose one of the following commands from the Transform menu:
   - **Set Neutral Pose** stores the current values for local scaling, rotation, and translation as the neutral pose and sets them to the default values.
   - **Set Neutral Scaling** stores the current scaling values in the neutral pose and sets the local scaling values to (1, 1, 1).
   - **Set Neutral Rotation** stores the current rotation values in the neutral pose and sets the local rotation values to (0, 0, 0).
   - **Set Neutral Translation** stores the current translation values in the neutral pose and sets the local translation values to (0, 0, 0).
To set neutral poses with a property editor
1. Open the Local Transform property editor for one or more objects.
   One way to do this is to select all the objects and press Ctrl+k.
2. On the Neutral Pose tab, click Use Current Pose.
   The current transformation values are stored in the neutral pose and the
   local transformation values are set to the defaults.

Removing Neutral Poses

When you remove the neutral pose, the neutral pose values are added to the
local transformation before being reset to the defaults. The object does not
move in global space as a result.

To remove neutral poses with menu commands
1. Select one or more objects or branches.
2. Choose Transform > Remove Neutral Pose.

To remove neutral poses with a property editor
1. Open the Local Transform property editor for one or more objects.
   One way to do this is to select all the objects and press Ctrl+k.
2. On the Neutral Pose tab, click Reset.
Chapter 16  •  Transformations

Matching and Aligning Transformations

You can align the transformations of objects using commands in the Transform menu. You can match the transformations of the selected objects to another one, or you can align a group of objects together.

**Matching Transformations**

Matching an object’s transformations to another changes its local transformations so that it shares the same global size, orientation, or position as a target object you pick.

*To match transformations*

1. Select one or more objects.
2. Choose one of the following commands from the Transform menu:
   - **Match All Transforms** matches all of the selected objects transformations to the target object in global space.
   - **Match Scaling** sets the selected objects’ global scaling values to match the target.
   - **Match Rotation** sets the selected objects’ global rotation values to match the target.
   - **Match Translation** sets the selected objects’ global translation values to match the target.
3. Pick the target object.

**Aligning Objects**

You can reposition a group of objects so that the bottom, top, right, left, or center of their bounding boxes are aligned. Aligning the bottoms of objects’ bounding boxes along the X axis, for example, is a quick way to position a group of objects onto a flat surface, such as a table.

*To align objects*

1. Select the objects to be aligned.
2. Choose **Transform > Align Objects**.
3. In the Align dialog box that opens, click the appropriate button for aligning all objects, or all except the first selected.
4. Toggle the **Which Axis** parameters to select each axis to which you want the objects aligned.
5. In the **What to Align - on Affected Objects** controls, choose the part of the objects to align: their maximum boundary, minimum boundary, or middle, respective to each axis.
6. In the **What to Align to - Reference** controls, choose how the alignment is to take place, and where.

The following examples assume the middle of each object is being aligned along the Y axis:

- **Minimum - of All Objects** aligns the bottom of all object bounding boxes with the object whose bounding-box bottom has the lowest axis value.

- **Middle - of All Objects** aligns objects according to the average midpoint of all their bounding boxes.

- **Maximum - of All Objects** aligns the top of all object bounding boxes with the object whose bounding box top has the highest axis value.

- **Minimum - of the First Selected Object** aligns all object bounding-box bottoms with that of the first object selected.
Chapter 16 • Transformations

**Middle - of the First Selected Object** aligns the midpoint of all object bounding boxes with that of the first object selected.

**Maximum - of the First Selected Object** aligns all object bounding-box tops with that of the first object selected.
Transform Setup

The Transform Setup property lets you define a preferred transformation for an object. When you select that object, its preferred transformation tool is automatically activated. Of course, you can still choose a different tool and change transformation options manually if you want to.

Transform setups are particularly useful when building animation rigs for characters. If you are using an object to control a character’s head orientation, you can set its preferred transformation to rotation. If you are using another object to control the character’s center of gravity (COG), you can set its preferred transformation to translation. When you select the head control, the Rotate tool is automatically activated, and then when you select the COG control, the Translate tool is automatically activated.

Transform setups are ignored if you select multiple objects with different transform setup options.

To apply a Transform Setup
1. Select one or more objects.
2. Choose Get > Property > Transform Setup from any toolbar. The property is applied and its editor opens.
3. Set the preferred transformation tool. In addition to Scale, Rotate, or Translate, you can select either of the following:
   - None uses whatever transformation tool is currently active.
   - Last uses the last transformation tool that was active on the specific object.
4. Set the other options as desired:
   - For a description of the Scale options, see Scaling Modes on page 379.
   - For a description of the Rotate options, see Rotation Modes on page 373.
   - For a description of the Translate options, see Translation Modes on page 368.
   - The X, Y, and Z options let you restrict the manipulation to specific axes. See Specifying Axes on page 359.
   - For a description of COG, see Setting the Center of Rotation on page 375 and Setting the Center of Scaling on page 380.
**To change a Transform Setup**

Transform setups are stored as properties on specific objects. To change the preferred tool and options for an object, display the Transform Setup property editor by clicking the Transform Setup icon under the object in an explorer.

**To ignore Transform Setups when selecting in 3D views in sticky mode**

With Transform Setups, it can be difficult to select multiple objects interactively because the Select tool gets replaced by one of the transformation tools each time you add an object to the selection.

There is a preference that ignores the Transform Setup property when using the Select tool in sticky mode in the 3D views.

1. Choose **Transform > Transform Preferences**.
2. On the Transform tab, turn **Transform Setup - Enable for 3D Supra Selection Only** on or off.
   - When this option is on, the Transform Setup property is ignored when you use the Select tool in sticky mode in the 3D views. This allows you to easily select multiple objects without having the current tool change as you work.
   - The Transform Setup property is still used when you select objects in any other way: using the Select tool in supra mode in the 3D views; using the explorer, schematic, or spreadsheet views; typing a name in the box on the Select panel; running a script command; and so on.
   - When this option is off, the Transform Setup property is always used and the current tool automatically changes no matter how you select an object.

**To ignore Transform Setups for all objects**

While Transform Setups are useful for many tasks, like animating a rig, at other times you don’t want the current tool to keep changing as you select objects. In these cases, you can ignore Transform Setups for all objects in your scene.

- Turn **Transform > Enable Transformation Setups** off. Turn it back on to resume using the preferred tool of each object.
Transformations and Hierarchies

Transformations are propagated down hierarchies. Each object’s local position is stored relative to its parent. It’s as if the parent’s center is the origin of the child’s world.

Basics of Transforming Hierarchies

Objects in hierarchies behave differently when they transformed depending on whether the objects are node-selected or branch-selected. By default:

- If an object is branch-selected, then its children are transformed as well. You can change this behavior by modifying the parent constraint on the Options tab of the child’s Local Transform property editor. See Parent Constraint on page 402.

- If an object is node-selected, then its children are not transformed unless their corresponding local transformations are animated. This is because animation on the local transformations is stored relative to the parent’s center. You can make unanimated children follow the parent with the ChildComp (Child Transform Compensation) option on the Constrain panel. See the next section, Child Transform Compensation.

Child Transform Compensation

The ChildComp option on the Constrain panel controls what happens to unanimated children if an object is node-selected and transformed. This is the same as the Constrain > Child Transform Compensation menu item.

- If this option is on, the children are not visibly affected. Their local transformations are compensated so that they maintain the same global position, orientation, and size. This is the default.

- If this option is off, all children with an active parent constraint follow the parent. You cannot move the parent without moving its children.

Child Transform Compensation does not affect what happens when a child has local animation on the corresponding transformation parameters or when the parent is branch-selected. If a child has animation on its local transformations, then the animated parameters always follow the parent whether or not Child Transform Compensation is on. This is because the local animation values are stored relative to the parent’s center. If the parent is branch-selected, then the parent constraint options determine how the child is affected.

Child Transform Compensation is the opposite of Preferences > Hierarchy Manipulation in SOFTIMAGE|3D.
Chapter 16 • Transformations

**Parent Constraint**

The settings on the Options tab of the Local Transform property editor control how an object inherits transformations from its parents. By default, children follow the parent when it is branch-selected and manipulated.

**Activating and Deactivating Transformation Inheritance**

The *Active* option on the Options tab of the Local Transform property editor turns the parent constraint on or off. When this option is off, the object does not follow its parent when the parent is transformed, not even when the parent is branch-selected nor when *Child Transform Compensation* is off.

You can also use the *Position*, *Orientation*, and *Scaling* options to turn inheritance on or off for translation, rotation, or scaling individually.

**Controlling How Position Is Affected**

When the parent of an object is scaled or rotated, the object’s position can be affected.

- The *Affected by Orientation* option on the Options tab of the Local Transform property editor changes the object’s position when its parent or ancestor is rotated. When this option is on, the descendant orbits like a geosynchronous satellite that stays over a fixed spot on the earth as the earth rotates. When it is off, the descendant spins around its own center when an ancestor is rotated.

- *Affected by Scaling* changes the object’s position when its parent or ancestor is scaled. When this option is on, the object moves away from or towards its parent in global space as the units of distance (in which its relative position in local space is measured) change size. When this option is off, the child scales with its parent but its center does not move.
Velocity & Acceleration

You can get XSI to calculate an object’s velocity and acceleration based on the object’s animated transformations. You cannot modify the velocity and acceleration directly, but you can use the computed values in expressions, scripted operators, and elsewhere.

Understanding Motion Components

A moving object has speed or velocity. If it is changing speed, then it also has acceleration or deceleration. For example, a car moving at a steady 100 km/h has a velocity of 100 but an acceleration (and deceleration) of 0.

Velocity and acceleration can each be further divided into two types: linear and angular (or rotational). For example, a car that moves along a straight line has only a linear motion, whereas a ball that spins on the spot has only angular motion. A ball rolling on the floor has both types.

Calculating Velocity and Acceleration

By default, XSI does not calculate velocity and acceleration to avoid unnecessary computations. However if you need to know these values for a specific object, you can activate them in the object’s Global Transform property editor.

To activate velocity and acceleration for an object
1. Select an object and open its Global Transform property editor.
2. On the Velocity/Acceleration tab, click Compute Vel/Acc.

The read-only Active option is selected to show that velocity and acceleration computations are performed for this object.

Removing Velocity and Acceleration

If you no longer need to know the velocity or acceleration of an object, there is no point continuing to perform those calculations because they are only slowing down your scene.

To stop computing velocity and acceleration for an object
1. Select the object and open its Global Transform property editor.
2. On the Velocity/Acceleration tab, click Remove Vel/Acc.

The read-only Active option is cleared to show that velocity and acceleration computations are no longer performed for this object.
Chapter 17  Reference Planes
Reference Planes

Reference planes let you choose the frame of reference used for transformations, as well as for drawing.

You can:

- Create transient and permanent reference planes.
- Activate reference planes for manipulating elements.
- Transform elements along reference planes.
- Set various options for reference planes.
About Reference Planes

Reference planes help you manipulate objects and components precisely. For example, you can move one element (such as a point) along the Y axis of another element (such as a polygon).

The *active* plane specifies the reference frame used for transformations, as well as for drawing objects such as curves and polygons. Only one reference plane can be active at a time—you can choose one of the default reference planes or create your own. You can create transient, or temporary, reference planes as you work, or you can create permanent reference planes that are saved with the scene.

You work with reference planes using the **Ref** and **Plane** buttons on the Transform panel. The main difference between the two is how the three mouse buttons work:

- **Ref** is an XYZ mode like Global, Local, Par, and Obj.
- **Plane** is a drag mode like View.

For details about transforming with Ref and Plane modes, see *Transforming Elements with Reference Planes* on page 413.

Reference planes are not relational. If you create a reference plane based on an object or component, and then move the object or component, the reference plane does not follow it.
Chapter 17  •  Reference Planes

Types of Reference Planes

There are three types of reference planes: default, transient, and permanent.

Default Reference Planes

The default reference planes include the major planes of the global coordinate system, as well as a View plane which depends on the 3D view.

Transient Reference Planes

As you work, you can create transient, or temporary, reference planes. Transient reference frames are not saved with the scene. There can be only one transient reference plane at a time; the current one is replaced as soon as you define a new one.

Permanent Reference Planes

Permanent reference planes let you use the same reference plane again at any time, even after saving and reopening the scene.

Reference Planes in the Explorer

All reference planes are listed in the explorer under the Application > Data node. To see them, make sure that the scope of the explorer is set to Application.

Reference Planes and Symmetry

You can use the axes of a reference plane for symmetry when drawing in Plane mode. For example, you can draw two curves or chains that are symmetric with respect to a reference plane of your choosing. Click Sym in the Transform panel to activate symmetry, and right-click Sym to specify a plane of symmetry.
**Using Reference Planes**

Here is an overview of the process for using reference planes:

1. If necessary, create a transient or permanent reference plane. This creates a reference frame which becomes available to use in Ref or Plane manipulation modes. For more information about creating reference planes, see *Creating Reference Planes* on page 410.

   If you want to use one of the default reference planes (XY, XZ, YZ, or View), you don’t need to create a reference plane first.

2. If necessary, activate the desired reference plane. The active reference plane specifies which reference frame to use in Ref and Plane modes.

   If you just created a reference plane, it is automatically active. If you used another reference plane or manipulation mode in the meantime, you can activate the desired reference plane as described in *Activating Reference Planes* on page 412.

3. Do something in Ref or Plane mode. For example:

   - Translate or rotate objects and components, or move points. See *Transforming Elements with Reference Planes* on page 413.

   - Draw curves, chains, or polygons in Plane mode. The new elements are placed on the active reference plane.

   - Duplicate objects using the Duplicate tool. The duplicated objects are placed on the reference frame.

   Rotating selected polygons... about this edge.
Creating Reference Planes

You can create permanent and temporary reference planes in different ways. As soon as you create a reference plane, it becomes the active one used by Ref and Plane modes.

If you set the pivot by Alt+clicking on a point, edge midpoint, polygon midpoint, or object center while Ref or Plane manipulation mode is active, a transient reference plane is automatically created and activated (replacing the previous transient plane).

To create a permanent reference plane
1. Select an object, or one or more components. If you select multiple components, the reference plane is based on the average reference frame.
2. Do one of the following:
   - Choose Transform > Create Reference Plane from the Transform panel. A permanent reference plane is created named ReferencePlane by default, and its property editor opens.
   - Press Ctrl+dash (Ctrl+-). A permanent reference plane is created named ReferencePlane by default, but its property editor does not open.

To create a transient reference plane based on the current selection
1. Select an object, or one or more components. If you select multiple components, the reference plane is based on the average reference frame.
2. Do one of the following:
   - Choose Transform > Create Transient Plane from the Transform panel.
   - Press the dash key (-).

A transient reference plane is created based on the selected element. The previous transient plane is “forgotten.”
Creating Reference Planes

To pick a new transient reference plane using the current selection filter

1. Do one of the following:
   - Left-click on the Ref button.
   or
   - Right-click on Ref or Plane and choose Pick New Reference.
2. Pick an object or component using the current selection filter on the Select panel. A transient reference frame is created based on the element you picked.

To pick a new transient reference plane using a specific selection filter

1. Right-click on Ref or Plane, then choose one of the following:
   - Pick Object Reference lets you pick an object with the Rectangle selection tool.
   - Pick Point Reference lets you pick one or more points with the Rectangle selection tool.
   - Pick Edge Reference lets you pick one or more edges with the Raycast selection tool.
   - Pick Polygon Reference lets you pick one or more polygons with the Raycast selection tool.
2. Pick an element. If you are picking a component type, you can first pick an object (if it is not already selected), then pick components on that object. A transient reference frame is created based on the element you picked.

Deleting Permanent Reference Planes

You can remove permanent reference planes from your scene if you are certain that you no longer need to use them to manipulate elements. You cannot delete default or transient reference planes.

To delete permanent reference planes

1. Select a permanent reference plane under the Application > Data node in an explorer.
2. Press Delete.
Activating Reference Planes

The active reference plane specifies the reference frame used for transformations as well as for drawing objects such as curves and polygons. You can quickly reactivate the last active reference plane or activate a specific one.

Each transformation tool remembers its last interaction mode. For example, if you use the Move Point tool in Ref mode, and then use the Rotate tool in Local mode, and finally activate the Move Point tool again, then Ref mode is automatically reactivated.

To reactivate the last-used reference plane

Do one of the following:

- Middle-click the Ref or Plane button.
  
or

- Right-click the Ref or Plane button and choose Use Current Reference.

To activate a specific reference plane

- Right-click on Ref or Plane, then choose one of the following options:
  - View: the coordinate system of the camera associated with the current 3D view.
  - XY: the plane defined by Z = 0 in global coordinates.
  - XZ: the plane defined by Y = 0 in global coordinates.
  - YZ: the plane defined by X = 0 in global coordinates.
  - Transform: the last-used transient reference plane.
  - [ReferencePlaneN]: any permanent reference plane you have defined. By default, these are named ReferencePlane, ReferencePlane1, and so on, but you can rename them.

You can also activate a specific reference plane by selecting it in the explorer—see Reference Planes in the Explorer on page 408.
Transforming Elements with Reference Planes

The Ref and Plane manipulation modes let you rotate and translate objects and components, as well as move points, with respect to a reference plane of your choice.

Ref and Plane differ principally in how the mouse buttons work when manipulating elements. In addition, Plane mode displays a bright blue representation of the active reference plane in the 3D views.

For more information about the Rotate and Translate tools, see Chapter 16: Transformations on page 351.

For more information about the Move Point tool, see Chapter 5: Manipulating Components in the Modeling & Deformations guide.

Transforming Elements in Ref Mode

Ref is an XYZ mode like Global, Local, Object, and Par. If you are not using the SRT manipulators, the left, middle, and right mouse buttons correspond to the X, Y, and Z axes.

Rotating Elements in Ref Mode

When rotating elements in Ref mode, they orbit around the center of the active reference plane relative to the axes of the reference plane.

If you are not using the SRT manipulators:

• The left mouse button rotates elements about the X axis of the active reference plane.

• The middle mouse button rotates elements about the Y axis of the active reference plane.

• The right mouse button rotates elements about the Z axis of the active reference plane.

If you are using the SRT manipulators, the manipulator’s handles let you rotate about each axis directly. See Transforming Interactively with the SRT Manipulators on page 362.
Translating Elements and Moving Points in Ref Mode

When translating elements or moving points in Ref mode, they move along the axes of the active reference plane. If you are not using the SRT manipulators:

- The left mouse button translates elements along the X axis of the active reference plane.
- The middle mouse button translates elements along the Y axis of the active reference plane.
- The right mouse button translates elements along the Z axis of the active reference plane.

If you are using the SRT manipulators, the manipulator’s handles let you translate along each axis directly. See Transforming Interactively with the SRT Manipulators on page 362.

You can move elements closer or farther from the camera by translating along Z in Ref mode with the View plane.

Transforming Elements in Plane Mode

Plane is a drag mode like View. If you are not using the SRT manipulators, the mouse buttons rotate elements around the active reference plane’s normal or translate elements in the reference’s UV plane.

Rotating Elements in Plane Mode

When rotating elements in Plane mode, they spin about their own center relative to the normal axis of the active reference plane.

If you are not using the SRT manipulators:

- The left mouse button rotates elements slowly about the normal of the active reference plane.
- The middle mouse button rotates elements at a medium speed about the normal of the active reference plane.
- The right mouse button rotates elements quickly about the normal of the active reference plane.

The plane’s normal is usually its Y axis, but you can change this by setting the Plane Normal parameter on the Pose tab of the active reference’s property editor—see Reference Plane Options on page 416.

If you are using the SRT manipulators, the manipulator’s handles let you rotate about each axis directly. See Transforming Interactively with the SRT Manipulators on page 362.
Translating Elements and Moving Points in Plane Mode

When translating elements or moving points in Plane mode, they move relative to the axes of the active reference plane.

If you are not using the SRT manipulators:

- The left mouse button drags elements across the UV plane.
- The middle mouse button translates elements up and down along the V axis of the active reference plane.
- The right mouse button translates elements side to side along the U axis of the active reference plane.

The UV plane is usually the XZ plane, but you can change this by setting the **Plane Normal** parameter on the Pose tab of the active reference's property editor—see Reference Plane Options on page 416.

If you are using the SRT manipulators, the manipulator's handles let you translate along each axis directly. See Transforming Interactively with the SRT Manipulators on page 362.
Reference Plane Options

You can set various properties of reference planes. For example, you can set some display options or give meaningful names to the permanent reference planes stored in your scene.

To set the properties of the current reference plane

1. Do one of the following to open the property editor of the current reference plane:
   - Right-click on Ref or Plane and choose Current Reference Properties.
   - Choose Transform > Reference Planes > Current Reference Properties.

2. Set the following properties:
   - The Name can be changed only for permanent reference planes, not for default or transient planes.
   - Cell Size/Snapping Increments control the visible grid used for snapping when translating in Plane mode. (Ref mode uses the Snap Increments that you can access using Transform > Transform Preferences.) For more information about snapping in general, see Chapter 18: Snapping on page 417.
   - The Display options control how the reference plane is represented in Plane mode.
   - The Scaling Orientation, Scaling, Rotation, and Position parameters on the Pose tab control the transformation of permanent and transient reference planes in global space. You can modify these options if desired, but it's probably easier to position an object in your scene and use it to define a new reference plane.
   - The Plane Normal option controls which axis is considered the normal and which plane is considered UV: X Axis (UV = YZ), Y Axis (UV = XZ), or Z Axis (UV = XY).
Chapter 18  Snapping
Snapping lets you align components and objects when moving or adding them. There are two kinds of snapping in XSI:

- You can snap to targets like objects, components, or grid intersections. See Snapping to Targets on page 419. In addition, you can:
  - Define the types of target to which you want to snap.
  - Set various options, for example, to control snapping in depth and other things.
  - Set the grid size when snapping to the grid.
- You can snap by increments. See Incremental Snapping on page 429.
Snapping to Targets

Target snapping lets you align elements with targets while manipulating or drawing them. Targets are the elements to which you can snap, such as points, centers, or grid intersections. You can use the target snap feature in conjunction with several different tools, such as Move Point and Add Point. You can define the target types, subtypes, and filters, as well as set other snap options.

Overview of Target Snapping

To snap elements to targets, you simply need to activate snapping. If necessary, you can define the targets to which to snap as described in Defining Targets on page 421. Targets are defined by their type and subtype. In addition, you can use a filter to further refine the valid targets.

You can also set various snapping options as described in Setting Options for Snapping to Targets on page 424, as well as set the grid size as described in Controlling Grid Size for Snapping on page 427.

To activate and deactivate snapping

- Do one of the following:
  - Click the On button in the Snap panel.
  - To temporarily turn snapping on or off, press the Ctrl key while manipulating the mouse.

With snapping on, you can use any tool that supports snapping—for example, translate an object or draw a curve. A box appears around the mouse pointer, indicating the current Region Size.

As you drag the mouse, the element you are manipulating snaps to targets within the snap region. The target subtype is displayed below the snap region—this is useful to distinguish targets when multiple types and subtypes are active.

When translating, the point that snaps to the target is the pivot. This is normally an object’s center (if COG is off) or the center of geometry (if COG is on for any type of element, or if Transform > Collapse Points When Snapping is on in the case of points only). However, you can set the pivot manually as described in Setting the Manipulation Pivot on page 360.
When snapping is on, the various manipulation modes (Global, Local, View, Par, Object, Ref, and Plane) change behavior.

When snapping to targets other than the grid:
- You can drag freely in the plane of the 3D view’s camera.
- If you restrict the manipulation to specific axes, those axes are projected onto the camera plane.
- When a target is found in a perspective view, the element snaps to it in 3D space.
- When a target is found in an orthographic view, the behavior depends on an option—see Use 2D Snapping in Orthographic Views on page 426.

When snapping to the grid, the different manipulation modes use different grids. See Controlling Grid Size for Snapping on page 427.

You can snap objects and components to targets while using many tools:
- The Translate tool, activated by pressing v or by clicking the t icon on the Transform panel.
- The Move Point tool, activated by pressing m or by choosing Modify > Component > Move Point Tool from the Model toolbar.
- The Add Point tool, activated by pressing Ctrl+Insert or by choosing Modify > Curve > Add Point Tool from the Model toolbar.
- The Add Polygon tool, activated by pressing n or by choosing Modify > Poly. Mesh > Add Polygon Tool from the Model toolbar.
- The Split Polygon tool, activated by choosing Modify > Poly. Mesh > Split Polygon Tool from the Model toolbar.
- The Duplicate tool, activated by pressing d or choosing Edit > Duplicate/Instantiate > Duplicate Tool.
- The 2D Chain and 3D Chain tools, activated by choosing Create > Skeleton > 2D Chain or 3D Chain from the Model or Animate toolbars.

Note that for 2D chains, snapping works only for the first two bones. After that, subsequent bones are forced to remain in the plane defined by the first two bones.
- The Move Joint/Branch tool, activated by choosing Create > Skeleton > Move Joint/Branch from the Model or Animate toolbars.
Defining Targets

The snapping targets are the objects and components to which you want to snap, such as points, object centers, or grid intersections.

To define the targets
- Use the Snap panel:
  - To quickly toggle a single option, use the icons on the Snap panel or the items on the Snap menu.
  - To set several options at the same time, it may be more convenient to display the Snapping preferences by choosing Snap > Snap Options.

You define the snapping targets by specifying the types, subtypes, and filters. All these settings combine to define the elements to which things snap. For example, to snap to polygonal edges, the type Segments and the subtype Edges must both be on, and the filter must be set to either All Objects or Polygon Meshes.

You can restrict the targets further as described in Snap to Tagged Components Only on page 425.

If you set multiple snap targets—such as Points and Midpoints—you may find it difficult to control which target gets snapped to. In these cases you can reduce the Region Size as described on page 424.

Target Types

You can activate and deactivate multiple target types independently. The target types provide a way to quickly allow or disallow categories of target subtypes. When a target type is off, none of its subtypes are valid targets for snapping, but when a target type is on, any of its subtypes can be targets (if they are also on).

- **Points** include zero-dimensional target subtypes such as points, midpoints, knots, and centers.
- **Segments** include one-dimensional target subtypes such as polygonal edges, curve objects, surface knot curves, and surface boundaries.
- **Facets** include two-dimensional target subtypes such as polygons and subsurfaces.
- **Grid** includes the global coordinate grid and the camera viewing plane, as well as any arbitrary reference planes that you define. You can also define the size of the grid cells as described in Controlling Grid Size for Snapping on page 427.

To turn a target type on or off
- Click its corresponding icon on the Snap panel.
To turn a target type on and simultaneously turn all the others off

- Ctrl+click or middle-click on its icon.

To set target subtypes

- Right-click the icon and select a subtype.

Target Subtypes

Within each target type, there are several available subtypes. You can activate and deactivate multiple subtypes independently. For example, you can choose to snap to knots without snapping to control points.

To be a valid target, a subtype must be on and its associated type must also be on. For example, to snap to edges, both the Edges subtype and the Segments type must be on.

The following subtypes are available under Snap > Target Points or by right-clicking on the Points button:

- Points include the control points or NURBS curves and surfaces, the vertices of polygon meshes, the control points of lattices, and particles. This is the equivalent of the Magnet option of a viewport’s Layout dialog box in SOFTIMAGE|3D.

- Knots include the knots of NURBS curves and surfaces.

- Centers include the center of any object.

- Midpoints include the midpoint of polygons and polygonal edges.

The following subtypes are available under Snap > Target Segments or by right-clicking on the Segments button:

- Edges include edges on polygon mesh objects.

- Curves include NURBS curve objects.

- U and V Knot Curves are the knot curves in the corresponding direction on NURBS surfaces.

- Boundaries include the boundary curves on NURBS surfaces.

The following subtypes are available under Snap > Target Facets or by right-clicking on the Facets button:

- Faces are polygons. Note that you cannot snap to invisible polygons.

- Surfaces include NURBS surfaces as well as subsurfaces on surface mesh objects.
When the Grid target type is on, you can choose the global coordinate grid or a specific reference plane. For more information, see Controlling Grid Size for Snapping on page 427.

- You can press Shift to keep menus open while you toggle multiple options.
- You can use the facet snap target types to place points on the surface of NURBS and polygon mesh objects, similar to SlidePoints in SOFTIMAGE|3D.

Filters

The snap filters further refine the snap targets specified by the type and subtype. You can specify All Objects or any combination of the following:

- Nulls/Chains works only with the Centers subtype.
- Polygon Meshes activates snapping to components on polygon mesh objects.
- NURBS Curves activates snapping to components on curve objects.
- NURBS Surfaces activates snapping to components on surface objects.
- Lattices works only with the Points and Centers subtypes.
- Particles works only with the Points and Centers subtypes.
- Hair works only with the Points and Centers subtypes.

For example, to snap only to vertices on polygon meshes and not to points on other objects, turn on the Points type and Points subtype and activate the Polygon Meshes filter.
Setting Options for Snapping to Targets

In addition to the targets, there are several other snap options that you can set. They affect the behavior of snapping in different ways, and can be set independently of each other.

All of these options are available on the Snap menu, as well as on the Options tab of the Snapping preferences that opens when you choose Snap > Snap Options.

Use Region for Snapping

The snapping region is a box around the mouse pointer that defines the targets to which elements can snap. The element you are moving or adding will snap to a target only when the target is within this box.

If you deactivate the region, elements snap to the closest target no matter how far away it is on screen. Note that deactivating the region can slow down snapping on large scenes because all visible objects must be tested for snapping.

To activate or deactivate the region

- Do one of the following:
  - On the Snap panel, choose Snap > Snap Options to display the Snap Option property editor. On the Options page, toggle Use Region for Snapping on or off.
  - On the Snap panel, choose Snap > Snap Region Size > None to deactivate the region or a numeric value to activate it.

Region Size

The Region Size is the size of the snapping box around the mouse pointer. The size is defined in pixels, so it is larger in Softimage units when you are zoomed out than when you are zoomed in.

The Snap Region Size is also used when welding vertices on polygon meshes interactively.

To set the region size

- Do any of the following:
  - On the Snap panel, choose Snap > Snap Region Size and choose a predefined value. Note that the value None turns off the region.
  - Or
- On the Snap panel, choose **Snap > Snap Options** to display the Snap Option property editor. On the Options page, set the **Region Size** to the desired number of pixels.

  or

- If you are using a mouse with a wheel, roll the wheel while pressing the **Ctrl** key.

The new region size is reflected by the box around the mouse pointer.

**Snap to Unselected Objects Only**

The **Snap to Unselected Objects Only** option prevents components from snapping to other components on the same object.

You can activate this option, for example, if you want to snap an object’s center to a point on another object while preventing the center from accidentally snapping one of the object’s own points.

**Snap to Tagged Components Only**

The **Snap to Tagged Components Only** option restricts the targets to the last set of components of a given type that were tagged (selected) on an object.

You can tag components such as points on the target object beforehand, and then when you move an element such as component on another object, it will snap only to those points.

**To snap to tagged components**

1. Select components on the target object.
2. Turn **Snap > Snap to Tagged Components Only** on.
3. Set the snapping targets and other options as desired.
   
   For example, if you want to snap to selected points on a polygon mesh, make sure that the Points target type is on, that the Points target subtype is on, and that the filter is set to All Objects or Polygon Meshes.
4. Activate snapping, and then use any tool that supports snapping. The element you are manipulating snaps only to the components you selected on the target object, and ignores unselected components. The tagged points on the unselected object are highlighted for reference.
Use 2D Snapping in Orthographic Views

The Use 2D Snapping in Orthographic Views option snaps an element only in its own plane with respect to an orthographic camera when manipulating in View mode.

When this option is on:

- An element’s Y position is not affected when snapping in the Top view.
- Its Z position is not affected when snapping in the Front view.
- Its X position is not affected when snapping in the Right view, and so on.

When this option is off, elements snap in depth in the orthographic views, except when snapping to the grid.

Perspective views always snap in depth in View mode.

Snap to Closest Segments/Midpoints Only

The Snap to Closest Segments/Midpoints Only option prevents elements from snapping to elements that are facing away from the camera as determined by the direction of their normals. This option applies only when snapping to midpoints, edges, or knot curves on closed shapes.

Snap to Visible Grid in Camera Views

The Snap to Visible Grid in Camera Views option snaps to the floor grid instead of the view plane grid when snapping to the grid in perspective views.

When this option is off, the snapping plane passes through the camera interest and is parallel to the viewing plane—as you manipulate elements, an overlaid orange grid shows the target grid.
Controlling Grid Size for Snapping

When snapping to the grid, elements snap to intersections of the grid lines. You can control the spacing of the intersections by setting the size of the cells between lines. For example, this would be useful if you wanted to place rivets at precise intervals along a metal plate.

The grid that is active for snapping depends on the manipulation mode:

- The XYZ manipulation modes—Global, Local, Par, Object, and Ref—use the **Snap Increments** set in the Transform preferences. They do not use the visible floor/grid displayed in 3D views.
- View mode uses the **Floor/Grid Setup** set in the Camera Visibility property editor.
- Plane mode uses the **Snap Size** set in the Reference Plane property editor.

### Setting the Grid Snapping Increments for XYZ Modes

When snapping to the grid in Global, Local, Par, Object, and Ref modes, the **Snap Increments** options in the Transform preferences are used. The visible floor/grid that is displayed in the 3D views is not used for snapping in the XYZ modes. However, you can copy the Snap Increment values to and from the visible floor/grid display of a 3D view—this lets you maintain a visual reference for the active grid when using XYZ modes. Whenever the grid for snapping does not match the displayed floor/grid, an orange snapping grid is overlaid on the view.

**To set the grid snapping increments for XYZ modes**

1. Open the Transform preferences by choosing **Transform > Transform Preferences**.
2. Set **Snap Increments - Translate**. Values are in Softimage units.
   
   When snapping to the grid in Global, Local, Par, Object, or Ref mode, the element you are manipulating will snap at exact multiples of the new value.

**To copy the visible grid increments to the grid snapping increments**

1. Open the Camera Visibility property editor.
   - To do this for a single 3D view, press Shift+s while the mouse pointer is over the view, or click the eye icon (Show menu) and choose **Visibility Options**.
   - To do this for all open 3D views, choose **View > Visibility Options (All Cameras)** from the main menu bar.
2. On the Visual Cues tab, set the **U** and **V Snap Size** under **Floor/Grid Setup** if necessary. Values are in Softimage units.
3. Click **Copy to Translate Snap Increments**.
The U Snap Size value is copied to the Snap Increments - Translate parameter of the Transform preferences.

When snapping to the grid in Global, Local, Par, Object, or Ref mode, the element you are manipulating will snap at exact multiples of the new Snap Increments - Translate value.

**To copy the visible grid increments from the grid snapping increments**

1. Open the Camera Visibility property editor.
   - To do this for a single 3D view, press Shift+s while the mouse pointer is over the view, or click the eye icon (Show menu) and choose Visibility Options.
   - To do this for all open 3D views, choose View > Visibility Options (All Cameras) from the main menu bar.

2. Click Copy from Translate Snap Increments.
   
   The value of the Snap Increments - Translate parameter in the Transform preferences is copied to the U and V Snap Size parameters.
   
   The visible floor/grid in the view port updates with the new cell size, which now reflects the grid used for snapping in Global, Local, Par, Object, or Ref mode.

**Setting the Grid Snapping Increments for View Mode**

When snapping to the grid in View mode, the settings under Floor/Grid Setup on the Visual Cues tab of the Camera Visibility property of the corresponding 3D view are used.

**To set the grid snapping increments for View mode**

1. Open the Camera Visibility property editor.
   - To do this for a single 3D view, press Shift+s while the mouse pointer is over the view, or click the eye icon (Show menu) and choose Visibility Options.
   - To do this for all open 3D views, choose View > Visibility Options (All Cameras) from the main menu bar.

2. On the Visual Cues tab, set the U and V Snap Size under Floor/Grid Setup. Values are in Softimage units.
   
   When snapping to the grid in View mode, the element you are manipulating snaps to exact multiples of the snap size.
Setting the Grid Snapping Increments for Plane Mode

When snapping to the grid in Plane mode, the Snap Size values set in the Reference Plane property editor are used.

To set the grid snapping increments for Plane mode
1. Open the property editor of the current reference plane by right-clicking on Plane and choosing Current Reference Properties.
2. Set the U and V Snap Size.
   When snapping to the grid in Plane mode, the element you are manipulating will snap at exact multiples of the new value.

Incremental Snapping

When translating, rotating, and scaling elements, you can snap incrementally. Instead of snapping to a target, elements jump in discrete increments from their current values. This is useful if you want to move an element by exact multiples of a certain value, but keep it offset from the global grid.

If both incremental and target snapping are active at the same time, incremental snapping takes priority.

To snap incrementally
- Do one of the following:
  - Press Shift while rotating or translating an element.
  - Press Ctrl while scaling (Shift is used for scaling uniformly).

To set options for incremental snapping
- Choose Transform > Transform Preferences.
  - For translation, objects and components jump by whole multiples of the Snap Increments - Translate value in Softimage units.
  - For rotation, the angle jumps by increments of the Snap Increments - Rotate value in degrees.
  - For scaling, the factor jumps by multiples of the Snap Increments - Scale value.
Chapter 18 • Snapping
Section IV • Data Management
Chapter 19  Data Management in XSI
Data Management in XSI

This chapter introduces some of the underlying concepts of data management in SOFTIMAGE|XSI. It describes:

- Where different types of files get stored.
- How to set a workgroup path for shared customizations.
- How to associate scene elements with thumbnail images for visual representation.
Where Files Get Stored

There are two types of files in SOFTIMAGE|XSI: project files and application data files.

Project files include scenes as well as any accompanying files such as texture images, referenced models, cached simulations, rendered pictures, and so on. They are stored in various subfolders of a main project folder. For more information about projects and project files, see Chapter 21: Projects on page 463.

Application data files are not specific to a single project. They include presets and various customizations you can make or install, such as commands, keyboard mappings, toolbars, shelves, views, layouts, plug-ins, add-ons, and so on. The application data files can be stored in various subfolders at one of three locations:

- **User** is the location for your personal customizations. Typically, it is C:\users\username\Softimage\XSI_4.0 on Windows or ~/Softimage/XSI_4.0 on Linux.

- **Workgroup** is the location for customizations that are shared among a group of users working on the same local area network. For information about setting a workgroup, see Setting a Workgroup on page 436.

- **Installation (Factory)** is the location for presets and sample customizations that ship with SOFTIMAGE|XSI. It is located in the directory where the XSI program files are installed. It is not recommended that you store your own customizations here.

When using the browser to access files on disk, you can switch among these three locations using the **Paths** button.
Setting a Workgroup

Workgroups provide a method for easily sharing customizations among a group of people working on the same project. Simply set your workgroup path to a shared location on your local network, and you can take advantage of any presets, plug-ins, add-ons, shaders, toolbars, views, and layouts that are installed there.

The workgroup is usually created by a technical director or site supervisor. For information about creating workgroups, see Chapter 1: Customization in XSI in the Customization guide.

- When you first connect to the workgroup, make sure you have permission to install software on your machine (write access to the HKEY_LOCAL_MACHINE section of the registry). Otherwise, SPDL files in the workgroup are not installed and hence not accessible. You also require this permission each time new SPDLs are installed to the workgroup (whether alone or as part of an add-on).
- If there are any problems with SPDL files not working over the workgroup, delete the `\Application\spdl.xsiindex` file in the user directory. This causes a more complete reinstallation of the workgroup SPDL files when XSI is restarted.
- In some situations, antivirus software can interfere with SPDL registration.
- Custom commands and events stored in the workgroup path will not work unless your environment is homogeneous—that is, all Windows or all Linux.
- You should not use an existing user or factory path for the workgroup.
To set the workgroup path

1. Open the Preferences window by choosing File > Preferences.
2. Click Data Management.
3. Enter the path of one or more existing workgroups in Workgroup(s).
   - Multiple workgroup paths must be separated by semicolons (;).
   - If elements with the same name appear in more than one location, the first location in the list has priority.
   - The first workgroup in the list is the default path for new elements, and is the path that is used when you choose Workgroup Application from the Paths button in the browser.
   - Any shared mental ray shaders must be installed in the first path listed.
   - You can disable a path without removing the string by putting an exclamation mark (!) at the beginning.
4. Exit and restart XSI.
Setting Thumbnails

When you work with images in XSI, many views display thumbnails of your scenes’ image clips, and sometimes of external images. This makes it easy to identify and select specific images from those views.

You can achieve the same thing for other scene elements by setting thumbnails for them. This is especially useful when you want to make things like shapes, scripts, materials, and so on available from a custom shelf or toolbar.

Several of XSI’s relational views display thumbnails, including the shape explorer (see Chapter 4: Shape Animation in the Nonlinear Animation guide), the material and texture explorer (see Chapter 3: Materials and Surface Shaders in the Shaders, Lights & Cameras guide), the material editor (see Chapter 3: Materials and Surface Shaders in the Shaders, Lights & Cameras guide), and the thumbnail viewer, described on page 440 of this guide.

Most scene elements can have thumbnails. As a general rule, if an element can be renamed, you can assign a thumbnail to it.

- Elements that *can* have thumbnails include: objects, cameras, lights, nulls, materials, groups, models, shapes, mixers, and so on.
- Elements that *cannot* have thumbnails include: operators, properties, parameters, and so on.

Finding Your Thumbnails

All thumbnails are stored in the project’s Thumbnails folder. When you set a thumbnail for a scene element, the thumbnail image is either created in or copied to that folder.

Projects created in older versions of XSI do not have a Thumbnails folder. The folder is created automatically when you first set a thumbnail for an element in one of the project’s scenes.
Assigning Thumbnails to Scene Elements

You can set thumbnails for scene elements in one of two ways:

- By setting an existing image as the thumbnail for one or more elements. The image is copied to the project’s Thumbnails folder.

  or

- By creating a thumbnail for one or more elements from the render region. The new image is added to the project’s Thumbnails folder.

To use an existing image as a thumbnail

1. Open an explorer (press 8).
2. Right-click the object for which you want to set a thumbnail and choose Set Thumbnail from the menu.
3. From the browser that opens, select the image that you wish to use as a thumbnail and click OK.

   The image is set as the object’s thumbnail. A copy of the image is added to the project’s Thumbnail directory.

To create a thumbnail from the render region

1. Draw a render region in any 3D view.
2. Open an explorer (press 8).
3. Right-click the object for which you want to set a thumbnail and choose Set Thumbnail From Region from the menu.
4. From the browser that opens, enter a name and file format for the new thumbnail image and click OK.

   You don’t need to set a path. The image is automatically added to the project’s Thumbnail directory and set as the object’s thumbnail.

Managing the Size of Thumbnails

Thumbnails are not tied to the image proxy generation options that you set in the rendering preferences. The images stored in the Thumbnails directory are full-size, and are only scaled down when they are displayed. Using large images as thumbnails can slow performance when the thumbnails are displayed.

If you have large images that you wish to use as thumbnails, it’s a good idea to create scaled-down copies first.
Viewing Thumbnails in the Thumbnail Viewer

The thumbnail viewer is a relational view consisting of an explorer in the left pane and a shelf in the right pane. You can use it to display the thumbnails assigned to scene elements and then select those elements using their thumbnails to help you identify them.

To view thumbnails with the thumbnail viewer

1. Choose Application > Views > Thumbnail Viewer from the main menu.
2. In the thumbnail viewer, select one or more scene elements in the explorer pane.
   - The selected elements’ thumbnails are displayed in the shelf pane.
   - If any of the selected elements are groups, the thumbnails of all of the elements in each group are displayed in the shelf pane.
3. Select any thumbnail to select the object to which it’s assigned.

   The shelf view is not refreshed until you make another selection from the explorer pane, regardless of whether you make a new selection from another view (another explorer, a 3D view, and so on).
Chapter 20  Scenes
About Scenes

A scene file contains all the information necessary to identify and position all the models and their animation, lights, cameras, textures, and so on for rendering. All the elements are compiled into a single file with an .scn extension.

To save your work during a session, use the File > Save or Save As commands to update the existing one or create a new scene in your current project.

Referenced Files in Saved Scenes

Scenes can also reference many external files such as external models, texture images, action sources, and audio clips. Some of these referenced files may be located outside of your project structure. When you save a scene, the path information that lets XSI locate and refer to these external files is saved as well.

Referenced Models

Referenced models are models that have been created in and exported from XSI. When used in a scene, the exported model file is referenced by the scene. Changes made to the exported model are also reflected in your scene when the reference is updated. For more information on referenced models, see Using Referenced Models on page 483.

Importing Scenes

Scenes are created from scratch in XSI, but you can also import existing SOFTIMAGE|3D scenes. In addition, you can also load scene and object files from other 3D or CAD/CAM programs saved to the dotXSI™ or IGES formats and import them into XSI. For more information, see Chapter 24: Importing and Exporting on page 515.
Creating Scenes

Each time you start XSI or create a new project, a new scene is automatically generated. However, you can also create a new scene at any time while you are working. Because you cannot have more than one scene open at a time, you are prompted to save the current scene before you can create a new one.

To create a new scene in the current project

- Choose File > New Scene from the main menu or press Ctrl+n.
  
  If you have modified the scene that is currently open, you are prompted to save the changes.
  
  The new scene is created within the current project and its name appears as “Untitled” on the title bar.

To clear your workspace and create a new scene

- Choose Edit > Delete All from the Edit panel in the main command area or press Ctrl+Delete.
  
  This clears your workspace by resetting all viewports to their default settings and creates a new untitled scene in the current project.

To create a new scene in a different project

1. Choose File > Project Manager from the main menu.
2. Select a project in the Select a Project list box where you want to create the new scene.
3. In the Select a Scene list box, make sure New Scene is selected and click the New Scene button.
   
   The new scene is created in the selected project and its name appears as “Untitled” on the title bar.

Deleting Scenes

You can delete any of your scenes except for the one in which you are currently working. To delete your current scene, you must close it, open another scene, then delete the scene in the Project Manager.

To delete a scene

1. From the main menu, choose File > Project Manager. The Project Manager dialog box opens.
2. Select a project from the Select a Project list box.
3. Click the name of the scene to be deleted from the Select a Scene pane.
4. Click the Delete button to delete the selected scene.
Opening Scenes

You can only view one scene at a time in XSI. Before you open a different scene, you are prompted to save any changes made to the one that is open.

As the scene is loaded, XSI looks for all its referenced files using the files' full path names. If any file is not located using this method, XSI looks for the file name in the current project folder. If the file isn’t found here, the users path, then the workgroup paths, and finally the factory path is searched. If the file is still not located, then you must manually correct the file’s paths. It is therefore important to make sure that all the files you use in a scene are stored in a folder that XSI can easily locate. For more information, see Correcting External File Paths for Scenes on page 451.

To open a scene in a project that is not on your project list

If you open a scene in a project that is not on your project list, a dialog box prompts you to add the project to your list. Answer Yes or No as you like. In addition, the dialog box lets you specify the behavior when opening other files in the future:

- **Always Ask** continues to prompt you to add new projects to your list.
- **Always Add New Projects** automatically adds projects to your list without prompting.
- **Never Add New Projects** does not add new projects to your list. You can still add projects manually using the Project Manager.

You can also control this behavior by setting **Add New Projects to the Projects List** in your Data Management preferences.

To open a scene from the browser

1. Choose **File > Open** from the main menu.
2. In the browser, go to the location of the project file you want to load. You can use the **Up** button to locate folders at higher levels.
3. Select the scene file to be loaded (its name appears in the File Name text box) and click OK.
   
   You can also double-click the scene name and it opens.

To open a recently-used scene

- Select it from the **File > Recent Scenes** menu. This menu contains the last few scenes you worked on.
To open a scene from the Project Manager
1. Choose File > Project Manager from the main menu.
2. Select a project from the Select a Project list box.
3. In the Select a Scene list box, double-click on the scene you wish to work on or select the scene name and click the Open button.

To open a scene by dragging and dropping
- Drag and drop an XSI scene (*.scn) file from the XSI browser or a Windows Explorer onto the background of a 3D view to load and replace the current scene.
  - If you drag and drop using the Ctrl key, the scene is merged with the current scene (see page 448).
  - You cannot drag and drop scenes from external windows on Linux systems.

To open a scene from the command line
- Start XSI and load a specific scene (*.scn) file at startup. Type:
  ```
  XSI <scene_file_name.scn>
  ```

To open a scene with a particular version of XSI (Windows only)
If you have more than one version of XSI installed on your system, you can choose which version of XSI opens scenes when you double-click on an SCN (*.scn) file.
1. Double-click an SCN (*.scn) file.
   The XSI Chooser dialog box opens (if several versions of XSI exist and none have been set as default yet).
2. Select the version of XSI to associate to the .scn file.
3. XSI starts and loads the specified scene. (If only one version of XSI exists or a default version has already been set, XSI starts automatically).

You can also access the XSI Chooser from the Windows Start Menu and select a default version from there: choose Start > Programs > Softimage Products > XSIChooser.
Chapter 20 • Scenes

Opening Locked Scenes

When you open a scene file, a temporary “lock” file is created. The lock file is deleted when you close the scene.

Anyone else who opens the file in the meantime is given a warning that the file is currently in use. The purpose of the lock mechanism is to let you know that somebody else is already working on a scene, and to avoid concurrent saving which can lead to data lost.

You can still open a “locked” scene, but in this case, the scene is loaded as a “shared copy” (which is displayed in the XSI window title bar) and any changes you make to the file need to be saved under a different name.

Opening Scenes with Auxiliary Data

An auxiliary data file contains a sequence of values that can be set once a scene has finished loading. All parameters are set sequentially prior to registered OnEndSceneOpen events.

Auxiliary data is especially useful for batch rendering because it provides a simple way to modify various parameters of a scene without having to modify the scene file.

- An alternative to auxiliary data is the scene TOC file. One difference is that scene TOC data is specific to individual scenes, while auxiliary data applies to any scene. For more information about scene TOC files, see Modifying Scene Data with the Scene TOC on page 455.
- You cannot apply auxiliary data to SOFTIMAGE|3D scenes and models directly. You have to import the SOFTIMAGE|3D scene or model and save it in the XSI scene format first.

Defining an Auxiliary Data File

The auxiliary data file format is a plain ASCII file that must start with the following header:

```
XSI_AuxiliaryDataFile ASCII 1 0
```

The header identifies the file as a v1.0 Auxiliary data file in plain ASCII. At the moment, there is no other format but other file formats may be introduced in the future.

Lines following the header can be:

- Comments (lines starting with //).
  - Comments cannot be put anywhere else but on the start of a line, unlike C++ style comments.
- White space (carriage returns, tabs, or spaces).
Opening Scenes

- Parameters.
  Parameters use the same syntax as the argument of the XSI VBScript command `SetValue`. Every parameter in the auxiliary data file must fit on a single line.

For example, using the following line in your auxiliary file...

```
"Passes.Default_Pass.RenderOptions.EndFrame", 1
```

...has the same effect as calling this command in XSI:

```
SetValue "Passes.Default_Pass.RenderOptions.EndFrame", 1
```

Loading and Applying Auxiliary Data

To apply auxiliary data in XSI, you have to specify which file contains the values you want to set with the `-auxiliary_data` switch.

1. If your auxiliary data file is named `c:\myData.txt`, type the following at the command line:

   `xsi -auxiliary_data c:\myData.txt`

   This creates a new check box labeled Apply Auxiliary Data in the Open Scene dialog box.

2. Turn this option on to apply the auxiliary data when a scene is opened. This is a convenient way to test if your auxiliary data is applied correctly.

To apply auxiliary data with scripting

You can use scripting to apply previously loaded auxiliary data. For example, if you want to apply auxiliary data to your scene called `c:\MyProject\Scenes\MyScene.scn`, use the following command:

```
OpenScene "c:\MyProject\Scenes\MyScene.scn",,TRUE
```

Auxiliary data is not applied by default in both cases (through the interface and scripting).

To apply auxiliary data from the command line

You can apply auxiliary data automatically to a scene from the command line by typing either of these lines at the prompt:

```
xsi c:\MyProject\Scenes\MyScene.scn -auxiliary_data c:\myData.txt
```

or

```
XSIBatch -r -scene c:\MyProject\Scenes\MyScene.scn -auxiliary_data c:/myData.txt
```
Merging Scenes

You can combine objects in any number of XSI scenes by merging them. When you merge a scene into the current scene, it is automatically loaded as a model. This ensures that the names of objects being merged into the scene are preserved—because each model maintains its own namespace, there is no need to append prefixes to ensure that object names are unique. For more information about models, see Chapter 22: Models on page 473.

When you merge a scene created with a previous version of XSI, the scene's ambience may be changed. For more information about ambience, see Setting a Scene's Ambience in Chapter 13 in the Shaders, Lights & Cameras guide.

When you merge one scene into another, light associations are not updated automatically. If you have inclusive or exclusive lights, you should modify their lists of associated objects to get the effect you want. For more information about light associations, see Using Selective Lights in Chapter 13 in the Shaders, Lights & Cameras guide.

To merge a scene into the current scene
1. Open an XSI scene.
2. From the main menu, choose File > Merge.
3. In the browser that appears, locate and select the XSI scene that you want to merge, then click OK. The Model property editor opens.
4. Specify a Name for the model, as well as whether the model's storage is Internal or External.

   If you don’t want the elements of the merged scene to be a separate model, you can “unparent” the model's children using either the Cut button on the Constrain panel or by dragging and dropping their nodes in the explorer, then deleting the model node.

To merge an XSI scene by dragging and dropping

- Press the Ctrl key as you drag and drop an XSI scene (*.scn) file from the XSI browser or a Windows Explorer onto the background of a 3D view to merge it as a model with the current scene.

   You cannot drag and drop scenes from external windows on Linux systems.
Image Clips and Merged Scenes

When you merge an XSI scene into another scene using **File > Merge**, the default is to share image clips. This means that if any image clips (for example, textures) on any model(s) in the merged scene are the same as clips that are already in the current scene, then the existing clips are automatically reused. This prevents unnecessary image clips from accumulating in your scene.

The rules for sharing image sources/clips are as follows:

- For all model types, identical image sources are always shared.
- Two clips are considered to be the same if they share the same image source and the same parameter values. Animated parameters are ignored.
- Local models will not share clips that are already used by, and therefore locked by, referenced models.
- Referenced models will only share clips that are already used and locked by other referenced models, or clips that are currently unused.

In some situations, you might not want to automatically share image clips. For example, you might have animated the clip parameters differently and you want to keep the different animations. In these cases, you can use the **MergeScene** command in the script editor to specify **0** for the **ShareOptions** parameter. For example in VBScript:

```vbscript
ImportModel filename.emdl, , True, , , 0
```

For more information about the syntax of the ImportModel command and other ShareOptions values, refer to the **SDK** documentation by pressing F1 or clicking **?** in the command bar of the script editor.

For more information about image clips and sources, see Chapter 6: Clips & Sources in the Shaders, Lights & Cameras guide.
Saving Scenes

All scenes are saved as a single file with an .scn extension. The scene contains any models, 3D objects, lights, cameras, animation, rendering options, effects (including shaders, textures, and shader assignments), and render passes that you have applied.

To save a scene

1. Choose File > Save from the main menu.
   If the scene has already been named, any changes are saved to the same file name. If the scene does not have a name (untitled), the Save Scene browser opens.
2. Enter a unique name for your scene in the File Name text box.
3. Use the path navigation buttons to locate the folder where you want to save your scene. It is recommended, however, that you save scenes to the Scenes folder of the project.
4. Click OK.

Saving Scenes with a Different Name

In some cases, you may want to create a copy of a scene and save it with a different name. This can be helpful when you want to test a more complex rendering effect before committing it to the actual scene.

To save a scene under a different name

1. Choose File > Save As from the main menu to open the Save As dialog box.
2. Type another name for the scene in the File Name browser and click OK.
   The new scene name is displayed on the title bar. The original scene remains unchanged in its most recently saved form.

Saving Scenes to a Different Project

You can save a scene from one project to another:

1. Open an XSI scene.
2. Choose File > Save As from the main menu to open the Save As dialog box.
3. Navigate to the location of the new project and save the scene with the same name into its Scenes folder.
4. Select the Copy External Files Under Project option. See the next section for details.
Copying Referenced Files Under Project

You can copy all external referenced files to the current project. This is particularly useful when you send project files to other users who otherwise cannot access the referenced files themselves. Or, you may have saved a scene to a different project and want all the referenced files used in that scene to be copied to the new project.

To copy referenced files into the current project
1. Choose File > Save As from the main menu.
2. In the Save As dialog box, select Copy External Files under Project and click OK.
   
   This scans your project and copies any referenced files such as textures, action sources, or audio files used in your scene to the new project.

Correcting External File Paths for Scenes

Each time you open or import a scene, XSI attempts to locate the external files (such as picture files, audio files, etc.) associated with the scene. You may need to update the path of a referenced file or locate missing files in scenes.

To locate and correct missing referenced files in scenes
1. Do one of the following:
   - Open the Application node's property editor to display a reference list that includes the paths of all external files referenced by the project.
   or
   - Choose File > Source Paths from the main menu to open the Project property editor.
   
   All referenced files and their paths are listed. The Resolved Path column lists the full paths as interpreted from the relative path entries in the File Path column. If a file cannot be found, the word “Invalid” appears in the Status column.

2. Click the name of the invalid file and modify its path or file name to resolve the error, or click Browse Selected Path to search for the file.

Modifying Multiple File Paths

If you have renamed or moved a directory containing external files, or changed your naming convention for referenced files (for example, changing all your existing images from clock1.pic, clock2.pic, etc. to clock01.pic, clock02.pic, etc.), you can modify the file paths of several files at once by clicking Search and Replace All. This opens the Search and Replace dialog box in which you can change parts of the path and file names globally.
To modify many file paths at once

1. Choose File > Source Paths from the main menu.
2. In the Project property editor that opens, click the Search and Replace button.
3. In the Search and Replace dialog box that opens, choose your settings:
   - In the File Category text box, select the type of files whose entries you want to modify (for example, All, Image, Audio, Script).
   - In the Old String text box, enter the text string to search for in the existing path and file names.
   - In the New String text box, enter the replacement text.
   - Check the Case Sensitive check box if you want to search and replace using the specific capitalization you've entered.
4. Click OK.
Displaying Scene Information

You can obtain important statistics for your scene and its elements in the Info Scene dialog box. This information can be helpful when evaluating a scene's complexity for the purpose of optimization.

To get scene information

- Choose Edit > Info Scene from the Edit panel on the main command area or press Ctrl+Enter.

  - The Objects tab displays the total number of objects in the scene. You can also get totals for specific object types such as polygon meshes and surface meshes, models, lights, cameras, nulls, and chain elements.

  - The Components tab displays the total number of triangles, points, segments (edges), facets (polygons and surfaces in surface meshes), and particles in the scene.

  - The Animation tab displays the total number of constraints, mixers, and animation sources in the scene.

  - The Rendering tab displays the total number of render passes, materials, image sources and clips in the scene. The name of the current pass is also shown, as well as an estimate of the total memory consumption of the various image clips.

  - The Project tab displays a list of external files used in the scene. In its Resolved Path text box, you can update a file's path if its location changed since you first loaded the file into the scene. For more information, see Correcting External File Paths for Scenes on page 451.

Displaying Information for Selected Scene Elements

You can also get specific information on your current selection in the Info Selection dialog box. Depending on the type of object you select, you can get a variety of information—even for single or multiple–selected objects.

To get information on a selection

1. Select an object (or multiple objects) for which you want information.

2. Choose Edit > Info Selection from the Edit panel on the main command area or press Shift+Enter.

   The Info Selection tab displays object name (which you can edit directly in the text box for a single selection); object type and family; number and type of components in the selection; whether it is a part of a hierarchy (name of children and parent object); and the name of the layer and partition in which it resides.

   In the case of a multiple selection, the name field is shown as <multi> and the number of objects in the selection is displayed in the Selection field.
Chapter 20  •  Scenes

Getting the Scene Version

The version of XSI used to create a particular scene is logged when loading the scene.

To display scene version information

1. Choose File > Open from the main menu and load an XSI scene.
2. Click the script editor icon next to the command box below the timeline to open the script editor.
3. In the script editor's history pane, look for the first INFO line logged to get version information.

You can also get version information using the printver standalone which outputs the XSI version used to last save a scene (.scn) file or an exported model (.emdl) file without opening SOFTIMAGE|XSI.

For more information see Getting Scene Version Information in the Standalones guide available on the Documentation CD.
Modifying Scene Data with the Scene TOC

The scene TOC (scene table of contents) is an XML-based file that contains scene information. It has an extension of .scntoc with the same name and in the same folder as the corresponding scene file.

When you open a scene file, XSI looks for a corresponding scene TOC file. If it is found, XSI automatically applies the information it contains.

This lets you use a text editor or XML editor to do any of the following:

- Change the path for external files such as texture images, referenced models, audio, or actions.
- Change render options.
- Change the current render pass.
- Run a script automatically after loading the scene.

An alternative to scene TOC files is auxiliary data. One difference is that scene TOC data is specific to individual scenes while auxiliary data applies to any scene. For more information about auxiliary data, see Opening Scenes with Auxiliary Data on page 446.

Enabling Scene TOC Files

When you enable scene TOC files, XSI saves the current scene information to the scene TOC file every time you save the scene. You can then modify the scene TOC file in a text editor or XML editor, and the modifications are automatically applied the next time the scene is opened.

To automatically generate the scene TOC files when a scene is saved

1. Choose File > Preferences from the main menu.
2. In the Preferences window, select Data Management.
3. Activate the Create scene TOC (Table of Contents) file option.

Disabling Scene TOC Files

You can turn off the generation of the scene TOC file at any time. The next time you save the scene, the TOC file's extension is changed from .scntoc to .scntocObsolete so that it will be ignored when you reopen the scene.

To disable the generation of scene TOC files

1. Choose File > Preferences from the main menu.
2. In the Preferences window, select Data Management.
3. Deactivate the Create scene TOC (Table of Contents) file option.
Modifying the Scene TOC

You can edit the scene TOC file outside of XSI using a text editor or XML editor. Any changes you make are automatically applied the next time the scene is opened.

The root <xsi_file> element has four child elements:

- <Sources> specifies the paths and file names of images, external actions, audio, and referenced models.
- <Passes> specifies the render options for every pass in the scene.
- <Parametersvalues> specifies the current (that is, active) render pass.
- <PostLoadScript> lets you write a script to be executed after the scene is loaded and after all other modifications in the scene TOC file have been applied.

In general, you can change the content of any element—that is, anything between the start and end tags. You should not change any attributes within the tags themselves.

Modifying Sources

You can change the contents of any source in the <Sources> section of the scene TOC file. For example, this lets you change the path of a texture file or even substitute textures. Do not change the source name attribute.

For example, you can change this:

```
<Image name="metal">\slowserver\myTexLib\dull.pic</Image>
```

To this:

```
<Image name="metal">\fastserver\myTexLib\shiny.pic</Image>
```

The order of elements within <Sources> is not important. If you do not want to modify a particular source, you can remove the corresponding element; however, that element reappears the next time the scene TOC is saved.
Modifying Render Options

The `<Passes>` element of the Scene TOC file contains a `<Pass>` element for every render pass in the scene. Each `<Pass>` element has a `<RenderOptions>` element that contains the render options for that pass.

You can modify a render option for a specific pass by changing the contents of the corresponding element. For example, you can change this:

```
<StartFrame>1</StartFrame>
```

To this:

```
<StartFrame>24</StartFrame>
```

Note that some options are interdependent; for example, `<PictureRatio>` is related to `<CameraXRes>` and `<CameraYRes>`. In these cases, XSI applies the values in order and recalculates the others so the last value “wins.” You can change the priority by reordering the elements in `<RenderOptions>`.

If you do not want to change a render option, you can remove the corresponding element; however, that element reappears the next time the scene TOC is saved.

You cannot add a pass or change the name of an existing pass.

Modifying the Current Pass

The `<Parametersvalues>` element of the Scene TOC file lets you specify which render pass is current. For example, you can change this:

```
<Param name="Passes.current">Passes.Default_Pass</Param>
```

To this:

```
<Param name="Passes.current">Passes.Diffuse</Param>
```

You must specify the name of an existing pass in the scene.

Running Post Load Scripts

The `<PostLoadScript>` element of the scene TOC file lets you run a script procedure after the scene is loaded and after all other modifications (both in the TOC file and in the auxiliary data, if any) have been applied. It consists of three children: `<Language>`, `<Function>`, and `<Script_Content>`.
Chapter 20  •  Scenes

The `<Language>` element specifies the scripting language used. Depending on the languages available on your computer, you can specify any of the following:

- VBScript
- JScript
- PerlScript
- Python

For example:

```xml
<Language>VBScript</Language>
```

The `<Function>` element specifies the procedure to run. For example:

```xml
<Function>myPostLoadProc</Function>
```

The specified procedure must be declared in the `<Script_Content>` element. The `<Script_Content>` element can contain multiple procedures, and you can switch between them easily by changing `<Function>.

If there is any global code in the `<Script_Content>` element (that is, if there is code that is not contained in a subroutine or function), the global code is executed before the specified procedure. This is a side-effect of parsing the script.

Global code is also executed if you do not specify a procedure to run.

The `<Script_Content>` element contains the actual code to run. You should enclose the script in a CDATA section; this allows you to use characters that have special meaning in XML syntax, such as `<`, `>`, and `&`. For example, in VBScript:

```xml
<Script_Content>
<![CDATA[
    sub myPostLoadProc
    LogMessage "Running scene TOC postload script"
    end sub
]]>
</Script_Content>
```

As an alternative to using a script in the scene TOC file to modify values, you can use auxiliary data. One difference is that scene TOC data is specific to individual scenes, while auxiliary data applies to any scene. For more information about auxiliary data, see Opening Scenes with Auxiliary Data on page 446.
Back Up and Recover Your Work

XSI provides a number of ways of recovering your work if your system crashes. In most cases, you can easily recover your work by using the autosave and recovery mechanisms. You also have backup options that let you load previously saved versions of your scene if you want to backtrack and rework some of your content.

**Autosaving Scene Files**

The autosave options in your Data Management preferences let you activate the autosave feature and determine how frequently autosaves are made.

1. The autosaved scene file is created and maintained separately from the files you save while working. It is deleted when you exit XSI in a normal manner. You must still make sure to save your work each time you exit.
2. The autosaved scene file is maintained in the hidden System folder under the active project.

**To set autosave**

1. From the main menu, choose File > Preferences to open the Preferences window.
2. Click Data Management.
3. Activate the Enable Autosave option.

By default, autosave is set to save every 30 minutes, but you can change this time span in the Autosave Interval text box.

**Backing Up Saved Scenes**

Each time you save your scene, its file is automatically saved in a backup folder. This means you can go back and load an earlier version of your scene if needed. This can also come in handy if your scene file could not be automatically recovered.

The default number of backed-up scenes is four, but you can change this number (to a maximum of 100) in your Data Management preferences.

**To set backup preferences**

- Choose File > Preferences. Click Data Management and set the number of backups in the Number of Scene Backups text box.

- Set backups over a specified number of days with the Number of Backup Days to Keep option. This is useful if you save often and the last backed up version does not include the information you need. This option ensures that you can retrieve your work from the last backed up versions of the n previous days.

Make sure you have enough disk space so that your backup files are created successfully.
To reload a scene file from its backup folder

1. Choose File > Open and navigate to your backup folder. By default, this folder is called Backup and is located in your project folder. This folder contains all your saved scene files. These files are labeled (Myscene)_B1, (Myscene)_B2, (Myscene)_B3 etc., with (Myscene)_B1 being the most recently saved scene.

2. Select the required backup version and click OK to load the scene.

Recovering Scene Files

Recovering Scenes After a Crash

After a crash occurs, a dialog box usually opens indicating that your scene file has been successfully saved to an autosave or crash backup directory in the project’s System folder.

XSI first tries to load the autosave file (if the Autosave option is enabled); if not, it falls back on the default crashsave file. You can continue to use the scene after restarting XSI.

To recover a scene file after a system crash

1. Restart XSI after the crash. A dialog box opens asking if you want to try to recover the scene. Click Yes.

2. If the scene is recoverable, an untitled scene opens with your latest work retrieved from the crashsave or autosave process.

3. Save the scene under a new name and restart XSI.

Recovering a Scene with Corrupt Models

If a scene crashes when you try to open it, it may be that a single model is corrupt. You can try to recover the rest of the scene using the recovery journal file.

To recover a scene that crashes on opening

1. Choose File > Preferences to open the Preferences window.

2. Click Data Management.

3. Enter a file path and name in Load Recovery Journal File. For example:
   
   C:\Temp\xsi\recovery.txt

4. Restart XSI and open the scene.

   As XSI processes the scene, it writes to the file when it begins to load each model within the scene, and again after it loads each model successfully. If XSI crashes while loading a particular model, the journal file indicates that the model never finished loading.
5. Restart XSI and open the scene again.

XSI reads the journal file, and skips the model that failed to load in the previous attempt.

You may need to repeat this step several times if there are several corrupt models in the same scene.

6. Once you have successfully recovered as much of the scene as possible, clear the contents of the Load Recovery Journal File box to deactivate the option.

This speeds up the process of opening scenes because XSI does not need to read and write to the file. In addition, it allows XSI to load models with the same name as those that were skipped, such as if you later open a backup of your scene that was saved before the corruption occurred.

**Recovering a Scene with Corrupt Operators**

If you recovered a scene after crashing, it’s possible that some operators are corrupted and are causing instability. You can try to hunt down and remove the operators that are causing problems.

**To diagnose and fix operator corruption**

1. In your Data Management preferences, activate Disable all geometry operators on load.

2. Open the problematic scene. Note that all operators in the geometry, texture, and envelope stacks have been disabled.

3. Try to find the corrupt operator. For example, delete the last operator you added, and then re-enable the stack from the bottom to see if the problem goes away.

   For information about enabling operators in the stack, see Disabling the Top of the Stack in Chapter 3 of the Modeling & Deformations guide.

4. Once you have found the problem and deleted that operator, save the scene and press Ctrl+n to start a new scene.

5. Deactivate Disable all geometry operators on load. Do not keep working with this option on—it is a debugging tool only.

6. Re-open the scene. The operators are now active and you can continue working.
Recovering a Scene with Corrupt Polygon Meshes

If you are having problems with a scene, it's possible that some polygon meshes are corrupt. You can find these meshes and try to recover your work.

To diagnose and fix polygon mesh corruption

1. In your Data Management preferences, activate Detect corrupted polygon meshes upon load/freeze.
2. Open the problematic scene.
   
   If a corrupt mesh is found, the name of the object and the indices of the illegal components are logged in the command history and you are prompted to hide the mesh (to avoid potential crashes when drawing the corrupt mesh structure).

3. Unhide the object and select all its polygons.
   
   If you can’t unhide and select the polygons without crashing, try selecting all the polygons by typing the following into the name selection box in the Select panel:
   
   ```objectname.poly[*]```

   
   A new mesh object is created from the polygons of the corrupted mesh.

5. Freeze the new mesh object.
   
   If no new messages about corrupt components are logged, you have successfully fixed the corruption. Delete the original mesh.
   
   Otherwise, continue with the next step.

6. Try to recover part of your work by selecting the uncorrupted polygons (leaving out an area around the corrupt components) and then repeating steps 4 and 5. Unfortunately, some corrupt meshes cannot be recovered.

7. When you have finished, turn Detect corrupted polygon meshes upon load/freeze off to avoid slowdowns when loading scenes and models or freezing objects.
Chapter 21  Projects
Chapter 21  •  Projects

What’s a Project?

In SOFTIMAGE|XSI, you always work within the structure of a project. Projects are a system of folders that contain the scenes that you build and all the external files that are referenced in the scenes. A project can contain an unlimited number of scenes. Scene files can be recognized by their .scn filename extension.

A project is XSI’s equivalent of the SOFTIMAGE|3D database.

Projects are used to keep your work organized and provide a level of consistency that can be used to simplify production for a workgroup. A project can exist locally on your machine or shared from a network drive. For a movie, projects could be organized by scene or location. For a television series, you could organize projects by episode, act, or sequence director.

XSI can also import or export project lists, which are text files that list projects and their locations. Project lists can be imported or exported automatically, which can allow administrators to make new projects easily and automatically available to a production team.

The Project Manager

The Project Manager is the tool that lets you manage multiple projects and scenes. You can create new projects and scenes, open existing projects and scenes, scan your system for projects, and add and remove projects and scenes from a list of projects. To work in XSI, you must create a project or open an existing one.

To display the Project Manager

• Choose File > Project Manager from the main menu.

Pressing the Shift key when you start XSI opens up the project manager so that you can select a new project right away.
The Project Structure

A project is a system of folders that store and organize the different elements of your work. You can view the project structure from the XSI browser.

A set of subfolders are created in every new project. The browser opens by default to these folders when opening, saving, importing or exporting specific scene elements. The table below describes how these folders are used:

<table>
<thead>
<tr>
<th>Project folder</th>
<th>Type of files stored</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actions</td>
<td>External action sources saved in either ASCII or binary dotXSI format (<em>.xsi) or native XSI binary format (</em>.eani). See Creating External Action Sources in Chapter 3 of the Nonlinear Animation guide.</td>
</tr>
<tr>
<td>Audio</td>
<td>Audio clips used for synchronizing with animation. See the Nonlinear Animation guide.</td>
</tr>
<tr>
<td>Backup</td>
<td>Backed up scene files with the backup version appended to the file name. See Backing Up and Recovering Your Work on page 459.</td>
</tr>
<tr>
<td>Composites</td>
<td>Rendered images and sequences output from the File Output operator in the FX Tree. The Composites folder is created the first time that you insert a File Output operator in the FX Tree. See The FxTree in Chapter 6 of the Rendering &amp; Compositing guide.</td>
</tr>
<tr>
<td>dotXSI</td>
<td>Exported ASCII or binary format dotXSI files (*.xsi).</td>
</tr>
<tr>
<td>Expressions</td>
<td>Expression text files (*.expr2). See Saving and Loading Expressions in Chapter 10 of the Animation guide.</td>
</tr>
<tr>
<td>FCurves</td>
<td>Raw function curve files saved from the animation editor or the expressions editor (*.fraw2) or exported from SOFTIMAGE</td>
</tr>
</tbody>
</table>
## Project folder | Type of files stored
--- | ---
MatLib | External material library files saved in either ASCII or binary dotXSI format (*.xsi).
Models | Exported models (*.emdl).
Pictures | Texture images and sequences.
Queries | Custom queries for the spreadsheet.
Render_Pictures | Rendered frames.
Scenes | Scene files (*.scn) and external models (*.mdl).
Scripts | Scripts specific to a particular project or scene. This is a good location if you want to make sure that the correct version of a script is stored with a project for the purpose of archiving. Although you can save script files anywhere, it is recommended that you use a standard location. The default location is the **Data\Scripts** subdirectory of your user path.
Simulation | Generated simulation files for particles (*.ptp). Although you can save .ptp files anywhere, it is recommended that you use a standard location.
Synoptic | Synoptic files (*.htm, *.html) and associated graphics used to build synoptic views. Although you can save synoptic files anywhere, this is the default location. See *Managing Synoptic Files* in Chapter 12 of the *Customization* guide.
Thumbnails | Thumbnail images associated to elements in the project. See *Setting Thumbnails* on page 438.
System | Hidden system folder used to identify the project. If this folder is remove or modified, the project will be invalid.
Creating a New Project

When you start XSI, the last project you worked with is opened and an empty “Untitled” scene is created. If no project exists or you are running SOFTIMAGE|XSI for the first time, you can create a new project. You can create a new project at any time while working in XSI.

To create a project

1. Do one of the following:
   - If you are already working in XSI and want to create a new project, choose File > New Project from the main menu to display the New Project dialog box.
   - or
   - If the Project Manager is open, click the New Project button to display the New Project dialog box.

2. In the Project Name text box, enter a unique name for your project.

3. In the Location text box, edit the path of the folder to which you would like the project to be saved.

   Store your projects in any convenient location outside the Softimage directory structure. This way, if you reinstall or upgrade XSI, you do not run the risk of deleting your work.

4. In the Project Manager, click New Scene to create a new scene for your project.
Opening an Existing Project

To open a project

1. From the main menu, choose File > Project Manager.
   All projects stored in the project list are displayed in the Select a Project pane of the Project Manager dialog box.

2. Click on a project name in the Select a Project list box.
   If you do not find the project you need in the displayed list, click the Scan Disk button and select a folder to scan for projects.

3. In the Select a Scene list box, double-click on a scene in the project you wish to work on.
Opening an Existing Project

**Setting a Default Project**

If you work with a particular project most of the time, you can set it as the default project. The default project is opened automatically when you start XSI. It is also the first project specified in the project list.

*To set the default project*

1. Choose File > Project Manager from the main menu to open the Project Manager.
2. Select the project you want to make the default.
3. Click Set as Default.

**Deleting Projects**

You cannot delete the project in which you are currently working. To delete your current project, you must close it, open another project, then delete the project in the Project Manager.

You cannot delete a project that is set as the default project. You must set another project as the default, then delete the project in the Project Manager.

*To delete a project*

1. Choose File > Project Manager from the main menu to open the Project Manager.
2. Click the name of the project to be deleted from the Select a Project pane.
3. Click the Delete Project button to delete the selected project.
Maintaining Project Lists

Complex productions can involve numerous individual projects. Some projects may be relevant to your work, and others not. Project lists in the Project Manager let you access the projects you need with the click of a mouse.

Project lists are text-based files with a .xsiprojects file name extension. They can be located in the Data subdirectory of the user, workgroup, or factory path. XSI collects all the .xsiprojects files found in these locations and merges them together. In the Project Manager, labels identify the location of the .xsiprojects file containing each entry: [U] for user, [W] for workgroup, and [F] for factory.

You can sort projects in the list by Name, Origin (factory, user, and workgroup), or none (no sorting).

The advantage of project lists is that for a given production you can define projects located on shared network drives. Then you can export the list and have all members of the workgroup import the list of projects.

When you open a scene from a project that is not in your project list, you may be prompted to add the project to your list. You can control this behavior by setting a preference. Choose File > Preferences, then click Data Management and set Add new projects to the projects list to the desired value: Always Ask, Always Add New Projects, or Never Add New Projects.

To build and maintain project lists

1. Choose File > Project Manager from the main menu to open the Project Manager.

2. In the Project List controls, click one of the following:
   - Add Project adds a project to the project list.
   - Remove from List removes a project from the project list. This does not delete the project.
   - Scan Disk opens a browser that lets you search for more projects in the specified directories.
   - Clear List removes all projects from the list. Use this command if you want to switch to another list.
   - Import List opens a browser that lets you search for a project list file containing a list of projects and their associated paths. These project names are added to any existing projects in the project list.
   - Export List creates a file that contains the path and name of each project currently displayed in the project list. You can then use Import List to access and display these projects.
Automating Project Lists

You can export the project list and have all members of the workgroup import the current list of projects. This can all be done automatically using the auto-import and auto-export preferences for project lists.

**To automatically export a project list**

1. Choose **File > Project Manager** from the main menu.
2. Build projects for your current production (click the **New Project** button) and add them to the project list (click the **Add Project** button.)
3. Export the project list (click the **Export List** button) and save it to a shared location for the workgroup (see *Setting a Workgroup* on page 436 for how to create a workgroup path). Close the Project Manager.
4. Choose **File > Preferences** from the main menu to open the Preferences window.
5. Click **Data Management**.
6. Select **Enable Auto-Export**.
7. Click the browse button (...) next to the **Auto Import/Export file** text box.
8. In the browser, navigate to the location where the project list was exported. Select the file and click **Open**.

This option automatically overwrites the project list text file each time you save changes to the project list in the Project Manager.

Workgroup members must now set their Project Manager to automatically import the most current project list whenever they start XSI.

**To automatically import a project list**

1. Choose **File > Preferences** from the main menu.
2. Click **Data Management**.
3. Select **Enable Auto-Import**.
4. Click the browse button (...) next to the **Auto Import/Export file** text box.
5. In the browser, navigate to the location where the project list was exported. Select the file and click **Open**.

This option automatically imports the project list text file and displays the most up-to-date list of projects in the Project Manager.
Managing Invalid Projects

A project can become invalid if it is moved to another location, if its hidden system sub-folder is deleted or altered, or if the project folder is renamed. In these cases, the Project Manager can no longer identify the project from the path information specified in its project list.

The Project Manager does not automatically remove an invalid project from its project list. Instead, the project is labelled as *Invalid* and you can choose to delete the project or rescan to locate it and add it back to the project list.
Chapter 22  Models
What Are Models?

Models are a powerful way of organizing objects in your scenes and projects. They act as a container for objects, usually hierarchies of objects, and many of their properties. Models contain not just the objects’ geometry but also the function curves, shaders, mixer information, and other properties. They can also contain internal expressions and constraints; that is, those expressions and constraints that refer only to elements within the model’s hierarchy.

In SOFTIMAGE|3D, the term *model* was used loosely to refer to any object or hierarchy that represented something in the real world. However in XSI, the term is used more strictly to refer to a hierarchy with a model node as the root.

Models are like “mini scenes” that can be easily reused in scenes and projects. In fact, exporting and importing models is how you can copy between scenes.

Every scene contains at least one model, called the Scene_Root, which is the parent of all other models. You can create as many other models as you like, even nesting them within each other in a hierarchy (that is, a model can be the child of another model). Models are nulls that act as the root of a hierarchy, and they also have other properties.

In the explorer, models are distinguished by special icons, as shown on the left. To make them easier to select, you can even set the explorer to show only models, which greatly simplifies the representation of your scene.

If you want to use the animation mixer, you should always create a model for the objects you want to animate. For more information, see Chapter 1: Nonlinear Animation Basics in the Nonlinear Animation guide.
There are two types of models: local and referenced. Local models are specific to a single scene, but referenced models are external files that can be reused in many scenes.

**Local Models**

Local models are specific to a single scene. They can be stored either internally or externally:

- **Internal** local models are saved within the scene file. They provide a way to organize a scene, allowing you to take advantage of namespaces so that different models can contain objects with the same names.

- **External** local models are saved outside of the scene file while retaining their links to other elements in the scene. For example, if a model is animated on a path and the path is not a child of the model, the model still retains the path constraint when the scene is reopened.

External models not only provide a way to organize your scene, they can also reduce time when saving complex scenes. When you save a scene that has many external models, only those models that have been modified since the last save are resaved.

External model files are saved in the Scenes folder of your project. They have an `.mdl` extension and a file name composed of the model name prefixed by the scene name. For example:

```
myScene-myModel.mdl
```

**Referenced Models**

Referenced models are exported models that are linked to external files. Any changes you make to the exported model will be reflected in your scene the next time you open it or update the reference.

You create a referenced model by exporting a model as an `.emdl` file, and then importing it as a referenced model in another scene. Each referenced model can be linked with up to three different `.emdl` files for working at different resolutions: low, medium, and high.

You can use referenced models in limited ways (for example, you can animate objects within the model, but not delete them), but they provide greater flexibility in sharing resources within a workgroup and keep scene file size to a minimum. For more information, see *Using Referenced Models* on page 483.
Chapter 22  •  Models

Models and Namespaces

Each model maintains its own namespace. This means that each object in a model’s hierarchy must have a unique name, but objects in different models can have the same name. For example, two characters in the same scene can both have chains named left_arm and right_arm if they are in different models.

All models exist in the namespace of the scene. This means that each model must have its own unique name, even if it is within the hierarchy of another model.

Namespaces let you reuse animations that have been stored as actions. If an action contains animation for one model’s left_arm chain, you can apply the action to another model and it automatically connects to the second model’s left_arm. If your models contain elements with different naming schemes, for example, LeftArm and L_ARM, you can use connection mapping templates to specify the proper connections. Actions and templates are described in Chapter 3: Actions in the Nonlinear Animation guide.

If you are familiar with SOFTIMAGE|3D, note that the concepts of models and namespaces replace the method of using prefixes to organize scene elements.

Integrating 3D Models with Property Overrides

You can maintain an imported model’s attributes without using referenced models by gathering all the applied property sets, such as materials and textures, and bundling them into a single preset called a property override. Once you delete the old model and re-import the new one, you can apply this preset to the model and effectively override all the properties and characteristics that existed on the original.

This method provides a different kind of flexibility because you can apply property overrides to different but similarly structured models. Also, you can use property sets with imported models created in SOFTIMAGE|3D and other 3D applications.

For more information on overrides, see Overriding Properties on page 291.

Maintaining the Model’s Fundamental Structure

Re-imported models can receive any property that existed in the previous model, as long as the new model’s hierarchy respects that of the original. For example, the texture on a robot’s hand is not reapplied if one or more joints connecting the hand to the body have been removed.
Overview of Models

The steps below give a quick overview of working with models in XSI:

1. Create a local model containing the selected objects, and specify whether the model is to be stored internally or externally. See Creating Local Models on page 478.

At this point, the model has its own namespace and its own mixer, so it can share action sources with other models in the same scene. It can also be instantiated or duplicated within the same scene. If that's all you need a model for, you do not need to export and import it.

2. Export the model as an .emdl file. This step is necessary only if you want to reuse the model in other scenes. See Exporting Models on page 479.

3. Import the model into a different scene. You have two options: import as a local model or import as a referenced model.

   - An imported local model behaves just like a model created within the scene—it does not "remember" that it was originally imported from elsewhere. As always, it has its own namespace and mixer, and can be instantiated, duplicated, and so on. See Importing Local Models on page 481.

   - A referenced model maintains its link to the external .emdl file. You can change the .emdl file, and the referenced model automatically updates in all scenes that contain it. Referenced models also allow you to specify different .emdl files for different levels of detail, thus speeding up your interaction and simplifying your view of the scene. See Using Referenced Models on page 483.
Creating Local Models

To create a model

1. Select the objects that you want to include in the model. The objects must be siblings; that is, they must be at the same level and share a parent node in the explorer hierarchy.

2. Click Create > Model on the Model toolbar. The Model property editor opens.

3. Specify a Name for the model, as well as whether the model's storage is Internal or External.

   A null is added to the scene as the parent of the selected objects. You can add other objects to the model at a later time by using the Parent button on the Constrain panel or by dragging and dropping them onto the model's node in the explorer.

Selecting and Editing Models

To select the model and the hierarchy beneath it

- Choose Select > Select Model from the Select panel or middle-click its node in the explorer.

To select just the model itself

- Click on its node (name) in the explorer or the schematic view.

To open a model's property editor

- Click the model's icon in an explorer.

   You can change the model name as well as specify whether the storage is internal or external.

Merging Scenes as Models

When you merge an XSI scene into the current scene, it is automatically made into a model. This ensures that the names of elements are preserved: because each model maintains its own namespace, there is no need to append element names with numbers to make unique names.

To merge a SOFTIMAGE|XSI scene into the current scene

1. From the main menu, choose File > Merge.

2. In the browser that opens, locate and select an XSI scene, then click OK. The Model property editor opens.

3. Specify a Name for the model, as well as whether the model's storage is Internal or External.

If you don’t want the elements of the merged scene to be a separate model, you can “unparent” the model’s children using either the Cut button on the Constrain panel or by dragging and dropping their nodes in the explorer, then deleting the model node.
Exporting Models

You can export models created in XSI for use in other scenes. Using models to export objects is the main way of sharing objects between scenes.

When you export a model, a copy is saved as an independent file. The file names of exported models have an `.emdl` extension.

The original model remains in the scene. If you ever need to modify the model, you can change it in the original scene, and then re-export it using the same file name. If other scenes use that file as a referenced model, they will update automatically when you open them. If you imported the file into another scene as a local model, you must delete the model from that scene and re-import it from the file to obtain the updated version.

The exported model contains only its internal relationships—the export process removes constraints, modeling relationships, expressions, linked parameters, and so on if they involve elements that are not children of the model.

The exception to this rule is envelopes: the export process preserves envelope operators even if they involve deformers that are not part of the same model. When you later import the referenced model containing the envelope into a scene containing objects with the same name as the envelope's original deformers, the deformers are automatically reconnected to the envelope. This lets you export an envelope model, delete it from the scene, and then import it back as a referenced model with the envelope still connected to the original deformers.

For deformers to be reconnected automatically, they must exactly the same model name and object name as the originals. Remember that the model name of a referenced model is based on the `.emdl` file name—this means that if you export the deformers as a model, you should use the unaltered name of the original model as the `.emdl` file name.

In addition, when you import the deformer model, **Referenced Models: Use Prefix for Referenced Model Names** should be off in your General preferences. Otherwise, you must manually specify model names as described in *Using External Envelope Deformers* on page 494.
To export a model

1. Select the model to be exported.
2. Choose File > Export > Model from the main menu.
3. In the Export Model browser, open the folder in which the model is to be saved. Under File Name, enter the name of the model to be exported and click OK.

- Although the Scene_Root is considered a model, you cannot export it as a model.
- Animation of the model's root is not exported. Only animation of the objects within the model is exported. However, you can add a null to the model, make all other objects in the model children of the null, and animate the null within the model.
- If the render region is displayed when you export, it will be used as a thumbnail for the model in the browser. Note that previous thumbnails are not kept when you re-export and overwrite the model file; if the render region is not open when you re-export, any existing thumbnail is lost.

You can also export models for use in other applications, such as SOFTIMAGE|3D. For more information see Exporting Scenes, Models, and Objects on page 522.
Importing Local Models

When you import a model locally instead of as a referenced model, its data becomes part of your scene (but not necessarily part of the scene file—you can still set the storage to external). It is as if the model was created directly in the scene—there is no live link to the .emdl file. You can make any changes you want to the model and its children.

Local models are also created when you import SOFTIMAGE|3D .dsc and .hrc files, as well as other formats. See Chapter 24: Importing and Exporting on page 515.

When you import a model created with a version of XSI previous to 3.0, the scene's ambience may be changed. For more information about ambience, see Setting a Scene's Ambience in Chapter 13 in the Shaders, Lights & Cameras guide.

To import a model
1. Choose File > Import > Model from the main menu.
2. In the Import Model browser, open the folder containing the model you wish to import. XSI models are identified by their .emdl file extensions.
3. Select the model file name and click OK.

   The model is placed just below the Scene_Root in your scene hierarchy.

To import a recent model
- Select it from the File > Recent Models menu. This menu lists the last few models you imported into a scene.

To import a referenced model by dragging and dropping
- Drag an .emdl file from a browser or a link on a Net View page and drop it onto the background of a 3D view. On Windows, you can also drag an .emdl file from a folder window.
When you import a local model using File > Import > Model, the default is to share image clips. This means that if any image clips (for example, textures) on the model are the same as clips that are already in the scene, then the existing clips are automatically reused. This prevents unnecessary image clips from accumulating in your scene.

Two clips are considered to be the same if they share the same image source and the same parameter values. Animated parameters are ignored, so be careful if you have animated clip settings such as cropping or clip FX.

Local models will not share clips that are already used by, and therefore locked by, referenced models. Image sources are always shared.

In some situations, you might not want to automatically share image clips. For example, you might have animated the clip parameters differently and you want to keep the different animations. In these cases, you can use the ImportModel command in the script editor to specify False for the ShareImageClips parameter. For example:

```plaintext
ImportModel filename.emdl, , , , , False
```

Incremental numbers are appended to duplicate clip names to keep names unique.

For more information about the syntax of the ImportModel command, refer to the SDK documentation by pressing F1 or clicking ? in the command bar of the script editor.

For more information about image clips and sources, see Chapter 6: Clips & Sources in the Shaders, Lights & Cameras guide.
Using Referenced Models

Referenced models are models that have been created in XSI and exported from it, but which are not actually incorporated within your scene file. As the name implies, they are referenced from elsewhere—somewhere on your hard disk or the network. Changes made to the exported model are reflected in your scene the next time you open the scene or update the reference.

For example, let’s say that you’re modeling a car that will be used in various scenes, but the animator needs to start animating with the car on another computer before you can finish the details. You export the car as porsche.emdl, which the animator can import into her scene while you continue your work. Any changes that the animator makes to the car, such as adding expressions, are automatically stored in the scene's model clip.

When you’re done modeling the car, you can re-export using the same file name. Now when the animator loads the scene or updates the referenced model, all the changes you made are automatically reflected in the car in her scene. After the model is updated, XSI reapplies the changes stored in the model clip to the model within the animator’s scene.

Referenced models also let you work at different levels of detail. You can have a low-resolution model for fast interaction while animating, a medium-resolution model for more accurate previewing, and a high-resolution model for the final results.

Exploring Referenced Models

Referenced models are indicated in the explorer by a red model icon. The name of this node depends on the name of the .emdl file. In the case of multiple model resolutions, the name depends on which .emdl file is currently loaded.

A referenced model has a model source and one or more model clips.

- The model source specifies the location of the external .emdl file for each possible resolution, and keeps track of which resolution is currently loaded.
A model clip contains the modifications you have made to the model while that resolution is loaded. There is a model clip for each resolution, and the modifications for all resolutions are combined for the final result (see Modifying and Animating Referenced Models on page 488 for more details).

A model clip does not appear in the explorer unless it’s necessary; that is, unless you have loaded the corresponding resolution during your current session or unless the clip contains modifications or animation. So if you don’t see a clip in the explorer, don’t panic; it will appear automatically when you switch to that resolution.

**To access referenced model, clip, and source properties**

- Do either of the following:
  - In an explorer, click the icon of a model, model clip, or model source.
  - In a 3D view, select the model’s root (represented by a null), then press Enter or choose Edit > Properties > General Properties.

For multiple models, you can node-select (not branch-select) all the models and press Enter.

The property editor for a model clip includes the page for the source, and the property editor for a model includes pages for both the clip and source.

For referenced models, the parameters in the model’s property page (Name and Storage) are locked and cannot be changed. You can change only the parameters in the source and clip property pages.

**Importing Referenced Models**

You can import a referenced model using a menu command or by dragging and dropping into a scene.

When you import a model created with a version of XSI previous to 3.0, the scene’s ambience may be changed. For more information about ambience, see Setting a Scene’s Ambience in Chapter 13 in the Shaders, Lights & Cameras guide.

**To import a referenced model with a menu command**

1. Choose File > Import > Referenced Model from the main menu.
2. Use the browser to locate and select the desired .emdl file, then click OK.

If you have prepared multiple .emdl files for different resolutions, select the medium-resolution model. By default, .emdl files are saved in the Models subdirectory of an XSI project.

A model source and clip are created, and their property pages are opened in an editor. You can use the editor to specify .emdl files for low and high resolutions.
To import a referenced model by dragging and dropping

- Press Ctrl while dragging an .emdl file onto the background of a 3D view from a browser or a link on a Net View page. On Windows, you can also press Ctrl while dragging an .emdl file from a folder window.

A model source and clip are created, and their property pages are opened in an editor. The model you dragged is used for the medium resolution. You can use the editor to specify .emdl files for low and high resolutions.

To create a blank model source

- Choose Create > Model > New Model Source from the Model toolbar.

A model source is created and its property editor opens. You can use the editor to specify .emdl files for whatever resolutions you want.

To duplicate a model source

- Select the referenced model and duplicate it (Ctrl+d).

To specify .emdl files for different resolutions

- On the model source property page, specify the path and name of an .emdl file under Filenames for Model Resolutions. You can specify different .emdl files for each resolution: Low, Medium, and High.

You can type a file path and name, or use the Browse (…) button to find and select a file. Use Rel to specify a path relative to the active project directory, or Abs to specify an absolute path. Valid paths are displayed in white, invalid paths are red, and read-only paths are gray.

To control the name of referenced models

You cannot rename referenced models. However, there is a preference that controls whether a prefix is automatically added to the names of referenced model nodes when they are imported.

If you have scripts or other things that refer to elements in a referenced model using the explicit model name, then you should turn this option off. In particular, you should turn this option off if a character’s envelope and deformers are in separate models. This is because the deformers are reconnected to the envelope based on their model and object names.

1. Open Preferences window by choosing File > Preferences.
2. Click the General node.
3. Turn **Use Prefix for Referenced Model Names** on or off:
   - If this option is on, the prefix `Referenced_` is added to the emdl file name (unless that string is already part of the name).
   - If this option is off, the .emdl file name is used as is.

### Changing the Resolution of Referenced Models

You can change the resolution of a single model, or of all models in a scene at once. When you change the resolution of a model, the following things happen:

- The model data is updated from the corresponding external .emdl file.
- The postload script for the new resolution is run, if a postload script has been specified—see *Using Postload Scripts* on page 491.
- The local modifications that you have chosen to save are reapplied—see *Modifying and Animating Referenced Models* on page 488.

If a particular model source does not specify an .emdl file for the chosen resolution, then its resolution is not changed.

As an alternative to changing the resolution, you can offload models that you don’t need at the moment—see *Offloading Referenced Models* on page 487.

If an .emdl file cannot be found at the path specified, the model is automatically offloaded.

**To change the resolution of specific referenced models**

- Do one of the following:
  - Select the desired models, then choose an item from the Modify > Model > Set Resolution submenu on the Model toolbar: **Low**, **Medium**, or **High**.
    - If you select a standard, non-referenced model instead of a referenced model before choosing the command, the resolution is set for all referenced model children of the selected model.
  or
  - On the model source property page, set the Active Resolution to the desired value: **Low Res**, **Medium Res**, or **High Res**.

**To change the resolution of all referenced models**

- With no model selected, choose an item from the Modify > Model > Set Resolution submenu on the Model toolbar: **Low**, **Medium**, or **High**.
When a referenced model is offloaded, the data in the external .emdl file is not represented in the scene. This can be useful for reducing the memory requirements, speeding up interaction, and simplifying your view of the scene when you are not directly working with a model. When you need to work with the model again, you can simply change its resolution again as described in Changing the Resolution of Referenced Models on page 486.

You can choose how a model is represented when it is offloaded: as a box or simply as a null. In the explorer, the icon of an offloaded model is white.

The offloaded representation of a referenced model is not updated as you work in the scene, even if you have animated the transformations of the model node while working in another resolution.

Any modifications or animation that you add to the model node while it is offloaded will be lost when you change the resolution.

**To offload specific referenced models**

- Do one of the following:
  - Select the desired models, then choose **Modify > Model > Set Resolution > Offloaded** from the Model toolbar.
  - On the model source property page, set the **Active Resolution** to **Offloaded**.

**To offload all referenced models**

- With no model selected, choose **Modify > Model > Set Resolution > Offloaded**.

**To set the offloaded representation**

- On the model source property page, set the **Offloaded Representation**:
  - **None** is simply a null at the scene's center.
  - **Bounding Box** is a box roughly representing the extent of the model before it was offloaded. It does not update to reflect the actual bounding box of the model at the current frame.
Modifying and Animating Referenced Models

While using referenced models allows for a more flexible workflow and lower overhead in a scene's file size, there are limitations on what can be done with a referenced model's elements.

When a referenced model is imported, its elements are locked and the label (REF LOCK) appears in the explorer. This means that you cannot:

- Add or remove objects from the model hierarchy.
- Add or remove operators in an operator stack, including the geometry stack (deformations, topology modifications), envelope weight stack, or texture projection stack.
- Delete an existing property, or make a shared property local.
- Assign a material to an object in a referenced model. In addition, you cannot connect and disconnect shaders on an existing material in the RefModel_Lib library.

On the other hand, you can change just about anything else, including:

- Modify and animate the transformations of any object in the model hierarchy, including the root.
- Modify and animate any parameter in an existing property or operator on any object in the model hierarchy. Note that parameters show a red lock icon but they can still be modified and animated. However, if there is a user lock on an element in a model, it cannot be modified.
- Apply new properties, such as custom parameter sets, to any object in the model hierarchy.
- Create a new material on an object in a referenced model.
- Associate objects in the model with selective lights, or lights in the model with other objects.

XSI lets you specify what type of local changes you want to save. When a referenced model is updated, the modifications you specify are reapplied like an override. If you choose not to save a particular type of modification, the data from the external .emdl file is loaded when you update. For information about specifying the types of modifications to save, see To specify the types of local modifications to save on page 489.

The modifications are stored in the model clip. The changes that have been made in a specific resolution are listed in the Parameters Changed box of the clip's property editor.

If you are using multiple resolutions, the modifications are gathered and reapplied from each resolution. If there are conflicting changes to the same parameter in different resolutions, the priority is given to the resolution most recently modified. In this way, all the resolutions "sync up" with the latest modifications. The exception is the animation mixer: there is only one mixer and all clips share it.
Modifications are reapplied based on the names of objects within the model. This means that if you change the name of objects and re-export the .emdl file, or if objects have different names in different resolutions, the modifications cannot be reapplied.

You cannot duplicate or clone objects inside a model. In addition, you cannot perform any operation that creates clusters on objects inside a referenced model, such as extracting polygons.

**To specify the types of local modifications to save**

- On the model clip property page, select the desired items under **Local Modifications to Save**:

  - **Static Pos and Other Parameter Values** saves any changes to unanimated parameter values, including transformations.
  - **FCurves** saves changes involving function curves, including new, modified, or deleted keys.
  - **Expressions** saves any changes involving expressions, including expressions and linked parameters that have been added, modified, or removed.
  - **Constraints** saves any constraints that have been added, modified, or removed on objects inside the model.

  Note that constraints on objects outside the model to objects inside the model are always saved. These constraints are active when there is an object with the appropriate name inside the model at the model’s current resolution.

  - **New Properties** saves any new properties that have been added to any object in the model hierarchy, such as custom parameter sets.
Chapter 22  •  Models

- **Animation Mixer** saves the entire animation mixer of the model, including any sources and clips: actions, shapes, and audio.

Be aware that if you activate this last option and then create new action or shape sources for the exported .emdl file, the new sources are not available to the referenced model. However, if you turn this option off and then update the referenced model, any modifications you have made in the animation mixer are lost.

If you have created and edited clips in the referenced model and want to keep them, then you can import a second version of the .emdl file, drag the sources to the first version, and then delete the second version. For more information about actions and shapes in general, see the *Nonlinear Animation* guide.

The **Local Modifications to Save** options are stored in the model clip. If an option is not active for a specific resolution, then you will lose the corresponding changes made while that resolution is loaded. Make sure that the options you want are active for all resolutions you work with.

Deactivating an option affects new changes as well as changes made previously. All changes are lost when the original model is updated.

### Updating Referenced Models

When you update a referenced model, XSI rereads the data in the external .emdl file. Any local modifications that you have chosen to save (as described in *Modifying and Animating Referenced Models* on page 488) are reapplied.

A referenced model is updated automatically in the following circumstances:

- When you open a scene.
- When you change the active resolution, as described in *Changing the Resolution of Referenced Models* on page 486.
- When you specify a new .emdl file for the active resolution, as described in *To specify .emdl files for different resolutions* on page 485.

In addition, you can update a referenced model manually. This is useful, for example, if another user re-exports the .emdl file and you want to use the new version right away.

You also have the option of specifying a script to run automatically each time a referenced model is updated.
Updating Referenced Models Manually

Updating a referenced model manually rereads the data from the .emdl file, runs the postload script (if one has been specified, and reapplies the saved local modifications.

To refresh a referenced model while you are working

- Do one of the following:
  - Select the root of the model and choose Create > Model > Update Referenced Model from the Model toolbar.
  - Right-click the root of the model in an explorer and choose Update Referenced Model.
  - Alt+right-click (Ctrl+Alt+right-click on Linux) the root of the model in a schematic or 3D view and choose Update Referenced Model.

If you select a standard, non-referenced model instead of a referenced model before choosing the command, all referenced model children of the selected model are updated.

Using Postload Scripts

The postload script allows you to use a script to apply any modifications you want every time a model clip is refreshed. You can specify a different postload script for each resolution.

- If the script file contains a procedure called RefModel_PostLoad, that procedure is run automatically after the .emdl file is reread and before the local modifications are reapplied. Among other things, this allows you to get the name of the model being updated as a string, and you can get a pointer to the object as described in To get a pointer to the model being updated on page 493.

The RefModel_PostLoad procedure must be declared with a single string argument. XSI calls the procedure with the model's name as the argument, so you can use the model's name in your code.

Here is the general VBScript syntax for the RefModel_PostLoad callback:

```vb
sub RefModel_PostLoad (model_name)
  'Your code goes here
  'For example, do something with model_name
end sub
```
Here is the general JScript syntax for the RefModel_PostLoad callback:

```javascript
function RefModel_PostLoad (model_name)
{
    //Your code goes here
    //For example, do something with model_name
}
```

For example, the following VBScript procedure simply logs the model name:

```vbs
sub RefModel_PostLoad (model_name)
    LogMessage "Running PostLoad on: " & model_name
end sub
```

If the script file contains a procedure called `RefModel_PostLoadAfterMod`, that procedure is run automatically after the local modifications are reapplied. You should use this procedure if you need to make modifications to the mixer, for example, apply expressions to control shape weights. As with RefModel_PostLoad, you can get the name of the model being updated as a string as well as get a pointer to the model object as described in To get a pointer to the model being updated on page 493.

The RefModel_PostLoadAfterMod procedure must be declared with a single string argument. XSI calls the procedure with the model’s name as the argument, so you can use the model’s name in your code.

Here is the general VBScript syntax for the RefModel_PostLoadAfterMod callback:

```vbs
sub RefModel_PostLoadAfterMod (model_name)
    'Your code goes here
    'For example, do something with model_name
end sub
```

Here is the general JScript syntax for the RefModel_PostLoadAfterMod callback:

```javascript
function RefModel_PostLoadAfterMod (model_name)
{
    //Your code goes here
    //For example, do something with model_name
}
```
For example, the following VBScript procedure simply logs the model name:

```vbnet
sub RefModel_PostLoadAfterMod (model_name)
    LogMessage "Running AfterMod on: " & model_name
end sub
```

- If the script file does not contain any procedure with those names, then
global code is run instead (that is, code that is not contained in any
function or subroutine). The global code is run after the .emdl file is
reread and before the local modifications are reapplied.

If there is global code in addition to procedures named
RefModel_PostLoad or RefModel_PostLoadAfterMod, then the
global code is executed the first time the script file is loaded (that is,
before running RefModel_PostLoad for the first time). This is a
consequence of parsing the script.

**To specify a postload script**

1. Open the model clip’s property editor.
2. Under Post Load Script, specify the following options:
   - Script Path is the path and file name of the script file to run. If Rel is on,
     the path is relative to the active project directory. If Abs is on, the path is
     absolute. You can type a path or use the Browse (...) button to locate
     and select a file. Valid paths are displayed in white, invalid paths are red,
     and read-only paths are gray.

   To stop using a postload script, simply clear the contents of this
   parameter.

   - Script Language specifies the language the script is written in:
     VBScript, JScript, PerlScript, or Python.

   Click Edit to open the script in the script editor. If the script editor
   contains unsaved changes, you are prompted to save first.

**To get a pointer to the model being updated**

If you need to get a pointer to the model object that is being updated in the
postload script, then you must create a RefModel_PostLoad or
RefModel_PostLoadAfterMod procedure as described above. XSI passes the
model’s name as a string in the single argument, and you can use the name to
get a pointer using GetValue.
For example, in VBScript:

```vbnet
sub RefModel_Postload (model_name)
    set oModel = GetValue ( model_name )
    ' Do something with oModel here
end sub
```

### Using External Envelope Deformers

If a referenced model contains an envelope but not its deformers, XSI searches for deformers with matching names. If it finds an exact match for the model and object names of the original deformers, it connects them automatically. This allows you to work with the envelope and the deformers in separate models.

Here's a possible workflow:

1. Create a model for the envelope.
2. Create a model for the deformers.
3. Envelope the first model on the second model.
4. Export the envelope model and the deformer model. Make sure that the .emdl file name is the same as the model name in the scene.
5. To create other resolutions for the envelope, you can delete the first model and reuse the existing deformer model, or you can import the deformers as a local model in a new scene. All resolutions should be enveloped to the same deformer model. When you have finished enveloping, export the other envelope resolutions as above.
6. Make sure that **Use Prefix for Referenced Model Names** is off in your General preferences. This allows XSI to match the envelope with the deformers automatically by name.

   Otherwise if the deformers are in another model whose name does not match the original, you can fix it manually after the next step. Enter the deformer model's name in **Models used for external envelope connections** in the Model Source property editor of the envelope model. Use commas to separate multiple model names.

7. In a new scene, import the envelope and deformer models.
8. If you want to update the envelope, for example, to change the envelope weighting, first import the envelope and deformers into a new scene as local models. Then, change the weighting and re-export.
Referenced Models in Groups, Layers, and Partitions

If you add an object within a referenced model to a group, layer, or partition in your scene, that relationship is saved and restored when you update the model. However, the relationship is specific to a resolution. For example, if you move `effector_arm_left` of the medium resolution model to the `Skeleton` layer of your scene, it does not automatically apply to the low and high resolutions. However, when you reload the medium resolution, `effector_arm_left` will still be in the `Skeleton` layer.

Referenced Models and Materials

When you import a model, its materials are added to a library called `RefModels_Lib`. This library is locked, meaning that you cannot do any of the following:

- Add or remove materials from the library.
- Connect or disconnect shaders and textures on materials in the library.

However, you can assign materials from this library to other objects in the scene.

To modify or animate shader parameters, you must use the material node under the model. If you use the material node in the library, your changes are not recognized.

You cannot assign an existing material to an object or cluster in a referenced model. However, you can select the object or cluster and create a new material for it. Alternatively, you can add the object or cluster to a group, and assign an existing material to the group.

Image Clips and Referenced Models

When you import a referenced model using `File > Import > Referenced Model`, the default is to share image clips. This means that if any image clips (for example, textures) on the model are the same as clips that are already in the scene, then the existing clips are automatically reused. This prevents unnecessary image clips from accumulating in your scene.

Two clips are considered to be the same if they share the same image source and the same parameter values. Animated parameters are ignored, so be careful if you have animated clip settings.

Referenced models will only share clips that are already used and locked by other referenced models, or clips that are currently unused. Image sources are always shared.

In some situations, you might not want to automatically share image clips. For example, you might have animated the clip parameters differently and you want to keep the different animations. In these cases, you can use the `ImportModel` command in the script editor to specify `0` for the `ShareOptions` parameter. For example in VBScript:

```
ImportModel filename.emdl, , True, , , 0
```
For more information about the syntax of the ImportModel command and other ShareOptions values, refer to the SDK documentation by pressing F1 or clicking ? in the command bar of the script editor.

For more information about image clips and sources, see Chapter 6: Clips & Sources in the Shaders, Lights & Cameras guide.

Referenced Models and Actions

Referenced models do not share action sources. If you apply an action to a referenced model, the source gets copied to the referenced model’s mixer and reloaded when you update the model.

Deleting Referenced Models

Deleting a referenced model deletes the model source and all of its associated clips from the scene.

You can also delete model sources and clips using the explorer, but be aware that:

- Deleting a source deletes the model and all clips.
- Deleting a clip does not remove the reference to the .emdl file from the source. Any information stored in the clip is lost, but the clip will be regenerated when you switch to the corresponding resolution. If you delete the clip for the active resolution, the model appears to have been removed from the scene but it will reappear when you change resolution.

To delete a referenced model

1. Branch-select the root of the model.
   
   If you node-select the root instead, a placeholder null is created with the same name as the model when you delete it. The children of the model are unaffected.

2. Press Delete.

Converting Referenced Models to Local

You can convert a referenced model into a local model. This breaks the link to the external .emdl file, and the local model in the scene is no longer affected by any changes to the external .emdl file.

The local model is based on the resolution that is active when you convert the referenced model.

To make a referenced model local

- Select the referenced model and choose Modify > Model > Make Referenced Model Local from the Model toolbar.
Instantiating Models

An instance is an exact replica of a model. Any type of model can be instanced. You can create as many instances as you like and position them anywhere in your scene. When you modify the original “master” model, all instances update automatically.

Instances are useful because they require very little memory: only the transformations of the instance root is stored. However, you cannot modify, for example, an instance's geometry or material. If you need to individually modify copies of an original object, use a duplicate or clone instead, as described in Duplicating and Cloning Objects on page 269.

Instantiation has the following advantages:

- Instances use much less disk space than duplicates or clones because you're not duplicating the geometry.
- Editing multiple identical objects is very simple because you only have to edit the original.
- Wireframe, shading, and memory operations are much faster.

Instantiation uses the same options as duplication and cloning. For complete details, see Duplicating and Cloning Objects on page 269.

Instances are displayed in the explorer with a cyan i superimposed on the model icon. In the schematic view, they are represented by trapezoids with the label I.

In XSI versions 2.0X and previous, the Instantiate commands behaved differently. The old Instantiate commands have been renamed Clone.

The old script command Instance is still available for backwards compatibility, but it has been deprecated in favor of the new synonym Clone. A new script command Instantiate is used for the new instantiation behavior on models.
To instantiate models

1. Select the roots of one or more models.

2. Choose one of the following commands from the Edit > Duplicate/Instantiate menu:
   - **Instantiate Single** creates a single instance of the selected models using the current options set in the Duplicate/Instantiate Options property editor.
   - **Instantiate Single without Options** creates a single instance of the selected models, ignoring any transformation options set in the Duplicate/Instantiate Options property editor. The instance is automatically selected and is at the same location as the original.
   - **Instantiate Multiple** creates any number of instances from the selected models.

To create instantiate models from animation

1. Select a model whose root node transformations have been animated.

2. Choose Edit > Duplicate/Instantiate > Duplicate/Instantiate from Animation from the Edit panel.

3. In the Duplicate from Animation dialog box, set the start and end frames of the animation to use for the duplicates, as well as the step values.
   
   For example, if the **Start Frame** is 10, the **End Frame** is 40, and the **Step Value** is 15, the duplicates are created based on the object’s state at frames 10, 25, and 40.

4. Make sure that **Instance** is activated, and click OK.
   
   An instance of the original model is created for each frame interval along the animated transformation.

Selecting Instances

You can click on any part of an instance in a 3D view to select it. You do not need to click on the root of the model.

Displaying Instances

You can toggle the display of instances on or off in the 3D views.

To toggle the display instances

- Do one of the following:
  - To toggle the display of instances in a single 3D view, click the eye icon (Show menu) and choose **Instances**.
  
  or
  
  - To toggle the display of instances in all open 3D views, choose View > **Instances** from the main menu bar.
Viewing Instance Relationships

You can display the relationship between instances and masters in the schematic view. When Show > Associated Model Links is on and an instance is selected, an orange link labeled Inst is displayed between the instance and its master. When a master is selected, links between the master and all its instances are displayed.

Notes on Working with Instances

This section includes some information you should be aware of when working with instances.

Understanding the InstanceGroup

When you instantiate a model, a new group is created in the master model called InstanceGroup. This group keeps track of all the instances of the master model in the scene.

The InstanceGroup is locked: you cannot add or remove members manually. Deleting a member of this group deletes the instance from the scene.

Modifying Instances

Instances are replicas of the master model. This means that, for example, you cannot modify the geometry nor change materials. However, you can:

- Transform the instance.
- Change its visibility, display, and other properties.
- Add new properties, such as annotations or custom parameter sets.
- Add new children and modify any of their properties, materials, and so on. These children are “real” children of the instance’s model root, and have no association with the master model.
- Apply a property or material in branch mode to the model root of the instance. These properties are propagated to the instance’s children, but do not affect any elements from the master model.

Although instances contain an animation mixer like any other model, you cannot use actions defined for the master to animate the instance separately. This is because the instance does not contain the master’s children. For example, the master may contain a child called leftarm_effector but the instance does not.

Visibility and Instances

Because instances are treated as single objects, you cannot control the visibility of individual objects within an instance. You can only set visibility options for the instance itself. Toggling visibility on or off affects the entire instance.

You can change the visibility options of individual objects within the master model’s hierarchy. Toggling any object’s visibility on or off affects the corresponding object in each instance.
**Instantiating Instances**

Instances behave like ordinary models except in one respect: instantiating them. If you try to instantiate an instance, another instance of the original master is created instead.

**Exporting Instances**

You can export an instance as an .emdl file. However, only the elements that you have manually added to the instance are included. The elements of the master model are not included.

**Motion Blur on Instances**

If you want to apply motion blur on instances, you should use estimated motion blur instead of regular motion blur. This is because estimated motion blur is based on the object’s motion, which can be different for each instance, while regular motion blur is part of an object’s geometry so all instances share the master’s motion blur.

For more information about motion blur in general, see *Creating Motion Blur* in Chapter 16 in the *Shaders, Lights & Cameras* guide.
Chapter 23  **Locking and Tagging Scene Elements**
Chapter 23 • Locking and Tagging Scene Elements

About Locks

When you create a scene or model, there may be certain parts of it that you don’t want to change or that you don’t want anyone else to change (this is particularly true in a workgroup environment). To help reduce the introduction of error, you can use locks to control the type of modifications allowed to parts of a scene. For example, if you’re a technical director, you can use locks to prevent modifications (accidental or otherwise!) to a rigged character. Or you can lock only the animation of certain parameters so that they’re available but can’t be keyed.

What Can You Lock?

You can lock these elements within a scene:

- The scene root.
- Local models, excluding referenced models which are locked by the system (see below for the difference between system and user locks).
- 3D objects, including geometry, lights, and cameras.
- Animation mixers.
- Groups, clusters, layers, and passes.
- Properties (excluding overrides which are also system-locked).
- Parameters.

User and System Locks

When you lock a scene element using the Lock command, you are applying a user lock. You can choose to unlock at any point.

A system lock is the same locking mechanism as a user lock but is used internally by XSI for locking specific types of scene elements. Override properties and referenced models are both protected by system locks, which means that they cannot be locked, unlocked, or removed with user locks.

You can identify if a scene element is user or system locked by choosing the Locks > Locks Info command—see Getting Information about Locks on page 511.

In the explorer, a referenced model has the label (REF LOCK) beside it, whereas a user-locked element simply has the label (LOCK or lock).

Levels of Locks

You can apply locks to scene elements at different levels: topology, animation, value, and all. These levels let you lock scene elements so that only certain types of modifications are restricted. For example, you cannot add or remove points from geometry that has been locked at the node topology/hierarchy level.
You can apply all levels at once or set them individually:

<table>
<thead>
<tr>
<th>Lock Level</th>
<th>Description</th>
<th>Scripting Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Node Topology/Hierarchy</td>
<td>Cannot modify topology or hierarchy</td>
<td>siLockLevelConstruction</td>
</tr>
<tr>
<td>Animation</td>
<td>Cannot set keys</td>
<td>siLockLevelAnimation</td>
</tr>
<tr>
<td>Value</td>
<td>Cannot change values</td>
<td>siLockLevelManipulation</td>
</tr>
<tr>
<td>All</td>
<td>All of the above</td>
<td>siLockLevelAll</td>
</tr>
</tbody>
</table>

Levels are progressive, which means that a given level includes all levels above it (the opposite of the parent-child analogy where properties are applied from the top down).

- The lowest lock level is the value level, so setting a lock at this level automatically activates the other level locks above it.
- Setting a lock at the animation level also locks the node topology/hierarchy level above it.
- The highest level lock is the node topology/hierarchy lock, and it can be set independently of the other two levels.

**Locking Animation**

When a scene element is locked at the animation level, you cannot set keys for it nor can you edit its fcurves in the animation editor.

In the fcurve editor, locked fcurves are drawn with dashed lines, as shown on the left.

You cannot select any locked fcurves, therefore you cannot select any keys on them and edit them. If you want to copy keys from fcurves, you can use the dopesheet.

In the dopesheet:

- Locked tracks have a black lock icon displayed at their left end. If a collapsed track contains all locked tracks, it has a black lock icon. If it contains a mix of locked and unlocked tracks, the lock icon is a mixture of black and green.
- You can select and/or create regions on locked fcurves (tracks), mostly for copying and pasting keys from them, but you can’t edit the keys.

If you try to edit the keys, an error message appears in the script window telling you that this cannot be done because the underlying fcurve is locked.

For more information on fcurves and the dopesheet, see Chapter 5: Editing Function Curves and Chapter 6: Editing Animation in the Dopesheet in the Animation guide.
The Lock Owner

You can unlock or change the level of a lock only from the node where the lock was originally applied. This node is referred to as the lock owner.

If you try to unlock or modify the lock level of a particular node, but the lock level menu items appear unavailable (gray) in the context menu, this means that the selected node/object has inherited the lock and you can modify it only from the lock owner. Even though the level is unavailable, the inherited lock levels are indicated by a check mark.

The only scene elements that you can unlock regardless of whether it is a lock owner or not, are parameters, which can be locked and unlocked only in node mode. See Locking Parameters on page 506 and Unlocking Parameters on page 510.

Inheriting Locks

Locks are always applied in branch mode. This means that when you lock an object, all its children inherit the lock. For example, to lock an entire scene, you apply a lock on the scene_root node. All of the objects and models below the scene_root are also locked, including their properties and parameters.

Locking a group locks all members of the group, and they remain locked as long as the group node is locked.
Locking Scene Elements

You can lock an entire scene or elements within a scene from an explorer. You can apply a lock at a specific level or lock all levels at the same time.

To lock scene elements by level

1. Open an explorer and set its scope to Scene Root.
2. Select the scene element node that you want to lock.
3. Right-click the selection to open its context menu.
4. Choose Locks and activate the specific lock level option:
   - Node Topology/Hierarchy Locked
   - Animation Locked
   - Value Locked
   - Lock All Levels

When a scene element is protected, the word (LOCK) is displayed beside its name in the explorer. When LOCK is in capital letters, it means that this is the lock owner.

All its child nodes inherit the lock and display the (lock) label as well, but in lowercase letters to denote their inheritance.

If you try to modify an object that is locked, the history pane in the script editor displays the error message ERROR : 2087 - The object: <object> is locked, and no action is taken.
Chapter 23 • Locking and Tagging Scene Elements

To apply additional lock levels to scene elements

You can progressively add lock levels to scene elements that are already locked.

1. In an explorer, select the lock owner (the node on which you originally applied the lock).

2. Right-click the selection to open its context menu.

3. Choose Locks and activate another lock level. You will notice that a check mark appears next to the applied lock levels in the menu.

Locking Parameters

You can lock parameters the same way you would lock any other scene element, but what makes locking parameters different is that they are the only element that you can also lock in node mode (all other locks are applied in branch mode).

A parameter can inherit a lock from the hierarchy above it, but you can always go back and apply another lock level or lock all levels for only that parameter: the parameter can be said to have a local lock.

When a parameter is locked, a lock icon appears beside it in both the explorer and its property editor:

- Black lock icons denote that the parameter is the lock owner.
- Gray lock icons denote an inherited lock.
- Red lock icons denote parameters in reference models or parameters with overrides. You cannot modify these parameters because they’re system-locked.

Proxy Parameters

If you lock a parameter that is then proxied in a custom parameter set, the proxy parameter is also locked. And when you lock a proxy parameter, the original parameter from which it was proxied is also locked.

If you lock a custom parameter set that contains proxy parameters, the proxy parameters inherit the lock, but the original parameters are not locked.

Example: Locking All for a Single Parameter

1. From the Model toolbar, choose Get > Primitive > Polygon Mesh > Sphere.

2. In an explorer, select the Sphere object node. Set the explorer scope to Scene Root and the filter to All Nodes or All + Animatable Params (as needed) to display parameters.
3. Right-click the Sphere node and choose **Locks > Node Topology/Hierarchy Locked**.

The word **(LOCK)** is displayed beside the node. All its child nodes inherit the lock and display the **(lock)** label as well, but in lowercase letters.

All its parameters have a gray lock icon beside them (in the explorer and property editor).

4. Expand the Sphere down to the **Kinematics > Local Transform > Pos > X** parameter.

5. Right-click the parameter and choose **Locks > Value Locked**.

The lock icon beside the parameter turns black to indicate that it’s locked at the parameter level.

The Sphere is locked at the Node Topology/Hierarchy level, except for this single parameter, which is essentially locked at all levels because the Value lock includes the Animation lock level above it.

- You can also lock a parameter by right-clicking its animation icon in the explorer or a property page and choosing **Locks > Animation Locked** or **Value Locked**.

- If the master parameter of a proxy parameter is locked, the proxy parameter is also locked and displays a **(lock)** label beside its name.
Chapter 23  •  Locking and Tagging Scene Elements

**Lock Level Results**

This table gives the results of locking specific scene elements at different levels.

<table>
<thead>
<tr>
<th>Element</th>
<th>Topology/hierarchy lock</th>
<th>Animation lock</th>
<th>Value lock</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parameters</td>
<td>n/a</td>
<td>Cannot set keyframes, expressions, or scripted operators.</td>
<td>Cannot set or modify parameter values.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Cannot modify the shape of fcurves or the content of expressions.</td>
<td></td>
</tr>
<tr>
<td>Parameter sets</td>
<td>Cannot add or remove parameters from a custom parameter set.</td>
<td>Equivalent to having all parameters locked at the animation level.</td>
<td>Equivalent to having all parameters locked at the value level.</td>
</tr>
<tr>
<td>Operators</td>
<td>Cannot delete locked topology operators.</td>
<td>n/a</td>
<td>Cannot delete locked deformation operators.</td>
</tr>
<tr>
<td>Geometry, primitives</td>
<td>Cannot apply topology operators (unable to modify the topology of the geometry).</td>
<td>Same as a value lock.</td>
<td>Cannot apply deformations including Move Component and Envelope operators (unable to modify the shape of the geometry).</td>
</tr>
<tr>
<td>3D objects and models</td>
<td>Cannot parent or cut objects from the hierarchy.</td>
<td>Cannot set keyframes, or apply expressions or scripted operators on parameters of the object node.</td>
<td>Cannot modify parameters or manipulate objects (SRT).</td>
</tr>
<tr>
<td></td>
<td>Cannot add parameter sets or apply operators.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Groups (and layers and clusters and partitions) and clusters</td>
<td>Cannot add or remove members or components.</td>
<td>Cannot set keyframes, or apply expressions or scripted operators on parameters for the group or group members.</td>
<td>Cannot change values of any property for the group or group member.</td>
</tr>
</tbody>
</table>
Unlocking Scene Elements

You can unlock a scene or any locked element within a scene from an explorer. With the exception of parameters, you must unlock from the node that owns the lock (where the lock was originally applied: see The Lock Owner description on page 504).

To unlock scene elements for all levels
1. Open an explorer and set its scope to Scene Root.
2. Select the scene element node that you want to unlock.
3. Right-click the selection to open its context menu.
4. Choose Locks > Unlock All Levels. This unlocks the element as well as its children, if any.

To unlock scene elements by level
You can progressively unlock scene elements by level.
1. In an explorer, select the lock owner (the node on which you originally applied the lock).
2. Right-click the selection to open its context menu.
3. Choose Locks and deactivate the specific lock level menu item: Node Topology/Hierarchy Locked, Animation Locked, or Value Locked.

If the lock level menu items are not available, this means that the selected node/object has inherited the lock and you have not selected the lock owner.

To unlock all locked elements and parameters in a hierarchy
1. In an explorer, select the lock owner at the highest level you want to unlock.
2. Right-click the selection to open its context menu.
3. Choose Locks > Remove All Locks in Hierarchy. This unlocks all elements at all levels in the hierarchy, including parameters.

Using the Unlock command with scripting, you can set the RemoveAll argument to "True" for any locked object and it will unlock any element or parameter it finds in its hierarchy.
Unlocking Parameters

You unlock parameters the same way you would unlock any other scene element. What makes unlocking parameters different is that they are the only element that can be unlocked in node mode. When you specifically unlock a parameter, the parameter becomes the owner of the lock information.

A parameter can inherit a lock from the hierarchy above it, but you can always go back and remove a lock level or unlock all levels just for that parameter.

Example: Unlocking All for Specific Parameters

1. From the Model toolbar, choose Get > Primitive > Polygon Mesh > Grid.
2. In an explorer, select the Grid object node.
   
   Set the explorer scope to Scene Root and the filter to All Nodes or All + Animatable Params (as needed) to display parameters.
3. Right-click the Grid node to open its context menu.
4. Choose Locks > Lock All Levels.
   
   The word (Lock) is displayed beside the node. All its children nodes, including its parameters, inherit the lock and display the (Lock) label as well.
5. Expand the Grid down to the Polygon Mesh > Geometry > U and V Subdiv parameters.
6. Right-click each parameter and choose Locks > Unlock All Levels.
   
   The Grid object is locked at all levels, except for its U and V Subdiv parameters.
Getting Information about Locks

You can get information on the locks on parameters, objects, models, or hierarchies in a scene. The Lock Info command opens a net view page that displays a table of the objects and parameters that own locks. Elements that have inherited locks are not displayed: only the root element (or lock owner) is listed.

When an object (and all its children) is locked, the root object stores the lock information and all other nested objects and parameters inherit that lock. When you specifically lock/unlock a parameter, the parameter also becomes a lock owner.

This table identifies the type of element that is locked (Object kind), its name and where in the scene tree it is located (Object path), the lock levels applied to the element (Level), and the type of lock it is (Type).

![Netview Lock Info Page]

To display information on all locked scene elements

If you want lock information on all lock owners in the scene, you must select the scene root. The net view lock information page will list all the objects and any parameters that own locks recursively from the scene root.

1. Open an explorer and set its scope to Scene Root.
2. Select the Scene_Root node.
3. Right-click the Scene_Root node to open its context menu.
4. Choose Locks > Lock Info. A net view page opens with a list of all lock owner nodes from that point down through the scene tree. This includes any parameters that have had their locks modified.
To display information on a specific locked scene element

If you want lock information on a specific parameter, object, model, or hierarchy in the scene, you must select the root element node (or lock owner). The net view lock information page lists the lock owner node and any of its parameters that have had their locks modified.

1. Open an explorer and set its scope to Scene Root.
2. Select any node element that owns a lock.
3. Right-click the node to open its context menu.
4. Choose Locks > Lock Info. A net view page opens and displays the selected lock owner node and any parameters under that node that have local lock information applied to them.

If the object is inheriting the lock, the lock owner is stated. For example, if you select the camera that is a child of a model that is the lock owner (master), this information is stated when you choose Lock Info for the camera.

<table>
<thead>
<tr>
<th>Lock Info on NODE object: jaiqua_model.Camera</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Select the object in Branch to inspect all the hierarchy)</td>
</tr>
<tr>
<td>The object jaiqua_model.Camera is Locked</td>
</tr>
<tr>
<td>Level: 2 (Construction &amp; Animation)</td>
</tr>
<tr>
<td>Type: User</td>
</tr>
<tr>
<td>Lock Masters: jaiqua_model</td>
</tr>
</tbody>
</table>

There is no lock owners under this object's hierarchy:
Using Locks with Scripts

You can lock and unlock scene elements at any level by entering commands in the script editor.

In some cases, certain tasks can only be done through scripting. For example, if you want to lock all parameters of the same type, enter the following in the editing pane of the script editor:

`Lock "*.kine.local.posx"`

If you want to unlock all parameters of the same type, enter the following in the editing pane of the script editor:

`Unlock "*.kine.local.posx"`

You can also get lock information on scene elements by using the `LockLevel` and `LockType` properties in the Object Model.

For more information about the `Lock` and `Unlock` commands, and the `LockLevel` and `LockType` Object Model properties, refer to the SDK documentation by pressing F1 or clicking the ? icon in the command bar of the script editor.
Tagging Parameters

You set tags on a parameter by choosing the Tags command from an explorer context menu. Tags are similar to marked parameters except that you can use tags to flag a parameter for further processing by a script or custom command. As well, tags are saved with the scene, unlike marked parameters.

Tags are easy to query and organize using a method to get the tagged parameters on an object. Keying, plotting, storing, transferring to other programs, etc. are all processes that can be done to a list of tagged parameters through scripting.

You can set one tag on a parameter or up to 10 tags named Tag1, Tag2, etc.

**To tag a parameter**

1. Open an explorer and set its scope to view All Nodes so that parameters are displayed.
2. Right-click the parameter that you want to tag.
3. From the context menu, choose Tag > Tagn.

   When a parameter is tagged, the word (Tagged -n) is displayed beside the node name in the explorer. Where n represents the tag ID number.

   You can also tag a parameter by right-clicking its animation icon in the explorer or a property page and choosing Tag > Tagn.

**To add another tag to a parameter**

- Right-click the parameter and choose Tags and select the next tag channel available. The tag ID number is appended to the name (Tagged -n n).
Chapter 24  
Importing and Exporting
Chapter 24 • Importing and Exporting

Importing and Exporting Scene Data

In any production pipeline, you need to import and export scene data for reuse in other scenes or software packages. In particular, you may often move information between SOFTIMAGE|3D and SOFTIMAGE|XSI.

This chapter covers the import and export commands available from the File > Import and File > Export menus.

The import commands let you import SOFTIMAGE|3D scenes and models, XSI models (both exported and referenced models), and dotXSI, IGES, and OBJ files. The export commands let you export XSI models, as well as dotXSI, IGES, and OBJ files.

Importing and Exporting Other Scene Elements

You can also import and export other scene elements such as function curves, actions, customized data, and MI2 files for mental ray.

Modeling

- You can import curves from an encapsulated postscript file (.eps) to be used for creating 3D text. See Importing EPS Files in Chapter 11 of the Modeling & Deformations guide.

Animation

- You can import and export SOFTIMAGE|3D function curves as .fraw files or import and export XSI function curves as .fraw2 files. See Saving and Loading Function Curves in Chapter 5 of the Animation guide.

- You cannot open a binary .exp format expression file from SOFTIMAGE|3D directly. Instead, you can import a scene or model with the expression in it. See Importing Expressions from SOFTIMAGE|3D in Chapter 10 of the Animation guide.

- You can import actions from SOFTIMAGE|3D animation files (*.ani and *.key). See Importing and Exporting Action Sources in Chapter 3 of the Nonlinear Animation guide.

- You can import and export external action sources saved in either ASCII or binary dotXSI format (*.xsi) or native XSI binary format (*.eani). See Importing and Exporting Action Sources in Chapter 3 of the Nonlinear Animation guide.

- You can import and export the entire animation mixer (*.xsimixer) for a model, making it easy to share animation between models. See Importing and Exporting the Animation Mixer in Chapter 2 of the Nonlinear Animation guide.

- You can import motion capture files in Biovision (*.bvh) and Acclaim (*.asf and *.amc) formats. See Importing Motion Capture Files in Chapter 4 of the Character Animation guide.
Materials

- You can import and export material libraries that are stored externally. See Managing Material Libraries in Chapter 3 of the Shaders, Lights & Cameras.

Rendering

- You can export a scene to the mental images MI2 file format that can be read by the mental ray rendering software. For more information on mental ray rendering, see the Rendering & Compositing guide.

Customized Elements

- You can package customized layouts, toolbars, keyboard shortcuts, custom commands, scripts, and events into files to import and export them between computers. See Chapter 11: Sharing and Managing Customizations of the Customization guide.
Importing Scenes, Models, and Objects

The import commands available from the File > Import menu on the main menu bar let you import scenes, models, and objects into XSI in the following formats:

- **dotXSI**—the ASCII or binary file format for storing scene data.
- **IGES**—the ANSI graphics file format for wireframe model interchange.
- **EPS**—the encapsulated postscript file format.
- **OBJ**—the Wavefront Object file format.
- **DSC**—the file format used in SOFTIMAGE|3D that contains information about a scene's hierarchies, camera, lights, animation, and geometry.
- **HRC**—the file format that contains information on the objects and object hierarchies (known as SI3D models) available in a SOFTIMAGE|3D scene.
- **Biovision** and **Acclaim**—You can also import motion capture files in Biovision (*.bvh) and Acclaim (*.asf and *.amc) formats. See Importing Motion Capture Files in Chapter 4 of the Character Animation guide for information.

Preparing to Import

When importing a scene or model into XSI, take note of the following to help you validate your scene after the import process:

**Timeline Information**

An imported scene contains timeline information that defines its length according to a start and end frame. By default, a scene's entire frame range is inserted at frame 1 of the timeline.

You can modify timeline information such as Start and End frame by editing the import options available for the file type being imported.

**Model Node**

In general, scenes and models are imported into the current scene under an XSI model node.

When importing a SOFTIMAGE|3D scene, this behavior can be modified by editing the SI3D Loader options.

**Viewing the Import Command History**

You can view the import command history in the script editor. To display the script editor, simply click the “script” icon at the bottom of the XSI window.

To make sure all the information is displayed in the script editor

1. Choose File > Preferences from the main menu bar.
2. In the Preferences view, click Scripting in the explorer on the left.
3. In the **Command Log** area, set a **Maximum** or **Unlimited** number of lines to be displayed in the script editor.

The script editor displays all the messages that occurred while the scene was being imported.

---

**Logging Commands to File**

During the loading process, messages appear in the command box in the lower-left side of the interface. The messages tell you about conversions that were made to certain objects or errors that may have occurred. You can store these messages in a command log.

This is particularly useful when you’re importing large and complex scenes, or for troubleshooting problems if you have difficulty importing a particular scene.

**To log commands to file**

1. Choose **File > Preferences** from the main menu bar.
2. In the Preferences view, click **Scripting** in the explorer on the left.
3. In the **Command Log** area, select **Log to File** and enter a name and location for that file.

---

**Importing XSI Models**

You can import an XSI model (**Import > Model**) for reuse in any scene. You can import the model as is and then choose whether or not to save it externally or internally to the scene file.

You can also import a model as a referenced model (**Import > Referenced Model**), so that any changes made to the model will be reflected in your scene the next time you open the scene or update the reference.

For details about importing models and working with models in general, see **Chapter 22: Models** on page 473.
Chapter 24  •  Importing and Exporting

Importing dotXSI Files

To import a file saved in the dotXSI format into XSI, do the following:

1. Choose **File > Import > dotXSI** from the main menu bar.

2. Set the necessary parameters in the .xsi Import options dialog box and click OK. Click the ? button to get help on all available import options.

3. The Import .xsi browser opens to the dotXSI folder of the current project. Navigate to the folder that contains the dotXSI file you want to import.

4. Select the file to be imported. Its name appears in the **File Name** text box.

   To select a dotXSI file (.xsi), make sure that the **File Types** text box is set to **Scene Files (.xsi)**.

5. Click OK. The imported scene's contents are added as a model under the current scene.

Importing SOFTIMAGE|3D Scenes and Models

XSI provides a robust scene and model importer that preserves much of what you have already created in SOFTIMAGE|3D. You can further manipulate how your SOFTIMAGE|3D scene or model is imported by changing the defaults in the Loader SI3D Options dialog box.

To help you make informed decisions about what you can and should import from SOFTIMAGE|3D for re-use in XSI, see *Chapter 25: Considerations for Importing SOFTIMAGE|3D Scenes* on page 525.

Make sure the scene is in a SOFTIMAGE|3D database before importing it.

To set import options for a SOFTIMAGE|3D scene or model

1. In the explorer, set the scope to **Application**, expand the Data folder, and click the Loader SI3D Options node. The Loader SI3D Options dialog box opens.

2. Set the appropriate import options. Click the ? button for help on how each option affects your imported scene or model.

To import a SOFTIMAGE|3D scene or model

1. Choose **File > Import > SI|3D Scene/Model** to display a browser.

2. Open the folder that contains the scene or model you want to import.

   If the SOFTIMAGE|3D DatabaseDir. rsrc file is installed on your computer, use the **Paths** button to display your SOFTIMAGE|3D databases. You can also drag and drop from the Windows Explorer or folder windows.
3. Select the scene file to be imported. Its name appears in the **File Name** text box.
   - To select a SOFTIMAGE|3D scene file (.dsc), make sure that the **File Types** is set to **Scene Files (*.dsc)**.
   - To select a SOFTIMAGE|3D model file (.hrc), make sure that the **File Types** is set to **Model Files (*.hrc)**.
4. Click **Open**. The imported scene's contents are added in the current scene.
5. Watch the command box at the bottom of the interface. When importing is complete, you can display all the messages in the script editor.

---

**Importing IGES Files**

You can import a file saved in IGES format (the ANSI graphics file format for wireframe model interchange).

**To import an IGES file into XSI**

1. Choose **File > Import > IGES File** from the main menu bar. The Import IGES browser opens to the Scenes folder of the current project.
2. Navigate to the folder that contains the IGES file you want to import, and select the file to be imported. Its name appears in the **File Name** text box.
   
   To select an IGES file, make sure that the **File Types** is set to **Iges Files (*.iges, *.igs)**.
3. Click **OK**.

The imported scene's contents are added as a model under the current scene root. The model name `_3D_Model` is appended to assure the uniqueness of all object names in the scene.

---

**Importing OBJ Files**

You can import a file saved in OBJ format (the Wavefront Object file format).

**To import an OBJ file into XSI**

1. Choose **File > Import > Obj File** from the main menu bar. The Wavefront OBJ Import dialog box opens.
2. Enter a path and file name for the OBJ file you want to import. Its name appears in the **Filename** text box.
   
   You can click the **Browse (…) button** to select a specific location and filename from a browser.
3. Set the necessary options in dialog box. Click the ? button to get help on all available import options.
4. When you have finished, click **OK**.

The imported objects are added under the current scene root.
Chapter 24 • Importing and Exporting

Exporting Scenes, Models, and Objects

The Export commands available from the File > Export menu on the main menu bar let you export scenes, models, and objects from XSI, in one of four formats:

- **EMDL**—the file format used to save exported XSI models.
- **dotXSI**—the ASCII file format for storing XSI scene data.
- **IGES**—the ANSI graphics file format for wireframe model interchange.
- **OBJ**—the Wavefront Object file format.

Only selected objects are exported. If no objects are selected, the entire scene is exported.

Exporting XSI Models

You can export models created in XSI for use in other scenes. When you export a model, a copy is saved as an independent file. The exported model contains only its internal relationships—the export process removes constraints, modeling relationships, expressions, linked parameters, and so on if they involve elements that are not children of the model. The file names of exported models have an .emdl extension and are saved to the Models folder of the project.

Although the Scene_Root is considered a model, you cannot export it as a model.

For details about exporting models, see Exporting Models on page 479.

Exporting to dotXSI

You can export a single object, multiple–selected objects, or the entire scene to a single dotXSI file. The dotXSI file can be saved to an ASCII or binary format—both of which use an .xsi file extension.

Consider the following when selecting objects for export:

- If a constrained object is selected without its constraining object, only the constrained object is exported. If you plot the animation, the fcurves are exported with the constrained object.
- The Plot option plots all parameters except for those that are affected by a constraint if the Constraint option is on. If the Constraint option is off, then all parameters affected by a constraint are plotted.
- If the selection does not include all nodes of an IK chain, nulls are exported.
- If the selection does not include all deformers that affect a selected envelope, the envelope is exported as a shape-animated object.
- If the selection does not include the Scene_Root, then the scene-level Mixer node is not exported. Be sure to select the Scene_Root to export its Mixer or enable the Export Scene Root When No Selection option in the dotXSI Export Options dialog box.
The entire scene is exported if there is no selection.

Other considerations when exporting to dotXSI:

- Scaling should be frozen before exporting to dotXSI if the destination is SOFTIMAGE|3D (this is particularly important when exporting rigs).
- Only local transformations are considered when exporting to dotXSI. If you have animated an object's global transformation values, nothing is exported. The solution is to plot the animation before exporting.
- Wrap UV option is disregarded for all materials imported to SOFTIMAGE|3D. You must re-enable UV wrapping after importing.
- The SOFTIMAGE|3D dotXSI importer does not deal well with certain cases where chain effectors have been reparented under different bones. When exporting chains for use with SOFTIMAGE|3D, avoid the following general structure:

```
  - root1
    - bone1
    - bone2
    - eff1
```

To export scene objects to the dotXSI format

1. Select the object or objects to be exported. If no objects are selected, the entire scene is exported (including the scene_root).
2. Choose File > Export > dotXSI from the main menu bar. The dotXSI Export options dialog box opens.
3. Set the necessary options in the dialog box and click OK. Click the ? button to get help on all available export options.
4. The Export .xsi browser opens to the dotXSI project folder. Enter a File Name for the file being exported, and click OK.

To take full advantage of the dotXSI file format, install the SOFTIMAGE|XSI FTK (File Transfer Kit) available from the Softimage web site. The SOFTIMAGE|XSI FTK is provided free of charge. No Softimage license keys are needed to install or use the FTK.

This straightforward toolkit enables rapid implementation of read and write support for the SOFTIMAGE dotXSI file format in a wide variety of circumstances. Designed to facilitate the integration of dotXSI into nearly any interactive media pipeline, the toolkit includes a set of core resources, including dotXSI file I/O library and header files and compilable source code for sample applications.
Exporting to Wavefront OBJ

You can export a single object, multiple-selected objects, or all objects in a scene to the Wavefront Object (*.obj) format. Exported files are saved with an .obj file extension.

To export scene objects to the Wavefront Object format
1. Select the object or objects to be exported. If no objects are selected, the entire scene is exported.
2. Choose File > Export > Obj File from the main menu bar. The Wavefront OBJ Export dialog box opens.
3. Set the File Output and Geometry Options in the dialog box. Click the ? button to get help on all available export options.
4. When you have finished, click OK.

Exporting to IGES

You can export a single object, multiple-selected objects, or the entire scene to a single IGES file. The file is saved with an .iges file extension.

Implicit and polygon mesh objects cannot be exported in IGES format.

To export a file to the IGES format
1. Select the object or objects to be exported. If no objects are selected, the entire scene is exported.
2. Choose File > Export > IGES File from the main menu bar.
3. The Export IGES browser opens to the Scenes folder of the current project. Under File Name, enter a name for the object(s) or scene being exported and click OK.
Chapter 25  Considerations for Importing SOFTIMAGE|3D Scenes
Chapter 25  •  Considerations for Importing SOFTIMAGE|3D Scenes

Importing from SOFTIMAGE|3D: An Overview

XSI provides a robust scene and model importer that preserves much of what you have already created in SOFTIMAGE|3D. This chapter is designed to help you make informed decisions about what you can and should import from SOFTIMAGE|3D for re-use in XSI. The major differences between SOFTIMAGE|3D and XSI are described, as well as the pros and cons of importing various elements from SOFTIMAGE|3D.

You can reuse models and animated characters from SOFTIMAGE|3D. The trick is learning what you should import to take full advantage of the animation and rendering features in XSI.
Preparing for Import into XSI

The File > Import > SI|3D Scene/Model command imports almost everything contained in your SOFTIMAGE|3D scene. However, depending on what you want to do, you may find it better to import only the elements you need or only the elements that will allow you to build your scene “the XSI way.” For example, you cannot connect imported shaders to other shader nodes in XSI’s render tree. If you want build complex material and texture effects in XSI, importing materials and textures may not be your best choice.

When you import a scene from SOFTIMAGE|3D, most of its contents are imported. When the importer encounters an object that is not supported in XSI, it often converts it to one that is supported. For example, you cannot create patch objects in XSI, so the importer converts these to NURBS objects, which are supported.

The low-resolution control rig in this example imports well into XSI:

- Polygonal and NURBS objects are imported with their materials, textures, and rendering properties intact.
- The named selections you’ve set in your SOFTIMAGE|3D scene are preserved and imported.
- Visibility and selectability in your SOFTIMAGE|3D scene are preserved and imported.
- If objects were animated or were envelopes for skeletons, they still deform as they would in SOFTIMAGE|3D.
- When you play back the animation, the scene uses the same start and end frames as in SOFTIMAGE|3D.


Chapter 25  •  Considerations for Importing SOFTIMAGE[3D Scenes

Character Rigs

You can import a NURBS or polygonal character and continue to animate it in XSI as you would in SOFTIMAGE[3D. However, chains imported from a SOFTIMAGE[3D scene retain their original hierarchical structure, which means that an effector’s orientation and position will be global, not local.

XSI offers a better solution for character rigging: when you create chains in XSI, the effector is the child of the chain root. This means you can create local animation on the effector that can be translated with the root. In other words, you can drag the entire hierarchy without the effector wanting to “stick” to the scene’s global coordinates as they do in SOFTIMAGE[3D. You no longer have to constrain a null to the effector and parent it to the chain root.

You can convert SOFTIMAGE[3D skeletons to XSI ones by reparenting the effectors and changing the effector’s properties (see the illustration on the next page). However, if the skeleton is animated, its animation is global and you’ll need to copy all the function curves to local coordinates, which may be a daunting task.

If you want to rig your character completely in XSI, you can simply import the model in its default pose.

For more information about animating with skeletons, see the Character Animation guide; for information about copying function curves, refer to the Animation guide.
Preserving Envelope Weights on Patch Objects

If you import your SOFTIMAGE|3D character but its envelope is a patch, the importer converts the object to NURBS and resets the envelope weighting, which deletes any weight modification you’ve done to the envelope. You can, however, avoid this by doing the conversion yourself in SOFTIMAGE|3D and importing the converted object.

To preserve envelope weights on Patch objects

1. Save the envelope weights using the Skin > weightCopy command in the Actor module.
2. Convert the object to a NURBS or polygonal object using the Effect > Convert command in the Model module.
3. Apply the envelope weights to the converted object using the Skin > WeightPaste command in the Actor module.

For more information about these commands, see the SOFTIMAGE|3D Reference Guide.
Chapter 25 • Considerations for Importing SOFTIMAGE|3D Scenes

Materials, Textures, and Shaders

Any material or texture attribute you've applied to an object is imported into the Material property page, which you can access from the explorer.

Materials in XSI don’t have quite the same function as they do in SOFTIMAGE|3D. What are called materials in SOFTIMAGE|3D are more accurately named surface shaders in XSI.

The Material node in the explorer acts like a container for all of the possible shaders that can be applied to an object.

Notice that the texture imports as a material property.

You can modify the imported parameters. You cannot, however, build a render tree from these parameters; that is, you cannot add additional textures or nodes to augment the effect. If you want to do this, delete the imported material and replace it with one of the new XSI surface shaders and build from there as described in the Shaders, Lights & Cameras guide.
The importer supports all of the SOFTIMAGE|3D mental ray shaders. However, like imported material parameters, you cannot use the render tree to augment the effect: you can only modify the imported parameters.

Objects modified by Softimage plug-ins (such as RenderMap and SetVertexColour) can be imported. Any object with a “persistent” effect (anything that had parameters that you could modify using Info > Custom Effect) can import into XSI, but the parameters won’t. You will see the object, but the plug-in is no longer available to modify the parameters. There are two exceptions to this: ToonAssistant and FXDirector. Because these effects are based on mental ray shaders, if you freeze the effects before importing them, you can continue modifying the shader parameters in XSI. If you do not freeze the effects, the shader parameters are not imported into XSI.

Freezing the effect deletes any animation you’ve applied using the plug-in.

Third-party persistent effects are not imported into XSI.

The importer does not import shader parameters from third-party plug-ins based on mental ray shaders.

XSI uses mental ray version 3.1 rendering software for all shading and rendering attributes. Some SOFTIMAGE|3D attributes are converted to mental ray 3.1 shader parameters (some camera parameters, for example). There may be instances when animated parameters do not import properly. This may be caused by there being no one-to-one relationship between a SOFTIMAGE|3D attribute and a mental ray 3.1 parameter. Non-animated properties, however, should import correctly.
Models

Importing NURBS or polygonal models is the simplest starting point and allows you to take full advantage of XSI’s inverse kinematics (IK), surface shading, and rendering capabilities.

Modeling Plug-ins

Any object with a “persistent” effect (anything that had parameters that you could modify using Info > Custom Effect) imports into XSI, but the parameters won’t. You will see the object, but the plug-in is no longer available to modify the parameters.

Third-Party Plug-ins

Third-party persistent effects are not imported into XSI.
Animation

You can import most types of animation, but there are some things that either don’t import well or not at all. Animated branch and node deformations (by curve or surface) import into XSI but do not look the same, although you can adjust them once they’re imported.

Although waves, quick stretch, particles, collisions, simulations, and dynamics are not imported, you can create all these effects (or similar effects) in XSI.

Expressions and Constraints

SOFTIMAGE|3D expressions and constraints import into XSI, but the order in which they are evaluated is different. For example, in SOFTIMAGE|3D you can apply a direction constraint to an object and also assign an expression to the object that controls its Y rotation. In XSI, you can do this as well, but only the constraint will work.

When you import an object into XSI that uses both a constraint and an expression, messages appear in the command log suggesting how you can replace the constraints with expressions so that the object will behave as it did in SOFTIMAGE|3D. For example:

WARNING : "3093 - The following expression(s) could be created to compensate for a constraint:
WARNING : "3055 - PosConst_ExpY_1-0.cube1.kine.global.posx = PosConst_ExpY_1-0.cone1.kine.global.posx
WARNING : "3055 - PosConst_ExpY_1-0.cube1.kine.global.posz = PosConst_ExpY_1-0.cone1.kine.global.posz
WARNING : "3094 - CnsPos on cube1 could be replaced with the previous expression(s)
Chapter 25 • Considerations for Importing SOFTIMAGE|3D Scenes

**B-Spline Curves and Path Animation**

Path animations on closed B-Spline curves may not import correctly. When a B-Spline curve is converted to a NURBS curve, the first control point is not at the same position as on the original curve. Convert the curve to NURBS in SOFTIMAGE|3D first—you'll have the same problem, but you can adjust it before importing.

**Animation Plug-ins**

Any object with a “persistent” effect (anything that had parameters that you could modify using Info > Custom Effect) imports into XSI, but the parameters won’t. You will see the object, but the plug-in is no longer available to modify the parameters.

**Third-Party Plug-ins**

Third-party persistent effects are not imported into XSI.
A First Look

This section shows you what happens when a SOFTIMAGE|3D scene is loaded into XSI.

When you import your SOFTIMAGE|3D scene, the scene is placed in a new model, which you can see in the explorer.

You can select everything under this model and scale its contents relative to the scene contents. If you want everything at the Scene level, drag and drop them on the Scene_Root node.

When you expand the model node, you see the scene objects. Use the options in the Show menu to display even more information in the explorer.

For more information about models in XSI, see Chapter 22: Models on page 473.
Many of the attributes that you applied to your objects, like selectability, visibility, and named selections, are imported as well.

The example above shows how a SOFTIMAGE|3D-named selection is imported and displayed in the explorer. Named selections appear as group nodes in the explorer. Click on them to select the objects assigned to the selection.
Materials only appear in the explorer if you choose to show them—choose Materials from the Filters menu in the explorer. Textures appear only in the material’s property page.
Shared materials appear as group nodes in the explorer. Click the node to see which objects share the material.

In an explorer, click the Filters menu and make sure that Materials are displayed, then double-click the group’s material node to display its property page. In this case, the shared materials and textures for The Jester’s eyelashes appear.

Local material and textures appear under the object’s Cluster node.

Click the Filters menu and make sure that All Nodes are displayed in the explorer, then expand the Polygon Mesh > Clusters node under the object.
Shaders

The importer supports all the SOFTIMAGE|3D shaders.

This table describes where to find the imported SOFTIMAGE|3D shader parameters:

<table>
<thead>
<tr>
<th>3D shader type</th>
<th>How to find in XSI</th>
</tr>
</thead>
<tbody>
<tr>
<td>Camera</td>
<td>Display the camera rendering properties.</td>
</tr>
<tr>
<td>Flares</td>
<td>Display the light properties.</td>
</tr>
<tr>
<td>Materials</td>
<td>Display material properties.</td>
</tr>
<tr>
<td>Output</td>
<td>Display the pass node.</td>
</tr>
<tr>
<td>Texture</td>
<td>Display material properties.</td>
</tr>
<tr>
<td>Volume</td>
<td>Display light properties.</td>
</tr>
</tbody>
</table>

Fog, Depth Fading, and Ambience

Fog and depth-fading parameters are stored in the soft_fog shader. To see this shader, display Passes in the explorer, then choose to show Local Properties and All Nodes.

Ambience is converted to ambient lighting. This node is available at the scene level in the explorer.

Improving Playback

If you have set your frame step to 0 in your SOFTIMAGE|3D scene, the importer does not set the equivalent playback setting in XSI. To improve playback in your imported scene, click the All button below the timeline in the XSI window so that it toggles to RT (real time) to have real-time playback. See the Animation guide for more information about improving playback quality in XSI.

If Your Scene Is Too Bright

There is a default light in the XSI default scene. When you import your SOFTIMAGE|3D scene, the default light is not replaced. If your imported scene seems overly bright, delete the default light.

If Your Textures Appear Flipped

Texture may appear flipped in the Textured view. When you draw a render region, the texture appears correctly.
### SOFTIMAGE|3D to XSI Conversion Table

Here is a summary of what XSI currently imports when you choose the **Import from SI|3D Scene/Model** command.

#### Models

<table>
<thead>
<tr>
<th>Element</th>
<th>Imported?</th>
<th>Notes and exceptions</th>
<th>Workarounds</th>
</tr>
</thead>
<tbody>
<tr>
<td>Polygon Meshes</td>
<td>Yes</td>
<td>If the polygonal object has holes, the importer triangulates the polygon mesh.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>May lose surface approximation attributes.</td>
<td></td>
</tr>
<tr>
<td>NURBS (Surfaces and Curves)</td>
<td>Yes</td>
<td>The object is converted to a NURBS surface. If the object was an envelope, the</td>
<td>See Preserving Envelope Weights on Patch Objects on page 529.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>envelope weights are deleted. Clusters are also deleted.</td>
<td></td>
</tr>
<tr>
<td>Patches</td>
<td>Yes</td>
<td>The object is converted to a NURBS surface.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Clusters are deleted.</td>
<td></td>
</tr>
<tr>
<td>Text/Faces</td>
<td>Yes</td>
<td>The object is converted to polygon mesh.</td>
<td>In some cases, the object may import as a null. If this is the case, convert the object to polygon or NURBS in SOFTIMAGE</td>
</tr>
<tr>
<td>Meta-Clay™</td>
<td>Yes</td>
<td>The object is converted to polygon mesh.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Note that rigid envelopes do not import.</td>
<td></td>
</tr>
<tr>
<td>Instances</td>
<td>Yes</td>
<td>Instances are expanded. Constraints and expressions are not copied to expanded</td>
<td>If the imported instances display undesirable results in XSI, expand the instances in SOFTIMAGE</td>
</tr>
<tr>
<td></td>
<td></td>
<td>instances.</td>
<td></td>
</tr>
<tr>
<td>Relational Models</td>
<td>Yes</td>
<td>Relational models are imported, but the modeling relation is not preserved.</td>
<td></td>
</tr>
<tr>
<td>Global Envelopes</td>
<td>Yes</td>
<td>If the envelope is a patch object, the envelope weights are not imported.</td>
<td>See Preserving Envelope Weights on Patch Objects on page 529.</td>
</tr>
<tr>
<td>Local Envelope</td>
<td>Yes</td>
<td>If the envelope is a patch object, the envelope weights are not imported.</td>
<td>See Preserving Envelope Weights on Patch Objects on page 529.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If you have applied deformation parameters or curves, these do not import.</td>
<td></td>
</tr>
<tr>
<td>Automatic Envelope</td>
<td>Yes</td>
<td>If the envelope is a patch object, the envelope weights are not imported.</td>
<td>See Preserving Envelope Weights on Patch Objects on page 529.</td>
</tr>
<tr>
<td>Rigid Envelopes</td>
<td>No</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Materials, Textures, & Rendering

<table>
<thead>
<tr>
<th>Element</th>
<th>Imported?</th>
<th>Notes and exceptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Materials</td>
<td>Yes</td>
<td>Local materials appear under the object’s node &gt; Polygon Mesh &gt; Clusters. Shared materials appear under group nodes. If materials are shared, applied expressions may not be imported. Some animated properties may not import properly. This is due to the conversion that occurs when some SOFTIMAGE</td>
</tr>
<tr>
<td>2D Textures</td>
<td>Yes</td>
<td>Local textures appear in the Material node found under the object’s node &gt; Polygon Mesh &gt; Clusters &gt; Polygon. If you have animated the textures, scaling, rotation, or transformation, its animation is not imported. Multiple UV properties (available in SOFTIMAGE</td>
</tr>
</tbody>
</table>
## Chapter 25 • Considerations for Importing SOFTIMAGE|3D Scenes

<table>
<thead>
<tr>
<th>Element</th>
<th>Imported?</th>
<th>Notes and exceptions</th>
<th>Workarounds</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D Textures</td>
<td>Yes</td>
<td>Some animated properties may not import properly. This is due to the conversion that occurs when some SOFTIMAGE</td>
<td>3D attributes are converted to mental ray 3.1 parameters—there may not be a one-to-one correlation between all parameters.</td>
</tr>
<tr>
<td>Camera</td>
<td>Yes</td>
<td>Some animated properties may not import properly. This is due to the conversion that occurs when some SOFTIMAGE</td>
<td>3D attributes are converted to mental ray 3.1 parameters—there may not be a one-to-one correlation between all parameters.</td>
</tr>
<tr>
<td>Lights</td>
<td>Yes</td>
<td>Sun light-types are not supported. They’re converted to Infinite lights. Area lights whose geometry is disabled imports with U and V values set to 0. Some animated properties may not import properly. This is due to the conversion that occurs when some SOFTIMAGE</td>
<td>3D attributes are converted to mental ray 3.1 parameters—there may not be a one-to-one correlation between all parameters.</td>
</tr>
<tr>
<td>Depth-fading</td>
<td>Yes</td>
<td>Depth-fading is imported as the soft_fog shader. Some animated properties may not import properly.</td>
<td></td>
</tr>
<tr>
<td>Fog</td>
<td>Yes</td>
<td>Fog is imported as the soft_fog shader.</td>
<td></td>
</tr>
<tr>
<td>Ambience</td>
<td>Yes</td>
<td>Ambience is imported as ambient lighting.</td>
<td></td>
</tr>
<tr>
<td>Palettes</td>
<td>No</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Render Settings</td>
<td>Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Photon Director</td>
<td>Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FXDirector</td>
<td>Yes</td>
<td></td>
<td>Freeze the effect before importing.</td>
</tr>
<tr>
<td>ToonAssistant</td>
<td>Yes</td>
<td></td>
<td>Freeze the effect before importing.</td>
</tr>
</tbody>
</table>

### Animation

<table>
<thead>
<tr>
<th>Element</th>
<th>Imported?</th>
<th>Notes and exceptions</th>
<th>Workarounds</th>
</tr>
</thead>
<tbody>
<tr>
<td>Skeletons</td>
<td>Yes</td>
<td>Chains loaded from a SOFTIMAGE</td>
<td>3D scene retain their original hierarchical structure. The effectors' orientation and position also remain global, not local.</td>
</tr>
<tr>
<td>SRT Animation</td>
<td>Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Element</td>
<td>Imported?</td>
<td>Notes and exceptions</td>
<td>Workarounds</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-----------</td>
<td>---------------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Cluster</td>
<td>Yes</td>
<td>Clusters are deleted unless they belong to a NURBS or polygon object.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Expressions applied to clusters do not import.</td>
<td></td>
</tr>
<tr>
<td>Shape</td>
<td>Yes</td>
<td>Shapes are converted to clusters.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Expressions applied to shape-animated objects do not import.</td>
<td></td>
</tr>
<tr>
<td>Lattice</td>
<td>Yes</td>
<td>Lattice animation is converted to cluster animation.</td>
<td>Lattice animation transition curves may not be exactly the same as in SOFTIMAGE</td>
</tr>
<tr>
<td>Path</td>
<td>Yes</td>
<td></td>
<td>If the original path is a closed B-spline, the first control point may not be at the same position as the original curve when it is converted to a NURBS curve. Convert the curve to NURBS in SOFTIMAGE</td>
</tr>
<tr>
<td>Constraints:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>position, orientation,</td>
<td>Yes</td>
<td>In SOFTIMAGE</td>
<td>3D, you could pick either another object (any other object) or use world space as the reference for the positional constraint. XSI only recognizes the parent object as a valid reference for a positional constraint.</td>
</tr>
<tr>
<td>direction, scaling,</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>bounding plane</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tangency</td>
<td>Yes</td>
<td>XSI only imports one type of tangency: if the object is on a path and is constrained to be tangent to the curve on that path. The two other types of tangency constraints available in SOFTIMAGE</td>
<td>3D (as described in the SOFTIMAGE</td>
</tr>
<tr>
<td>Camera roll</td>
<td>No</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Constraints:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cluster to object,</td>
<td>Yes</td>
<td>Object to cluster is imported as a cluster centre.</td>
<td></td>
</tr>
<tr>
<td>Object to cluster</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Constraints:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cluster centre,</td>
<td>Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>two and three points</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Chapter 25 • Considerations for Importing SOFTIMAGE|3D Scenes

<table>
<thead>
<tr>
<th>Element</th>
<th>Imported?</th>
<th>Notes and exceptions</th>
<th>Workarounds</th>
</tr>
</thead>
<tbody>
<tr>
<td>Constraints: Up vector</td>
<td>Yes</td>
<td>Imports the up vector if coupled with an IK chain, path animation, direction constraint, or two-point constraint.</td>
<td></td>
</tr>
<tr>
<td>Constraints: Normal to surface</td>
<td>No</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Expressions</td>
<td>Yes</td>
<td>The complete syntax is imported. If a variable is encountered, it is expanded and placed in the expression syntax. However, “has relation” is not imported. Expressions applied to shape animated objects do not import. Expressions applied to clusters do not import. Expressions applied to instances do not import. Expressions applied to materials and textures may not import.</td>
<td></td>
</tr>
<tr>
<td>Function curves</td>
<td>Yes</td>
<td>Deactivated function curves (set in the Dopesheet) are imported as activated.</td>
<td></td>
</tr>
<tr>
<td>Deformations</td>
<td>Yes</td>
<td>Deformations by curve and surface are imported, but may not display the same results.</td>
<td></td>
</tr>
<tr>
<td>Wave</td>
<td>No</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Flock</td>
<td>Yes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dynamics</td>
<td>No</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Simulation</td>
<td>No</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Quickstretch</td>
<td>No</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Controls</td>
<td>No</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Collisions</td>
<td>No</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Animated Booleans</td>
<td>No</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Channels</td>
<td>No</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Audio</td>
<td>No</td>
<td>Refer to the command log for information about any sound files associated with the imported scene. See Chapter 5: Audio and Animation in the Nonlinear Animation guide for information about reloading the audio file.</td>
<td></td>
</tr>
<tr>
<td>Actions</td>
<td>No</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Chapter 26  User Preferences
About User Preferences

SOFTIMAGE|XSI has many preferences to control various aspects of its behavior. This chapter describes how to set and manage your preferences in general. Descriptions of individual options can be found in the online help as well as interspersed throughout the user guides.

You manage preferences from the Preferences window. You can set, export, and import your preferences, as well as restore the defaults.

Preferences are saved in the *.xsipref format. These are text files that can be edited manually in any text editor.

At startup, SOFTIMAGE|XSI loads all *.xsipref files that it finds in the Data\Preferences folder of your factory or user path. If there are conflicts, the settings in your user path have priority.

SOFTIMAGE|XSI saves only those preferences that you modify. Modified preferences are always saved in the default.xsipref file in the Data\Preferences folder of your user path.
Accessing Preferences

You can access any preference by choosing **File > Preferences** from the main menu at the top of the XSI window.

Expand or collapse folders to show or hide more categories.
Select a folder name to summarize preferences in a grid on the right as shown.
Select a category name to dock its property editor on the right (not shown).
Click a category icon to open its property editor in a floating window.

You can also set the scope of an explorer to **Preferences**.
Setting Preferences

Any preferences that you set are stored in default.xsipref in the Data\Preferences subfolder of your user path, and reloaded the next time you start XSI.

To set preferences

1. Open the Preferences window by choosing File > Preferences from the main menu.

2. Select a category of preferences in the left pane by doing one of the following:
   - Click a category name to display it in the right pane.
   - Click a category icon to display it in a floating property editor.

3. Set the desired values.

   For a detailed description of every option, click ? (available only in floating property editors).
Importing and Exporting Preferences

You can import and export preferences. Preferences are saved as files with a .xsipref extension. They are text files and can be edited manually in any text editor.

Exporting Preferences

You can export your preferences if you want to use them on another installation of XSI or share them with other users.

To export preferences
1. In the left pane of the Preferences window, right-click on the node you want to export.
   
   For example, right-click on the Scene Colors node to export that category, or right-click on the Preferences folder to export all your preferences.
2. Choose Export from the context menu that appears.
3. In the file browser that opens, specify a path and file name for the exported preference file, and click OK.

Importing Preferences

If you or someone else has exported preferences, you can import them.

To import preferences
1. In the left pane of the Preferences window, right-click on the Preferences folder.
2. Choose Import from the context menu that appears.
3. In the file browser that opens, select the .xsipref file to import and click OK.
Restoring Preferences

You can restore any preference to its original factory default.

To restore all preferences

- In the left pane of the Preferences window, right-click on the Preferences folder and choose Restore Default from the context menu.

To restore a category of preferences

- In the left pane of the Preferences window, expand a folder if necessary and then right-click on a category such as Animation Editor and choose Restore Default from the context menu.

To restore an individual preference

1. In the left pane of the Preferences window, select a folder.

   The preferences are summarized in a grid in the right pane. Preferences that have been changed from their default values have a check mark in the Modified column (you may need to widen the Preferences window to see this column).

2. Click in the corresponding row of the Modified column to remove the check mark.

   The preference reverts to its default value.
Changing Interaction Preferences

When you start XSI for the first time, you are prompted to choose between the SOFTIMAGE|3D and XSI interaction models, each of which include their own respective mouse-interaction method and keyboard mapping.

To switch to XSI interaction

If you are unsure of the method set in your system, or you are using the SOFTIMAGE|3D method and want to switch to the XSI method, do the following:

1. Choose File > Keyboard Mapping and choose XSI Key Map or a similar keyboard mapping template that you know is based on XSI keyboard mapping.
2. Choose File > Preferences to open the Preferences window.
3. Click Interaction.
5. On the Property Editors/Views tab, activate Select Contents of Text Boxes on First Click.
6. Click Display in the Preferences window.
8. In the Preferences window, expand the Tools node and click Selection.
9. In the Selection preferences, make sure that SOFTIMAGE|3D Selection Model is not selected.

For more information on the differences between XSI and SOFTIMAGE|3D interaction, choose Help > Contents and Index > Customization and Preferences > Interaction Model Dialog Box from the main menu.
Setting the Language for the User Interface

SOFTIMAGE|XSI lets you choose the language for displaying buttons, menus, parameter names, and so on.

To set the language
1. Open the Preferences window by choosing File > Preferences.
2. Click General, and then set Default Language and Help Language. The drop-down list contains the languages installed on your machine.
3. Exit and restart XSI. The new language setting will be in effect.

Custom Preferences

Some of the preferences displayed in the Preferences window may be custom preferences designed to work with plug-ins and add-ons. For a description of how to create your own custom preferences, see Creating Custom Preferences in Chapter 7 of the Customization guide.
## Index

### Numerics

<table>
<thead>
<tr>
<th>Term</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>2D textures</td>
<td></td>
</tr>
<tr>
<td>importing</td>
<td>541</td>
</tr>
<tr>
<td>3D textures</td>
<td></td>
</tr>
<tr>
<td>importing</td>
<td>542</td>
</tr>
<tr>
<td>3D views</td>
<td></td>
</tr>
<tr>
<td>background color</td>
<td>154</td>
</tr>
<tr>
<td>background images, matching</td>
<td></td>
</tr>
<tr>
<td>See rotoscopes</td>
<td></td>
</tr>
<tr>
<td>Camera view</td>
<td>156</td>
</tr>
<tr>
<td>customizing grids in</td>
<td>155</td>
</tr>
<tr>
<td>display types (See display</td>
<td></td>
</tr>
<tr>
<td>types)</td>
<td></td>
</tr>
<tr>
<td>geometry views</td>
<td>157</td>
</tr>
<tr>
<td>navigating</td>
<td>160</td>
</tr>
<tr>
<td>navigation tools (See navigation tools)</td>
<td>155</td>
</tr>
<tr>
<td>object visibility in</td>
<td>168</td>
</tr>
<tr>
<td>panning</td>
<td>161</td>
</tr>
<tr>
<td>resetting views in</td>
<td>167</td>
</tr>
<tr>
<td>Spotlight view</td>
<td>156</td>
</tr>
<tr>
<td>tracking in</td>
<td>162</td>
</tr>
<tr>
<td>user</td>
<td>159</td>
</tr>
<tr>
<td>XYZ buttons</td>
<td>158</td>
</tr>
<tr>
<td>zooming</td>
<td>161</td>
</tr>
</tbody>
</table>

### A

<table>
<thead>
<tr>
<th>Term</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>acceleration</td>
<td>403</td>
</tr>
<tr>
<td>access keys</td>
<td>71</td>
</tr>
<tr>
<td>action clips</td>
<td></td>
</tr>
<tr>
<td>namespace</td>
<td>206</td>
</tr>
<tr>
<td>action sources</td>
<td></td>
</tr>
<tr>
<td>changing paths in scene (TOC)</td>
<td>456</td>
</tr>
<tr>
<td>namespace</td>
<td>206</td>
</tr>
<tr>
<td>actions</td>
<td></td>
</tr>
<tr>
<td>importing</td>
<td>544</td>
</tr>
<tr>
<td>namespace</td>
<td>206</td>
</tr>
<tr>
<td>add manipulation mode</td>
<td></td>
</tr>
<tr>
<td>rotating objects</td>
<td>374</td>
</tr>
<tr>
<td>aligning</td>
<td></td>
</tr>
<tr>
<td>objects</td>
<td>396</td>
</tr>
<tr>
<td>ambience</td>
<td></td>
</tr>
<tr>
<td>importing</td>
<td>539</td>
</tr>
<tr>
<td>parameters</td>
<td>539</td>
</tr>
<tr>
<td>angular motion</td>
<td>403</td>
</tr>
</tbody>
</table>

### animated Booleans, importing

<table>
<thead>
<tr>
<th>Term</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>animating</td>
<td></td>
</tr>
<tr>
<td>pivot pose</td>
<td>390</td>
</tr>
<tr>
<td>animation</td>
<td></td>
</tr>
<tr>
<td>clusters</td>
<td>543</td>
</tr>
<tr>
<td>differences between</td>
<td></td>
</tr>
<tr>
<td>SOFTWARE</td>
<td>3D and XSI</td>
</tr>
<tr>
<td>duplication objects from</td>
<td>274</td>
</tr>
<tr>
<td>importing</td>
<td>533, 542</td>
</tr>
<tr>
<td>inverse kinematics</td>
<td>528</td>
</tr>
<tr>
<td>lattice</td>
<td>543</td>
</tr>
<tr>
<td>locking</td>
<td>508</td>
</tr>
<tr>
<td>path</td>
<td>543</td>
</tr>
<tr>
<td>shape</td>
<td>543</td>
</tr>
<tr>
<td>skeletons</td>
<td>528</td>
</tr>
<tr>
<td>animation pivot</td>
<td>388</td>
</tr>
<tr>
<td>annotating objects</td>
<td>287</td>
</tr>
<tr>
<td>Application &gt; Views</td>
<td>108</td>
</tr>
<tr>
<td>application data paths</td>
<td></td>
</tr>
<tr>
<td>installation (factory)</td>
<td>435</td>
</tr>
<tr>
<td>user</td>
<td>435</td>
</tr>
<tr>
<td>workgroup</td>
<td>435</td>
</tr>
<tr>
<td>articulated chains</td>
<td></td>
</tr>
<tr>
<td>converting from SOFTWARE</td>
<td>3D built-in XSI</td>
</tr>
<tr>
<td>differences between</td>
<td></td>
</tr>
<tr>
<td>SOFTWARE</td>
<td>3D and XSI</td>
</tr>
<tr>
<td>importing</td>
<td>528</td>
</tr>
<tr>
<td>attributes, displaying object</td>
<td>168</td>
</tr>
<tr>
<td>audio</td>
<td></td>
</tr>
<tr>
<td>importing</td>
<td>544</td>
</tr>
<tr>
<td>audio clips</td>
<td></td>
</tr>
<tr>
<td>namespace</td>
<td>206</td>
</tr>
<tr>
<td>audio sources</td>
<td></td>
</tr>
<tr>
<td>namespace</td>
<td>206</td>
</tr>
<tr>
<td>automatic envelopes, importing</td>
<td></td>
</tr>
<tr>
<td>auxiliary data</td>
<td></td>
</tr>
<tr>
<td>about</td>
<td>446</td>
</tr>
<tr>
<td>defining</td>
<td>446</td>
</tr>
<tr>
<td>loading</td>
<td>447</td>
</tr>
<tr>
<td>Avid Mojo</td>
<td></td>
</tr>
<tr>
<td>outputting views to</td>
<td>192</td>
</tr>
<tr>
<td>axes</td>
<td></td>
</tr>
<tr>
<td>specifying for manipulation</td>
<td>359</td>
</tr>
<tr>
<td>XYZ</td>
<td>346</td>
</tr>
</tbody>
</table>

### B

<table>
<thead>
<tr>
<th>Term</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>backed-up scenes, restoring</td>
<td>459</td>
</tr>
<tr>
<td>background color</td>
<td></td>
</tr>
<tr>
<td>background color, See 3D views, background color</td>
<td></td>
</tr>
<tr>
<td>background images, matching</td>
<td></td>
</tr>
<tr>
<td>See rotoscopes</td>
<td></td>
</tr>
<tr>
<td>backplates</td>
<td></td>
</tr>
<tr>
<td>See rotoscopes</td>
<td></td>
</tr>
<tr>
<td>backplates</td>
<td></td>
</tr>
<tr>
<td>See rotoscopes</td>
<td></td>
</tr>
<tr>
<td>batch rendering</td>
<td></td>
</tr>
<tr>
<td>command-line options</td>
<td>60</td>
</tr>
<tr>
<td>boundaries</td>
<td></td>
</tr>
<tr>
<td>about</td>
<td>315</td>
</tr>
<tr>
<td>selecting</td>
<td>232</td>
</tr>
<tr>
<td>bounding box display type</td>
<td>175</td>
</tr>
<tr>
<td>bounding boxes</td>
<td></td>
</tr>
<tr>
<td>moving center</td>
<td>387</td>
</tr>
<tr>
<td>bounding volumes in envelopes</td>
<td></td>
</tr>
<tr>
<td>importing</td>
<td>541</td>
</tr>
<tr>
<td>bounding-box manipulators</td>
<td>385</td>
</tr>
<tr>
<td>bracketing parameters</td>
<td>91</td>
</tr>
<tr>
<td>branch selection</td>
<td>214, 326</td>
</tr>
<tr>
<td>branches</td>
<td></td>
</tr>
<tr>
<td>in hierarchies</td>
<td>324</td>
</tr>
<tr>
<td>selecting in hierarchies</td>
<td>326</td>
</tr>
<tr>
<td>browsers</td>
<td></td>
</tr>
<tr>
<td>accessing a network</td>
<td>142</td>
</tr>
<tr>
<td>accessing files in</td>
<td>141</td>
</tr>
<tr>
<td>layout of</td>
<td>137</td>
</tr>
<tr>
<td>opening</td>
<td>138</td>
</tr>
<tr>
<td>path controls</td>
<td>141</td>
</tr>
<tr>
<td>setting favorites in</td>
<td>141</td>
</tr>
<tr>
<td>viewing files in</td>
<td>139</td>
</tr>
<tr>
<td>viewing folders in</td>
<td>138</td>
</tr>
<tr>
<td>brush properties</td>
<td>303</td>
</tr>
<tr>
<td>symmetry</td>
<td>307</td>
</tr>
<tr>
<td>B-Spline curves and surfaces</td>
<td>540</td>
</tr>
</tbody>
</table>

### C

<table>
<thead>
<tr>
<th>Term</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Camera view</td>
<td>156</td>
</tr>
<tr>
<td>cameras</td>
<td></td>
</tr>
<tr>
<td>combination mode</td>
<td>166</td>
</tr>
<tr>
<td>dollying with</td>
<td>162</td>
</tr>
<tr>
<td>driving with</td>
<td>164</td>
</tr>
<tr>
<td>flying with</td>
<td>163, 164</td>
</tr>
<tr>
<td>framing elements with</td>
<td>160</td>
</tr>
</tbody>
</table>
importing 542
navigation tool 166
orbiting with 162
pivoting with 162
resetting 167
rolling with 163
setting display options for 179
shaders 539
walking with 163
zooming with 161
Cardinal curves and surfaces 540
cautics
importing 542
center pivot 388
centers
about 348, 354
moving to bounding box center 387
moving to vertices 387
rotations and 375
scaling and 380
transforming 387
chains
importing 528
channels
importing 544
character rigs, importing 528
Child Transform Compensation 401
children 324
ChildComp 401
classic scaling 383
clips
namespaces 206
cloning 276
cluster animation, importing 543
clusters
about 316
adding components 319
animating 322
creating 318
deforming 322
display colors 319
displaying 317
importing 343
local materials and textures 320
locking 502
namespaces 206
overlapping materials and textures 321
polygon, hiding 172
reference frames 320
removing 321
removing components 319
selecting 238, 317
transforming 322
CMYK in color editor 97
COG mode
rotations 375, 381
scaling 381
snapping 371
translations 371
collapsing
hierarchies 111
collisions
importing 544
colors
3D views, background 154
CMYK 97
defining 95
defining with color editor 95
defining with sliders 95
editor 95
models (RGB, HLS, HSV) 96
picker 95
scene 186
wireframe 188
command box 68
command-line options
starting XSI 58
starting XSI on Windows 54
commands
choosing 70
menu 70
MergeScene 449
redoing 98
undoing 98
comments
See also annotating objects
components
about 310
adding to clusters 319
animating 322
creating clusters 318
deforming 322
deselecting 218
display options 186
displaying 311
navigating 250
removing from clusters 319
selecting 217, 230
selecting loops 234, 236
selecting ranges 234, 235
selection filters 232
transforming 322
types 312
Constant display type 176
Constrain > Child Transform Compensation 401
Constrain > Select Constraining Objs 240
Constrain panel 67
constraints
importing 533, 543
parent 402
context menus
about 70
explorer 118
control objects
about 260
controls, importing 544
coordinates
Cartesian 346
global and local 348
copying
objects between scenes with models 479
curve boundaries
about 314
selecting 232
curves
B-Spline 540
Cardinal 540
deforming components and clusters 322
importing 540
linear 540
custom preferences 552
custom displays
viewports, displaying in 159
custom effects, importing 531, 532, 534
custom parameter sets
namespaces 206
custom parameters
namespaces 207
customizing
viewport grid 155
cutting links in hierarchies 329
cycling
through floating views 108

deacceleration 403
default layer 333, 336
default reference planes 408
deformations
clusters 322
components 322
importing 544
deleting
layers 341
referenced models 496
depth fading
importing 539, 542
parameters 539
deselecting 218
in explorer 245
display
optimizing 189
display options
components 186
objects 186
setting for all cameras 179
viewports 154
display types
bounding box 175
constant 176
depth cue 175
fast manipulation 189
hidden-line removal 176
individual objects, setting for 177
mixed viewing 184
overriding 178
realtime shaders 177
shaded 176
textured 176
textured decal 177
wireframe 175
x-ray shading 179
displaying
clusters 317
components 311
information in schematic views 122
instances 498
object attributes 168
properties 240
weight maps 300
dollying cameras 162
dotXSI files
exporting 522
file transfer toolkit (FTK) 523
importing 520
driving
with camera 164
dSC files
importing 521
dummy objects See implicit objects duplicating
groups of objects 271
in symmetry 273
objects 269, 270
objects along a path 275
objects from animation 274
with transformations 272
without options 272
See also cloning, copying, instances
dynamics, importing 544

e edge loops
selecting 236
dges
about 313
animating 322
deforming 322
selecting 232
selecting loops 236
selecting ranges 234, 235
transforming 322
Edit panel 67
elements
basic scene 204
EMDL files 479
exporting 522
envelope weights, importing 541
envelopes
automatic 540
bounding volumes 541
global 540
importing 528
local 540
preserving before importing 529
rigid 540
weights 541
exiting XSI 64
expanding hierarchies 111
Explore > Groups 229
explorer
context menus 118
expanding and collapsing hierarchies in 111
filtering information in 114
finding objects 114
framing elements in 113
layout of 110
locking 113
navigating in 112
opening 111
pop-up 119
renaming elements in 119
reordering objects 117
selecting 243
Index

<table>
<thead>
<tr>
<th>Sorting elements 116</th>
</tr>
</thead>
<tbody>
<tr>
<td>Viewing basic properties 281</td>
</tr>
<tr>
<td>Viewing hierarchies in 111</td>
</tr>
<tr>
<td>Exporting</td>
</tr>
<tr>
<td>Model instances 500</td>
</tr>
<tr>
<td>Models 479, 522</td>
</tr>
<tr>
<td>Preferences 549</td>
</tr>
<tr>
<td>Scenes and objects to dotXSI 522</td>
</tr>
<tr>
<td>Scenes and objects to IGES 524</td>
</tr>
<tr>
<td>Scenes and objects to OBJ 524</td>
</tr>
<tr>
<td>Expressions</td>
</tr>
<tr>
<td>Importing 533, 544</td>
</tr>
<tr>
<td>Extended Component Selection 233</td>
</tr>
<tr>
<td>External files</td>
</tr>
<tr>
<td>Locating 451</td>
</tr>
<tr>
<td>External local models 475</td>
</tr>
</tbody>
</table>

**F**

<table>
<thead>
<tr>
<th>Faces</th>
</tr>
</thead>
<tbody>
<tr>
<td>Importing from SOFTIMAGE</td>
</tr>
<tr>
<td>Factory application data path 435</td>
</tr>
<tr>
<td>Fast manipulation 189</td>
</tr>
<tr>
<td>Fast playback 184, 190</td>
</tr>
<tr>
<td>Favorites</td>
</tr>
<tr>
<td>Adding to favorite list 141</td>
</tr>
<tr>
<td>Deleting from favorite list 141</td>
</tr>
<tr>
<td>Selecting 141</td>
</tr>
<tr>
<td>File &gt; Preferences 547</td>
</tr>
</tbody>
</table>

**File types**

| .dsc 521 |
| .emdl 479, 522 |
| .hrc 521 |
| .iges 521, 524 |
| .mdl 475 |
| .obj 521, 524 |
| .preset (general) 289 |
| .scn 464 |
| .scntoc 455 |
| .xsi 520, 522 |
| .xsipref 546 |
| .xsiprojects 470 |

**Files**

| Accessing from browser 141 |

| Deleting projects 469 |
| Deleting scene 443 |
| External 451 |
| Recovery journal 460 |
| Referenced 451 |
| Restoring backed-up versions of 459 |
| Searching for 444 |

**Filtering**

| Elements in explorer 114 |
| Elements in Schematic view 124 |

**Finding**

| Objects in explorer 114 |

**Flares**

| Shaders 539 |

**Flipbooks**

| Matching colors in 96 |

**Floating views**

| 107 |

**Flying**

| With camera 164 |

**Fog**

| Importing 539, 542 |
| Parameters 539 |

**Frame of reference**

| Objects 348 |

**Framing**

| Elements in 3D views 160 |
| Elements in explorer 113 |
| Elements in the Schematic view 126 |

**Freeform selection tool**

| 222 |

**Freezing**

| Transformations 392 |
| Weight maps 304 |

**G**

| Generic attribute painting (GAP) See painting |
| Geometric objects |
| About 263 |
| Geometry approximation |
| About 282 |
| Hardware display 190 |
| Geometry types |
| Of objects 263 |
| Global coordinates 348 |
| Displaying in View manipulation mode 366 |
| Global envelopes |
| Importing 540 |
| Global illumination |
| Importing 542 |
| Global manipulation mode |
| Rotating objects 373 |
| Translating objects 368 |
| Global transforms 353 |
| Grid |
| Size 427 |
| Snapping 423, 427 |

**Grouped skeletons, importing** 541

**Groups**

| Adding/removing objects in 267 |
| Clones of 276 |
| Creating 265 |
| Deleting 268 |
| Duplicating 271 |
| Locking 502 |
| Namespace 206 |
| Of objects 265 |

**PropertyFixup** 286

**Referenced models and** 495

**Selecting**

| 228 |

556 • SOFTIMAGE|XSI
H

hardware, OGL 176
helper objects See implicit objects
  hiding
    object attributes 168
    objects 171
    objects in layers 332
    polygon clusters 172
    polygons 172
hierarchical (Softimage) scaling 383
hierarchies
  about 324
  clones of 276
  collapsing 111
  creating 325
  cutting links between parents and
    children 329
  expanding and collapsing 111
  in explorer view 111
  in schematic view 121
  navigating in 248, 328
  parent constraint 402
  reordering objects 117, 131
  selecting 214, 247
  selecting branches in 326
  selecting nodes in 326
  selecting objects in 326
  selecting trees in 327
  sorting in the schematic 129
  transforming 401
Hierarchy Manipulation 401
HLS color 96
hotkeys See keyboard shortcuts
HRC files 521
HSV color 96
I
icons
  in schematic views 123
IGES files 521
  exporting 524
  importing 521
image clips
  local models and 482
  merged scenes and 449
  models and 482
  namespace 206
  referenced models and 495
image sources
  changing paths in scene TOC 456
  namespace 206
images
  namespace 206
  implicit
    objects 260
importing
  about 518
  command history 518
  dotXSI files 520
  IGES files 521
  local models 481
  logging messages to file 519
  models 519
  models from
    SOFTIMAGE|3D 520, 526
  OBJ files 521
  preferences 549
  referenced models 484
  scenes from
    SOFTIMAGE|3D 520, 526
  SI3D loader options 520
  incremental snapping 429
  Info Scene 453
inheritance
  lock information 504
  installation application data
    path 435
InstanceGroup 499
instances 497
  creating 498
  creating from animation 498
  displaying 498
  exporting 500
  importing from
    SOFTIMAGE|3D 540
  instantiating 500
  modifying 499
  motion blur on 500
selecting 498
  showing relations 499
instantiating relations 499
interaction models
  changing 551
  selection 227, 233
internal local models 475
invalid projects 472
isolines
  about 315
  selecting 232
isopoints
  about 314
  selecting 232
J
joints
  importing joint color from
    SOFTIMAGE|3D 541
  journal file for recovery 460
K
keyboard shortcuts
  about 71
  access keys 71
  activating tools with 72
  for navigating hierarchies 249
  for selection 217
  shortcut keys 71
  sticky-key mode 73
  supra-key mode 73
keys
  access 71
  shortcut 71
  temporary mode 73
  See also keyboard shortcuts
kinematics
  properties of objects 281, 356
knot curves
  about 314
  selecting 232
knots
  about 313
  selecting 232
Index

L
language preference
command-line option 60
setting 552
lasso selection tool 221
lattice animation, importing 543
layers
about 332
adding objects to 337
attributes 332
controlling 334
creating 336
current 336
deleting 341
in the explorer 334
layer control 335
locking 502
menu 334
moving objects to 337
namespaces 206
panel 334
property editor 338
referenced models and 495
selecting all objects in 340
setting attributes 337
Layers panel 67
layouts
default 66
letter identifiers See viewports
levels of detail 483
See also referenced models
licensing
command-line options 58
lights
importing from
SOFTIMAGE|3D 542
linear
values in text boxes 88
linear curve, importing 540
linear motion 403
links
displaying in schematic view 122
displaying in schematic views 124
Linux
starting XSI on 56
local coordinates 348
displaying in View manipulation mode 366
local envelopes
importing 540
local manipulation mode
rotating objects 373
scaling objects 379
translating objects 368
local materials
about 320
importing from
SOFTIMAGE|3D 538
overlapping clusters 321
sharing 321
viewing data 321
local models 475
converting from referenced models 496
image clips and 482
local textures
about 320
importing from
SOFTIMAGE|3D 538
overlapping clusters 321
sharing 321
viewing data 321
local transforms 353
locators
See nulls
locking
property editors 79
scene elements 502
scenes 446
schematic view 125
XSI explorer 136
locks
3D objects 502
animation 508
clusters 502
getting information about 511
groups 502
inheritance 504
layers 502
level of 502
local models 502
owner of 504
parameters 502, 506
passes 502
proxy parameters 506
unlocking parameters 510
unlocking scene elements 509
user vs. system locks 502
using scripts 513
LOD (levels of detail) 483
See also referenced models
loops of components
selecting 234, 236
M
Magnet option 422
main command area 67
See also specific panels
main menu bar 66
manipulation
fast 189
manipulation modes 353
rotation 373
scaling 379
snapping and 420
translations 368
manipulators
bounding-box 385
rotate 374
scale 380
SRT 362
translate 370
maps
weight 297
matching
transformations 396
materials
displaying in explorer 536, 537
importing 530, 541
importing local materials from
SOFTIMAGE|3D 538
local 320
modifying imported materials 530
overlapping polygon clusters 321
referenced models 495
shaders 539
shared materials 537
shared materials, importing from SOFTIMAGE|3D 538
math operators
in text boxes 88
maximizing
viewports 106
MCA, See main command area
MDL files 475
memo cams 151
mental ray
shaders See shaders
menus
context 70
drop-down 70
main (main menu bar) 66
pop-up 70
MergeScene 449
merging
scenes as models 448
meta-clay systems
importing 540
migrating preferences
command-line options 59, 61
minimizing
floating views 108
mixed-viewing mode 184
mixing
weight maps 306
model clips for referenced models 483
model sources for referenced models 483
models
about 474
converting referenced to local 496
copying objects between scenes 479
creating 478
exporting 479, 522
external 475
faces 540
image clips and 482
importing 519, 532
importing local 481
instantiating 497
internal 475
local 475
locking 502
merging scenes as 478
meta-clay 540
namespace 206
namespaces of 476
NURBS (Surfaces and Curves) 540
organizing objects into structures 474
Patches 540
polygons meshes 540
referenced 475, 483
re-importing 476
relational modeling 540
selecting 478
text 540
transferring properties with overrides 294
modes
bounding-box display 175
constant display 176
hidden line-removal display 176
mixed viewing 184
rotation 373
scaling 379
shaded display 176
texture decal 177
textured decal display 177
translation 368
Mojo See Avid Mojo
motion blur
and instances 500
mouse
information and status line 68
three-button 70
moving
See also translating
Multi mode (SOFTIMAGE 3D) 210
N
named selections 265, 536
See also groups, marking sets
names
about 206
finding objects by 114
selecting by 252
valid characters 206
namespaces 206
in models 476
navigation tools
dolly 162
drive 164
fly 164
nav/dolly 166
orbit 162
pan and zoom 161
pivot 162
rectangular zoom 161
roll 163
track 162
walk 163
zoom on cursor 161
zoom, rectangular 161
net view
about 143
configuring 144
proxy server 144
neutral poses 394
node selection 214, 326
nulls
about 260
OBJ files
exporting 524
importing 521
object attributes, displaying 168
object view
about 151
preferences, setting 153
Index

view menu options 152
working with 152
objects
aligning 396
annotating (comments) 287
basic types 260
cloned 276
clones of 276
control 260
deleting 278
deselected 218
display options 186
displaying attributes of 168
duplicating 269, 270
exporting to dotXSI 522
geometric 263
groups 265
hiding/unhiding 171
in hierarchies 324
moving to a layer 337
moving to layers 337
namespace 206
naming 206
organizing into structures 204
render visibility 170
selectability 255
selecting 216, 225
unhiding 171
visibility of in 3D views 168
OGL
hardware shaded 176
Online Help
from main menu bar 71
from property editors 78
opacity, brush 303
operations
entering math in text boxes 88
redoing 98
undoing 98
operator stack
weight maps 297
orbiting
with camera 162
origin 346
output
shaders 539
overlapping points 257
overrides
about 291
adding parameters and properties to 292
creating 292, 293
deleting 294
on parameters 291
on properties 291
property with models 476
transferring properties between models 294
P
paint selection tool 223
painting
brush properties 303
on subdivision surfaces 304
paint modes 302
symmetrically 307
weights 301
palettes, importing 542
panels
Constrain 67
Edit 67
Layers 67
Select 67
Transform 67
panning
See also tracking
par manipulation mode
rotating objects 374
translating objects 369
parameters
bracketing 91
changing values with virtual sliders 85
editing in property editors 84
editing in text boxes 86
editing using sliders 85
locking 506
overrides 291
randomizing 90
randomizing when sampling 92
sampling 91
tagging 514
parent constraint 402
parent-child relationships between objects (hierarchies) 324
partitions
namespaces 207
referenced models and 495
passes
changing current pass in scene
TOC 457
locking 502
namespaces 206
patch objects
importing 540
preserving envelope weights when importing 529
path animation
importing 543
path controls 141
paths
duplicating objects on 275
paths (file)
correcting 451
displaying SOFTIMAGE|3D databases in browser 520
in browser 141
presets 289
searching 444
permanent reference planes 408
persistent effects, importing 531, 532, 534
photon director 542
pivot
activating/deactivating 389
animating 390
animation pivot 388
center pivot 388
compensation 389
displaying 390
for transformations 360
setting 388
pivoting
with camera 162
560 • SOFTIMAGE|XSI
plane manipulation mode 407, 414
  rotating objects 374
  translating objects 370
planes
  XYZ 347
plug-ins
  command-line options 59, 60
  importing 531, 532, 534
point objects See nulls
points
  about 312
  animating 322
  deforming 322
  overlapping 257
  selecting 232
  selecting loops 234, 236
  selecting ranges 234, 235
  transforming 322
polygon meshes
  deforming components and clusters 322
  importing 540
polygons
  about 313
  animating 322
  deforming 322
  hiding 172
  local materials and textures 320
  overlapping materials and textures 321
  selecting 232
  selecting loops 234, 236
  selecting ranges 234, 235
  transforming 322
pop-up explorer
  in Schematic view 120
  in Select panel 119
preferences
  about 546
  custom 552
  display 190
  exporting 549
  importing 549
  interaction models 551
language 552
migrating 59, 61
number of undo levels 98
overlapping local materials 321
restoring 350
setting 548
transformation 357
Preferences window 547
presets
  about 289
  loading 290
  of properties 289
  saving 290
previewing
  Mojo, outputting preview render to 192
Project Manager
  opening 464
projects
  adding to list 470
  automating lists 471
  creating 467
  creating the first one 63
  default 469
  deleting 469
  folder structure 465
  invalid 472
  lists 470
  opening 468
  saving 467
Prop option 355
propagation
  of properties in a hierarchy 283
properties
  about 281
  annotation 287
  applying 287
  color 95
  displaying in views 240
  editing in property editors 77
  for multiple elements 83
  overriding 291
  presets 289
propagation of 283
reusing 289
selecting 240
types of 281
viewing propagation 285
Property > Brush Properties 302, 303
Property > Paint Tool 302
Property > Transform Setup 399
Property > Weight Map 298, 300
property editors
  about 77
  displaying 80
  docking in viewports 82
  editing properties in 84
  focusing 79
  for multiple elements 83
  locking 79
  opening from schematic views 123
  recycling 79
  tab-style 82
property maps See weight maps
PropertyFixup groups 286
proportional modeling 355
Q
queries
  See also spreadsheet
quickstretch
  importing 544
R
radius, brush 303
random values in text boxes 88
randomizing
  parameter values 90
  when sampling parameters 92
ranges of components
  selecting 234, 235
raycast selection tool 222
  See also rectangle-raycast selection tool
recovery journal file 460
rectangle selection tool 220
rectangle-raycast selection tool 223
redoing
undone changes 98
ref manipulation mode
about 407, 413
rotating objects 374
translating objects 370
reference frames
clusters 320
objects 348
reference planes
about 407
activating 412
creating 410
deleting 411
options 416
symmetry and 408
transforming with 413
types 408
referenced files
saving 451
searching and replacing 451
referenced models
about 475, 483
animating 488
changing paths in scene TOC 456
changing resolution 486
converting to local 496
deleting 496
image clips and 495
importing 484
in groups, layers, and partitions 495
materials 495
modifying 488
offloading 487
sources and clips 483
updating 490
regex 115, 254
regular expressions 115, 254
relation modeling, importing 540
relations
in schematic views 124
relative input for math operations 88
renaming
objects 206
scenes 450
render options
changing in scene TOC 457
render regions
rotscoped images in 200
render settings, importing 542
Render window
Mojo, outputting to 192
reordering
objects in explorer 117
objects in schematic view 131
resetting
transformations 393
viewports 107
restoring
floating views 108
preferences 550
viewports 106
RGB
color 96
rigid envelopes
importing 540
rolling
with cameras 163
roots
in hierarchies 324
rotations 358, 372
add manipulation mode 374
centers and 375
COG mode 375, 381
editing multiple values numerically 366
global manipulation mode 373
interaction speed 364
limits 376
local manipulation mode 373
manipulation modes 373
manipulator 374
numerical 365
order of 376
par manipulation mode 374
pivot 388
plane manipulation mode 374
ref manipulation mode 374
setting the pivot 360
view manipulation mode 373
with manipulator 386
See also transformations
rotscopy
about 196
importing images 197
in render region 200
picking colors from 95
previewing 176
zooming in the view 199
S
sample points
about 315
selecting 232
sampling
parameters 91
saving
presets 290
projects 467
scenes 450
scaling 358, 378
centers and 380
classic 383
COG mode 381
editing multiple values numerically 366
hierarchical 383
interaction speed 364
local manipulation mode 379
manipulation modes 379
manipulator 380
numerical 365
on an angle 382
orientation 382
pivot 388
setting the pivot 360
shearing 382
uni manipulation mode 379
vol manipulation mode 380
with manipulator 386
See also transformations
scene colors
setting 186
scene TOC
about 455
changing current pass 457
changing render options 457
changing source paths 456
running postload scripts 457
scenes
auxiliary data 446
backup preferences 459
basic elements in 204
copying objects between with models 479
creating 443
deleting 443
exporting to dotXSI 522
information on scene 453
information on selection 453
locking 446
merging as models 448, 478
moving to different project 450
opening 444
renaming 450
restoring from backup 459
saving 450
saving referenced files in 451
transporting properties between 289
version saved with 454
within projects 464
schematic
reordering objects 131
schematic view
displaying information 122
displaying properties 241
filtering elements in 124
layout of 121
locking 125
navigating in 126
rearranging objects in 127
resetting user positions 128
selecting elements in 122
showing icons 123
showing instance relations 499
sorting hierarchies 129
SCN (scene) files 450, 464
sctoc files 455
scripts
command-line options 60
running automatically after loading scene 457
scrubbing
to enter information in text boxes 87
searching
objects 114
Select > Extended Component Selection 233
Select > Select Members/Components 229
Select > Select Single Object in Region 227, 228
Select > Softimage|3D Selection Model 227
Select panel 67, 211
selectability 255
selecting
about 211
adding to selection 218
branches 214
branches in hierarchies 326
by name 252
by painting 223
clusters 238, 317
components 217, 230
defining selectability 255
defining selectability 255
defining selectability 255
defining selectability 255
defining selectability 255
defining selectability 255
defining selectability 255
edge loops 236
extending 218
filtering 246
groups 228
hierarchies 214, 247
in explorer 243
in schematic views 122
in the explorer 112
instances 498
interaction models 227, 233
keyboard shortcuts 217
loops of components 234, 236
models 478
multiple elements 244
multiple objects 228
navigating components 250
navigating hierarchies 248
nodes 214
nodes in hierarchies 326
objects 216, 225
objects in hierarchies 326
properties 240
ranges of components 234, 235
refining 246
tools 219
trees 215
trees in hierarchies 327
visual feedback 212
weight maps 301
with filters 213
selection filters
about 213
components 232
object 226
properties 241
selection interaction models
about 213
components 233
objects 227
selection modes 213
components 231
object 225
selection tools 213, 219
freeform 222
lasso 221
paint 223
raycast 222
rectangle 220
rectangle-raycast 223
shaders
camera 539
flare 539
Index

importing from 
SOFTIMAGE|3D 531, 539
materials 539
output 539
texture 539
volume 539
shape animation
importing 543
shape clips
namespace 206
shape sources
namespace 206
shapes
namespace 206
shared image clips 449
shared materials
displaying 537
importing from 
SOFTIMAGE|3D 538
on clusters 321
shearing, scaling 382
classic scaling 383
scaling orientation 382
shelves
about 69
shortcut keys  See keyboard shortcuts
simulations
importing from 
SOFTIMAGE|3D 544
Single mode (SOFTIMAGE|3D) 210
skeletons
groups 541
importing 528, 542
SlidePoints 423
sliders
in property editors 85
polymorphic 79
virtual 85
Snap panel 67
snapping
about 419
activating 419
COG mode 371
filters 423
grid size 427
incremental 429
manipulation modes and 420
options 424
targets 421
tools that use 420
Softimage scaling 383
Softimage units 349
SOFTIMAGE|3D
differences with XSI 30
importing
models from 526
scenes from 526
importing models from 520
importing scenes from 520
SOFTIMAGE|3D selection
model 227, 233
SOFTIMAGE|XSI selection
model 227, 233
sorting
elements in explorer 116
sorting, spreadsheet queries 133
sources
namespaces 206
Spotlight view 156
spreadsheet
about 132
annotation query 287
local materials and textures 321
navigating in 134
opening 133
selecting elements in 134
sorting 133
updating display 133
starting XSI
command-line options 58
command-line options for 
Windows 54
creating the first project 63
on Linux 56
on Windows 54
sticky key mode 73
storing
files in projects 465
subcurves
about 314
selecting 232
subdivision surfaces
painting weights 304
subsurfaces
about 314
selecting 232
supra keys 73
surface curves
about 315
selecting 232
surfaces
deforming components and 
clusters 322
Sym button 355
symmetrical manipulation 355
symmetry
brush properties 307
duplication 273
reference planes and 408
weight maps 307
symmetry maps
for weight maps 307
synoptic views
about 99
displaying 100
navigating 100
samples 101
using 99
system locks 502
T
tab-style property editors 82
tagging
parameters 514
tagging  See selecting
text
importing 540
text boxes
entering property values in 86
math operations in 88
moving among 86
texture shaders 539
textured decal display type 177

textures
  displaying in material property page 536, 537
  importing 530, 541, 542
  importing local textures from SOFTIMAGE|3D 538
  local 320
  modifying imported in XSI 530
  overlapping polygon clusters 321
  third-party plug-ins, importing 531, 532, 534

thumbnail viewer
  selecting objects from 440
  using 440

thumbnails
  about 438
  assigning to scene elements 439
  creating from render regions 439
  finding 438
  folder in the project structure 438
  image proxies and 439
  managing size of 439
  relational view 440
  setting for scene elements 439
  thumbnail viewer 440

title bar 66

toolbars
  about 69

tools
  activating with shortcut keys 72
  tracking active tools 75

ToonAssistant, importing effects 542

tracking
  3D views, tracking in 162

Transform > Align Objects 396
Transform > Freeze commands 392
Transform > Ignore Transformation Setups 400
Transform > Kinematics 356
Transform > Match commands 396
Transform > Move Center to Vertices 387

Transform > Remove Neutral Pose 395
Transform > Reset commands 393
Transform > Set Neutral commands 394
Transform panel 67, 355
  editing multiple parameters 366
  transform setup 399
  ignoring 400
  transformations 358
  axes 359
  bounding-box manipulator 385
  center 387
  clusters 322
  components 322
  editing multiple parameters numerically 366
  freezing 392
  global 353
  hidden objects 366
  hierarchies and 401
  interaction speed 364
  kinematics property editor 356
  local 353
  manipulation modes 353
  manipulators 362
  matching 396
  neutral poses 394
  numerical 365
  pivot 388
  preferences 357
  preferred tool 399
  resetting 393
  rotation 372
  scaling 378
  setting the pivot 360
  setup 399
  translation 367
  using reference planes 413
  visual cues 364
  while duplicating objects 272
  transient reference planes 408
  translations 358, 367
  COG mode 371
  editing multiple values numerically 366
  global manipulation mode 368
  interaction speed 364
  limits 371
  local manipulation mode 368
  manipulation modes 368
  manipulator 370
  numerical 365
  par manipulation mode 369
  plane manipulation mode 370
  ref manipulation mode 370
  setting the pivot 360
  snapping multiple objects 371
  view manipulation mode 369
  with manipulator 386

See also transformations
tree selection 215
trees
  about 324
  selecting in hierarchies 327
trim curves
  about 315
  selecting 232

U
undoing changes
  number of levels 98
unhiding
  objects 171
uni manipulation mode
  scaling objects 379
units, Softimage 349
user application data path 435
user locks 502

V
velocity 403
versioning
  scenes saved with 454
View manipulation mode
  displaying local or global coordinates 366
view manipulation mode
  rotating objects 373
  translating objects 369
viewing
  modes, mixed 184
  rotoscoped images 196
viewpoint buttons 158
viewpoints
  about 157
Viewports
  Mojo, outputting to 192
viewports 105
  changing views in 105
  display options 154
  displaying properties 240
  layout of 149
  letter identifiers of 105
  maximizing 106
  memo cams 151
  muting and soloing 150
  property editor docked in 82
  resetting 107
  resizing 106
  restoring 106
views
  browser 137
  camera 156
  docked 105
  explorer 110
  floating 107
  geometry 157
  net view 143
  schematic 121
  spotlight 156
  spreadsheet 132
  storing (memo cams) 151
  synoptic 99
  viewports 105
  XSI explorer 135
virtual sliders for changing
  parameter values 85
visibility 536
vol manipulation mode
  scaling objects 380
  volume shaders 539

W
  walking
    with camera 163
  wave, importing 544
  weight maps
    changing color 304
    connecting 305
    creating 300
    defined 297
    displaying 300
    freezing 304
    mixing 306
    on subdivision surfaces 304
    operator stack 297
    painting 301
    selecting 301
    symmetry 307
    using 298
  weights
    importing 541
    Window > Close All 108
    Window > Minimize All 108
    Window > Restore All 109
    Windows
      starting XSI on 54
      wireframe
        color, importing 541
        display type 175
        index color, calculating 188
        setting color of 188
      workgroup application data
        path 435
      workgroups
        setting 436
      workspace
        XSI 66
X
  x-ray shading 179
  XSI
    basic concepts 33
    exiting 64
    interface 66
    starting 54

start-up options 58
versus SOFTIMAGE|3D 30
XSI explorer
  about 135
  locking 136
  opening 136
  updating 136
xsipref files 546
xsiprojects files 470
XY
  planes 347
XYZ
  axes 346
  coordinates 346
XZ
  planes 347
Y
  YZ
    planes 347
Z
  zooming
    cameras, zooming with 161
    in a rotoscoped view 199
    on cursor 161
    rectangular 161